Subject: [Ieprep] Comment for WG Last Call on draft-ietf-ieprep-sip-reqs-01.txt

From: Ottensmeyer Joerg <[email-masked]>
Date: Wed, 6 Nov 2002 22:07:27 +0100

Dear all,

in my draft (draft-otty-ieprep-pstn-features-00.txt), I outlined the emergency services implemented in PSTN. As the charter of this WG says, "...consider how it (the Internet) can best support emergency management...", we should have a look how these services can be modeled using SIP. And as the SIP requirements draft covers the requirements for just this modelling, I tried to match those services with SIP.

In short, those services which I called "user-dependent/authenticated emergency call service" and "origin-dependent emergency call service" are (I believe) covered by the SIP requirements document. In my opinion, in the Internet context these services fall together: as there is no "trust by wire model" in the Internet, the origin-dependent call has to be authenticated and authorized as well, to set the appropriate flag(s) according the "SIP priority scheme". 

However, the (basic) emergency call service (or 911 call) has additional requirements. This are:
- for this service, the SIP server needs be able to resolve the dialed URI (e.g. sip:ambulance@closest) to the address of the nearest Emergency Response Center. 
- it must be possible to place this call must from all SIP phones and the user does not need to be authenticated or even not registered.
- then, the call must be able to receive the same priority levels as the other emergency calls to ensure that the call is processed in the SIP proxies and servers when a "catastrophe level" is activated, i.e. the overall service has to be restricted.

I feel, that those requirements have to be reflected somehow in the document under last call.

best regards
-Jörg                                     
_______________________________________________
Ieprep mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ieprep

---

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 06 Nov 2002 17:02:03 -0500

Since charter discussions seem all the rage these days, it might be 
worth noting that we have, I believe, several times reached the 
conclusion that 911/112-style calls are out of scope. However, I've been 
working on this very topic for a while. You can find a detailed 
description of the issues in the draft draft-schulzrinne-sipping-sos-02 
and draft-ietf-sip-emergency-00. (If they are expired, you can find them 
at http://www.cs.columbia.edu/sip/drafts/).

We have been building a system locally that solves the first of the 
problem you list below. The second and third appear to be operational 
ones that does not seem to require any additional protocol capabilities. 
With the *sos* draft, a proxy can detect that the call is destined for a 
PSAP and thus modify normal AAA procedures and elevate call priority 
should local operating procedures call for that.

A number of BOFs have been held under the auspices of the SIP(PING) 
working group, but not enough people seem to care about this topic, so 
it seems to always be displaced by more urgent things like ISUP 
interworking :-)

I'll be glad to get into more details, but my interpretation is that at 
least the first two issues are considered out of scope of IEPREP.

Ottensmeyer Joerg wrote:

> Dear all,
>
>
> - for this service, the SIP server needs be able to resolve the dialed 
> URI (e.g. sip:ambulance@closest) to the address of the nearest 
> Emergency Response Center.
> - it must be possible to place this call must from all SIP phones and 
> the user does not need to be authenticated or even not registered.
> - then, the call must be able to receive the same priority levels as 
> the other emergency calls to ensure that the call is processed in the 
> SIP proxies and servers when a "catastrophe level" is activated, i.e. 
> the overall service has to be restricted.
>

---

From: Scott Bradner <[email-masked]>
Date: Wed, 6 Nov 2002 18:57:55 -0500 (EST)

> least the first two issues are considered out of scope of IEPREP.

I agree with Hanning, this is not in IEPREP's charter

I do think that we (the IETF) should think about this space at some point
but not in this WG

(also note that one requirement of e911 is missing, which is location
determination)

Scott