Subject: RE: [Ieprep] Re: PSTN collapse

From: "Gunn, Janet" <[email-masked]>
Date: Tue, 10 Dec 2002 15:56:20 -0500

-----Original Message-----
From: RJ Atkinson [mailto:[email-masked]]
Sent: Tuesday, December 10, 2002 3:45 PM

> IP has packets, and does not have "calls" so there is no concept in IP
> of "call completion".
>
> [JPG] If you mean the IP protocol by itself, OK.  But the term "IP" is 
> often
> used to apply to the entire protocol suite (IP, UDP, TCP, RTP, SIP, 
> etc.),
> and some parts of the protocol suite DO have "calls".

Hmm.  Your definition of "calls" isn't clear to me.
Clarity would help.

[JPG] Well, you are the one who said "IP...does not have "calls"...", so
what did YOU mean.

The example protocols were only intended to illustrate what I meant by
"protocol suite", and yes, SIP is the one that most obviously has "calls".

UDP is connectionless, so it probably is not what you mean.
TCP and SCTP have connection state, so might be what you mean.
RTP runs on UDP but does have some session state within RTP.
SIP clearly has the concept of a phone call.

> [JPG] Maybe I am being naive, but it looks to me as if we have "rough
> consensus" that "access and gateways" are the issues the group should 
> focus
> on.

Certainly, I'd agree we should focus on individual access links,
not the core, and not inter-domain QoS, but others here have been
taking issue with that notion.

I am unclear what you mean by "gateways", since some folks might
mean a "SIP gateway", others might mean some kind of middle-box,
others might mean "IP router", and there might be other definitions
that I haven't imagined.

[JPG] Anything that isn't "core", and might be a bottleneck/congestion
point.

Ran
[email-masked]
_______________________________________________
Ieprep mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ieprep

---

From: RJ Atkinson <[email-masked]>
Date: Tue, 10 Dec 2002 16:31:37 -0500

> "protocol suite", and yes, SIP is the one that most obviously has 

The crux of my point was:
	- routers operate only at the IP-layer
	- the IP-layer does not have the concept of a call
	- routers are what might implement special queuing of the
		set of packets that are trying to get onto an access uplink
	- routers are what might drop packets if the offered load
		is greater than the access link capacity

So unclear to me how the Internet is really capable of "prioritising 
calls".
The Internet can (within specific constraints omitted here) prioritise 
packets
(several examples were described in various earlier notes about your 
scenario example).

> [JPG] Anything that isn't "core", and might be a bottleneck/congestion

OK, but I remain confused on what sort of widget you mean by "gateway".
Is a "gateway" an IP router ?  Or is it some kind of middlebox ?
Or some kind of SIP application-layer-only widget ?

If the WG wants to focus on "approaches to using IP-layer routers to 
manage
potential issues with packet congestion on access links", then that 
sounds fine
to me.  I'm not sure if that is exactly what you intended.

Ran
[email-masked]