Subject: RE: [Ieprep] NATs

From: "King, Kimberly S." <[email-masked]>
Date: Mon, 30 Dec 2002 11:18:55 -0500

Okay, what have we learned?

NATs exist.

Their developers claimed lack of address 
space was a motivation.

Different people disagree about whether 
these developers were able to foresee 
problems in address space or whether 
they lied, whether analyses are flawed 
about the lack of address space for 
China, or whether more than a handful 
of ISPs will ever implement IPv6. 

So, what's our IEPREP perspective?  
NATs exist.  NATs mean hundreds of 
user sessions are potential behind a 
single /32.  They can cause problems 
for applications such as VoIP.  
Workarounds exist.  Marketing hype 
exists and people use things in ways 
their creators didn't envision.

What ieprep problem were we trying 
to examine?  As I recall, we were 
trying to understand the nature of 
congestion on the Internet.

Kimberly

_______________________________________________
Ieprep mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ieprep

---

From: RJ Atkinson <[email-masked]>
Date: Mon, 30 Dec 2002 11:43:57 -0500

On Monday, Dec 30, 2002, at 11:18 America/Montreal, King, Kimberly S. 
wrote:
> NATs exist.  NATs mean hundreds of user sessions are potential
> behind a  single /32.  They can cause problems for applications
> such as VoIP.

I take several things away from this discussion.

1) If one wants an application to have the greatest deployability,
	then one should design that application to work well through
	an unexpected or unknown NAT device.
2) Voice might not be the best application to try to make work through
	an unknown or unexpected NAT device (i.e. one where one cannot
	preconfigure stuff to facilitate RTP through the NAT).
3) NATs don't really provide any security properties by themselves,
	so folks ought not deploy a security architecture based on the
	assumption that "NATs provide security".

Ran