Subject: Re: [Ieprep] alternate model for edge QoS

From: [email-masked]
Date: Mon, 2 Dec 2002 10:30:43 EST

In a message dated 11/30/2002 9:20:47 AM Eastern Standard Time, 
[email-masked] writes:

> > That was not the problem with RSVP deployments and is not the problem with 
> RSVP MD5.
> > The problem with RSVP deployments included at least (1) too much state in 
> routers,
> 
> This might have been a problem a few years ago, but I'm having a hard 
> time believing that a router that can handle on the order of 100,000 
> route entries has trouble with, say, a few hundred reservation entries. 
> As was pointed out by Fred, there are large MPLS path counts in 
> operation today, with no noticeable state problems. (Not counting the 
> pain of configuration.)
> 
> To be more precise, we have to distinguish three types of states:
> 
> (1) scheduling state; this only matters if you have per-flow queueing
> (2) filtering/policing state, which polices flows;
> (3) reservation state, one for each reservation, but only affecting the 
> control processor
> 

[MAP] Thanks Henning.

I think it's time to end this circular argument that:

1. States are bad.
2. Any notion of "connections" requires "states".
3. Any notion of "connections" is bad (I regard RSVP as a way to make IP look 
"connection oriented")
4. IP is connectionless, therefore any notion of "connections" destroys its 
beauty.
5. Any notion of "state" destroys its beauty.

As you've pointed out, there are different kinds of state. Telephone switches 
have been designed which maintain "state" for 10's of thousands of calls, and 
that was before memory cost only hundreds of dollars per Gigabyte.

Mike Pierce
Artel

---

From: RJ Atkinson <[email-masked]>
Date: Mon, 2 Dec 2002 11:20:56 -0500

On Monday, Dec 2, 2002, at 10:30 America/Montreal, [email-masked] 
wrote:
> 3. Any notion of "connections" is bad (I regard RSVP as a way to make 
> IP look "connection oriented")
> 4. IP is connectionless, therefore any notion of "connections" 
> destroys its beauty.

1 is true if edited to be "excessive state is bad".
2 and 3 are unequivocally true for an IP router.

If you ever were to build a router, you'd learn this.
Folks who build routers and folks who operate lots of
routers generally have already learned this.

4 and 5 above aren't technical comments.

And this WG will NOT be making radical changes to the Internet
Architecture as that is NOT within scope here.

MPLS exists and can be used to build a circuit-switched overlay
on top of an IP network.  If folks want a circuit-switched network
but want to call it "IP", then that would be what one could do.
Those sorts of networks are MORE prone to failure in a crisis
of course.  Our existing IP network does really well.

Ran

_______________________________________________
Ieprep mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ieprep