Subject: Re: [Ieprep] Multiple instances of EF

From: [email-masked]
Date: Wed, 23 Jul 2003 09:31:28 EDT

In a message dated 7/22/2003 4:17:40 PM Eastern Standard Time, 
[email-masked] writes:

> Responding in particular to:
> " As noted above, with a multilevel priority scheduler, an instance of EF
> (queue) not at the highest priority would not comply with the criteria for
> being called "EF". Therefore, it is not EF."
> 
> Yes it is.  It is just EF with a relatively large  E_a and E_p.  The
> definition of EF doesn't say they have to be small, just they have to be
> bounds.
> 

Guess I'm thinking of the use of the multiple queues for voice, since that 
was the subject here (emergeny calls). While it is true that the lower 
"priority" queue could meet the criteria for EF for some other constant bit rate 
service with much less stringent delay requirements, I don't believe it could meet 
the requirements for voice.

Mike

---

From: RJ Atkinson <[email-masked]>
Date: Wed, 23 Jul 2003 10:34:30 -0400

On Wednesday, Jul 23, 2003, at 09:31 America/Montreal, [email-masked] 
wrote:
> Guess I'm thinking of the use of the multiple queues for voice, since
> that was the subject here (emergeny calls). While it is true that the
> lower "priority" queue could meet the criteria for EF for some other
> constant bit rate service with much less stringent delay requirements, 
> I
> don't believe it could meet the requirements for voice.

I know of deployed DoD voice/IP applications whose requirements
are well below even needing *any* form of DiffServ, so I do not
believe the claim that only one queue of EF will meet 'voice
requirements' is very generally true.

The claim might be true for some particular vocoder algorithm,
though no particular algorithm or other qualification was made
clear in the quoted text.   To some of us, such a lack of
resilience would be a large clue to use a different vocoder
algorithm.  A number of ITU-T vocoder algorithms appear to
lack resilience -- not surprising since many (all ?) of them
were designed for the circuit-switched phone system.

Folks here might really want to grab a copy of NRL's Ivox
and play with it.  It has a range of vocoders (several
proprietary to DoD).  The software is freely available
for a number of OS/CPU platforms and it works quite well.
(Google for "NRL IVOX" and you should turn it up :-).

Cheers,

Ran

_______________________________________________
Ieprep mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ieprep