Subject: [Ietf-and-github] Create .md file

From: Behcet Sarikaya <[email-masked]>
Date: Fri, 17 Sep 2021 15:29:57 -0500

Hi all,

Can someone tell me how I can create .md file from my draft .txt (or .xml)
file?
I could not find an answer to this in that places I have been looking so
far:)

Behcet

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 17 Sep 2021 22:54:25 +0200

On 17. Sep 2021, at 22:29, Behcet Sarikaya <[email-masked]> wrote:
> 
> Hi all,
> 
> Can someone tell me how I can create .md file from my draft .txt (or .xml) file?
> I could not find an answer to this in that places I have been looking so far:)

You can do this manually (there is not really that much different between .txt and .md).
Or you can send me the XML, wait till I’m back from vacation (W39), and I’ll let my tool convert that to .md.

Grüße, Carsten

---

From: Richard Barnes <[email-masked]>
Date: Mon, 20 Sep 2021 13:32:30 -0400

If you're starting from .txt, you can hack something basic with a few steps:

1. Annotate headings with an appropriate number of '#' characters.  For
instance, "5. Security Considerations" would become "# Security
Considerations" and "3.2.4.1. Packet Format" would become "#### Packet
Format".
2. Remove leading whitespace `s/^   //`
3. Put `~~~` fences around figures and move captions to `{}` metadata
4. Convert references to MD-friendly ones.  For example, change "[RFC8555]"
to "{{!RFC8555}}".

That should get you most of the way.
--RLB

On Fri, Sep 17, 2021 at 4:54 PM Carsten Bormann <[email-masked]> wrote:

> _______________________________________________
> Ietf-and-github mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-and-github
>

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Mon, 20 Sep 2021 18:34:12 +0000

For the YAML headers and "--- abstract" "--- middle" dividers and such, I find Carsten's STuPiD example to be a useful template to copy from or use as a template to paste into.
https://raw.githubusercontent.com/cabo/kramdown-rfc2629/master/examples/stupid-s.mkd

Barbara

From: Ietf-and-github <[email-masked]> On Behalf Of Richard Barnes
Sent: Monday, September 20, 2021 12:33 PM
To: Carsten Bormann <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [Ietf-and-github] Create .md file

If you're starting from .txt, you can hack something basic with a few steps:
1. Annotate headings with an appropriate number of '#' characters.  For instance, "5. Security Considerations" would become "# Security Considerations" and "3.2.4.1. Packet Format" would become "#### Packet Format".
2. Remove leading whitespace `s/^   //`
3. Put `~~~` fences around figures and move captions to `{}` metadata
4. Convert references to MD-friendly ones.  For example, change "[RFC8555]" to "{{!RFC8555}}".

On Fri, Sep 17, 2021 at 4:54 PM Carsten Bormann <[email-masked]<mailto:[email-masked]>> wrote:

You can do this manually (there is not really that much different between .txt and .md).
Or you can send me the XML, wait till I'm back from vacation (W39), and I'll let my tool convert that to .md.

Grüße, Carsten

_______________________________________________
Ietf-and-github mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ietf-and-github<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/ietf-and-github__;!!BhdT!1s3jAc727W3AuTfCO1N_Kz4UpQnHOvorhBIIBGgWGz7P1wvXv36_I0o7rGj5Ww$>