Subject: [ietf-dkim] Bug in our "l=" extension stats

From: "Murray S. Kucherawy" <[email-masked]>
Date: Tue, 10 May 2011 12:15:25 -0700

I think OpenDKIM's stats stuff has a discrepancy in how we've been reporting "l=".  The use counts are right, but the stats about "received size was greater than l= size" is wrong at least for the cases where "relaxed" body canonicalization is in use and the value of "l=" was not zero.

The quantities recorded are:

-          Total body length

-          Canonicalized bytes

-          Value of "l="

Where "simple" is in use, comparing these values can tell you whether or not the message was extended.  Where "relaxed" is in use, you have to account for the fact that the second value might be smaller than the first even for a message that had nothing appended to it (for bytes that were dropped), and we haven't been doing that.

I'm working to correct this for the next version which will be out soonish.  I'll re-run the report selecting for "simple" only in the near future to get a more accurate picture.  I don't expect the message will be largely different, but I do prefer to be accurate.

-MSK

_______________________________________________
NOTE WELL: This list operates according to 
http://mipassoc.org/dkim/ietf-list-rules.html

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Thu, 12 May 2011 00:28:38 -0700

The next version out will fix this, in less than a month.  After we have a few months of data I might get a more accurate picture of relaxed body extension results, etc.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Murray S. Kucherawy
Sent: Tuesday, May 10, 2011 12:15 PM
To: [email-masked]
Subject: [ietf-dkim] Bug in our "l=" extension stats

-          Total body length

-          Canonicalized bytes

-          Value of "l="

-MSK