Subject: Re: [Ietf-languages] Registration requests: akuapem, asante

From: "Doug Ewell" <[email-masked]>
Date: Sun, 28 May 2017 12:29:04 -0600

Don Osborn wrote:

> It would be nice to maintain a unified approach to Akan, but probably
> not necessary to have two ISO 639 codes in this tag.

I'm not sure what you mean by "a unified approach." ISO 639 has assigned 
separate code elements for Twi and Fanti, and therefore individual 
subtags have been assigned in the LSR as well. Do you suggest that users 
ignore these and tag all Akan content with the macrolanguage subtag 
'ak'?

I never got a response (from anyone) to my question about current 
tagging practice, quoted yet again below:

| The purpose of BCP 47 is to provide identifiers for language content,
| based when possible on ISO standard code elements.
|
| ISO 639 has coded Twi [tw, twi] separately from Akan [ak, aka].
|
| Irrespective of the fact that "Twi" is actually a name for two of the
| three major dialects of Akan (the two for which Sascha has proposed
| variant subtags), I believe it would be destabilizing for BCP 47 to
| encourage users to tag Twi content as "ak" or "ak-anything" instead of
| using "tw".

> Sent this to the list, but apparently a snafu with my subscription 
> (?).

Try re-subscribing. Remember it's @ietf.org now, not @alvestrand.no.

--
Doug Ewell | Thornton, CO, US | ewellic.org

---

From: "Don Osborn" <[email-masked]>
Date: Sun, 28 May 2017 14:52:10 -0400

There is a unified orthography for Akan. What does that mean when, say, Twi Asante, Twi Akuapem, and Fante (which from all descriptions are mutually intelligible) are written in it? One might refer simply to writing Akan (ak)? Or would new subtags for the unified orthography in question reference it under tw or fat?

It seemed that an alternative would be to tag under ak for the unified orthography and those for Asante, Akuapem, and Fante (4 subtags). I'm not arguing for that, and recognize the potential BCP 47 issue you mention (and also, as a not-speaker wouldn't have the knowledge of the languages to make the case), but it was a thought.

This is why, in addition to clearer documentation on usage (for instance on Wikipedia), involvement of experts in the language(s) in question would be helpful. Not intending that as a criticism, but an observation.

Don

PS- A mailbox issue may have booted me off the subscriber's list - will sort it out, thanks

-----Original Message-----
From: Doug Ewell [mailto:[email-masked]] 
Sent: Sunday, May 28, 2017 2:29 PM
To: [email-masked]
Cc: Don Osborn <[email-masked]>; Michael Everson <[email-masked]>; [email-masked]
Subject: Re: [Ietf-languages] Registration requests: akuapem, asante

> not necessary to have two ISO 639 codes in this tag.

I'm not sure what you mean by "a unified approach." ISO 639 has assigned separate code elements for Twi and Fanti, and therefore individual subtags have been assigned in the LSR as well. Do you suggest that users ignore these and tag all Akan content with the macrolanguage subtag 'ak'?

I never got a response (from anyone) to my question about current tagging practice, quoted yet again below:

---

From: "Doug Ewell" <[email-masked]>
Date: Sun, 28 May 2017 16:50:00 -0600

Don Osborn wrote:

> There is a unified orthography for Akan. What does that mean when,
> say, Twi Asante, Twi Akuapem, and Fante (which from all descriptions
> are mutually intelligible) are written in it? One might refer simply
> to writing Akan (ak)? Or would new subtags for the unified orthography
> in question reference it under tw or fat?

Well, again, it really comes down to current practice. If there is no 
current practice to speak of -- if Twi and Fanti and unified-orthography 
Akan aren't being tagged at present, or if tagging is all over the 
place -- then we are in a position to encourage a best practice. A 
reasonable solution might be:

ak - for unified-orthography Akan¹
tw-akuapem - for Akuapem Twi
tw-asante - for Asante² Twi
fat - for Fanti²

¹ if it really is distinct from Twi and Fanti per se
² pick your favorite spelling

If there *is* an existing practice for tagging these languages (without 
the Twi-disambiguation variants, of course), then we ought to honor that 
and apply the new variants to the subtag(s) that is/are currently used 
for Twi. But again, someone needs to speak up and offer some evidence of 
the existing practice, or else we have no way of knowing.

> This is why, in addition to clearer documentation on usage (for
> instance on Wikipedia), involvement of experts in the language(s) in
> question would be helpful. Not intending that as a criticism, but an
> observation.

Yes, this is always something to strive for when proposing a subtag, 
especially variant subtags for a living language with 9 million speakers 
(WP).

---

From: Martin Hosken <[email-masked]>
Date: Mon, 29 May 2017 10:20:01 +0100

Dear Doug,

> reasonable solution might be:

I think your solution is a good one. But it does raise the question of whether this is the right time to add this subtag. I have a list of 3000+ dialects from one registry. We could try to add variants for them all speculatively, but that would be a lot of work much of which we would get wrong. So, I've tended to say: don't ask for a variant until you need it. Is this a right approach or not?

> especially variant subtags for a living language with 9 million speakers 

This does make it riper for resolving in this case.

Yours,
Martin

---

From: Sascha Brawer <[email-masked]>
Date: Mon, 29 May 2017 11:53:26 +0200

> So, I've tended to say: don't ask for a variant until you need it.
There’s a concrete need, namely to assign different BCP47 language tags to
these three documents:
http://www.unicode.org/udhr/d/udhr_aka_akuapem.xml
http://www.unicode.org/udhr/d/udhr_aka_asante.xml
http://www.unicode.org/udhr/d/udhr_aka_fante.xml

Currently, all three are tagged as xml:lang="ak". Based on this discussion,
it sounds like they can be tagged as xml:lang="tw-akuapem",
xml:lang="tw-asante" and xml:lang="fat" once the proposed new variant
subtags (for akuapem and asante) have been registered.

— Sascha

On Mon, May 29, 2017 at 11:20 AM, Martin Hosken <[email-masked]>
wrote:

> I think your solution is a good one. But it does raise the question of
> whether this is the right time to add this subtag. I have a list of 3000+
> dialects from one registry. We could try to add variants for them all
> speculatively, but that would be a lot of work much of which we would get
> wrong. So, I've tended to say: don't ask for a variant until you need it.
> Is this a right approach or not?
>

---

From: Michael Everson <[email-masked]>
Date: Mon, 29 May 2017 13:46:44 +0100

Um, well, three example documents on the Unicode website is not the strongest user case I’ve seen.

Michael Everson

> On 29 May 2017, at 10:53, Sascha Brawer <[email-masked]> wrote:
> 
> There’s a concrete need, namely to assign different BCP47 language tags to these three documents:
> Currently, all three are tagged as xml:lang="ak". Based on this discussion, it sounds like they can be tagged as xml:lang="tw-akuapem", xml:lang="tw-asante" and xml:lang="fat" once the proposed new variant subtags (for akuapem and asante) have been registered.
> 
> — Sascha

---

From: "Doug Ewell" <[email-masked]>
Date: Mon, 29 May 2017 17:33:06 -0600

(cc: list trimmed)

Martin Hosken wrote:

> whether this is the right time to add this subtag. I have a list of
> 3000+ dialects from one registry. We could try to add variants for
> them all speculatively, but that would be a lot of work much of which
> we would get wrong. So, I've tended to say: don't ask for a variant
> until you need it. Is this a right approach or not?

I didn't have the impression Sascha was asking for a flood of thousands 
of dialects with no demonstrated tagging need. Back on May 18 he 
mentioned the three UDHR samples.

Sascha replied:

> Currently, all three are tagged as xml:lang="ak". Based on this
> discussion, it sounds like they can be tagged as
> xml:lang="tw-akuapem", xml:lang="tw-asante" and xml:lang="fat" once
> the proposed new variant subtags (for akuapem and asante) have been
> registered.

Even without the variant subtags, "tw" and "tw" and "fat" would still 
have been better than calling them all "ak".

---

From: Peter Constable <[email-masked]>
Date: Wed, 31 May 2017 00:44:18 +0000

What I find most ironic in this case is that "tw" was coded in ISO 639:1988, and "ak" was added to ISO 639-1 in 1999. (The first edition of ISO 639-2 was published in 1998, and the first edition of ISO 639-1 was published in 2002, so it appears that "ak" was added to 639-2 while 639-1 was still in ballot.) At that point, 639-2 had a requirement that the language must be used in at least 50 documents across one to five agencies; and 639-1 had further requirements relating to use in technical documentation and terminologies. Yet in 2017 it's unclear what usage there is. 

I'm left wondering: how did "tw" get added to ISO 639:1988? 

(I've wondered since I first starting working on ISO 639 over 15 years ago how ISO 639-1 and ISO 639-2 ended up with both ak/aka and tw/twi.)

Peter

-----Original Message-----
From: Ietf-languages [mailto:[email-masked]] On Behalf Of Doug Ewell
Sent: Sunday, May 28, 2017 3:50 PM
To: Don Osborn <[email-masked]>; [email-masked]
Cc: 'Michael Everson' <[email-masked]>; [email-masked]
Subject: Re: [Ietf-languages] Registration requests: akuapem, asante

> in question reference it under tw or fat?

Well, again, it really comes down to current practice. If there is no current practice to speak of -- if Twi and Fanti and unified-orthography Akan aren't being tagged at present, or if tagging is all over the place -- then we are in a position to encourage a best practice. A reasonable solution might be:

¹ if it really is distinct from Twi and Fanti per se ² pick your favorite spelling

If there *is* an existing practice for tagging these languages (without the Twi-disambiguation variants, of course), then we ought to honor that and apply the new variants to the subtag(s) that is/are currently used for Twi. But again, someone needs to speak up and offer some evidence of the existing practice, or else we have no way of knowing.

> question would be helpful. Not intending that as a criticism, but an 

Yes, this is always something to strive for when proposing a subtag, especially variant subtags for a living language with 9 million speakers (WP).

_______________________________________________
Ietf-languages mailing list
[email-masked]
https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fietf-languages&data=02%7C01%7Cpetercon%40microsoft.com%7Caf4faaf792864a06e7ed08d4a61c08ff%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636316086735229874&sdata=4SiibdR9%2FcvE%2F25juTMa7gqraOAktW5FwW6OZCnWxw4%3D&reserved=0