Subject: [Ietf-languages] BCP 47 and subdivisions (was: RE: Montenegrin)

From: "Doug Ewell" <[email-masked]>
Date: Tue, 10 Oct 2017 11:32:52 -0700

Mark Davis wrote on the Montenegrin thread:

> And such action further muddies the line for what constitutes a
> language: one step further along a slippery slope to an "American"
> language code, or a "Texan" language code, etc.

Arthur Reutenauer replied to Mark:

> If the latter is ever requested, we may consider extending the set of
> region subtags to include ISO 3166-2 ;-)

BCP 47 extension U allows this, except that the subtags for subdivisions
are CLDR identifiers, a superset of ISO 3166-2 in which deleted 3166-2
code elements are deprecated but still present in CLDR.

CLDR subdivision codes and Extension U may not have been specifically
invented for one another, but I don't see what violation would result
from using them in this way.

John Cowan responded to Arthur:

> We considered that when writing the RFC.  But it falls down on a
> number of counts:
>
> 1) 3166-2 codes aren't freely and publicly available direct from ISO
> (although Wikipedia is pretty good about keeping its copies up to date).

Extension U solves this, by making the IP CLDR's problem instead of
ours.

> 2) They often represent merely administrative units that keep changing
> all the time: after centuries of stability in county names and
> boundaries until 1974, the UK has rearranged its administrative units
> every few years, most recently in 2015.
>
> 3) Partly because of (2), dialect boundaries don't actually follow
> ISO-3166-2 unit boundaries.

These arguments could be, and have often been, made against region
subtags in general: they are variably too broad, too narrow, and just
right.

> 4) The codes are variable-length (1-3 alphanumerics) , which does not
> fit into our rather rigid structure.

Solved by Extension U, as shown below.

> If necessary they could be added using a reserved singleton, like
> en-us-2-tx or en-gb-2-sct.

IIRC, with Extension U these would be "en-US-u-sd-ustx" and
"en-GB-u-sd-gbsct" respectively.

--
Doug Ewell | Thornton, CO, US | ewellic.org

---

From: <[email-masked]>
Date: Tue, 10 Oct 2017 19:32:16 +0000

Re-sending ...

-----Original Message-----
From: Wolf, Misha (TR Technology & Ops) 
Sent: 10 October 2017 19:37
To: [email-masked]
Subject: RE: [Ietf-languages] BCP 47 and subdivisions (was: RE: Montenegrin)

> (although Wikipedia is pretty good about keeping its copies up to date).

See:
    https://www.iso.org/obp/ui/

Regards,
Misha

---

From: John Cowan <[email-masked]>
Date: Tue, 10 Oct 2017 17:33:05 -0400

Yes, they are publicly available at 38 Swiss francs.  That doesn't count as
"freely".

On Tue, Oct 10, 2017 at 3:32 PM, <[email-masked]> wrote:

> _______________________________________________
> Ietf-languages mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-languages
>

---

From: <[email-masked]>
Date: Tue, 10 Oct 2017 22:56:41 +0000

I see them at that link and I haven’t paid anything.

Regards,
Misha

From: John Cowan [mailto:[email-masked]]
Sent: 10 October 2017 22:33
To: Wolf, Misha (TR Technology & Ops)
Cc: [email-masked]
Subject: Re: [Ietf-languages] BCP 47 and subdivisions (was: RE: Montenegrin)

Yes, they are publicly available at 38 Swiss francs.  That doesn't count as "freely".

On Tue, Oct 10, 2017 at 3:32 PM, <[email-masked]<mailto:[email-masked]>> wrote:
Re-sending ...

-----Original Message-----
From: Wolf, Misha (TR Technology & Ops)
Sent: 10 October 2017 19:37
To: [email-masked]<mailto:[email-masked]>
Subject: RE: [Ietf-languages] BCP 47 and subdivisions (was: RE: Montenegrin)

> (although Wikipedia is pretty good about keeping its copies up to date).

See:
    https://www.iso.org/obp/ui/<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.iso.org_obp_ui_&d=DwMFaQ&c=4ZIZThykDLcoWk-GVjSLmy8-1Cr1I4FWIvbLFebwKgY&r=gSZzDTMLhoJ9fH_e_ENXbFX3XT9rMPPkyhocqtbi8Xw&m=JfHtHSlhaS92mkH0H2rCZ1dDL144VP2jcuIvwKa-nsU&s=5BDxDA5f6xMD9GX_cIqvNYyCWTuFdLH-K3Iv4tYOE7Y&e=>

Regards,
Misha

_______________________________________________
Ietf-languages mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ietf-languages<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_ietf-2Dlanguages&d=DwMFaQ&c=4ZIZThykDLcoWk-GVjSLmy8-1Cr1I4FWIvbLFebwKgY&r=gSZzDTMLhoJ9fH_e_ENXbFX3XT9rMPPkyhocqtbi8Xw&m=JfHtHSlhaS92mkH0H2rCZ1dDL144VP2jcuIvwKa-nsU&s=EFGIa_iJrVNksYe1kV4BulAgRFBi73DFTR3re75y43I&e=>