Subject: [Ietf-languages] Montenegrin has been given an ISO 639-3 code

From: Michael Everson <[email-masked]>
Date: Wed, 15 Nov 2017 18:33:02 +0100

The code is “cnr”. 

This may have implications for us; we use sr-ME, do we not?

Michael Everson

---

From: "Phillips, Addison" <[email-masked]>
Date: Wed, 15 Nov 2017 18:25:56 +0000

Doesn't it have a macrolanguage? Hmm... I'd guess it would have 'sh' as a macrolanguage, which isn't helpful.

"sr-ME" means Serbian as used in Montenegro. "cnr-ME" would mean Montenegrin as used in Montenegro. Both will be valid tags after 'cnr' goes in the registry. Users will probably get better results using 'sr' than 'cnr' for general interchange (such as on the Web), but they are welcome to use 'cnr' if it helps them, I suppose.

Addison

Addison Phillips
Principal SDE, I18N Architect (Amazon)
Chair (W3C I18N WG)

Internationalization is not a feature.
It is an architecture.

> -----Original Message-----
> From: Ietf-languages [mailto:[email-masked]] On Behalf Of
> Michael Everson
> Sent: Wednesday, November 15, 2017 9:33 AM
> To: IETF Languages Discussion <[email-masked]>
> Subject: [Ietf-languages] Montenegrin has been given an ISO 639-3 code
> 
> The code is “cnr”.
> 
> _______________________________________________
> Ietf-languages mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-languages

---

From: Peter Constable <[email-masked]>
Date: Wed, 15 Nov 2017 19:04:44 +0000

Yes, sh/hbs is the macrolanguage encompassing cnr. That macrolanguage also encompasses bs/bos, hr/hrv and sr/srp.

Peter

-----Original Message-----
From: Ietf-languages [mailto:[email-masked]] On Behalf Of Phillips, Addison
Sent: Wednesday, November 15, 2017 10:26 AM
To: Michael Everson <[email-masked]>; IETF Languages Discussion <[email-masked]>
Subject: Re: [Ietf-languages] Montenegrin has been given an ISO 639-3 code

Addison

Addison Phillips

> From: Ietf-languages [mailto:[email-masked]] On 
> Behalf Of Michael Everson
> https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.i
> etf.org%2Fmailman%2Flistinfo%2Fietf-languages&data=02%7C01%7Cpetercon%
> 40microsoft.com%7C15a8e4eb8a924e74665808d52c57a090%7C72f988bf86f141af9
> 1ab2d7cd011db47%7C1%7C0%7C636463677226848779&sdata=ER38CszzKdikhqBUEe7
> BcnsmiBsC%2Fm5aJtcBm4u9S34%3D&reserved=0
_______________________________________________
Ietf-languages mailing list
[email-masked]
https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fietf-languages&data=02%7C01%7Cpetercon%40microsoft.com%7C15a8e4eb8a924e74665808d52c57a090%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636463677226848779&sdata=ER38CszzKdikhqBUEe7BcnsmiBsC%2Fm5aJtcBm4u9S34%3D&reserved=0

---

From: John Cowan <[email-masked]>
Date: Wed, 15 Nov 2017 16:41:43 -0500

We have informally recommended that people use "sr-ME" to represent
Montenegrin varieties of Naš Jezik, since they are closest to Standard
Serbian.  Now they should probably use "cnr" without a country code.  This
whole area remains a mess, with large numbers of varieties of N.J. lacking
a code more specific than "sh".