Subject: [Ietf-languages] Revised forms for Montenegrin (was: RE: Macrolanguage)

From: "Doug Ewell" <[email-masked]>
Date: Mon, 08 Jan 2018 08:55:22 -0700

Kent Karlsson wrote:

> But that form lacks the macrolanguage bit. The 639-3 registration
> includes the macrolanguage.

Great point. Below are the revised forms for Montenegrin, with the
Macrolanguage field added and with a note in the registration form about
both 639-2 and 639-3 adding the code element (the effective date was the
same for both). I'm also re-posting the Serbian forms although there are
no changes there.

The review period runs through Monday, January 22 AoE.

---

LANGUAGE SUBTAG MODIFICATION
File-Date: 2018-xx-xx
%%
Type: language
Subtag: cnr
Description: Montenegrin
Added: 2018-xx-xx
Macrolanguage: sh
Comments: see sr for Serbian
%%

---

LANGUAGE SUBTAG REGISTRATION FORM

1. Name of requester: Doug Ewell
2. E-mail address of requester: doug at ewellic.org

3. Record Requested:

Type: language
Subtag: cnr
Description: Montenegrin
Macrolanguage: sh
Comments: see sr for Serbian

4. Intended meaning of the subtag:

5. Reference to published description of the language (book or article):

6. Any other relevant information:

This registration tracks a change made to ISO 639-2 and 639-3 effective
2017-12-21, adding the code element 'cnr' for Montenegrin.

The ISO 639-2/RA Change Notice that includes this change is available at
http://www.loc.gov/standards/iso639-2/php/code_changes.php .

--

LANGUAGE SUBTAG MODIFICATION
File-Date: 2018-xx-xx
%%
Type: language
Subtag: sr
Description: Serbian
Added: 2005-10-16
Macrolanguage: sh
Comments: see cnr for Montenegrin
%%

--

LANGUAGE SUBTAG REGISTRATION FORM

1. Name of requester: Doug Ewell
2. E-mail address of requester: doug at ewellic.org

3. Record Requested:

Type: language
Subtag: sr
Description: Serbian
Macrolanguage: sh
Comments: see cnr for Montenegrin

4. Intended meaning of the subtag:

5. Reference to published description of the language (book or article):

6. Any other relevant information:

This registration adds a Comments field to the existing record for
language subtag 'sr', providing a cross-reference to the new language
subtag 'cnr' for Montenegrin, which was previously tagged as 'sr'.

--
Doug Ewell | Thornton, CO, US | ewellic.org

---

From: Kent Karlsson <[email-masked]>
Date: Mon, 08 Jan 2018 22:17:52 +0100

If we are to have comments like:

  Comments: see <every other language code under the same macrolanguage>
     for <every other language under the same macrolanguage>

then we should do so systematically. We don't seem to have them for any
other macrolanguage, so why for 'sh' (and then only partial such comments)?

We have a fow comment like "see ...", mostly for deprecated stuff, but they
do not have this format.

/Kent K

Den 2018-01-08 16:55, skrev "Doug Ewell" <[email-masked]>:

> _______________________________________________
> Ietf-languages mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-languages

---

From: John Cowan <[email-masked]>
Date: Mon, 8 Jan 2018 16:38:58 -0500

On Mon, Jan 8, 2018 at 4:17 PM, Kent Karlsson <[email-masked]>
wrote:

> other macrolanguage, so why for 'sh' (and then only partial such comments)
>

Because "Serbo-Croatian" is not a name people use any more.

-- 
 John Cowan          http://vrici.lojban.org/~cowan        [email-masked]
I come from under the hill, and under the hills and over the hills my paths
led. And through the air. I am he that walks unseen.  I am the clue-finder,
the web-cutter, the stinging fly. I was chosen for the lucky number.
--Bilbo