Subject: Re: [Ietf-languages] Click letters in ISO 639-3 and Registry (long)

From: Mark Davis ☕️ <[email-masked]>
Date: Mon, 8 Oct 2018 14:29:50 +0200

Revisiting this because I happened on
=/Kx'au//'ein
which caused a spreadsheet to hiccough (not prepared for initial ASCII =).
It would be far better to use ≠ rather than =/.

I would really like to see all the ASCII hacks removed, and replaced with
either the correct character or an escaped version thereof. BTW, as for
02BC, in CLDR we ended up mapping that to 2019, because nobody is
consistent about the distinction. (The danger of having two identical
characters, not separated by script.)

Mark

On Thu, Mar 15, 2018 at 5:47 PM Arthur Reutenauer <
[email-masked]> wrote:

> On Sat, Mar 10, 2018 at 06:59:06PM -0700, Doug Ewell wrote:
> > Michael Everson wrote:
> >
> >> Those two are ejectives, so the should use 02BC.
> >
> > and Arthur Reutenauer replied:
> >
> >> Actually, according to Wikipedia, the apostrophe-like character
> > >indicates glottalisation after a click, and ejectiveness (is that a
> > >word?) after other consonants, but I agree, the character definitely
> > >is U+02BC in all cases.
> >
> > Mark and others, do you agree? Can we recommend spellings to 639-3/RA for
> > these two languages using this character? Remember we are NOT trying to
> > solve the apostrophe problem for all language names, let alone for
> running
> > text in these languages and others (such as Polynesian languages).
> >
> > What about the click characters in my original post of February 27? ( ǀ
> ǁ ǂ
> > ǃ ) Can we agree on the names using these characters as I posted?
>
>   I agree to all the names you’ve suggested in that email, and to not
> use ASCII fallbacks in the registry.
>
> > What about ASCII fallbacks? We will need to give the RA something to put
> in
> > their Latin-1–restricted files. They are currently using ( | || ! ) which
> > seem OK, and ( ‡ ) which is awful and not even Latin-1. Can we recommend
> > that they use ( | || |= ! ) plus U+0027 for the glottal-ejective-whatever
> > apostrophe?
>
>   Actually, they’re only using ‡ once in the UTF-8 file, in ASCII it’s =/
> which to be consistent we could recommend replacing by =| instead.  I
> agree with all the rest.
>
>         Best,
>
>                 Arthur
>
> _______________________________________________
> Ietf-languages mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-languages
>

---

From: Michael Everson <[email-masked]>
Date: Mon, 8 Oct 2018 13:48:31 +0100

On 8 Oct 2018, at 13:29, Mark Davis ☕️ <[email-masked]> wrote:

> BTW, as for 02BC, in CLDR we ended up mapping that to 2019, because nobody is consistent about the distinction. (The danger of having two identical characters, not separated by script.) 

That was a bad idea. I’ve been publishing material in the Hawaiian language for some time now (Alice, Looking-Glass, the Wizard of Oz, Harry Potter, and more in preparation).

It is NOT possible to read Hawaiian narrative texts (you know, with conversational dialogue between characters, using quotation marks and nested quotation marks) if the quotation marks and the glottal stop are identical. Whatever the origin of the modifier letter apostrophe, if it is not distinguished from the quotation marks, the text becomes illegible. We found that retaining the circular shape of the dot in the comma-shaped 02BC but increasing the size of the character to 140% of the original makes a good, legible character.

At some stage (in my non-existent abundant spare time) I should write a Unicode Technical Note about this. But the status quo is not acceptable to actual readers of the language. (Same goes for Sāmoan and Tongan.) 

Michael Everson

---

From: Arthur Reutenauer <[email-masked]>
Date: Mon, 8 Oct 2018 14:45:49 +0200

On Mon, Oct 08, 2018 at 02:29:50PM +0200, Mark Davis ☕️ wrote:
> which caused a spreadsheet to hiccough (not prepared for initial ASCII =)..

  Since ≠ (U+2260) is neither latin-1 nor ASCII, is there any advantage
to refraining from using the real character (U+01C2 ǂ)?

> characters, not separated by script.)

  That may be wise; there is definitely a grey area with many ambiguous
cases.  Around the time of that discussion I researched some of the 100+
language names from ISO 639-3 containing apostrophe-like characters, and
it was sometimes really hard to decide between U+02BC and U+2019, in
particular.  (It was however really instructive to investigate all these
language names.)

	Best,

		Arthur

---

From: Arthur Reutenauer <[email-masked]>
Date: Mon, 8 Oct 2018 14:57:33 +0200

> It is NOT possible to read Hawaiian narrative texts (you know, with conversational dialogue between characters, using quotation marks and nested quotation marks) if the quotation marks and the glot…

  Note that Mark is talking about U+02BC, not U+02BB which, as I
understand, is commonly used to represent the Hawaiian ʻokina.

	Best,

		Arthur

---

From: Michael Everson <[email-masked]>
Date: Mon, 8 Oct 2018 14:49:58 +0100

I suspect that the principle must hold true for all of these characters.

> On 8 Oct 2018, at 13:57, Arthur Reutenauer <[email-masked]> wrote:
>

---

From: Mark Davis ☕️ <[email-masked]>
Date: Mon, 8 Oct 2018 16:18:12 +0200

Sorry, I miswrote: yes, U+01C2 ǂ is the right one.

Mark

---

From: Mark Davis ☕️ <[email-masked]>
Date: Mon, 8 Oct 2018 16:44:30 +0200

> We found that retaining the circular shape of the dot in the comma-shaped
02BC but increasing the size of the character to 140% of the original makes
a good, legible character.

At the time that these were encoded, there was no distinction made in the
appearance of  \u{2019} and \u{2BC} or of \u{2018} and \u{2BB}. And that is
the policy followed by fonts in general, eg:

… ’ and ʼ or of ‘ and ʻ …

Of course, one can design a special font to make them distinct. But if
there is free variation among users as to what they type, and if a majority
of widespread fonts don't distinguish them, it just causes confusion (and
mismatches) to artificially separate them. It's like the old proposal to
distinguish . as sentence terminator from . as abbreviation terminator from
. as number grouping separator from . as number decimal separator. Nice
idea in theory, but only in theory.

Mark

On Mon, Oct 8, 2018 at 2:49 PM Michael Everson <[email-masked]> wrote:

> > BTW, as for 02BC, in CLDR we ended up mapping that to 2019, because
> nobody is consistent about the distinction. (The danger of having two
> identical characters, not separated by script.)
>
> That was a bad idea. I’ve been publishing material in the Hawaiian
> language for some time now (Alice, Looking-Glass, the Wizard of Oz, Harry
> Potter, and more in preparation).
>
> It is NOT possible to read Hawaiian narrative texts (you know, with
> conversational dialogue between characters, using quotation marks and
> nested quotation marks) if the quotation marks and the glottal stop are
> identical. Whatever the origin of the modifier letter apostrophe, if it is
> not distinguished from the quotation marks, the text becomes illegible. We
> found that retaining the circular shape of the dot in the comma-shaped 02BC
> but increasing the size of the character to 140% of the original makes a
> good, legible character.
>
> At some stage (in my non-existent abundant spare time) I should write a
> Unicode Technical Note about this. But the status quo is not acceptable to
> actual readers of the language. (Same goes for Sāmoan and Tongan.)
>
> Michael Everson