Subject: [Ietf-message-headers] [ietf-message-headers] Provisional registration for traceparent and tracestate

From: Philippe Le Hégaret <[email-masked]>
Date: Wed, 28 Nov 2018 16:57:51 -0500

The Trace Context specification defines the following headers:

* traceparent
   https://www.w3.org/TR/trace-context/#traceparent-field

* tracestate
   https://www.w3.org/TR/trace-context/#tracestate-field

Both are applicable to the http protocol.

Philippe

---

From: Martin J. Dürst <[email-masked]>
Date: Thu, 29 Nov 2018 04:16:54 +0000

Hello Philippe,

Please post the actual registration templates to this list. That 
increases the chance of getting useful comments.

Regards,   Martin.

---

From: Philippe Le Hégaret <[email-masked]>
Date: Thu, 29 Nov 2018 07:54:02 -0500

On 11/28/2018 11:16 PM, Martin J. Dürst wrote:> Hello Philippe,
 > increases the chance of getting useful comments.

Hi Martin,

Here are the templates:

Header field name: traceparent
Applicable protocol: http
Status: provisional
Change Controller:
  Distributed Tracing Working Group
  https://www.w3.org/2018/distributed-tracing/
  [email-masked]
Specification:
  https://www.w3.org/TR/trace-context/#traceparent-field

Header field name: tracestate
Applicable protocol: http
Status: provisional
Change Controller:
  Distributed Tracing Working Group
  https://www.w3.org/2018/distributed-tracing/
  [email-masked]
Specification:
  https://www.w3.org/TR/trace-context/#tracestate-field

Philippe