Subject: [Ietf-message-headers] Updates to registration request for EntityId, Isolation, OData-MaxVersion, and OData-Version

From: Chet Ensign <[email-masked]>
Date: Thu, 6 Dec 2018 13:05:08 -0500

This message contains an update to the registration request submitted on
August 29 2018 in
https://www.ietf.org/mail-archive/web/ietf-message-headers/current/msg00195.html

In response to this request, on August 29, in
https://www.ietf.org/mail-archive/web/ietf-message-headers/current/msg00196.html,
Ted Hardie wrote:

---

I'm a little confused on one point.  The Isolation header states that it
was called OData-Isolation in version 4.0, but the linked ABNF document
says:

isolation  = [ "OData-" ] "Isolation" ":" OWS "snapshot"

That seems to indicate that both ODate-Isolation and Isolation are expected
to be valid for this token.  The ABNF for EntityID is similar:

entityid   = [ "OData-" ] "EntityID" ":" OWS IRI-in-header

Can you clarify the intent here?  Are both expressions of this token
expected to continue?

In general, "Isolation" seems to be a very general concept, and the
reservation of it, unadorned, for a single token use ("snapshot") is
somewhat surprising compared to the more-obviously scoped OData-isolation.
EntityID seems similar board in possible usage outside the OData
specification.

---

In response, the TC renamed EntityId header to OData-EntityId and added
additional values for the Isolation header to align with most database
systems.

On August 30, in
https://www.ietf.org/mail-archive/web/ietf-message-headers/current/msg00197.html,
Mark Nottingham wrote:

---

"Applicable protocol" should be "http", I think.

---

In response, the TC changed the Applicable protocol to http.

Below, please find the revised request. I have included the prior values in
[ ]s so that all the changes are visible.

Please let us know if this addresses your comments and if you have any
other questions or concerns.

---

Open Data (OData) Protocol IANA Header registration request
28-Nov-2018

This documentation contains the information needed for Permanent
Registration of the OData specific request headers with IANA as called out
in RFC 3864 - Registration Procedures for Message Header Fields.

The OData headers to be registered as Permanent Headers are

OData-EntityId  [WAS EntityID]
Isolation
OData-MaxVersion
OData-Version

The details as required by RFC 3864 for these headers are listed below

####
Header field name:
OData-EntityId  [WAS EntityID]

Applicable protocol:
http   [WAS OASIS Open Data Protocol (OData)]

Status:
Standard

Author/Change controller:
OASIS

Specification document(s):
OData Version 4.01 Part 1: Protocol -
http://docs.oasis-open.org/odata/odata/v4.01/odata-v4.01-part1-protocol.html#sec_HeaderEntityIdODataEntityId

Related information:
    None  [WAS The EntityId header was named OData-EntityId in OData
version 4.0.]

####
Header field name:
Isolation

Applicable protocol:
http   [WAS OASIS Open Data Protocol (OData)]

Status:
Standard

Author/Change controller:
OASIS

Specification document(s):
OData Version 4.01 Part 1: Protocol -
http://docs.oasis-open.org/odata/odata/v4.01/odata-v4.01-part1-protocol.html#sec_HeaderIsolationODataIsolation

Related information:
The Isolation header was named OData-Isolation in OData version 4.0.  The
OData Protocol document referenced above defines one valid value,
snapshot.  To make this header useful to applications other than OData this
registration also defines the values read-uncommitted, read-committed,
repeatable-read and serializable.  These correspond to the standard
transaction isolation levels exposed by most database systems.
   [WAS The Isolation header was named OData-Isolation in OData version
4.0.]

####
Header field name:
OData-MaxVersion

Applicable protocol:
http   [WAS OASIS Open Data Protocol (OData)]

Status:
Standard

Author/Change controller:
OASIS

Specification document(s):
OData Version 4.01 Part 1: Protocol -
http://docs.oasis-open.org/odata/odata/v4.01/odata-v4.01-part1-protocol.html#sec_HeaderODataMaxVersion

Related information:
<none>

####
Header field name:
OData-Version

Applicable protocol:
http   [WAS OASIS Open Data Protocol (OData)]

Status:
Standard

Author/Change controller:
OASIS

Specification document(s):
OData Version 4.01 Part 1: Protocol -
http://docs.oasis-open.org/odata/odata/v4.01/odata-v4.01-part1-protocol.html#sec_HeaderODataVersion

Related information:
<none>

-- 

/chet
----------------
Chet Ensign
Chief Technical Community Steward
OASIS: Advancing open standards for the information society
http://www.oasis-open.org

Primary: +1 973-996-2298
Mobile: +1 201-341-1393

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 7 Dec 2018 11:57:33 +1100

Chet,

Can you speak to why the request is still for "Isolation", instead of "OData-Isolation"?

Cheers,

> On 7 Dec 2018, at 5:05 am, Chet Ensign <[email-masked]> wrote:
> 
> This message contains an update to the registration request submitted on August 29 2018 in https://www.ietf.org/mail-archive/web/ietf-message-headers/current/msg00195.html
> 
> In response to this request, on August 29, in https://www.ietf.org/mail-archive/web/ietf-message-headers/current/msg00196.html, Ted Hardie wrote: 
> 
> ---
> 
> I'm a little confused on one point.  The Isolation header states that it was called OData-Isolation in version 4.0, but the linked ABNF document says:
> 
> That seems to indicate that both ODate-Isolation and Isolation are expected to be valid for this token.  The ABNF for EntityID is similar:
> 
> Can you clarify the intent here?  Are both expressions of this token expected to continue?
> 
> In general, "Isolation" seems to be a very general concept, and the reservation of it, unadorned, for a single token use ("snapshot") is somewhat surprising compared to the more-obviously scoped OData-isolation.  EntityID seems similar board in possible usage outside the OData specification.  
> 
> ---
> 
> In response, the TC renamed EntityId header to OData-EntityId and added additional values for the Isolation header to align with most database systems. 
> 
> 
> On August 30, in https://www.ietf.org/mail-archive/web/ietf-message-headers/current/msg00197.html, Mark Nottingham wrote: 
> 
> --- 
> 
> Below, please find the revised request. I have included the prior values in [ ]s so that all the changes are visible. 
> 
> Please let us know if this addresses your comments and if you have any other questions or concerns. 
> 
> ---
> 
> This documentation contains the information needed for Permanent Registration of the OData specific request headers with IANA as called out in RFC 3864 - Registration Procedures for Message Header Fields.
> 
>     None  [WAS The EntityId header was named OData-EntityId in OData version 4.0.]
> 
> 
> ####
> Header field name:
> 	Isolation
> 
> Applicable protocol:
> The Isolation header was named OData-Isolation in OData version 4.0.  The OData Protocol document referenced above defines one valid value, snapshot.  To make this header useful to applications other than OData this registration also defines the values read-uncommitted, read-committed, repeatable-read and serializable.  These correspond to the standard transaction isolation levels exposed by most database systems.   
>    [WAS The Isolation header was named OData-Isolation in OData version 4.0.]
> 
> 
> ####
> Header field name:
> 	OData-MaxVersion
> 
> Applicable protocol:
> _______________________________________________
> Ietf-message-headers mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-message-headers

--
Mark Nottingham   https://www.mnot.net/

---

From: "Handl, Ralf" <[email-masked]>
Date: Fri, 7 Dec 2018 15:23:08 +0000

Hi Mark,

We no longer want to reserve it for single token use and instead want to register five values: read-uncommitted, read-committed, repeatable-read, snapshot, and serializable.

Thanks
Ralf

-----Original Message-----
From: Mark Nottingham <[email-masked]> 
Sent: Freitag, 7. Dezember 2018 01:58
To: Chet Ensign <[email-masked]>
Cc: [email-masked]; Handl, Ralf <[email-masked]>
Subject: Re: [Ietf-message-headers] Updates to registration request for EntityId, Isolation, OData-MaxVersion, and OData-Version

Chet,

Cheers,

---

From: Chet Ensign <[email-masked]>
Date: Tue, 18 Dec 2018 16:28:12 -0500

Hi Mark,

Can you advise on the best way to proceed? Should I work with the TC to
draft a revised registration request?

Thank you,

/chet

On Fri, Dec 7, 2018 at 10:23 AM Handl, Ralf <[email-masked]> wrote:

> Hi Mark,
>
> We no longer want to reserve it for single token use and instead want to
> register five values: read-uncommitted, read-committed, repeatable-read,
> snapshot, and serializable.
>
> Thanks
> Ralf
>
> Subject: Re: [Ietf-message-headers] Updates to registration request for
> EntityId, Isolation, OData-MaxVersion, and OData-Version
>
> Chet,
>
> > That seems to indicate that both ODate-Isolation and Isolation are
> expected to be valid for this token.  The ABNF for EntityID is similar:
> >
> > Below, please find the revised request. I have included the prior values
> in [ ]s so that all the changes are visible.
> >
> > The Isolation header was named OData-Isolation in OData version 4.0.
> The OData Protocol document referenced above defines one valid value,

-- 

/chet
----------------
Chet Ensign

Primary: +1 973-996-2298
Mobile: +1 201-341-1393

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 20 Dec 2018 19:07:49 +1100

Hi Chet,

I have to admit I was confused by Ralf's response. The purpose of asking why "Isolation" was chosen instead of "OData-Isolation" was to draw out how this header was potentially generic (i.e., applicable to other things than OData).

Cheers,

> On 19 Dec 2018, at 8:28 am, Chet Ensign <[email-masked]> wrote:
> 
> Hi Mark, 
> 
> Can you advise on the best way to proceed? Should I work with the TC to draft a revised registration request? 
> 
> Thank you, 
> 
> /chet 
>

---

From: Chet Ensign <[email-masked]>
Date: Thu, 20 Dec 2018 08:59:29 -0500

Thanks Mark. I will follow up with Ralf and the TC and get back to you.

/chet

On Thu, Dec 20, 2018 at 3:07 AM Mark Nottingham <[email-masked]> wrote:

> Hi Chet,
>
> I have to admit I was confused by Ralf's response. The purpose of asking
> why "Isolation" was chosen instead of "OData-Isolation" was to draw out how
> this header was potentially generic (i.e., applicable to other things than
> OData).
>
> Cheers,
>
>
> > > This message contains an update to the registration request submitted
> on August 29 2018 in
> > > I'm a little confused on one point.  The Isolation header states that
> it was called OData-Isolation in version 4.0, but the linked ABNF document
> says:
> > >
> > > In response, the TC renamed EntityId header to OData-EntityId and
> added additional values for the Isolation header to align with most
> database systems.
> > >
> > >
> > > On August 30, in
> > > Below, please find the revised request. I have included the prior
> values in [ ]s so that all the changes are visible.
> > >

-- 

/chet
----------------
Chet Ensign

Primary: +1 973-996-2298
Mobile: +1 201-341-1393