Subject: Re: [Ietf-message-headers] Requesting provisional registration for AMP-Cache-Transform header

From: Mark Nottingham <[email-masked]>
Date: Tue, 5 Feb 2019 14:45:02 +1100

Hi Devin,

Sorry for the delay; I saw this a while ago but didn't look into it deeply. For future reference, you're much more likely to get reviews if you send this to the HTTP WG mailing list (we're in the process of separating HTTP headers out into their own registry, in part to make that more clear).

Without commenting on the entire document you link to, it says:

> Therefore, the need arises for the origin to distinguish requests from users and requests from SXG intermediaries. That is, there is a difference between "I can understand the SXG format" and "I prefer an SXG if available". Accept: application/signed-exchange indicates the former. No currently-defined header indicates the latter.

However, Accept *can* express that; e.g.,

Accept: application/signed-exchange;q=1.0, */*;q=0.05

Did you consider using qvalues in the accept header to achieve this?

Cheers,

P.S. It may be good to follow up on [email-masked], and then report the result back here. I haven't CC:ed them to avoid cross-posting.

> On 7 Sep 2018, at 10:33 am, Devin Mullins <twifkak=[email-masked]> wrote:
> 
> Header field name: AMP-Cache-Transform
> Applicable protocol: http
> Status: provisional
> Author: Devin Mullins <[email-masked]>; Google; https://www.ampproject.org/
> Specification: https://github.com/ampproject/amphtml/blob/master/spec/amp-cache-transform.md
> 
> Let me know what other information I can provide.
> 
> Thanks!
> Devin
> _______________________________________________
> Ietf-message-headers mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-message-headers

--
Mark Nottingham   https://www.mnot.net/

---

From: Devin Mullins <[email-masked]>
Date: Fri, 22 Feb 2019 19:10:55 -0800

Hi Mark, thanks for the reply. Just a short FYI, I replied with details to
ietf-http-wg last week. It is pending moderator approval; I contacted the
moderator & will let this list know the results of that discussion once
it's happened.

On Mon, Feb 4, 2019 at 7:45 PM Mark Nottingham <[email-masked]> wrote:

> Hi Devin,
>
> Sorry for the delay; I saw this a while ago but didn't look into it
> deeply. For future reference, you're much more likely to get reviews if you
> send this to the HTTP WG mailing list (we're in the process of separating
> HTTP headers out into their own registry, in part to make that more clear).
>
> > Therefore, the need arises for the origin to distinguish requests from
> users and requests from SXG intermediaries. That is, there is a difference
> between "I can understand the SXG format" and "I prefer an SXG if
> available". Accept: application/signed-exchange indicates the former. No
> currently-defined header indicates the latter.
>
> P.S. It may be good to follow up on [email-masked], and then report
> the result back here. I haven't CC:ed them to avoid cross-posting.
>
>
>
> > Specification:
> https://github.com/ampproject/amphtml/blob/master/spec/amp-cache-transform..md
> >