Subject: [ietf-types] Review requested for draft-ietf-sidr-repos-struct

From: Stewart Bryant <[email-masked]>
Date: Fri, 17 Jun 2011 14:14:52 +0100

draft-ietf-sidr-repos-struct

https://datatracker.ietf.org/doc/draft-ietf-sidr-repos-struct/

Makes the following types request.

Review comments by 1 July would be appreciated.

Many thanks

- Stewart

7.1.1.  application/rpki-manifest

    MIME media type name:  application
    MIME subtype name:  rpki-manifest
    Required parameters:  None
    Optional parameters:  None
    Encoding considerations:  binary
    Security considerations:  Carries a RPKI Manifest
       [I-D.ietf-sidr-rpki-manifests].
    Interoperability considerations:  None
    Published specification:  This document
    Applications which use this media type:  Any MIME-complaint transport
    Additional information:
       Magic number(s):  None
       File extension(s):  .mft
       Macintosh File Type Code(s):
    Person&  email address to contact for further information:  Geoff
       Huston<[email-masked]>
    Intended usage:  COMMON
    Author/Change controller:  Geoff Huston<[email-masked]>

7.1.2.  application/rpki-roa

    MIME media type name:  application>
    MIME subtype name:  rpki-roa
    Required parameters:  None
    Optional parameters:  None
    Encoding considerations:  binary
    Security considerations:  Carries a RPKI ROA
       [I-D.ietf-sidr-roa-format]
    Interoperability considerations:  None

Huston, et al.          Expires December 10, 2011              [Page 12]
Internet-Draft        ResCert Repository Structure             June 2011

    Published specification:  This document
    Applications which use this media type:  Any MIME-complaint transport
    Additional information:
       Magic number(s):  None
       File extension(s):  .roa
       Macintosh File Type Code(s):
    Person&  email address to contact for further information:  Geoff
       Huston<[email-masked]>
    Intended usage:  COMMON
    Author/Change controller:  Geoff Huston<[email-masked]>

---

From: Bjoern Hoehrmann <[email-masked]>
Date: Fri, 17 Jun 2011 15:22:01 +0200

>    MIME subtype name:  rpki-manifest

This uses an outdated template, the current template is in RFC 4288.

>       [I-D.ietf-sidr-rpki-manifests].

This should perhaps reference the Security Considerations of that
document then.

>    Applications which use this media type:  Any MIME-complaint transport

This should say something more like "3D Modeling Software".

(Same comments apply to the other type.)
-- 
Björn Höhrmann · mailto:[email-masked] · http://bjoern.hoehrmann.de
Am Badedeich 7 · Telefon: +49(0)160/4415681 · http://www.bjoernsworld.de
25899 Dagebüll · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/

---

From: Peter Saint-Andre <[email-masked]>
Date: Fri, 17 Jun 2011 08:52:23 -0600

> This uses an outdated template, the current template is in RFC 4288.

Bjoern, I notice that many of your reviews start with "this uses an
outdated template". Do we need to update pointers somewhere so that
people know which template to use?

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Chris Lilley <[email-masked]>
Date: Fri, 17 Jun 2011 17:00:01 +0200

On Friday, June 17, 2011, 4:52:23 PM, Peter wrote:

>> This uses an outdated template, the current template is in RFC 4288.

PSA> Bjoern, I notice that many of your reviews start with "this uses an
PSA> outdated template". Do we need to update pointers somewhere so that
PSA> people know which template to use?

People reading RFC 4288  know
a) which template to use
b) that it obsoletes RFC 2048

People reading RFC 2048 think they know
a) which template to use

and they know that it obsoletes some older RFCs but don't know (from reading the text) that it is obsoleted by RFC 4288.

I have seen a checker for documents, to make sure the referenced RFCs are up to date; is there a tool (that doesn't start with a document), to see if a single RFC is the latest?

Also, I assume its a policy decision that RFCs once published are never updated to say that they are obsoleted; but perhapsit is time to review that decision? I imagine most people consult an online copy nowadays rather than taking out a dusty pile of lineprinter paper to read.

-- 
 Chris Lilley   Technical Director, Interaction Domain                 
 W3C Graphics Activity Lead, Fonts Activity Lead
 Co-Chair, W3C Hypertext CG
 Member, CSS, WebFonts, SVG Working Groups

---

From: Peter Saint-Andre <[email-masked]>
Date: Fri, 17 Jun 2011 09:07:43 -0600

On 6/17/11 9:00 AM, Chris Lilley wrote:
>>>> MIME media type name:  application MIME subtype name:
>>>> rpki-manifest
> 
> PSA> Bjoern, I notice that many of your reviews start with "this uses
> an PSA> outdated template". Do we need to update pointers somewhere
> so that PSA> people know which template to use?
> 
> People reading RFC 4288  know a) which template to use b) that it
> obsoletes RFC 2048
> 
> People reading RFC 2048 think they know a) which template to use
> 
> and they know that it obsoletes some older RFCs but don't know (from
> reading the text) that it is obsoleted by RFC 4288.

People reading http://tools.ietf.org/html/rfc2048 know that it's been
obsoleted, but the plain text versions don't have the forward link.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: "Martin J. Dürst" <[email-masked]>
Date: Sat, 18 Jun 2011 14:46:14 +0900

> Also, I assume its a policy decision that RFCs once published are never updated to say that they are obsoleted; but perhapsit is time to review that decision? I imagine most people consult an onlin…

If you look at the 'right' copy online, e.g. 
http://tools.ietf.org/html/rfc2048, then it actually gets updated :-). 
So one way to help with this is to use the 'right' reference where 
possible (e.g. in the W3C), and to push this kind of format (or a 
similar one) from the IETF and the RFC Editor.

Regards,   Martin.

---

From: Julian Reschke <[email-masked]>
Date: Sat, 18 Jun 2011 10:10:16 +0200

On 2011-06-17 17:00, Chris Lilley wrote:
> ...

Nowadays there's a status page at rfc-editor.org, for instance:

   http://www.rfc-editor.org/info/rfc2048

And yes, this link appears in the new RFCs as well; but as you have 
observed this doesn't help with old ones.

And, as Martin pointed out, the HTMLized versions on tools.ietf.org are 
very useful. Use them whenever you can (despite they are not the 
"canonical" versions).

Best regards, Julian

---

From: Eric Prud'hommeaux <[email-masked]>
Date: Sat, 18 Jun 2011 11:54:04 -0400

* "Martin J. Dürst" <[email-masked]> [2011-06-18 14:46+0900]
> http://tools.ietf.org/html/rfc2048, then it actually gets updated
> :-). So one way to help with this is to use the 'right' reference
> where possible (e.g. in the W3C), and to push this kind of format
> (or a similar one) from the IETF and the RFC Editor.

If that is indeed the 'right' reference, I'd certainly prefer to reference the HTML, with anchors and all that web-y stuff, over http://www.ietf.org/rfc/rfc*.txt. Iirc, the /html/ dir started sort of unofficially, with a few RFCs offered as an aid to a growingly hypertext web. The decades have past and no doubt social contracts have changed; is there enough of a guarantee of stability that ISO, OASIS, W3C, journals etc. can reference the HTML versions?

> Regards,   Martin.
> _______________________________________________
> ietf-types mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-types

-- 
-ericP

---

From: Paul Libbrecht <[email-masked]>
Date: Sat, 18 Jun 2011 22:37:56 +0200

Stewart,

would you consider adding information in this registration request about names of the clipboard flavors?
My modest experience has shown me that importing files with certificates is rather a painful approach but drag-and-dropping or copy-and-pasting them worked much better.

If you agree, I would suggest a Windows Flavor Name (e.g. "RPKI Manifest") and Macintosh Uniform Type Identifier (e.g. "public.rpki.manifest").

paul

---

From: "Martin J. Dürst" <[email-masked]>
Date: Mon, 20 Jun 2011 12:40:58 +0900

Hello Eric,

On 2011/06/19 0:54, Eric Prud'hommeaux wrote:
> * "Martin J. Dürst"<[email-masked]>  [2011-06-18 14:46+0900]

> If that is indeed the 'right' reference, I'd certainly prefer to reference the HTML, with anchors and all that web-y stuff, over http://www.ietf.org/rfc/rfc*.txt. Iirc, the /html/ dir started sort…

In my understanding, the "official" answer to this question would still 
be: The *right* reference is referencing the RFC as such, without any 
link, the same way it would have been done pre-Web.

Of course, that's not very user-friendly these days, so that's why many 
formats add a link. Once you do that, you have to balance 
user-friendliness and stability yourself. Also, the more you use links 
to a particular location, the more you create social pressure to not 
change that. And in the end, if the link ever goes away, people will 
still know how to search for the RFC anyway. The rest is your choice.

Regards,   Martin.

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 20 Jun 2011 11:48:25 +0100

Hi Paul

Thank you for the suggestion.

RTG will follow IETF best practice on this and to that end
I will take the advice of my IESG colleges who are have
more experience with ietf-types.

- Stewart

-- 
For corporate legal information go to:

http://www.cisco.com/web/about/doing_business/legal/cri/index.html