Subject: [ietf-types] Registration of media type text/vnd.matriksoft.mfff.description+xml

From: Mateusz Karcz <[email-masked]>
Date: Sun, 12 Feb 2012 01:35:48 +0100

Type name:
 text
Subtype name:
 vnd.matriksoft.mfff.description+xml
Required parameters:
 revision <- defined in 
Optional parameters:
 charset <- Same as charset parameter of text/xml as specified in RFC 3023.
Encoding considerations:
 Same as encoding considerations of text/xml as specified in RFC 3023.
Security considerations:
 Same as described in RFC 3023.
 Fragments of file linked with Matriksoft Fragmented File Descriptions are often small in size after downloading. However, linking output file can be huge. Before linking, the user should check the amount of available resources.
Interoperability considerations:
 It's XML-based media type. XML is device-, platform-, and vendor-neutral and is supported by a wide range of Web user agents. Matriksoft Fragmented File Format Description is also platform-neutral.
Published specification:
 http://res.oimatriksoft.tk/spec/mfff/1.0-en.spec
Applications that use this media type:
 Matriksoft DeFragmenter
Additional information:
 Magic number(s): As specified in RFC 3023.
 File extension(s): .mfd .mffd .xml
 Macintosh file type code(s): TEXT
Person & email address to contact for further information:
 Mateusz Karcz
 [email-masked]
Intended usage:
 COMMON
Restrictions on usage:
 None
Author:
 Mateusz Karcz
Change controller:
 Mateusz Karcz

---

From: Bjoern Hoehrmann <[email-masked]>
Date: Sun, 12 Feb 2012 21:05:54 +0100

> vnd.matriksoft.mfff.description+xml

XML media types under the 'text' top level type are unpopular, it would
probably be a good idea to explain why this does not use 'application'.

> revision <- defined in 

Text missing.

> Same as described in RFC 3023.

This suggests there are no other considerations which is unlikely to be
the case. This should probably say something along the lines of "in
addition to ..."

> File extension(s): .mfd .mffd .xml

If there are specific extensions, this should not list "xml" because it
could also be used, there would have to be more specific reasons.
-- 
Björn Höhrmann · mailto:[email-masked] · http://bjoern.hoehrmann.de
Am Badedeich 7 · Telefon: +49(0)160/4415681 · http://www.bjoernsworld.de
25899 Dagebüll · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/

---

From: Paul Libbrecht <[email-masked]>
Date: Mon, 13 Feb 2012 00:23:13 +0100

Mateusz,

can you be clearer on the following:

> COMMON

so one would expect a category of applications to be applicable by this registration.

> Applications that use this media type:

(my intent was to figure out if media of such type would fit into the clipboard, I could not answer this curiosity from this line neither from the web-page).

... or maybe you intended to register an application-specific media-type?
If yes, the vnd tree is for you!

paul