Subject: How IP Packets are encapsulation in DS1 Signal

From: David Wang <[email-masked]>
Date: Mon, 27 Mar 2000 16:23:42 -0600

Dear Friends,

There are plenty of books describing how IP packets are encapsulated in
Ethernet frames or ATM cells, or PPP frames. But I have not seen a book
describe how IP packets be carried in DS1, Fractional DS1, DS3, Fractional
DS3 signals. These signals are point to point, byte streams. I think IP
packets should be directly put on those TDM time slots and send from one end
point to the other. Can somebody answer my question or point out a book, web
site, or a standard so I can find the answer.

Thanks
David

---

From: "Taylor, Johnny" <[email-masked]>
Date: Tue, 28 Mar 2000 11:52:24 -0500

As for the data packet flow in DS1s, DS3s, or Fractional pipes, you
have three modes:

		1) Circuit Switched - Let's say you call Grandma and once
she answers you two have 
		exclusive and full use of the circuit that was established
between you. You have that
		circuit unti lone of you hang up, at which time it goes idle
until the system of switches 
		grabs it for another call. The call could be voice, video,
or data The advantage of
		circuit swiching is you have it the entire time and it's
full duplex. The disadvantage
		is since you have the entire circuit you pay and it is
expensive.

		2) Packet Switching - Sending data in packets through a
network to some remote
		location. The data to be sent is assembled in the PAD
(Packet Assembler / Disassembler)
		into indivisual packets of data, involving a process of
segmentation. Each packet has an 
		unique ID as well as the destination address. Packet can
take variuos routes to the destination
		address and are Reassembled (normally there is a form of
latency due to different paths and lengths).
		You have an error checking and correcting occurring through
this process as well since you have
		packets arriving at different times and out of order.

		3) Message Switching -  A technique of receiving a message,
storing it for a while and then
		sending it on to the destination. Normally used when the
desired recipinent is not there. The
		message will keep attempting delivery, freeing the calling
party to handle other work. No 
		direct connection is made in message switching between the
incoming and out going
		message.

	Hopefully this helps you out. I would recommend going to
www.data.com or cisco.com (packet magazine).

	JT

	From:	David Wang <[email-masked]> on 03/27/2000 05:23
PM
	To:	[email-masked]@SMTP@Exchange
	cc:	 

	Subject:	How IP Packets are encapsulation in DS1 Signal

	Dear Friends,

	There are plenty of books describing how IP packets are encapsulated
in
	Ethernet frames or ATM cells, or PPP frames. But I have not seen a
book
	describe how IP packets be carried in DS1, Fractional DS1, DS3,
Fractional
	DS3 signals. These signals are point to point, byte streams. I think
IP
	packets should be directly put on those TDM time slots and send from
one end
	point to the other. Can somebody answer my question or point out a
book, web
	site, or a standard so I can find the answer.

	Thanks
	David

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 29 Mar 2000 08:34:09 -0500

David,

>site, or a standard so I can find the answer.

Sorry if I'm stating the obvious, but you can't just carry IP packets over 
point-to-point links without some sort of framing, so you can tell where 
one packet ends and the next begins.  In addition to various 
vendor-proprietary framing methods for IP over serial links developed over 
the years, there have been two major methods standardized in the IETF to 
frame IP packets over point-to-point links, SLIP (RFC 1055) and PPP (RFCs 
1661 and 1662).  SLIP is actually a "non-standard standard" (see the RFC 
for more info).  PPP was developed to address SLIP's deficiencies, some of 
which are discussed in the SLIP RFC itself.

Cheers,
Andy