Subject: Re: runumbering (was: Re: IPv6: Past mistakes repeated?)

From: Sean Doran <[email-masked]>
Date: Wed, 26 Apr 2000 18:44:54 +0200 (CEST)

Thomas Narten writes:

| Actually, if your assumption is that NATv6 is better than IPv6 with
| renumbering, then IPv4 and NATv4 was good enough to start with and
| there was need to move to IPv6 in the first place.
           ^
	   no  (right?  maybe this is where the previous "not" came from -:) )

Did you see Noel's excellent observation that the problem with
NAT is architectural and not mechanical?   The architectural problem:
more things to address on one side of the NAT than there are addresses
on the other side of the NAT.

IPv6 does bring *ONE* thing significantly different from IPv4:
lots of address space.  So much, that we do not obviously need to
have situations where there is an addressability mismatch on any
side of a NAT.

NATv6 therefore does not suffer the architectural flaw that
causes him to have real problems with NAT, although it can
suffer many of the mechanical problems, particularly if IPv6
deliberately seeks to worsen the mechanical difficulties of NATv6.

This allows for the architectural features of NAT to be
less awkwared to exploit.

| But if NATv4 doesn't cut it, I don't see how NATv6 between IPv6
| sites cuts it either.

I hope this makes it clearer for you.

	Sean.

---

From: "Evstiounin, Mikhail" <[email-masked]>
Date: Thu, 27 Apr 2000 09:42:51 -0400

> From:	Masataka Ohta [SMTP:[email-masked]]
> "good *if* and only if"?
> 
> With cookies, a network is as secure as a telephone or fax network, which
> is *GOOD* enough for credit card companies.

Not exactly. It's pretty easy to intercept any packet on the Internet,
that's not
the case for regular phones. Nevertheless, I've read some warnings from
credit companies about not using wireless phones because of security
concerns. Especially, if you live in a crowded area.
... 
> 							Masataka Ohta