Subject: Re: An Internet Draft as reference material

From: Bob Braden <[email-masked]>
Date: Fri, 22 Sep 2000 22:33:08 GMT

*> 
  *> If the patent office staff and patent infringement defense attorneys had 
  *> searchable access to the database of Internet Drafts, their jobs would bne 
  *> easier and the quality of their work would improve.
  *> 
  *> d/
  *> 
  *> 
Dave,

In other words, the Lawyers Rule.

Bob Braden

---

From: Dave Crocker <[email-masked]>
Date: Fri, 22 Sep 2000 18:56:38 -0700

>In other words, the Lawyers Rule.

Community  *Need*  Rules.

As it is supposed to for the IETF.

Lawyers do not initiate patents, nor do they initiate patent infringement 
cases.

At 04:43 PM 9/22/00 -0600, Vernon Schryver wrote:
>That assumes facts not in evidence and even contrary to well known
>evidence.  Defense attorneys would have only a somewhat easier time of

I've no idea what "well known evidence" you are referring to.

My experience is limited to 3 cases.  In every one of them, easy access to 
the I-D archives would have reduced legal research effort (and therefore 
cost); in one case, the effect probably would have been quite substantial.

>it, but the outher side would gain even more.  The defense can now ask
>around quietly to find prior art.  However if the other guys know what

"ask around" is usually very expensive.

>you're going to say, your case can be lost.  A concrete example of that

This is one of the more bizarre arguments against having public access to 
prior art that I can imagine.

Keep it private so that the holders of the patent won't know you know about 
it???  That, of course, ignores the likelihood that it won't be discovered 
by the defense, either.

If the information is readily public, it inherently reduces the ability to 
claim that the art is sufficient for a patent.

>If the patent office staff can't be bothered to check textbooks, do you

Checking textbooks is different effort from an automated search of a data 
base.  At that, the patent file histories I have seen do show that the 
patent folks occasionally do serious research, not just limited to patents.

>really expect them to figure out how to search a mass of text like 1000's
>of I-D's?  If they issue patents on "hyper-light-speed" antennas (see
>http://www.patents.ibm.com/details?&pn=US06025810__ ), can you really
>expect them understand

This line of logic competes with the earlier one, since it says we should 
make no effort to improve the information available to the patent office 
because they won't use it.

(That' logic has been used, over the centuries, to claim that all sorts of 
groups should be deprived of information, education, and the like.  It is 
an argument against change, essentially using a "this is the way it has 
always worked" basis.

>I favor of an IETF archive of I-D's, because the current ad hoc network
>of I-D archives is inconvenient to use and subject to manipulation.  The

Isn't it nice, the way entirely different views can lead to the same 
conclusion?  And the nice thing about consensus is that it does not matter 
whether we agree on the underpinnings, as longs as we agree on the decision.

d/

---

From: Jon Crowcroft <[email-masked]>
Date: Sun, 24 Sep 2000 11:26:07 +0100

anyone with a worthy i-d which is not gonna make it as an RFC could do
worse than consider submiting it to INET....a lot of the papers there
are in that line and would then count as prior art, be archival, and
citable.

possible source of pressure/problem:
interestingly enough, in tenure, most universities in the US 
to my knowledge (on
checking recently) don't admit of RFCs at all as part of the
publiations list in a CV...this may be good in some senses, as it
stops researchers trying to use the IETF as a place to get visibility
for tenures sake alone (but shouldnt put them off if they have
geneuine working code and think they;ll get consensus roughly:-)

escape valve::
so if i have a recommendation for folsk with well worked out i-ds,
its "find a good workshop - e.g. ieee sponsored, but also isoc or acm
or other and send it there" - alternatives too are some of the
magazines and newsletters  e.g. IEEE Network (publishes the most cited
work on RSVP for example) and ACM CCR (publishes a lot of inciteful
work on protocol implementation and experience...)

j.

---

From: Grenville Armitage <[email-masked]>
Date: Mon, 25 Sep 2000 08:34:09 -0700

Discussions about whether good I-Ds always become RFCs or
not misses the point. You wont stop marketing droids from
making overblown statements about the relative worth of
'publishing' an I-D.... you could make I-Ds last only
the week of an IETF meeting, and marketing droids will
gleefully announce "our proposal was contributed to
the XYZ IETF!".

Anyway the original question wasn't about the archival
worthiness (or not) of I-Ds, but rather the wisdom of
citing I-Ds given their presupposed unworthiness. As
has been noted, RFCs dont (or at least aren't supposed
to, modulo mistakes) make *normative* cites to I-Ds
(although historical cites to 'work in progress' are
sometimes valid).  As has also been noted, works
outside the jurisdiction of the IETF (e.g. books)
can do what they please.

So, since we already have in place rules on when
I-Ds can be cited in 'IETF approved' documents, and
the IETF can't stop anyone else from pointing to
IETF works in progress, is there anything left to
discuss here?

cheers,
gja

---

From: Keith Moore <[email-masked]>
Date: Mon, 25 Sep 2000 13:32:25 -0400

> IETF works in progress, is there anything left to

historically IETF has discouraged even external references to
I-Ds by removing I-Ds from the repository after six months.
if IETF starts providing a reliable archive of I-Ds, I-Ds 
will be referenced more often in external documents

Keith

---

From: Grenville Armitage <[email-masked]>
Date: Mon, 25 Sep 2000 11:22:11 -0700

Keith Moore wrote:
	[..]
> I-Ds by removing I-Ds from the repository after six months.

Discouraged != Can Prevent, so again I wonder what we're
achieving in this thread.

> will be referenced more often in external documents

I dont believe it will make any difference. When I cite
an I-D today I do so to indicate a historical marker,
regardless of whether the source material will evolve
or disappear. Only the most misleading of citation
habits, or naieve of readers, will be under any illusions
that an archive of I-Ds represents any stamp of technical
merit. We have CD-ROMs and websites of previous IETF
meetings - do you not consider these to already provide
a distributed record of the ramblings of the IETF?

cheers,
gja