Subject: RE: I-D ACTION:draft-coates-urn-namespace-00.txt

From: "Dawkins, Spencer" <[email-masked]>
Date: Mon, 25 Sep 2000 08:45:08 -0500

I agree completely with the author's goals, but are we really going to do this?

Hint: how many people in the world have the three initials "abc"?

I'm not sure that per-carbon-based-lifeform URN spaces are going to scale a lot better than networks or domain names with the same level of granularity - especially since the URN seems headed for a flat namespace (think ".com", only it's a URN namespace).

Am I missing something obvious (it IS 8:44 AM in my timezone)?

Spencer

> -----Original Message-----
> From:	[email-masked] [SMTP:[email-masked]]
> Sent:	Monday, September 25, 2000 5:51 AM
> Subject:	I-D ACTION:draft-coates-urn-namespace-00.txt
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
> 	Title		: URN Namespace for Literate Programming: 
>                           Anthony B. Coates 
>                           URN-NID-abc
> 	Author(s)	: A. Coates
> 	Filename	: draft-coates-urn-namespace-00.txt
> 	Pages		: 5
> 	Date		: 22-Sep-00
> 	
> This document describes a URN namespace for use in identifying XML
> namespaces for use with applications created by the author, Anthony
> B. Coates.  In particular, the author develops applications for
> literate programming.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-coates-urn-namespace-00.txt
> 
> Internet-Drafts are also available by anonymous FTP. Login with the username
> "anonymous" and a password of your e-mail address. After logging in,
> type "cd internet-drafts" and then
> 	"get draft-coates-urn-namespace-00.txt".
> 
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html 
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE /internet-drafts/draft-coates-urn-namespace-00.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
> 		
> 		
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft. << Message: Untitled Attachment >>

---

From: Leslie Daigle <[email-masked]>
Date: Mon, 25 Sep 2000 10:57:06 -0400

Howdy,

It is indeed perceived as an issue.  It's currently being
discussed in the URN Working Group, in the form of proposed revisions
to the URN NID registration process document.

Personally, I think a solution is to have a more generic URN namespace
that serves the needs of more individual publishers, such as
this (and Norman Walsh, who has a similar proposal for "ndw").

I haven't had the time to sit down and propose one that could be
globally supported, and wouldn't simply push the ".com" problem
down a level.

Leslie.

-- 

-------------------------------------------------------------------
"Reality with a delicate splash of the imaginary... 
    ... or was that the other way around?"
   -- ThinkingCat

Leslie Daigle
[email-masked]
-------------------------------------------------------------------