Subject: Re: Topic drift Re: An Internet Draft as reference material

From: "J. Noel Chiappa" <[email-masked]>
Date: Mon, 25 Sep 2000 15:31:36 -0400

> From: Keith Moore <[email-masked]>

    > if IETF starts providing a reliable archive of I-Ds, I-Ds will be
    > referenced more often in external documents

I suppose the risk here might be reduced a tiny bit if such an archive
didn't make old I-D's available directly (i.e. via a URL) - i.e. you'd have
only a "search page" where you'd have to enter some data and press a button
to get an I-D.

	Noel

---

From: Dave Crocker <[email-masked]>
Date: Mon, 25 Sep 2000 12:58:20 -0700

>only a "search page" where you'd have to enter some data and press a button

that limits searching only to the title.  searching content is essential.

d/

---

From: [email-masked]
Date: Mon, 25 Sep 2000 16:17:38 -0400

> only a "search page" where you'd have to enter some data and press a button

Umm.. Noel?

I just checked - my browser bookmarks include at least 5 bookmarked references
to the output of search pages.  People are going to do it. ;)

All this is going to do is make for UGLY references that you'll need OCR
gear to get back out of the book and into a browser. ;)

-- 
				Valdis Kletnieks
				Operating Systems Analyst
				Virginia Tech

---

From: Keith Moore <[email-masked]>
Date: Mon, 25 Sep 2000 18:33:32 -0400

> that limits searching only to the title.  

why? 

Keith

---

From: Keith Moore <[email-masked]>
Date: Mon, 25 Sep 2000 19:45:48 -0400

> to the output of search pages.  People are going to do it. ;)

I'm not at all sure that we want to go the search engine route, but 
it's a trivial matter to make a search engine return URLs that can only
be referenced for a short time.

Keith

---

From: Dave Crocker <[email-masked]>
Date: Mon, 25 Sep 2000 17:07:55 -0700

> > that limits searching only to the title.

The stated goal was to restrict access.  The mechanism was described 
tersely.  I'm assuming that limiting access really means limiting access, 
rather than just being something entirely trivial like adding one more 
key-click into the sequence.

d/

---

From: Grenville Armitage <[email-masked]>
Date: Mon, 25 Sep 2000 17:43:43 -0700

I just love this mythology that "expires in 6 months"
means expunged from all retrievable record in 6 months.
Practically speaking it only ever means "if it hasn't been
picked up by a WG and revised in 6 months it is no longer
of interest to the IETF". Expunging it from the IETF's
official I-D site could never have hoped to be anything
more than a symbolic gesture, since there's no way to
stop anyone else archiving each I-D as it is released.

Somehow restricting a search engine so it returns some
sort of 'one time' URL pointer to an archived I-D seems
to rather miss the point. People will cite I-Ds because
they once existed - no-one is going to *not* cite an
archived I-D just because retrieval takes 20+ key strokes
instead of two. Even 20+ keystrokes sure beats moving one's
ass down to the library and pulling out a printed work
(I've observed that some cited works actually required
physical movement like the aforementioned library trip,
yet it didn't seem to stop the work being cited).

Just for laughs, I popped in my CD-ROM "Proceedings of
the 46th Internet Engineering Task Force". Opened the
I-D folder. Interesting. There's a stack of readable
(and therefore searchable) I-Ds in there, all telling me
they've expired. Perhaps the magic self-destruct codes
didn't work on my CD.

Oops.

Now, what was the question?

cheers,
gja

---

From: Randy Bush <[email-masked]>
Date: Mon, 25 Sep 2000 21:53:07 -0600

> I just love this mythology that "expires in 6 months"

so do i.  it makes it clear that, if you keep it, it's your game
not ours.  we don't support it beyond six months.

randy

---

From: Grenville Armitage <[email-masked]>
Date: Tue, 26 Sep 2000 00:12:45 -0700

good. so this thread can be closed now?

gja

-- 
________________________________________________________________________
Grenville Armitage                    http://members.home.net/garmitage/
Bell Labs Research Silicon Valley

---

From: John Stracke <[email-masked]>
Date: Tue, 26 Sep 2000 11:26:25 -0400

> be referenced for a short time.

Unless your search engine's form handler rejects GET (most Web programming APIs try
to hide the difference between GET and POST), it's an even more trivial matter to
construct URLs that invoke the search engine with specified parameters.

If the form handler does reject GET, it's...not trivial, maybe, but easy...to build
a handler someplace else that accepts GET and POSTs the query to the search engine.

All in all, blocking like this just isn't worth the trouble.

--
/===============================================================\
|John Stracke    | http://www.ecal.com |My opinions are my own. |
|Chief Scientist |==============================================|
|eCal Corp.      |"Hastur was paranoid, which was simply a      |
[email-masked]|sensible...well-adjusted reaction to living in|
|                |Hell." --_Good Omens_                         |
\===============================================================/

---

From: Keith Moore <[email-masked]>
Date: Tue, 26 Sep 2000 12:19:19 -0400

> means expunged from all retrievable record in 6 months.

nobody believes that, nor has anybody said they really want that.  
just because IETF has a policy of not making I-Ds available after
6 months does not mean that IETF's goal is to suppress these
documents after that length of time, or ever.    It just means
that IETF is removing the most widely known and most authoritative
source of an I-D after six months.

don't confuse the policy with the goal, they are not the same.

the relationship of the value of information according to the degree
of its exposure is rarely monotonic.   specifically for internet drafts,
IETF's current policy makes the I-D series more valuable than it would
be if either I-Ds did not expire at all, or if they somehow disappeared
from existence. 

Keith

---

From: Grenville Armitage <[email-masked]>
Date: Tue, 26 Sep 2000 09:40:26 -0700

Keith Moore wrote:
	[..]
> It just means

I think that was my point.

	[..]

> be if either I-Ds did not expire at all, or if they somehow disappeared

We clearly differ. This thread isn't about whether IETF's policy
makes I-Ds more or less valuable. It started with the circumstances
under which citation of I-Ds is warranted (there are some), and
moved to whether longevity of I-D archives would be a good thing
for IPR searches (it would be). Arguing that anyone can stop such
archiving - especially since the IETF has been doing it indirectly
with CD-ROM proceedings - is what I'm finding pointless about this
entire thread now. Asserting that somehow somehow any of this will
make I-D citations any more or less prevalent is naieve.

cheers,
gja

---

From: John Stracke <[email-masked]>
Date: Tue, 26 Sep 2000 13:26:46 -0400

Keith Moore wrote:

> be if [...] I-Ds did not expire at all

I see your point, but there's an easy solution.  If there are two
interfaces (or one, with a checkbox), and the default is to search only the
I-Ds under 6 months old, then the noise level doesn't go up unless you
decide you need it to.

--
/==============================================================\
|John Stracke    | http://www.ecal.com |My opinions are my own.|
|Chief Scientist |=============================================|
|eCal Corp.      |Earth: love it or leave it.                  |
[email-masked]|                                             |
\==============================================================/

---

From: Keith Moore <[email-masked]>
Date: Tue, 26 Sep 2000 15:09:11 -0400

> I-Ds under 6 months old, then the noise level doesn't go up unless you

actually my point isn't about the noise level associated with having
additional documents returned in a search - it's about the I-D series
being more useful for particular purposes *precisely because of 
mechanisms that are designed to limit, but not totally prevent, 
use of old I-Ds*.

Keith

---

From: Stephen Kent <[email-masked]>
Date: Tue, 26 Sep 2000 17:00:21 -0400

As someone who was around when the notion of an I-D was created, let 
me disagree somewhat.  There was a very definite intent to cause I-Ds 
to "officially" disappear after a limited time frame.

Steve

---

From: Keith Moore <[email-masked]>
Date: Tue, 26 Sep 2000 17:20:49 -0400

> to "officially" disappear after a limited time frame.

I don't doubt that at all.  But did folks really think that I-Ds 
would completely vanish from the face of the earth?  And did they
consider that I-D expiration might be useful even if I-Ds did not 
completely vanish?

we've got people arguing that since we can't make I-Ds vanish
completely, that the expiration is pointless.  my argument is
that the combination of the expiration and the fact that old
I-Ds can be found if you look hard enough, turns out to be
useful.

Keith

---

From: "Melinda Shore" <[email-masked]>
Date: Wed, 27 Sep 2000 09:07:21 -0700

>From: Stephen Kent <[email-masked]>
>To: Keith Moore <[email-masked]>
>Cc: <[email-masked]>
>Sent: Tuesday, September 26, 2000 2:00 PM
>Subject: Re: Topic drift Re: An Internet Draft as reference
material

> to "officially" disappear after a limited time frame.

Am I the only librarian in the crowd?

Archival material is *extremely* important for
future research.  Just because the document isn't
for publication and cannot be used normatively
doesn't mean that it should be obliterated.  Aside
from their use in resolving IPR issues, conceivably
at some point in the future someone is going to
want to look at some aspect(s) of the process of
how we got from here to there and expunging
documents is guaranteed to make that work considerably
more difficult.  Those documents aren't just
technical documents, they're also historical
documents.

Additionally, other bodies have a clear delineation
between normative references and informational
references, and presumably that's not a problem
here.  Certainly, the review process should be
weeding out incorrect/invalid references.

Melinda

---

From: RJ Atkinson <[email-masked]>
Date: Wed, 27 Sep 2000 09:58:25 -0400

At 12:07 27/09/00, Melinda Shore wrote:

>future research.  

The archival material is the RFC --*only*--.

>Just because the document isn't
>doesn't mean that it should be obliterated.  

I would not want my old drafty Internet-Drafts
to be kept archivally, just as others have indicated
they don't want theirs kept around.  Drafts are
just that -- drafts -- hence not appropriate
archival material.

Ran
[email-masked]

---

From: Keith Moore <[email-masked]>
Date: Wed, 27 Sep 2000 10:35:58 -0400

> Archival material is *extremely* important for future research.

no doubt.  but we have a conflict of interests here.

on one hand, historians and folks doing patent searches could
make good use of archived internet-drafts.

on the other hand, IETF needs the Internet-Draft series to be very
lightweight.  already there are too many folks who avoid issuing
I-Ds except when required to do so because they feel that the
publication process is too burdensome and too slow, and too many
people treat I-Ds as something akin to final form documents 
(as in, they need to be close to "right") rather than working drafts.  
having the drafts placed in a permanent and easily accessible 
archive increases that burden.

IMHO internet-drafts ought to be about as accessible as WG mailing 
list archives - which is to say, the stuff is out there if you want
to dig through it, but you have to dig.

Keith

---

From: "Melinda Shore" <[email-masked]>
Date: Wed, 27 Sep 2000 10:41:27 -0700

>From: RJ Atkinson <[email-masked]>
>To: Melinda Shore <[email-masked]>
>Cc: <[email-masked]>
>Sent: Wednesday, September 27, 2000 6:58 AM
material

> The archival material is the RFC --*only*--.

Actually, it's not.  It's whatever's archived.

> just that -- drafts -- hence not appropriate

I really have no idea what Gertrude Stein would
think of her letters, notebooks, and random
unpublished scribblings ending up at Yale or
if Theo Van Gogh would approve of his sales
ledgers ending up in an art museum in Amsterdam.
At some level it doesn't really matter - you
can't always control what happens to the stuff
around you.  In fact, you can't often control
what happens to it.  It's difficult to predict
in what particular way material will be useful
in the future (the above two sets of archives
have proven to be *enormously* valuable for
contemporary scholars), and if someone wants to
preserve internet drafts for historical purposes, that
seems reasonable (and even desirable) to me.
Besides, someone has to continue to provide Peter
Salus with source material.

Please consider that internet drafts have revision
numbers.  At some level we do value historical
process, even if it's as simple as this-version-is-
modified-from-that-version.  We don't simply say
"this is the document NOW."

Melinda

---

From: "Melinda Shore" <[email-masked]>
Date: Wed, 27 Sep 2000 11:24:13 -0700

>Sent: Wednesday, September 27, 2000 7:35 AM
material

> already there are too many folks who avoid issuing

It seems to me that that has a lot more to do with
the ascendancy of the professional standardizer,
combined with excessive scrutiny by the trade press
(aggravated by those "HEY!  WE ISSUED AN INTERNET
DRAFT!!!" press releases).

At the same time, people seem not to have the same
concerns about archiving mailing lists, which supports
what you're saying about drafts being perceived as being
weighty.

> to dig through it, but you have to dig.

Seems reasonable.  Indexing/retrieval aren't the same
problem as storage/retention.

Melinda

---

From: Keith Moore <[email-masked]>
Date: Wed, 27 Sep 2000 11:42:44 -0400

> > publication process is too burdensome and too slow, and too
> > many people treat I-Ds as something akin to final form documents

> the ascendancy of the professional standardizer,

as far as I can tell a lot of it comes from people who write 
documents in microsoft word as opposed to nroff.  so you could 
well be right.  :)

> DRAFT!!!" press releases).

as far as I can tell, the trade press doesn't actually read the drafts.
they just believe the vendors when they say "we've submitted something
to IETF".

IMHO, we'd be far better off if the trade press actually did scrutinize
the stuff that the vendors produce.

Keith

---

From: [email-masked]
Date: Wed, 27 Sep 2000 12:13:07 -0400

> the stuff that the vendors produce.

Yet another great source of misquotes and mis-statments for the trade rags. ;)

But seriously - it would be *nice* if the trade press scrutinized all the
documents - but sometimes I wish the reporter would wave a cluon-flux meter
over the press release..

(Sorry, I just saw a howler of a clue-challenged article in a trade rag this
morning...)

---

From: John C Klensin <[email-masked]>
Date: Wed, 27 Sep 2000 12:23:07 -0400

> The archival material is the RFC --*only*--.

Melinda,

I've got very mixed feelings about this topic: I understand the
reasons for an archive, but I'm extremely concerned that, as
Keith, Ran, and others have pointed out, turning I-Ds into a
permanent record may make it harder to get half-baked ideas
exposed in the community rapidly enough that we can make
progress.

The "library" analogy to an I-D is, I suspect, an unpublished,
privately-circulated, draft of something that might evolve into
a book.  Such drafts are, precisely as you suggest, invaluable
for historical research into the development and evolution of
ideas.  But, when they are retained and available at all, they
are traditionally also severely encumbered as to access.
Restrictions such as "no access during the author's lifetime",
"no access while the copyright on the final publication is still
in effect", or "no access without special arrangements that
require identification of the researcher and purpose of the
research" are all, as you must know, fairly common.

I, and I suspect many others reading this, have early drafts of
books in my personal library that contain materials that were
removed to make the books short enough to be published.  Some of
those materials are valuable technically as well as historically
and an author would have to twist my arm fairly hard to get me
to destroy or return them.   But I feel at least morally
obligated to honor that author's request to not duplicate or
cite that material without explicit, case-by-case, permission.  

I find it interesting in this regard that you cite long-dead
authors and painters in your comparison; I strongly suspect that
a library which obtained personal journals or letters from a
contemporary figure and made them widely available without
permission would find itself in deep legal and professional
difficulties.

It seems to me that the real question here is not whether I-D
materials should be retained for historical or related purposes
or not: almost no one seems to be questioning that.  Instead, I
think it would be helpful if the people and communities with
experience in the area, especially the library one, would help
us find appropriate analogies to the restrictions on access that
often characterize collections of what may be similar character.

In particular, "make it available, but make it hard to get to"
suggestions don't impress me as quite right.  As someone who has
put out some fairly dumb ideas in I-Ds that I'd prefer not be
generally circulated --especially with the implication that they
are my final, considered, thoughts on those subjects-- I'd far
prefer that anyone who wanted to get to an old I-D needed to
identify him or herself and a reason.  I'm not particularly
concerned about whether or not the reason is audited or formally
verified, nor do I think the lists of people who made the
requests need be public (although I'd assume authors should have
access to the list for their materials), but I think there ought
to be a record.

Does that seem unreasonable to you as a librarian?  Can you
suggest a way to accomplish it?

     john

---

From: "Melinda Shore" <[email-masked]>
Date: Wed, 27 Sep 2000 13:04:32 -0700

> exposed in the community rapidly enough that we can make

I think that this is probably the heart of the
problem.  It's not a matter of turning drafts
into a permanent record - for better or worse
they already are a permanent record, at least
until such time as the technology is developed
to obliterate every copy everywhere stored on
every medium, blah blah blah.

It seems to me that the question at hand is
whether or not this gives drafts any additional
weight in standards-land.  The answer to that
question lies in how references are controlled.
Given that they can be controlled quite tightly
through the review process, I'm not sure I see
the problem.

> But, when they are retained and available at all, they

This situation is quite different, I think.  An internet
draft is not limited in its distribution.  It's
limited temporally, and I really can't think of anything
analogous elsewhere.

> research" are all, as you must know, fairly common.

Sure, but this is different.  We're not talking about
private documents being passed between two private
parties.  Internet drafts are available to anybody
who wants them, and there are effectively no restrictions
on reproducing and archiving them.  What is very different
is that they "expire" after six months.  I think that
one thing that might come out of this discussion is
a definition of what it means to expire a document in
the context of the IETF.

> Instead, I

This just strikes me as wrong.  I think that the
most desirable and realistically achievable result
would be what we've already got - you can't cite the
things in standards (and I might note that the ITU-T
and ETSI already specify that you can't reference
internet drafts in their documents), but otherwise
the information is out there.  Heaven knows I've said
things on mailing lists that I'd like to retract, but
some things are just beyond my control.

Melinda

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Wed, 27 Sep 2000 10:36:11 -0700

I, for one, would like to see the IETF host an public archive
of expired I-Ds for technical reasons.  Having past works, even
those not worthy of RFC publication (on any track), available
adds to wealth of knowledge available to future Internet
engineering.  This will allow future efforts to take full
advantage of past efforts.  Having them available for IPR reasons,
IMO, is secondary (as it addresses a non-technical issue).

I suggest that the URIs for an expired I-D contain the word
"expired" to limit confusion with active I-Ds, e.g.:
  http://www.ietf.org/EXPIRED-INTERNET-DRAFT/draft-....txt

	Kurt

---

From: [email-masked] (Steve Conner)
Date: Wed, 27 Sep 2000 12:41:13 -0700

Or "archived".

Steve

---

From: Keith Moore <[email-masked]>
Date: Wed, 27 Sep 2000 16:30:28 -0400

> weight in standards-land. 

no, I don't think that's the question.  it's already well established
that standards-track RFCs cannot have normative references to I-Ds.

rather, the questions at hand are whether an official archive of 
internet-drafts would

a) impair their utility, and thereby hurt IETF's ability to function, or

b) violate the rights of I-D authors who allowed IETF to publish 
their I-Ds based on the understanding that IETF would only do
so for a short time

Keith

---

From: Pete Loshin <[email-masked]>
Date: Wed, 27 Sep 2000 18:01:07 -0400

OK, I've got some very specific questions about RFCs and I-Ds and the RFC
Editor queue. The IESG announces via mailing list when a document or
protocol action is being taken; as far as I can tell this always means that
an I-D has been approved for publication as an RFC and that I-D is then
released to the RFC Editor to get an RFC number and be published.

Questions:

1. Does the RFC Editor make any changes to the I-D other than changing
internal references to the document from the I-D identifier to the RFC
number, and changes specified by the IESG? More specifically, does the RFC
Editor have the option of doing things like fixing spelling and grammer
errors (if any)?

2. The RFC Editor queue (http://www.rfc-editor.org/queue.html) lists
various documents along with information about where they stand in the
process. The first entry in the queue this afternoon was this:

----start excerpt from RFC Editor's queue----

----------------------------------------
IETF STANDARDS TRACK (by date received)
----------------------------------------

1999/09/16     draft-ietf-mpls-arch-07.txt
REF            draft-ietf-mpls-atm-04.txt
               draft-ietf-mpls-bgp4-mpls-04.txt
               draft-ietf-mpls-cr-ldp-04.txt
               draft-ietf-mpls-framework-05.txt
               draft-ietf-mpls-fr-06.txt
               draft-ietf-mpls-ldp-10.txt
               draft-ietf-mpls-rsvp-lsp-tunnel-06.txt
               draft-ietf-mpls-label-encaps-08.txt
E. Rosen, A. Viswanathan, R. Callon
Multiprotocol Label Switching Architecture

----end excerpt from RFC Editor's queue----

The "REF" indicates (according to the same page) that "REF=holding for
normative reference (followed by ID string of referenced document)."

Does this particular entry mean <draft-ietf-mpls-arch-07.txt> is being held
for normative reference to the I-Ds listed below it, or that all those I-Ds
are being held for normative references?

3. Assuming that the entry above indicates that the first I-D (in this
case, <draft-ietf-mpls-arch-07.txt>) is being held until the other RFCs
become RFCs as well, doesn't this mean that it might be years before an
approved I-D would ever be published as an RFC?

Thanks!
-pl

+-------------------------------------------------------------+
| Pete Loshin             http://www.loshin.com               |
| Internet-Standard.com   http://Internet-Standard.com        |
| The RFC Books Series    http://www.loshin.com/bigbooks.html |
| The Linux Project       http://www.thelinuxproject.com      |
+-------------------------------------------------------------+

---

From: vint cerf <[email-masked]>
Date: Thu, 28 Sep 2000 02:28:53 -0400

perhaps I-Ds are more like elaborated lab notebooks?
very useful for patent references, reviewing dead ends, partly
explored ideas, etc. One doesn't typically throw away lab
notebooks just because you didn't write a published paper
based on them.

vint

---

From: John C Klensin <[email-masked]>
Date: Thu, 28 Sep 2000 03:28:14 -0400

> notebooks just because you didn't write a published paper

That is obviously closer to my model.  If I correctly understand
Melinda's counterargument, it is that you don't make a few
hundred copies of your lab notebook and pass it out to your
closest friends, much less make it available to anyone who wants
it, at zero cost, as long as they agree to destroy it (or let it
self-destruct) at the end of six months.  

And, if I correctly understand the implications of what Keith is
suggesting, assume you pass the notebook to me with instructions
(and an agreement) that I make it available to others for six
months, and no longer, and with a proviso that whoever receives
it should destroy (or at least not further circulate it) after
that time.  Given that agreement, I'm obligated --morally, even
if not legally-- to follow your wishes.  And that means that I
can't start a public archive containing your notebook(s)
independent of whether someone else might do so.

I think the notebook analogy, or one involving a
privately-circulated preliminary manuscript where the author
applies some restrictions to the readers/ recipients, are
probably the right ones.  In the interest of making life easier
for historians, Melinda doesn't agree and, while I think history
is important, she and I probably aren't going to convince each
other.  That said, the conclusions I'm personally drawing from
this discussion --for whatever they might be worth-- are:

(i) There is a fairly strong case for keeping I-Ds as close to a
"lab notebook" or "working preliminary draft" model as possible
consistent with reality and other interests.

(ii) Given the types of nonsense for which patents are awarded
these days, there is a compelling community interest in having
expired I-Ds available for "prior art" searches.  It would be
quite rational for IETF to make author agreement to that type of
long-term availability a condition for our making the document
available in our archives or publicizing it on our "announce"
lists.   Much as I'd prefer to discourage it, an author who
doesn't like those conditions is able to post a URL pointing
elsewhere, to a repository he or she controls and can destroy.
However, having material available for "prior art" searches does
not require that material be generally accessible without
restrictions.

(iii) While I recognize the value of historical research, I
don't see that requirement as so compelling to the community
that we need to make easy availability of documents for that
purpose a condition for posting using IETF facilities.

(iv) Anyone who uses a networked computer in recent years and
who has even a trace of a clue is aware that anything posted in
a public place, even briefly, is probably archived somewhere.
And, while Murphy's Law may apply, a sufficiently diligent
effort (and, often, willingness to agree to some restrictions),
will usually turn up a copy of any given piece of material.
There is, however, a huge difference between such repositories
and a public, readily-accessible, and unrestricted archive.

(v) The observation above about existing collections
notwithstanding, it seems to me that we are on thin ice (morally
if not legally) if the IETF itself decides to make documents
accepted and posted on the basis of a six-month expiration cycle
and turns them into a permanent, public, archive.

(vi) Putting Melinda's concerns aside for a moment, and looking
at "prior art" searches as the driving issue, it seems to me
that we may be approaching the problem backwards.  Some members
of the community, yourself included, have periodically been able
to get the ear of one or more of the world's patent offices.
Would it be at all practical for us to help someone set up a
restricted/ historical repository of old I-Ds (and, for that
matter, old lab notebooks from those who wished to supply them).
(Of course, there need not be only one.)  Such a repository
could offer searches of materials that were previously generally
available (such as I-Ds) on a fee basis and might be able to
make other materials available while enforcing author-imposed
restrictions.  Would that be sufficient protection that the
community would agree to, at worst, an "opt out" provision for
older materials?  

Could we sufficiently draw the attention of patent offices to
the availability of that repository to create the presumption
that anyone who hadn't searched it had not done a competent
search for prior art?  Certainly it would be a resource for
someone trying to defeat a patent, whether the examiners were
aware of it or not, but it seems to me that there is a rising
societal interest in preventing stupid patents from issuing,
rather than forcing resources that ought to go into scientific
advancement to be spent on defenses against them.

   john

---

From: vint cerf <[email-masked]>
Date: Thu, 28 Sep 2000 03:36:40 -0400

the twist between I-D and lab notebook is that the I-D is
often an explicitly shared document (group lab notebook).

Vint

---

From: Henning Schulzrinne <[email-masked]>
Date: Thu, 28 Sep 2000 09:45:23 -0400

In general, I would guess that there would be no problem, ethical, legal
or otherwise, if authors explicitly agreed, retroactively or by
boilerplate, to have the document archived. Thus, one could envision at
least three solutions:

(1) Modify I-D boilerplate to include (or not) a statement like

  "The author consents to public archival beyond the expiration date."
or
  "The author consents to restricted archival beyond the expiration
date."

(2) Ask for retroactive approval (via some web page check-off, since
this probably satisfies the relevant e-signature laws in the EU and the
US) for authors who consent to public archival. To keep this manageable,
it would probably be an all-or-nothing proposition.

(3) Allow I-D authors to restrict access to I-Ds. Depending on one's
interpretation of the strength of presumption of evanescence (which I
find a stretch - after all, many I-Ds were and are posted in their
entirety to mailing lists and included in other archival records that
are archived forever and publically searchable), this may or may not be
satisfactory.

My guess is that the vast majority of I-D authors don't care whether old
drafts are plastered over the electronic display on Times Square and
would be flattered if another author considers the idea relevant enough
to cite them in a publication. Having a well-known repository is a much
better solution than hoping that Google will ferret out a copy in a
forgotten dark corner of the Internet.

Beyond the IPR issue, articles and books don't have a choice about
including references to I-Ds if they are to be intellectually honest.
Indeed, not including an I-D could well be considered plagiarism or
stealing ideas without attribution. Just labeling it as the equivalent
of "private conversation" is not very helpful or honest, either. Authors
can't wait until I-Ds become RFCs to publish technical work.

-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs

---

From: Eric Rosen <[email-masked]>
Date: Thu, 28 Sep 2000 11:54:07 -0400

Pete> Does this particular entry mean <draft-ietf-mpls-arch-07.txt> is being
Pete> held for normative reference to the  I-Ds listed below it, or that all
Pete> those I-Ds are being held for normative references? 

The meaning  of that  queue entry  is that the  first document  mentioned is
being  delayed because  of  normative  references to  the  I-Ds that  appear
beneath it in the list. 

Pete> Assuming that  the entry above indicates  that the first  I-D (in this
Pete> case,  <draft-ietf-mpls-arch-07.txt>) is  being held  until  the other
Pete> RFCs become  RFCs as well,  doesn't this mean  that it might  be years
Pete> before an approved I-D would ever be published as an RFC?

In fact, this is the actual situation.

---

From: "Eliot Lear" <[email-masked]>
Date: Thu, 28 Sep 2000 12:02:04 -0700

John,

I would accept your interpretation if you can go to a major search engine,
like Yahoo or Altavista, and find me in a brief period of time ANY version
of Mike O'Dell's 8+8 proposal.  Don't you think it shameful that there is
no permanent record about a serious effort to deal with a serious problem
(multihoming)?  And this is a recent (read: current) problem!

Eliot

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 28 Sep 2000 14:24:55 -0500

http://www.alternic.org/drafts/drafts-i-j/draft-ietf-ipngwg-gseaddr-00.txt

(this is the revised version, I didn't look for the original 8+8)
   Brian

-- 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Brian E Carpenter 
Program Director, Internet Standards & Technology, IBM 
On assignment for IBM at http://www.iCAIR.org 
Board Chairman, Internet Society http://www.isoc.org
Non-IBM email: [email-masked]

---

From: Masataka Ohta <[email-masked]>
Date: Fri, 29 Sep 2000 15:42:53 +0859 ()

Eliot;

> of Mike O'Dell's 8+8 proposal.

You should really check archive of a big internet mailing list (does
someone know where it is archived?) for various 8+8 proposals
(including mine), some of which was available as IDs (thus, archive of
expired IDs are useful).

Mike's is the latest but the least useful one.

> Don't you think it shameful that there is

Handling of multihoming in Mike's draft is very old (even at the time
of his proposal) one.

As is briefly explained in <draft-ohta-e2e-multihoming-00.txt>, the
method violates the end to end principle and does not scale.

							Masataka Ohta

---

From: John C Klensin <[email-masked]>
Date: Fri, 29 Sep 2000 11:45:52 -0400

--On Thursday, 28 September, 2000 12:02 -0700 Eliot Lear
<[email-masked]> wrote:

> John,
> 
> I would accept your interpretation if you can go to a major
> search engine, like Yahoo or Altavista, and find me in a brief
> period of time ANY version of Mike O'Dell's 8+8 proposal.
> Don't you think it shameful that there is no permanent record
> about a serious effort to deal with a serious problem

Eliot,

I agree with Bob Braden's identification of this particular
document's slipping through the cracks as "shameful" and hope we
can fix it.  But, if one looks at the bottom line, Mike
essentially chose to let it expire, and no one else chose to pick
it up and push for RFC publication.  The shame lies there, not in
issues with the I-D expiration/ archiving process.
    john

---

From: "Eliot Lear" <[email-masked]>
Date: Fri, 29 Sep 2000 13:02:16 -0700

John,

Let's assume that Mike O'Dell never submits his idea as an RFC.  What then?
It's not just Mike O'Dell who loses.  Perhaps he doesn't lose at all, since
he'll be able to reproduce what he wrote from his personal archives.  So
while you may argue what's morally correct (and others might argue
otherwise),  the fact is that we don't have the document, and that's a loss
to us.

Also, I'm picking on Mike's document (not saying he's right or wrong for
not publishing the doc. as an RFC), but there are many other examples where
this has happened (something similar has happened to a few of my own drafts
that other authors have then asked me to reproduce).  Sometimes the ideas
are BAD.  More often they're either undeveloped or just so far out that the
standards process doesn't know how to cope with them - YET.  Also, quite
frankly, often times a working group will "compromise"  away some good
ideas for the sake of expedience in the standards process, and a useful
idea is dropped or neutered, and we've all seen this.

And there have been a number of documents which were meant to discuss an
ephemeral topic, where the author has no intent of going through the
rigmarole of getting the document turned into an RFC.

I think there was great concern about this during IPng, which is why MOST
of those documents eventually turned into RFCs.  But even in this VISIBLE
case one has slipped through the cracks.

Eliot

---

From: "Mike O'Dell" <[email-masked]>
Date: Sat, 30 Sep 2000 09:14:25 -0400

one point you are ignoring when it comes to publishing just
anything as an RFC:  once it has that designation "RFC",
THE IDEA IS SANCTIFIED, no matter what disclaimers you
plaster all over it.  (Even a biohazard symbol with a
legend reading "DANGER: LIVE EBOLA" wouldn't help. Ooops -
can't do the symbol in ASCII - sorry - bad idea.)

i know it isn't supposed to be this way, but 

	THIS IS REALITY - GET OVER IT.

the IETF has been in denial about this problem
for many years. I personally submitted an alternative
which was roundly defeated as it had the temerity to
try and bring intent in line with current reality.

instead, people decided to continue insisting that
reality was as they desired, not as it is.

until this get fixed, worrying about any one
incident is worse than pointless - it continues
the denial.

have a nice day.

	-mo

PS - i let the draft in question expire because i wanted to.
that's the nice thing about expiry - the author retains a tiny
modicum of control over something.  the notion that people
other than the author can usurp control and publish it anyway
is repugnant and is plagarism, pure and simple, no matter
whether the author gets listed or not.  you didn't have permission,
it's plagarism, if not theft.

---

From: Bill Manning <[email-masked]>
Date: Sat, 30 Sep 2000 08:24:24 -0700 (PDT)

% have a nice day.
% 
% 	-mo
% 
% PS - i let the draft in question expire because i wanted to.
% that's the nice thing about expiry - the author retains a tiny
% modicum of control over something.  the notion that people
% other than the author can usurp control and publish it anyway
% is repugnant and is plagarism, pure and simple, no matter
% whether the author gets listed or not.  you didn't have permission,
% it's plagarism, if not theft.
% 

Thanks Mike. You nearly always say it better than I. :)

--bill