Subject: Re: An Internet Draft as reference material

From: Bob Braden <[email-masked]>
Date: Wed, 20 Sep 2000 16:56:34 GMT

Valdis,

Please see RFC 1127.

Bob Braden

---

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 20 Sep 2000 14:05:43 -0400

> Although, actually, what would *really* benefit the 
> historians would be
> searchable archives of the working group mailing lists, but that's a
> different issue.... ;)
Why is that?

Seems to me it's part of the same issue, and technologically,
whatever solution you find for one ought to be pretty close
to the other, and if you do one, you should do the other.

I do think that just because a I-D expires, does not mean it
is unworthy of being preserved.  

Now the thread started with references to I-Ds. I do think
such references, except when used as historical references,
should be discouraged.  Certainly, I would not like to see
an RFC, especially a standard's track RFC, reference an I-D.

Brian

---

From: "Kay, Rodney" <[email-masked]>
Date: Wed, 20 Sep 2000 08:32:25 -0500

It is legitimate, but not very logical.  To base arguments, or suppositions,
on any "draft" document leaves you wide open for error.

Rodney H. Kay

-----Original Message-----
From: Lee, Jiwoong [mailto:[email-masked]]
Sent: Tuesday, September 19, 2000 10:34 PM
To: [email-masked]
Subject: An Internet Draft as reference material

Dear all

What do you think about "de facto" that many technical documents
are currently using Internet Drafts as referece material?

I've seen next two cases:
1. An Internet Draft refers to another Internet Draft.
2. A book refers to another Internet Draft.

I'm not sure of the next case. Any body observed this?
3. An RFC refers to an Internet Draft.

Hereby I'd like to ask your opinion, esp. on no.1
Is it legitimate?

Cheers,

Jiwoong Lee
KT M.com

---

From: Vernon Schryver <[email-masked]>
Date: Fri, 22 Sep 2000 16:43:40 -0600 (MDT)

> From: Dave Crocker <[email-masked]>

> ...
> If the patent office staff and patent infringement defense attorneys had 
> searchable access to the database of Internet Drafts, their jobs would bne 
> easier and the quality of their work would improve.

That assumes facts not in evidence and even contrary to well known
evidence.  Defense attorneys would have only a somewhat easier time of
it, but the outher side would gain even more.  The defense can now ask
around quietly to find prior art.  However if the other guys know what
you're going to say, your case can be lost.  A concrete example of that
is what happened in the AT&T backing store patent fight.  (Dave should
ask ex-employees of that graphics computer vendor for details, especially
those who worked with Phil Karlton.)

If the patent office staff can't be bothered to check textbooks, do you
really expect them to figure out how to search a mass of text like 1000's
of I-D's?  If they issue patents on "hyper-light-speed" antennas (see
http://www.patents.ibm.com/details?&pn=US06025810__ ), can you really
expect them understand
draft-terrell-logic-analy-bin-ip-spec-ipv7-ipv8-*.txt?

I favor of an IETF archive of I-D's, because the current ad hoc network
of I-D archives is inconvenient to use and subject to manipulation.  The
IETF's archive of I-D's could be relied upon more to be complete and to
contain unimproved text.  In other words, if you've ever needed to find
an expired I-D, you know the the question of whether I-D's should be
archived has been moot for almost as long as have I-D's existed.

Vernon Schryver    [email-masked]

---

From: "Steven M. Bellovin" <[email-masked]>
Date: Fri, 22 Sep 2000 19:42:25 -0400

In message <[email-masked]>, RJ Atkinson w
rites:
>At 15:44 22/09/00, Pete Loshin wrote:
>
>>IMO, it's not helpful to publish an RFC that points to a
>>"work-in-progress" as the source for explanatory or background
>>information about that RFC, if those documents disappear within months
>>of publication. It makes the RFCs less useful.
>
>Do such RFCs actually exist ?   
>Do you have a specific example ?  I don't know of any.

grep is your friend.  (Most, but not all, of these are actual 
references in the References section.)

RFC 1738
1753
1815
1889
1915
1943
1949
1999
2074
2084
2088
2150
2183
2189
2257
2301
2306
2360
2376
2411
2412
2416
2553
2585
2688
2731
2861
2882

		--Steve Bellovin

---

From: Christian Huitema <[email-masked]>
Date: Mon, 25 Sep 2000 10:52:57 -0700

> Since Internet Drafts are designed and announced to vanish after
> 6 months (they even carry their own expiration date!), referencing one
> in a book seems to be tacityly admitting that the book will be
> worthless after 6 months.  Which, one suspects, is probably true
> for most books that reference Internet Drafts.
> 
> Bob Braden
> 

Well, when you write a book chapter, you can either describe only what is
available in "archived publications" or describe what you believe is the
state of the art. The former is available in RFC and academic journals,
which generally were written 2 years ago; the latter  often correspond to
internet drafts. At this point, it really is up to the author, who should
indeed use the appropriate tenses, etc.

Note that in one specific case, CIDR/BGP-4, the technology moved to the real
world before it was ever published as an RFC. What is an author to do in
such cases?

-- Christian Huitema

---

From: Scott Bradner <[email-masked]>
Date: Mon, 25 Sep 2000 17:44:37 -0400 (EDT)

>> ... though i understand the ipr motivation.
`
> i'm afraid i don't.  perhaps someone could summarize?  sob?

finding IPR prior art

Scott

---

From: Jeffrey Mogul <[email-masked]>
Date: Mon, 25 Sep 2000 18:34:21 -0700

I think we should be willing to admit that an Internet-Draft
often serves two distinct roles:

	(1) As a formal part of the IETF document process.
	(2) As an informal record of intellectual content.

Role 1 is obviously the primary purpose of an I-D; they are
created in the service of the IETF document process, not
just to document ideas.  But the unavoidable fact is that
they *do* document ideas, as well as the trajectory by
which those ideas are accepted (or rejected).

It seems foolish to me to actively destroy a record of the
intellectual history of the IETF and its contributors.
Even the bad ideas, once they are written down, ought to be
archived, at least so that we can say "we tried that 3
years ago, and it didn't work" (or, with apologies to
Santayana, "Those who cannot remember the past are
condemned to re-invent it").  And even those documents that
are ultimately rejected as "bad protocols" might contain
"good ideas."

Others have already mentioned the utility of an I-D archive
for establishing intellectual priority, both for patent
disputes and for scientific publication.  If I'm reviewing
a paper by X who claims to have invented Y, and I know that
Y was published by Z in an I-D long ago, I'm certainly
going to insist that X give due credit to Z.

For role 1, we require
	(a) forward progress - i.e., I-Ds expire after 6 months
	(b) a public distinction between I-Ds and finished IETF work
	(c) no normative references to I-Ds from finished IETF work
	(d) no normative references to I-Ds by other authorities

Role 2 depends on a permanent archive (and, with all due respect
to JNC, without a needlessly punitive mechanism to make it
inconvenient to reference archived I-Ds).

There is no inherent conflict between that archive and the
need to preserve the distinction between archived I-Ds and
active ones.  We don't want people making normative
references to any kind of I-D, active or expired; creating
a convenient, stable archive really doesn't affect that.
And it's disingenuous to pretend that if the IETF doesn't
archive I-Ds, nobody else will.  In other words, the IETF
cannot successfully police (b) and (d), and it shouldn't try.
All we can do is educate people.

The IETF is perfectly capable of policing (a) and (c) above,
through its standard procedures.

Perhaps the IETF should consider adding an explicit warning
to each I-D when it enters the archive:

	STATUS OF THIS MEMO:

	THIS DOCUMENT IS AN EXPIRED INTERNET-DRAFT.  USE OF
	THIS MEMO FOR ANY PURPOSE EXCEPT AS A HISTORICAL
	DOCUMENT IS STUPID, WRONG, AND EVIL, AND WILL LEAD
	TO PUBLIC DERISION.

-Jeff

---

From: "Steven M. Bellovin" <[email-masked]>
Date: Mon, 25 Sep 2000 22:27:39 -0400

As someone who has cited I-Ds in published papers (if you're curious, 
see http://www.research.att.com/~smb/papers/badesp.ps -- I even 
identified one of the I-Ds as an "obsolete Internet draft), I have to 
support the notion of keeping them around.  In my case, I wanted to 
point out the inherent problems in a particular approach to IPsec.  I 
also needed to point out the evolution of the ideas over time.  I know 
of no better way to do that than to refer to successive versions of the 
same document.  In fact, I had to hunt through the net to find various 
versions of the documents in question...

		--Steve Bellovin