Subject: Unreliable TCP work?

From: Sam Liang <[email-masked]>
Date: Fri, 13 Oct 2000 15:03:51 -0700 (PDT)

Hello,

  I am wondering if there has been any work done on enhancing TCP to allow
unreliable transmission for real-time applications (audio/video).  Any
information is appreciated.

Sam

[email-masked]

---

From: Mahadevan Iyer <[email-masked]>
Date: Fri, 13 Oct 2000 09:26:43 -0700

Sam Liang wrote:

> unreliable transmission for real-time applications (audio/video).

enhancing...don't you mean degrading? :) :)

---

From: "Randall R. Stewart" <[email-masked]>
Date: Wed, 18 Oct 2000 07:22:03 -0500

> information is appreciated.
Sam:

I will put forth two answers to your question...

First: I don't think TCP is being enhanced to allow
unreliable delivery... 

Second: There is work underway to provide this on a different
venue besides UDP and RTP :). Recently a new transport
protocol SCTP has been approved (you should see a RFC soon). The
protocol has some nice extensions such as:

1) No head of line blocking
2) multi-homing
3) SACK built in to the protocol.
... others please see the following draft (or wait a week or two
and you can look at a RFC .. I hope :->)

http://search.ietf.org/internet-drafts/draft-ietf-sigtran-sctp-13.txt

Now SCTP is quite extensible and there are 3 drafts currently submitted
to sigtran that effect SCTP, one in particular is:

http://search.ietf.org/internet-drafts/draft-xie-usctp-sigtran-00.txt

This adds the ability to transmit data in a SCTP stream unreliably. 

Please have a look at these drafts you may find some interesting
reading :)

R
-- 
Randall R. Stewart
[email-masked] or [email-masked]
815-342-5222 (cell) 815-477-2127 (work)