Subject: Standartization of User Input for find\search engines

From: "Levinboim Family" <[email-masked]>
Date: Sat, 14 Oct 2000 18:29:43 +0200

As far as I'm aware of, there's no RFC\Draft or standard of any kind at the subject.

there isn't even a standard for simple operations like AND, OR, and NOT, for example, one can search:

ietf and rfc  - at one search engine

+ietf +rfc - at another

and this is just a simple search,
There should also be a standard mechanism for multiple searches and complex searches.

Please correct me if I'm wrong. 
I believe some work can and is needed to be done in the field.
any comments?

Tomer Levinboim

---

From: John C Klensin - IAB Chair <[email-masked]>
Date: Sat, 14 Oct 2000 16:57:37 -0400

Hi.

While some [additional] work would probably be useful, the IETF
has traditionally focused on on-the-wire protocols and avoided
user interface issues and standards as in neither our area or
our area of main competence.  If you want to pursue this, I'd
recommend some of the professional or standards groups concerned
about either human factors in computing or information search
and retrieval. My recollection is that there has been some
standardization work done by organizations in those areas, but
that it has mostly been ignored in the marketplace.  But this
could be a good time to try again.

best wishes.

--On Saturday, 14 October, 2000 18:29 +0200 Levinboim Family
<[email-masked]> wrote:

> there isn't even a standard for simple operations like AND,
> OR, and NOT, for example, one can search:
>

---

From: Srihari Varada <[email-masked]>
Date: Sun, 15 Oct 2000 15:15:08 -0400

Hello:

I am not aware of any efforts to standardize the operators in search
strings. However, I agree with and
felt the need for such standardization as it facilitates universal
interface.

Regards,

Srihari Varada

Levinboim Family wrote:

> As far as I'm aware of, there's no RFC\Draft or standard of any kind
> at the subject. there isn't even a standard for simple operations like
> AND, OR, and NOT, for example, one can search: ietf and rfc  - at one
> search engine +ietf +rfc - at another and this is just a simple
> search,There should also be a standard mechanism for multiple searches
> and complex searches. Please correct me if I'm wrong.I believe some
> work can and is needed to be done in the field.any comments? Tomer
> Levinboim