Subject: Re: [Re: Standartization of User Input for find\search engines]

From: "Robert G. Ferrell" <[email-masked]>
Date: Mon, 16 Oct 2000 14:57:55 -0500 (CDT)

>The common users will benefit from the things like the obvious-ness of
>Boolean operations (always being OR\AND\NOT) and simplicity.

I think this proposal has merit, although I'm not sure what, if any, role the 
IETF has to play in its implementation.

I get really tired of having to switch syntax for every search engine.  It would 
be nice if we had a standard that all engines could adopt (or at least offer 
compliance with).

Cheers,

RGF 

Robert G. Ferrell, CISSP
Information Systems Security Officer
National Business Center
U. S. Dept. of the Interior
[email-masked]
========================================
 Who goeth without humor goeth unarmed.
========================================

---

From: Glen Turner <[email-masked]>
Date: Tue, 17 Oct 2000 14:22:37 +0930

> IETF has to play in its implementation.

None.  It would be the equivalent of the IETF designing the
interface for e-mail clients.

> be nice if we had a standard that all engines could adopt (or at least offer

From the server's point of view, supporting Z39.50v3 with the WAIS
profile solves the interoperability problem, allowing a large
variety of clients to launch a database search that returns
an ordered set of URLs, ratings, titles and abstracts.

From the user's point of view they need only learn one user
interface -- that of their favoured Z39.50 client (which
might be Mozilla or a WWW/Z39.50 gateway).

This is exactly analogous to the split of protocol and user
interface used in the design of e-mail: the user probably
doesn't know what SMTP is and their view of e-mail is that
of one particular e-mail client (otherwise they'd be a lot
less postings of HTML, vCard and various Microsoft crud).

Essentially, the library community has already solved your
problem by specifying and deploying an international standard
protocol for generic search and retrieval from remote databases
of free and structured text.

In my view, the IETF should not develop a competing protocol.

Unfortunately, the business plans of some databases rely upon
the sale of advertising or ancillary products, these are not
really interested in deploying a standard search interface of
any type, including standards from ISO, IETF, W3C or anyone
else.

-- 
 Glen Turner                                 Network Engineer
 (08) 8303 3936      Australian Academic and Research Network
 [email-masked]          http://www.aarnet.edu.au/
--
 The revolution will not be televised, it will be digitised