Subject: Re: HTML better for small PDAs

From: "Robert G. Ferrell" <[email-masked]>
Date: Fri, 23 Feb 2001 12:44:15 -0600 (CST)

>Actually, it *is* a valid argument - consider that hieroglyphs were
>unreadable until they found the Rosetta Stone.  The media lasted, but the
>ability to parse didn't.

If we're going to stray onto the treacherous ice of logic here, 
then I feel constrained to point out that ASCII, XML, and so 
on are merely ways of formatting characters, not languages 
in and of themselves.  The clay tablet vs paper comparison really 
isn't applicable either, because the basic storage and display media 
do not change in our example, regardless of which format we adopt. 
A more precise analogy would be something along the lines of 
'shall we use ink, paint, chisels, or chalk?'  I'm afraid that even 
this construct isn't particularly useful in our context.  

There are times when analogies can shine a bright light on a dark 
debate, but they may also be the last refuge of the obfuscator.  

I say ASCII source documents are fine; if someone wants to convert their 
personal copies of the docs into XML, PDF, HTML, or Morse Code, they're 
perfectly welcome to do so.

Cheers,

RGF

Robert G. Ferrell, CISSP
========================================
 Who goeth without humor goeth unarmed.
========================================

---

From: "Wang Xianzhu" <[email-masked]>
Date: Sat, 24 Feb 2001 10:22:58 +0800

> perfectly welcome to do so.
ASCII source documents are not suitable for convertion.  This is also true for
HTML and pdf files.  If I convert a document, I need to know the logical structure
of the document. ASCII documents lack these meta information.  Although
HTML and pdf files have information about structure, but this information is
only for presentation, not the logical information of the document.

All these formats of documents are for presentation, not for manipulating.
Mixing up the manipulating and presentation processes has many problems.
XML/SGML is the solution.

Regards,
Wang Xianzhu

---

From: Bill Manning <[email-masked]>
Date: Sun, 25 Feb 2001 00:32:37 -0800 (PST)

% 
% > 
% > I say ASCII source documents are fine; if someone wants to convert their 
% > personal copies of the docs into XML, PDF, HTML, or Morse Code, they're 
% > perfectly welcome to do so.
% >
% ASCII source documents are not suitable for convertion.  This is also true for
% HTML and pdf files.  If I convert a document, I need to know the logical structure
% of the document. ASCII documents lack these meta information.  Although
% HTML and pdf files have information about structure, but this information is
% only for presentation, not the logical information of the document.

	Sure they are. Your "logic" and mine could be different and
 	you should have the privlege of "tagging for meta information"
	to meet your needs.
	Its just more work for you to figure out where you might want
	to place things. Punctuation is always fun.

% All these formats of documents are for presentation, not for manipulating.
% Mixing up the manipulating and presentation processes has many problems.
% XML/SGML is the solution.
		
	For some. Its not for me.
% 
% Regards,
% Wang Xianzhu
% 
% > Cheers,
% > 
% > RGF
% > 
% > Robert G. Ferrell, CISSP
% > ========================================
% >  Who goeth without humor goeth unarmed.
% > ========================================
% > 
% > 
% 
% 

-- 
--bill