Subject: RE: ECC limits? (was RE: An alternative to TCP ...)

From: "Christian Huitema" <[email-masked]>
Date: Fri, 9 Feb 2001 16:34:14 -0800

Yes, in theory you may obtain an arbitrary residual rate for any given
input rate + overhead, if you are willing to make your codes long
enough. That may quickly become a tad pricy, however. There is also the
additional problem that most demonstrations assume errors are randomly
distributed. If the error distribution is heavy tailed, which is the
case on very many technologies, all bets are off... This is one of the
ways to not achieve the desired result.

-- Christian Huitema

> -----Original Message-----
> From: James P. Salsman [mailto:[email-masked]] 
> Sent: Friday, February 09, 2001 4:22 PM
> To: Christian Huitema
> Cc: [email-masked]
> Subject: ECC limits? (was RE: An alternative to TCP ...)
> 
> 
> >... To reach 10 Gbps, you will need a BER of 1.E-14....
> > There are very many ways to not achieve that....
> 
> Are there any limits to what error correcting codes can provide?
> 
> If you have 15 Gbps with a natural error rate of 1 in 100, 
> I think you can still get better than 1 in 1e14 bit errors 
> at 10 Gbps with traditional techniques such as Reed-Solomon.
> 
> Please correct me if I am wrong.
> 
> Cheers,
> James
>

---

From: Jon Crowcroft <[email-masked]>
Date: Sun, 11 Feb 2001 14:54:10 +0000

there's some very fancy codes that digital fountain and other
companies doing FEC based reliable multicast have - see tornado codes
and other references

can this and the TCP discussion move to end2end-interest
[email-masked]     
coz its a more appropriate (focussed) place!

In message <[email-masked]>, Christian 

 >>> Please correct me if I am wrong.

 cheers

   jon