Subject: re: Mail sent to midcom

From: "Mike O'Dell" <[email-masked]>
Date: Tue, 13 Feb 2001 09:11:19 -0500 (EST)

I think this discussion is revealing a deep truth and
avoiding that truth at the same time.

the real root-cause of this discussion is the assertion
of identity as determined by email address. 
that's the operational basis for any kind of "subscription"
model based on email address.

the whole "moderation" thing is really about the identity
of posters, not their email address, and the imputed 
motives for their posting.  on the one hand, it's hard
to argue that it is unreasonable to try and protect
WG discourse from individuals with "hostile" motives.
the problem, though, is the technology currently has
not strong notion of identity upon which to base such
a determination other than email address.

once upon a time, people were lucky to have *one* email
address and a given individual tended to be associated
with that email address in a very strong way, enough
so that people decided it was a sufficient indicator
of identity.

today, with many more people having email addresses
and many people having more than one email address
for good and righteous reasons, that model simply
doesn't work anymore.  it isn't a "good-bad" thing,
it's a "not applicable at the current scale" thing.

it did work - it doesn't work anymore.

if we want to do such discrimination based on the identity of
the poster, (and i happen to believe *lots* of people want to
do this), then we need to get busy and improve the technology
and stop trying to pound the tree-trunk through the small
knot-hole.

	-mo

ps - no, i didn't say anything about removing anonymity,
if people do not wish to assert an identity in an email,
that's fine with me.  the recipients can use that tidbit
of information as they see fit.

---

From: Harald Alvestrand <[email-masked]>
Date: Tue, 13 Feb 2001 19:40:30 +0100

>it did work - it doesn't work anymore.

I recently had the dubious pleasure of sending out 40.000 emails to a set 
of email addresses gathered (with the owners' approval!) over a period of 
seven years.

The result was roughly 10.000 bounces (naturally), dozens of requests to 
merge multiple registrations for the same person, and on the order of FIVE 
occurences of an email address previously used by one person now being used 
by another.

The mapping address -> person is pretty strong, and mostly single-valued.
The mapping person -> address is multivalued, and getting more so.

Not quite "not working", if we take it for what it is.

--
Harald Tveit Alvestrand, [email-masked]
+47 41 44 29 94
Personal email: [email-masked]

---

From: John Stracke <[email-masked]>
Date: Tue, 13 Feb 2001 15:29:54 -0500

> The mapping address -> person is pretty strong, and mostly single-valued.

Interesting.  Hypothesis: this might happen because (a) ISPs (in the US) try
to avoid reusing addresses in order to avoid ECPA problems; and (b)
corporations try to avoid reusing addresses because they'd rather have email
bounce than have confidential information go to the wrong person.

--
/==============================================================\
|John Stracke    | http://www.ecal.com |My opinions are my own.|
|Chief Scientist |=============================================|
|eCal Corp.      |Campbell's has it wrong--it's "Never         |
[email-masked]|underestimate the power of *chocolate*".     |
\==============================================================/

---

From: Keith Moore <[email-masked]>
Date: Tue, 13 Feb 2001 17:18:11 -0500

> Hypothesis: this might happen because (a) ISPs (in the US) try
> corporations try to avoid reusing addresses because they'd rather 
> have email bounce than have confidential information go to the wrong person.

I also wonder about Harald's sample - might this particular group of 
people be more likely to 

- understand the value of a stable email address
- pick a ISP that provides good service and has good potential for longevity
- have his/her own personal domain name
- forward his/her mail from older addresses to newer ones.

than the average email user?

(though presumably IETF folks are also more likely to fit the above 
criteria than the average email user)

Keith

---

From: Harald Alvestrand <[email-masked]>
Date: Wed, 14 Feb 2001 11:49:53 +0100

>than the average email user?

with 4.400 Yahoo accounts and 7.400 Hotmail accounts in the mix, I doubt 
that it is completey untypical .-)

---

From: "Dassa" <[email-masked]>
Date: Wed, 14 Feb 2001 22:25:26 +1100

|>-----Original Message-----
|>From: Harald Alvestrand [mailto:[email-masked]]
|>Sent: Wednesday, February 14, 2001 5:41 AM
|>To: Mike O'Dell; [email-masked]
|>Subject: Relation email - person (re: Mail sent to midcom)
|>
|>I recently had the dubious pleasure of sending out 40.000 
|>emails to a set of email addresses gathered (with the owners' approval!) over 
|>a period of seven years.
|>
|>The result was roughly 10.000 bounces (naturally), dozens of 
|>requests to merge multiple registrations for the same person, and on the 
|>order of FIVE occurences of an email address previously used by one person 
|>now being used by another.
|>
|>The mapping address -> person is pretty strong, and mostly single-valued.
|>The mapping person -> address is multivalued, and getting more so.
|>
|>Not quite "not working", if we take it for what it is.

I would consider such results the fault of the list maintainer and not a fault in the email system.  Much like physical addresses used within the postal system, anyone maintaining a list needs to provide a means to maintain the validity of the data.  If the data is invalid it is a cost the person using the data has to carry.  It doesn't mean that all the data is invalid, just the means to keep it current was inadequate.  Most mailing lists for instance employ means to maintain the integrity of the subscribtions, including regular probes.  There are means available for other types of lists, a lot depending on the usage and value.

Darryl (Dassa) Lynch.

---

From: [email-masked]
Date: Wed, 14 Feb 2001 11:48:46 -0500

On Wed, 14 Feb 2001 22:25:26 +1100, Dassa <[email-masked]>  said:

> I would consider such results the fault of the list maintainer and not
> a fault in the email system.  Much like physical addresses used within
> the postal system, anyone maintaining a list needs to provide a means
> to maintain the validity of the data.  If the data is invalid it is a

Yes, crufty data causes a lot of bounces, and data should be cleaned...

But Harald's point was that *EVEN* in data *so* crufty that fully 1/4 of
it bounced because the destination was defunct, he had:

25.00%  defunct
 0.1%   duplicates (same person, different addresses)
 0.01%  wrong person

which is a pretty strong evidence of Harald's assertion:

One would expect that in "clean" data, these mappings would be even stronger.

-- 
				Valdis Kletnieks
				Operating Systems Analyst
				Virginia Tech

---

From: "Dassa" <[email-masked]>
Date: Thu, 15 Feb 2001 19:13:36 +1100

|>-----Original Message-----
|>From: [email-masked] [mailto:[email-masked]]
|>Sent: Thursday, February 15, 2001 3:49 AM
|>Subject: Re: Relation email - person (re: Mail sent to midcom) 
|>
|>25.00%  defunct
|> 0.1%   duplicates (same person, different addresses)
|> 0.01%  wrong person
|>
|>which is a pretty strong evidence of Harald's assertion:
|>
|>|>The mapping address -> person is pretty strong, and mostly single-valued.
|>|>The mapping person -> address is multivalued, and getting more so.
|>
|>One would expect that in "clean" data, these mappings would 
|>be even stronger.

The first and second statistics can be taken care of with management.  The last one is of concern but could also be taken care of with management.  Not sure that it is strong evidence.

I have multiple e-mail addresses, some of them redirections to other addresses and others that map finally through redirections to multiple addresses and individuals.

Take mailing list addresses for instance where a single address resolves out to multiple individuals, some in fact may not be to individuals but expanded out in other directions, add in wap and it starts getting complicated. It may be desirable to have an authoritive address for each individual and I assume this is where this thread is heading.  I'm interested in the subject of e-mail which is why I broke my lurking :).

Darryl (Dassa) Lynch.