Subject: RE: [midcom] WG scope/deliverables

From: "Fleischman, Eric W" <[email-masked]>
Date: Fri, 16 Feb 2001 16:20:03 -0800

Taking your valuable points a bit further, NAT avoidance arguments aren't likely to sell IPv6 to us large end users, because this is a problem for which it is difficult to construct a business case that will excite the non-technical managers who are in charge of blessing large capital expenses.  

By contrast, what will sell IPv6 will be "Killer Applications" that require IPv6. I am optimistic that advances like the UMTS Release 2000 Cell Phone standard, which requires IPv6, will provide the impetus for us end users to eventually justify the expenses of an IPv6 deployment. Should that business case be made, then 6to4 can ease this newer infrastructure into our systems. Once that occurs, then the advantages of a NAT-less IPv6 would become relevant to us large corporations. As it is, this is a theoretical concern at best to us due to the real-life implications (time, $$$) of deploying IPv6 into our networks compared to the advantages of cheaper stop-gap "solutions" like NATs.

By saying this, I don't want to imply that I have any technical disagreement with the arguments that have led many  to conclude that "NATs are evil." I am only stating that such arguments alone don't make a good business case. Similarly, while the best current approximations that the H-ratio, which determines when the IPv4 Address Space will be saturated for all practical purposes, will most likely occur in 2002 (i.e., NEXT YEAR) motivates me as a technical person, conveying these concerns into a viable business case that will motivate the "guys with the bucks" is a very different proposition indeed. That is why we need the "escape hatch" which midcom will hopefully provide us with, especially in view of the difficulties which current NAT approaches will introduce as we increasingly deploy peer-to-peer applications within our infrastructures.

-----Original Message-----
From: Brian E Carpenter [mailto:[email-masked]]
Sent: Friday, February 16, 2001 8:04 AM
To: Bernard Aboba
Cc: Randy Bush; Melinda Shore; Michael W. Condry; [email-masked]
Subject: Re: [midcom] WG scope/deliverables

Bernard,

Exactly. That is why 6to4 came out the way it did - it offers a way
for a NATted IPv4 site to introduce non-NATted IPv6 without losing
anything or throwing away anything.

There are RFCs explaining the issues with NAT technically and objectively.
I don't see why this generates comments about anti-NAT religion.
It's obvious when you read those RFCs and think about P2P computing
that NAT is a problem. If we don't avoid that problem in IPv6
we will have failed as engineers.

  Brian

Bernard Aboba wrote:
> 
> >i suggest that, for most of us, there are more useful and concrete major
> >direct goals of ipv6 than anti-nat religion.
> 
> And in fact, the anti-NAT religion hurts deployment of IPv6
> because it is hard to get customers to throw away things
> they have already bought.
> 
> I would also suggest that the rapidity at which NAT is
> being deployed for IPv4 suggests that we need to think about
> how to deploy IPv6 in an environment where IPv4 NATs are prevalent.
> Thus, it is unlikely that IPv6 will displace IPv4 NATs; tather
> it will augment them.

---

From: Keith Moore <[email-masked]>
Date: Fri, 16 Feb 2001 21:24:18 -0500

> Taking your valuable points a bit further, NAT avoidance arguments aren't
> likely to sell IPv6 to us large end users, because this is a problem for which
> it is difficult to construct a business case that will excite the
> non-technical managers who are in charge of blessing large capital expenses.

this is why some of us are working on solutions for interim deployment
of IPv6 without the need for large capital expenses; i.e. at a similar
cost to deployment of NAT.

Keith