Subject: First bit of IP Addresses

From: Anshul Jain <[email-masked]>
Date: Wed, 31 Jan 2001 23:57:07 -0800 (PST)

Hi,

I am not clear in basics of ip address format, why we are not using the
first bit as 0 to define new class of addresses, may this double the
available IPs,

Regards,

__________________________________________________
Get personalized email addresses from Yahoo! Mail - only $35 
a year!  http://personal.mail.yahoo.com/

---

From: James Aldridge <[email-masked]>
Date: Thu, 01 Feb 2001 10:43:32 +0100

> first bit as 0 to define new class of addresses, may this double the

Hmmm... and why not call this new class of addresses "Class A"?

In the classful world:
	bit 1 = 0		-> Class A
	bits 1,2 = 10		-> Class B
	bits 1,2,3 = 110	-> Class C
	bits 1,2,3,4 = 1110	-> Class D (Multicast)
	etc.

James

---

From: [email-masked]
Date: Thu, 01 Feb 2001 09:44:17 -0500

> 	bits 1,2,3,4 = 1110	-> Class D (Multicast)

Note that since the creation of CIDR, class A/B/C has been essentially
deprecated in favor of address/mask pairs.  In fact, so much so that in
today's net, stuff that still insists on class A/B/C distictions is
considered "broken".

-- 
				Valdis Kletnieks
				Operating Systems Analyst
				Virginia Tech