Subject: Why XML is perferable

From: "Wang Xianzhu" <[email-masked]>
Date: Fri, 23 Feb 2001 17:13:17 +0800

> to render XML documents to pure text presentation.  There will be
>                                                             ^^^^^^^
> > converters from XML to HTML, ms word, ps, pdf and any other types of
> > presentation, suitable for any type of readers.
> 
> Meanwhile I stick with ASCII, which I can grep, cut & paste.
> 
1. You can easily get a very well-formed ASCII file from a XML file.
2. With XML, you can not only grep, cut & paste, but also manage and process it.

For example, I can grep XML files for whose level 2 headings containing 
the string 'file transfer protocol'.  But for ASCII files, this is impossible, because 
1) the computer program does not know where are level 2 headings
2) the string may be split into two lines, grep fails in this situation.

> Also I don't think it will be at all practical to drive email
> discussions
> for ietf drafts if we have to start using XML/HTML/SGML/*ML crap.
>  
> > BTW, there are RFCs (1125, 1129, etc.) only available in ps format, and some
> > provided both text and ps versions.  ASCII text is not enough to describe
> > information.
> 
> Well it worked fine for 2800+ documents and how many today ?
3060+ today, with many ugly figures in '-', '_', 'o', '/', '\' chars, which
is very difficult to read.  In XML, you can even search for figures if 
we develop unified Internet/flowchart/etc DTDs.

> implementations
> of tcp/ip protocols running on how many devices ?
> 
> > I wonder if anyone can write a readable pure text version of ITU-T P.861.
> 
> What P.861 {Objective quality measurement of telephone-band (300-3400 Hz) 
> speech codecs} has to do with tcp/ip and rfc's ???
> 
Yes, their content of P.861 seems have nothing to do with RFCs.  
P.861 is an informational document, like any RFCs.  If a RFC face a 
similar problem like P.861, I wonder how it can describe it clearly in 
pure text.

XML provides a way to describe information in documents, and can be 
easily converted to different types of target formats, such as pure text,
pdf, HTML, etc.   Again: XML is not for display.

> BTW, I hate to pay for ITU documents what are supposed to be public (I
> still
> remember the years old discussion when they ceased to exist available
> for anon ftp)

I hate ITU too. :)

> Regards
> Jorge.
Regards,
Wang Xianzhu

---

From: [email-masked]
Date: Fri, 23 Feb 2001 09:29:44 -0000

> -----Original Message-----
> From:	Wang Xianzhu [SMTP:[email-masked]]
> Sent:	Friday, February 23, 2001 9:13 AM
> To:	ietf
> Subject:	Why XML is perferable
> 
> > 
	Yes, fine  - if you happen to like messy diagrams; are not Chinese,
Japanese, Korean, Arabic, .......

> > remember the years old discussion when they ceased to exist available
	Nice to see some reasoned argument for a change !

---

From: "Shaw, Robert" <[email-masked]>
Date: Fri, 23 Feb 2001 12:09:12 +0100

> > > BTW, I hate to pay for ITU documents what are supposed to 
> be public (I still remember the years old discussion when they 
> ceased to exist available for anon ftp)
> > 
> > I hate ITU too. :)
> > 

Well, it's always useful for religious groups to have a
"great satan"... :-)

> 	Nice to see some reasoned argument for a change !

Errr...it's not even reasoned....

See http://www.itu.int/publications/bookshop/how-to-buy.html#free

The implications of this are left as an exercise for the clever
engineer.

Bob
--
Robert Shaw <[email-masked]>
ITU Internet Strategy and Policy Advisor
International Telecommunication Union <http://www.itu.int>
Place des Nations, 1211 Geneva, Switzerland

---

From: Bob Braden <[email-masked]>
Date: Fri, 23 Feb 2001 17:21:52 GMT

*> well-known, but some RFCs such as those on OSPF may be much
  *> more vivid if written in XML. There have been quite a few

Vivid?  We are talking about deeply complex technical documents
here, not MTV.  What do you mean, "vivid"?

Bob Braden

---

From: Ren <[email-masked]>
Date: 24 Feb 2001 15:49:00 -0800

One additional consideration, the poster had a .cn address.

If a graph will help with language/translation issues so much the better.

-Ren

On Sat, 24 February 2001, Stephen McHenry wrote:

> 
> At 12:20 PM 2/24/2001, Bob Braden wrote:
> >Surely you jest.  Animated GIF?  How did you get through school without
> >having your algebra dance on a screen?  We can color the independent
> >variables red, the functions green, and ...
> 
> Hey, that's not a bad idea.

<repeats snipped>

-Ren 
http://www.i-regatta.org