Subject: Re: An alternative to TCP (part 1)

From: [email-masked] (Jun'an Gao)
Date: Wed, 07 Feb 2001 14:56:34 +0800 (CST)

> General Question:

> - How to migrate?
>  I have been using the "QWERTY" keyboard all the time.
>  I am aware that it is not the best, but I am stuck.
So a set of APIs must be defined. They should be downward-compatible with basic socket APIs supporting TCP.

Because ATP is optimzed for IPv6, and because generally speaking a network application has to be recompiled if not rewritten to be migrated to IPv6 (from TCP/IPv4), I think it can be rationally assumed that a network application may be recompiled and relinked with an ATP/IPv6 library.

>> 4. Each time the client end initiates a new connection it 
>>    will allocate a new IPv6 address. The allocation may 
>>    be done randomly, providing client anonymity.

>How are you going to route those random packets?

Well, actually only the interface ID part of the IPv6 address is randomly chosen. The site level aggregation ID and above might be fixed or might be randomly chosen from a small set if the site is multi-homed. Routing of IPv6 packet is based on hierarchical aggregation ID. The real problem is not routing but instead the scale problem of the network edge router: as each new connection consumes a new IPv6 address the router must create a new entry mapping the network-layer address to the link-layer address or else the ND protocol has to be applied again and again. A similar problem challenges the NAT devices as well.

---

From: Harald Alvestrand <[email-masked]>
Date: Wed, 07 Feb 2001 17:58:38 +0100

General question:

if you are proposing that the IETF should investigate ATP, have you 
submitted the proposal as an internet-draft?

If not, why not?
--
Harald Tveit Alvestrand, [email-masked]
+47 41 44 29 94
Personal email: [email-masked]