Subject: Re: Writing Internet Drafts on a Macintosh

From: Keith Moore <[email-masked]>
Date: Thu, 22 Feb 2001 11:21:44 -0500

> Then, IMO ietf needs to define a set of XML tags and instead of 'well 
> defined' or valid HTML we will have 'valid' XML and it will be indexable 
> and the same every time, otherwise it won't render. :)

a fine idea and certanily doable, though it wouldn't allow people 
to produce or read I-Ds any more easily than they can do so now.
tools for creatng (something resembling) HTML and for reading it 
abound; tools for manipulating XML exist but are not as widely deployed.

---

From: Patrik Fältström <[email-masked]>
Date: Thu, 22 Feb 2001 09:31:12 -0800

>abound; tools for manipulating XML exist but are not as widely deployed.

The XML DTD is defined. You use the XML source to create ASCII which 
becomes the acrchival format. The XML can be saved _aswell_ (just 
like the postscript, nroff source or whatever).

There are even people which have the RFC-Index.txt (sort of) file in 
XML format so it is easy to cut&paste and create the references 
section.

   paf

---

From: Keith Moore <[email-masked]>
Date: Thu, 22 Feb 2001 13:36:28 -0500

> like the postscript, nroff source or whatever).

sure, and it's a fine way to create an I-D if you have the tools.
but if you have the tools to create an XML document then you probably
also have the tools to create an I-D in ASCII.  after all, I-Ds only
require line-wrapping and some boilerplate; last I knew, they didn't
even require pagination.

if you don't have the tools to create an I-D via either XML or ASCII, 
you can probably get either kind of tools with about the same amount 
of difficulty.  they're available; you just have to know where to look,
and you have to learn how to use them.

I think the frustration that people experience is from having tools
already with which they are familar, and which (apparently) are quite 
useful for producing other kinds of documents, but which are not 
effective tools for producing I-Ds.

Keith

---

From: Patrik Fältström <[email-masked]>
Date: Thu, 22 Feb 2001 10:55:26 -0800

At 13.36 -0500 01-02-22, Keith Moore wrote:
>also have the tools to create an I-D in ASCII.

I write the XML in a text editor, aka email equivalent. The DTD is 
not that difficult.

>after all, I-Ds only

Correct.

The linewrapping can be a nightmare though.

    paf

---

From: "Doug Sauder" <[email-masked]>
Date: Thu, 22 Feb 2001 15:53:56 -0500

I read the entire XML-SOAP document on my PDA, and that convinced me that reading documents on a small device is doable.  I would be happy to put lots of RFCs and I-Ds on my PDA and have them available even when I don't have a laptop around.  However, plain ASCII text, like the RFCs, looks pretty bad on a small device, because the paragraphs don't wrap in a pleasing way.  HTML looks a lot better on a PDA than plain ASCII.

For this reason, I would like to see documents authored in some kind of HTML or XML format that can be converted to plain text as well as formats that are viewable on small devices.

--
Doug Sauder

---

From: [email-masked]
Date: Thu, 22 Feb 2001 17:49:38 -0500

On Thu, 22 Feb 2001 15:53:56 EST, Doug Sauder <[email-masked]>  said:

> I read the entire XML-SOAP document on my PDA, and that convinced me
> that reading documents on a small device is doable.  I would be happy to
> put lots of RFCs and I-Ds on my PDA and have them available even when I
> don't have a laptop around.  However, plain ASCII text, like the RFCs,
> looks pretty bad on a small device, because the paragraphs don't wrap
> in a pleasing way.  HTML looks a lot better on a PDA than plain ASCII.

Ironically enough, the previous paragraph arrived as one long string
without a 'format=flowed'.  As a result, it didn't wrap in a pleasing way. ;)

Of course, the concept that we should redo all the RFCs into XML so they are
more pleasing on a GameBoy-class display misses the point that rfc1.txt is
still readable 32 years after being written, while both the XML and the
display you're trying to support will probably be history within a decade.

Trivia Question 1:  What was the *first* popular word-processing program
that used embedded codes, etc, in addition to flat ascii, on a PC/Apple/etc
machine?

Trivia Question 2:  What year was it released?

Trivia Question 3:  If you were handed a file in that format, could you read it?

-- 
				Valdis Kletnieks
				Operating Systems Analyst
				Virginia Tech

---

From: "Doug Sauder" <[email-masked]>
Date: Thu, 22 Feb 2001 21:01:23 -0500

> From: [email-masked] [mailto:[email-masked]]

I am not sure I agree with the statement that in 10 years XML will be history.  One of XML's greatest values is in the fact that it is a good format for long-term archiving of written material.  Some very old material (several millenia old) is available in XML format -- that's more than the 32 years for RFC1.  ;-)  The reason old text has been converted to XML is not so that people can read it on a GameBoy, but so that it can be archived, indexed, converted to other formats, etc.  An alternative point of view is that in 10 years XML will have achieved a critical mass, so that it becomes as entrenched as many other standards: ASCII, TCP/IP, C, etc.

My original point about XML is that you can convert to whatever format suits you.  You want plain ASCII text?  Prefer to archive in plain text?  You can.  It's not taking anything away, but it does offer a bit more.

--
Doug Sauder

---

From: [email-masked]
Date: Thu, 22 Feb 2001 22:37:23 -0500

On Thu, 22 Feb 2001 21:01:23 EST, you said:

> I am not sure I agree with the statement that in 10 years XML will
> be history.  One of XML's greatest values is in the fact that it is a
> good format for long-term archiving of written material.  Some very
> old material (several millenia old) is available in XML format --
> that's more than the 32 years for RFC1.  ;-)  The reason old text has
> been converted to XML is not so that people can read it on a GameBoy,
> but so that it can be archived, indexed, converted to other formats, etc.

1) Was your millenia-old data *written in XML*, or was it *converted to* XML
within the past 5 years?

2) Will you be able to find the DTD you need in 2035?

> An alternative point of view is that in 10 years XML will have achieved a
> critical mass, so that it becomes as entrenched as many other standards:
> ASCII, TCP/IP, C, etc.

OK.. Wake me up in 2011 and I'll be MORE than happy to reconsider. ;)

				Valdis Kletnieks

---

From: "Doug Sauder" <[email-masked]>
Date: Fri, 23 Feb 2001 10:18:17 -0500

> 1) Was your millenia-old data *written in XML*, or was it 

Duh!?  ;-)  Obviously, this is a rhetorical question.

> 2) Will you be able to find the DTD you need in 2035?

Well-formed XML documents still have value even without a DTD.  It's usually pretty easy to guess at what the elements mean.  If the documents are of value to a lot of people at the time, then yes, you probably will be able to find the DTD and one or more style sheets.  If it's just a historical document, then maybe or maybe not.  I'll bet that you'd be able to find a plain text rendering of the document, though.

> OK.. Wake me up in 2011 and I'll be MORE than happy to reconsider. ;)

I don't have a crystal ball, and I have been around long enough to have seen fads come and go.  XML seems to me to strike the right balance between simplicity and value-add, so that I would consider it a pretty safe bet for the long-term as a document format.  Anyway, I don't expect that the IETF will be moving from plain text to any other format for years, if ever.  For the most part, this discussion is academic.

Here's a proposal though:  how about multipart/alternative!  ;-)  Seriously, storage is incredibly cheap.  Why not store documents in several formats?  If the plain text rendering is the normative document, I don't think anyone would have a problem with that.  Perhaps the RFC editor could accept documents using the DTD from M Rose as well as the normative plain text format.  I'm not suggesting that the editor take on a lot of new work, just that XML documents, when submitted by authors, be made available from the Web.

BTW, I have always liked the layout of the RFCs -- namely, that they are nicely paginated with page numbers and headers.  On the other hand, HTML often doesn't print very well.

--
Doug Sauder

---

From: "Doug Sauder" <[email-masked]>
Date: Fri, 23 Feb 2001 12:27:39 -0500

Just a few final observations, then I'll bug out of the discussion.

1. Some folks scoff at the idea of reading I-Ds and RFCs on a PDA, yet they think it's necessary to accommodate those who would read them on 1950s-style teletypes or other old, outdated equipment.  We say that lines should be, what, 76 characters long?  Why?   What about 40 characters per line?  Then I could read the RFCs on my old Commodore 64  in addition to my PDA.  ;-)  What *is* the lowest common denominator, anyway?

2. RFCs have a limited lifetime.  RFC 1 might be 32 years old, but it's probably only relevant to historians.  Historians will probably find the tools they need to view old documents.  So, if RFCs are maintained in a format that outlives the technology documented in the RFCs, then there's no problem, right?  (Speaking from the aspect of archives.)  Anyone know how long ASCII will be around?

--
Doug Sauder