Subject: RE: rfc publication suggestions

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 12 Mar 2001 16:57:03 -0500

Just as a practical matter from recent experience.

Usually, an RFC originates as an IESG approved I-D.
Usually, you don't submit nroff for an I-D.
The RFC editor never asks if you have nroff
The RFC editor sometimes forgets when you offer it.
So, even if you have nroff source, you may have to work
   to get it to the right folks at the right time.

Of course a big problem is the decreasing number of
IETF people who know nroff, and even fewer that are fluent,
and even fewer who would, if they had a choice, choose it.

Brian

> -----Original Message-----
> From: Vernon Schryver [mailto:[email-masked]]
> Sent: Sunday, March 11, 2001 8:24 PM
> To: [email-masked]
> Subject: Re: rfc publication suggestions
> 
> 
> > From: Dave Crocker <[email-masked]>
> 
> > ...
> > The current RFC publication process has some astonishing 
> delays apparently 
> > due to the process including a conversion of the source text to 
> > nroff.  Eliminating that step, or at least automating its 
> equivalent, could 
> > only help.
> > ...
> 
> I don't understand that statement.
> Has the RFC editor stopped accepting nroff?
> Has the old tool that generates nroff from simple ASCII been lost?
> 
> Unless things have changed in unlikely and unannounced ways, that
> people either don't read RFC 2223 or refuse to submit nroff suggests
> something about some of the nominal issues, including whether the
> delays matter to authors and whether authors would use a 
> better format.
> 
> No rocket science (but maybe some patience) is required to 
> write nroff.
> Thanks to groff, typesetting nroff has become free.
> 
> 
> Vernon Schryver    [email-masked]
> 
> -
> This message was passed through [email-masked], which
> is a sublist of [email-masked]. Not all messages are passed.
> Decisions on what to pass are made solely by Harald Alvestrand.
>

---

From: "Timothy J. Salo" <[email-masked]>
Date: Tue, 13 Mar 2001 08:56:16 -0600 (CST)

> From: "Rosen, Brian" <[email-masked]>
> Subject: RE: rfc publication suggestions
> Date: Mon, 12 Mar 2001 16:57:03 -0500
> 

Perhaps, the perils of a cost-plus-fixed-fee contract?  (Note that I
haven't seen the RFC Editor contract, nor have I checked to see if it
is public.)

> and even fewer who would, if they had a choice, choose it.

Back when SRI was running the NIC (registering domain names, for those
not familiar with ancient history) I understand that they were running
stuff on some big, ancient (even at the time) DEC system (DEC-10 or
DEC-20 -- I forget because I'm not a DEC guy).  Network Solutions
apparently underbid SRI's (presumably cost-plus-fixed-fee) proposal
and converted all the processes to some Unix platform, (Solaris, I
think).

So, maybe, just maybe, the use of nroff is an artifact of un-competed
cost-plus-fixed-fee contracts, rather than any sort of intellectual
sclerosis of the IETF.

Or, we could go back to talking about NATs.

Never mind...

		-tjs