Subject: RE: rfc publication suggestions

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 12 Mar 2001 17:55:14 -0500

An interesting metric would be the time from the date something enters
a queue to the time its status is first changed - i.e. the first time
the editor looks at it.  I believe that is some number of months.  
Once the editor picks it up, then its time in queue is more a function 
of outside influence (waiting for others to do something), 
then internal processing of the RFC editor.

That's my recent experience anyway.

I'd love to have a discussion of:
	What do we WANT the queue time to be
	What would we have to do to get it there

I'd say that time to first action should be a couple of weeks to a month.
I'd also like to see if there were some more processes we could 
put in place so that the text never entered the queue until things
we KNOW have to be done, are actually done (like normative references,
IANA considerations,....).  What happens now is silliness due to 
the known queue length - we put things in we know are deficient,
always assuming we will have the issues resolved before it wends it's
way through the queue.  Of course, it rarely works out that way,
and instead the RFC editor gets to be the nagging mother to us all.
Maybe we change the process so that a document is looked at
immediately for those missing things, and put in a hold queue
until they are resolved, and THEN they get into the "real" queue.
How much work would it be to scan the document for the normal
missing items?  Could we allocate people to do that as they
enter the process?

Brian

> -----Original Message-----
> From: Fred Baker [mailto:[email-masked]]
> Sent: Monday, March 12, 2001 4:18 PM
> To: Dave Crocker
> Cc: Steven M. Bellovin; [email-masked]
> Subject: Re: rfc publication suggestions 
> 
> 
> At 02:16 PM 3/12/2001 +1100, Dave Crocker wrote:
> >however the editor queue can hold things for a very long 
> time, and not 
> >just due to waiting for an author to fix something.  (gosh.  
> we haven't 
> >discussed THIS topic in a couple of years...)
> 
> the most common hold-up that I see is a wait for normative 
> references. That 
> held the MPLS documents up for a year.
> 
> -
> This message was passed through [email-masked], which
> is a sublist of [email-masked]. Not all messages are passed.
> Decisions on what to pass are made solely by Harald Alvestrand.
>

---

From: Keith Moore <[email-masked]>
Date: Mon, 12 Mar 2001 19:17:42 -0500

> What happens now is silliness due to 
> way through the queue. 

Where in the world do you get that idea?  I spent four years on IESG
and I can't recall a single instance of this happening.

Seems like what we have now is a lot of uninformed speculation. 

Keith

---

From: Lloyd Wood <[email-masked]>
Date: Tue, 13 Mar 2001 13:25:39 +0000 (GMT)

> 	What would we have to do to get it there

Editor queue time is not a meaningful engineering constraint, and we
shouldn't be optimising for it.

The IETF should not be organised around time to publication or time to
decisions.

L.

<[email-masked]>PGP<http://www.ee.surrey.ac.uk/Personal/L.Wood/>