Subject: Last Call: Using SOAP in BEEP to Proposed Standard

From: [email-masked]
Date: Wed, 12 Sep 2001 12:28:28 +0100

I would like to see this work taken into a standards track, if possible.

     Cheers,
          Tony.
========
Anthony B. Coates
(1) Content Distribution Architect - Project Gazelle
(2) Leader of XML Architecture & Design - Chief Technology Office
Reuters Plc, London.
[email-masked]
========
----- Forwarded by Tony Coates/LON/GB/Reuters on 12/09/2001 12:29 -----
                                                                                                                       
                    Larry Masinter                                                                                     
                    <[email-masked]>            To:     [email-masked]                                               
                    Sent by:                 cc:                                                                       
                    xml-dist-app-requ        Subject:     Last Call: Using SOAP in BEEP to Proposed Standard           
                    [email-masked]               Header:      Internal Use Only                                            

                    10/09/2001 00:56                                                                                   
                    Please respond to                                                                                  
                    iesg                                                                                               

The IESG has received a request to consider Using SOAP in BEEP
<draft-etal-beep-soap-04.txt> as a Proposed Standard.  This has been
reviewed in the IETF but is not the product of an IETF Working Group.

The IESG plans to make a decision in the next few weeks, and solicits
final comments on this action.  Please send any comments to the
[email-masked] or [email-masked] mailing lists by October 7, 2001.

Files can be obtained via
http://www.ietf.org/internet-drafts/draft-etal-beep-soap-04.txt

-----------------------------------------------------------------
        Visit our Internet site at http://www.reuters.com

Any views expressed in this message are those of  the  individual
sender,  except  where  the sender specifically states them to be
the views of Reuters Ltd.

---

From: "Eamon O'Tuathail" <[email-masked]>
Date: Thu, 13 Sep 2001 16:16:50 +0100

The SOAP in BEEP spec describes how SOAP envelopes (of XML data) are
transported. It will carry SOAP 1.1. and any future compatible version. 

SOAP 1.1. is in very widespread use already - the quicker people are
provided with a strong alternative to running it over HTTP the better.

SOAP 1.2 also relies on the SOAP envelope concept - so it can be also
carried over the current proposal. There are ongoing discussions in the
W3C about certain XML fields inside the envelope - as BEEP does not even
examine the envelope it is not a factor. 

I don't know what might be in some future SOAP 1.3 - if it is compatible
with the SOAP envelope concept it too will be able to be carried in the
current 'soap over beep' spec without modifications. 

Some of the new extension fields in SOAP 1.2 are in effect to produce a
mini-application protocol inside SOAP - what we might accurately call
the "soap with custom application protocol over tcp option" - what
others call the "soap-over-tcp" option (the former is technically more
accurate while the latter is nicer from a marketing perspective [are we
technical or marketing people here?]). I can see why those who approve
this competing approach would like to delay 'soap in beep' as long as
possible, but I hope you can appreciate that the rest of us people
believe **IETF** BEEP is a good idea, believe the mapping as specified
is finished, and now would like to agree on the spec and get on with
using it. 

Eamon O'Tuathail