Subject: I-D's, Table of Contents in the beginning in nroff macros

From: Pekka Savola <[email-masked]>
Date: Sat, 15 Sep 2001 19:48:23 +0300 (EEST)

Hi,

I'm writing an I-D using nroff -ms macros.

Is there a way to _automatically_ create Table of Contents with .PX and
.XS/.XE while writing _in the beginning of the draft_; like mentioned in
http://www.cs.berkeley.edu/~janp/Help/textms.html#2.10

The problem appears to be that using .PX to generate the TOC before
automatically-to-be-added items are defined with .XS/.XE creates a null
table.

Of course this could be avoided by:
 1) forget about toc, it isn't mandatory anyway (personally, I like them
even in shorter drafts.. they give a good overview)
 2) do the damn thing manually
 3) do it automatically with .PX at the end and when the draft is ready to
be printed in text, move it to the beginning of the text file.

But still.. is there something obvious I'm missing?

-- 
Pekka Savola                 "Tell me of difficulties surmounted,
Netcore Oy                   not those you stumble over and fall"
Systems. Networks. Security.  -- Robert Jordan: A Crown of Swords

---

From: "Dan Kohn" <[email-masked]>
Date: Sat, 15 Sep 2001 13:04:06 -0700

I would heartily suggest using Marshall Rose's XML2RFC tool, which now
supports nroff output for forwarding to the RFC Editor.

http://xml.resource.org/
http://www.normos.org/ietf/rfc/rfc2629.txt

		- dan
--
Dan Kohn <mailto:[email-masked]>
<http://www.dankohn.com/>  <tel:+1-650-327-2600>

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Pekka
Savola
Sent: Saturday, September 15, 2001 09:48
To: [email-masked]
Subject: I-D's, Table of Contents in the beginning in nroff macros

Hi,

 3) do it automatically with .PX at the end and when the draft is ready
to

-
This message was passed through [email-masked],
which
is a sublist of [email-masked]. Not all messages are passed.
Decisions on what to pass are made solely by Raffaele D'Albenzio.

---

From: "Donald E. Eastlake 3rd" <[email-masked]>
Date: Sun, 16 Sep 2001 12:24:21 -0400

The formatting of I-Ds with nroff is so trivial I have never found the
need to any of the various complex external macro packages
available. I'd be happy to send you the source for one of my drafts
which you can edit into the draft you want.

Donald

From:  Pekka Savola <[email-masked]>
Date:  Sat, 15 Sep 2001 19:48:23 +0300 (EEST)
To:  <[email-masked]>
Message-ID:  <[email-masked]>