Subject: Acronyms

From: "Jiwoong Lee" <[email-masked]>
Date: Sat, 8 Sep 2001 10:20:18 +0900

This is about Internet Draft writing skills. And I wish to listen to some wisdom.

I think Readability and comprehensibility are the main goal in writing and organizing a technical document. 

We have plenty of acronyms in this field. Some are public-domain (wide-spread and well-known) and some are newly defined by the author and are introduced to the Internet society. (Not ISOC.) 

As I demonstrated just now, when I write "ISOC", some people know it very much and some do not understand it at all. 

In technical writings, we MAY fill most parts of the technical document with the bunch of acronyms - so the document sometimes looks like high-level code language at a glance. For this we usually define the frequently-used acronyms at the first section of the document and now  the document looks logically organized and technicians feel comfortable about this. 

On the other hand some authors use acronyms extreme-sparingly so that the document looks so prosaic, with high-top page numbers.

One good example in my mind is node mobility terminologies. We've got MN, CoA, CN, HA, blah..

Some authors never use these acronyms in the main part of their document. They say, mobile node, care-of addresses, correspondent node, home agent, eg., 

"A correspondent node sends a packet to the care-of addresses of the mobile node via its home agent."

Other authors just say: "

"CN sens a packet to CoA of MN via HA."

Which one do you think is better ? :> 
Wise answers plz..

Jiwoong

---

From: [email-masked]
Date: Sat, 08 Sep 2001 21:33:31 -0400

> We have plenty of acronyms in this field. Some are public-domain (wide-spread and well-known) and some are newly defined by the author and are introduced to the Internet society. (Not ISOC.) 
...
 
> Which one do you think is better ? :> 

Acronyms aren't as bad as what people in other fields have to deal with.

At least we *have* the letters on our keyboards, and don't have to resort to
special typsetting because we have partial derivative symbols, or capital letters
with vector arrows over them, or other things like that...

Having said that, most style books say that acronyms when used in moderation
are acceptable, as long as at first use they are identified - in your example,
the use of ISOC as an acronym is OK if one of the following is true:

1) the reader is expected to have completed prerequisite work where the
acronym was defined, and thus should already know it - thus the frequent
use of 'RFC' in the IETF.

2) If the acronym is new or not reasonably expected to be known by
the audience, the first use should be spelled out and then the acronym
presented.  For example:  "In other news, the Internet Society (ISOC) announced.."
Additionally, this is a good spot to add definitions or expository material.

				Valdis Kletnieks
				Operating Systems Analyst
				Virginia Tech

---

From: "Balaji H. Kasal" <[email-masked]>
Date: Tue, 25 Sep 2001 11:16:59 +0530 (IST)

Hi,
 It's better to add all acronyms on index page.

--balaji

-- 
--balaji

---

From: Lloyd Wood <[email-masked]>
Date: Tue, 25 Sep 2001 11:32:18 +0100 (BST)

It's good practice to always define an abbreviation
(abbreviation!=acronym) in full the first time it is used.

_Especially_ if you're part of the group that has brought that
abbreviation into existence. Littering a draft (and its abstract) with
abbreviations meaningful only within your working group is a great way
to have zero impact on the world.

(I suspect the biggest reason for reorganising the whole MPLS area was
the sheer number of impenetrable drafts produced, filled with
abbreviations as shorthand for concepts they'd just made up but were
still arguing about. They'd just handwave at the moving target of
another work-in-progress draft instead.)

I'm always amazed at how some people seem to _like_ inventing
pointless abbreviations where plain language would do; encapsulating
the concept in jargon seems to be a way to avoid thinking
about what the concept _is_.

L.

<[email-masked]>PGP<http://www.ee.surrey.ac.uk/Personal/L.Wood/>