Subject: RE: MPLS,IETF, etc..

From: "Natale, Robert C (Bob)" <[email-masked]>
Date: Tue, 4 Sep 2001 02:32:52 -0400

> From: [email-masked] [mailto:[email-masked]]
> Sent: Sunday, September 02, 2001 1:07 AM

Hi Valdis,

> Now as for MLPS, it sounds to me like a good idea for its original
> design goals, but is being promoted for so many other things that
> many people are confused - Does it *really* slice, dice, *and*
> make Julienne fries?

Yes, I think that was the gist of Mike O'Dell's critique...and I
have to agree that the rapid and broad expansion of goals for MPLS
is a threat to the success of its fundamental purpose.

I do believe that the MPLS -> MPlS -> G-MPLS expansion to
accommodate PSC and TDM -> LSC -> FSC devices is a beneficial
and natural extension.  The benefits offered by the traffic
engineering opportunities would be hard to pass up too.

IMHO, Worrying about L3 protocols other than IP seems fairly
pointless and L2->MPLS->L2-only scenarios also seem like
"make work" to me.  I am sure that others hold differing
opinions on these matters, with good arguments.

The basic point, I think, is that any substantive positive
work of synthesis (e.g., the L3/L2 synergy afforded by
fundamental MPLS) always provides a new plateau for re-thinking
how many related things are done.  This is a phenomenon that
needs to be managed...in this case, by the IETF and WG leadership.

Thanks,

BobN

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Mon, 10 Sep 2001 08:45:01 +0200

> engineering opportunities would be hard to pass up too.

my personal (and largely irrelevant) belief about this evolution is that we 
are reusing mechanisms (GMPLS, MPLS-TE, RSVP-TE, CR-LDP) that were 
originally (?) evolved for MPLS tunnels to control other kinds of paths.

this is probably good (commonality is good).

However, I do not see how it validates tag-switching or the original MPLS 
design.

To me, there is a fundamental difference between two classes of decisions:

- decisions taken at setup time (lambda allocation, routing computation, 
path establishment, Strowger switch contact movement)
- decisions taken at packet switching time (IPv4 packet routing, ATM cell 
switching, MPLS label switching)

I have heard argued that MPLS (the tag switching thing) was irrelevant on 
the day that it was economically feasible to deploy 32-bit-wide associative 
memory for routing table lookup in hardware. AND that the chief benefit of 
the 6to4 and other 6-in-4 wrapper mechanisms is that you don't have to 
develop 128-bit-wide associative memory for core switches (yet).

And arguments (like Bob's) that the benefits are real and present.

But I haven't yet figured out whether the latter class of argument applies 
to the setup protocols or to the actual tag switching.
I'm sure I'll figure it out (sooner or later).

                       Harald