Subject: Software Module Information Protocol (SMIP)

From: "Daniel Kraft" <[email-masked]>
Date: Sun, 16 Dec 2001 09:30:42 +0100

Here is a draft for the (very simple) protocol to get information about the
needed software module (Software Module Information Protocol (SMIP)):

A request is in this format:
SMIP <version>: request
Needed: <protocol or MIME type> <"interpretor" or "client">

A response in this format:
SMIP <version>: response <"successful" or "error">
If no error is returned:
Path: <path to the main file of the application>
Communication: <communication type>

<version> is the SMIP protocol version

valid values for <communication type> are:
"stdio": data transfer (for example the URI from which the client should get
the data) by using the "stdout" or "stdin" stream.
"commandline": for interpretors only, the data is passed to the program by
using the command line.
"file=*": the data is written in the file * to pass from the one application
to the other.

An example for a request and response (on a Windows system):

Request:
SMIP 1.0: request
Needed: image/png interpretor

Response:
SMIP 1.0: response successful
Path: C:\Windows\png.exe
Communication: stdio

Or an example when an error is returned:

Request:
SMIP 1.0: request
Needed: UnknownProtocol client

Response:
SMIP 1.0: response error

An extended model of how the modules should work together:
there is one main application, where the user enteres the URI which should
be loaded. This application runs the client for the needed protocol, and
then, after the client did its work, the interpretion software for the
needed MIME type. Then ist could close itself.
The interpretor renders the data and calls, if needed, another client or
interpretor (for instance, for pictures or if the user clicks on a
hyperlink).

Daniel Kraft
---
http://www.daniel-kraft.net/

---

From: Joe Abley <[email-masked]>
Date: Sun, 16 Dec 2001 11:30:41 -0500

> needed software module (Software Module Information Protocol (SMIP)):

Looks like you forgot to attach or mention the name of the draft.

> Needed: <protocol or MIME type> <"interpretor" or "client">

"interpreter", I think.

Joe

---

From: "Daniel Kraft" <[email-masked]>
Date: Sun, 16 Dec 2001 21:03:11 +0100

Sorry, English is a foreign language for me ;)
The name of the draft?
I would suggest Software Modul Information Protocol (SMIP) for the protocol
and a name like modul based client software (I think, this sounds silly...)
for the together-working of the software modules.
Have you got better ideas?

Daniel Kraft

---

From: Joe Abley <[email-masked]>
Date: Sun, 16 Dec 2001 21:44:17 -0500

> Sorry, English is a foreign language for me ;)

You speak it very well :)

> The name of the draft?

I meant the name of the draft as sent to the RFC editor, formatted
according to the conventions associated with internet drafts. See
http://www.ietf.org/ID.html for details if you're not already
familiar with them.

Joe