Subject: RE: Multihoming Issues

From: Caitlin Bestler <[email-masked]>
Date: Sun, 1 Sep 2002 14:36:42 -0500

On 8/31/02, Michel Py wrote:

>> Caitlin Bestler wrote:

>> The potential mismatch between IPv6 and classic DNS
>> is that an IPv6 unicast address is structured in two
>> parts: the network identifier (the high 64 bits) and
>> an Interface ID (the low 64 bits).
>
>This is equally true for IPv4: The network part, whose
>bits are "1"s in the subnet mask, and the host part, whose
>bits are "0"s in the subnet mask.

IPv4 is silent on how the lower portion is formed. IPv6
describes two techniques. Under IPv4 there is no reason to
presume that the same host will have the same network
identifier on multiple networks (other than the desire of
some network administrators to maintain some shred of
sanity). The method of generating the interface ID under
IPv6 would appear to be independent of the number of
identities that the network itself has.

>> Half of the Interface IDs are globally unique, the
>> other half are assigned locally within the network.
>
>I wonder where you got that from. The entire IID is
>assigned with EUI-64 and we just had a long thread on the
>ipv6 list about not using it for routing purposes.
>

That is the definition of EUI-64.

A globally unique EUI-64 can be found on at most one
network, by definition.

If you were to use it for a global location service you
would have to prevent address spoofing.  This would likely
prove to be difficult, which is a valid reason for not using
it for routing purposes. These are all concerns that must be
addressed for mobile IP, which is why I suggested waiting
for those solutions to be proven in that context first.

---

From: "Michel Py" <[email-masked]>
Date: Mon, 23 Sep 2002 15:28:47 -0700

>> Simon Leinen wrote:
>> What is needed is some sort of feedback loop that
>> weighs the interest of multi-homing entities against
>> its impact on remote parts of the infrastructure.

> Tony Hain wrote:
> That is the basis of the multi-6 wg requirements
> document. Unfortunately there are so many competing
> interests that it is impossible to meet them all
> with a simple solution. The end sites want
> capabilities that strain the resources of the
> service providers, and the service providers want
> approaches that are non-starters for the end sites. 

Agree with Tony. There is always something in any solution that would
not meet the multi6 requirements.

Michel.