Subject: Fw: Fuzzy-layering... - Towards better QoS solution in the IPv6 network

From: "Jason Gao" <[email-masked]>
Date: Wed, 11 Sep 2002 10:13:12 +0800

But, as far as I know, IPv8 doesn't give a solution for the QoS issue. IPv6 has the potential. I think the killer applications of IPv6, or whichever the next generation IP protocol, are very likely what demand high QoS and natively peer-to-peer, such as video interactive game. If an application doesn't demand high QoS it can somehow be implemented with the inexpensive NAT middleboxes and/or message relays with ripe experience.
> 
> Jason.
> 
> ----- Original Message ----- 
> From: "Jim Fleming" <[email-masked]>
> To: "Fred Baker" <[email-masked]>; "Jason Gao" <[email-masked]>
> Cc: <[email-masked]>; "Richard J. Sexton" <[email-masked]>; <[email-masked]>; "Joe Baptista" <[email-masked]>; <[email-masked]>; <[email-masked]>; "@quasar Internet Solutions, Inc." <[email-masked]>; "Vittorio Bertola" <[email-masked]>; <[email-masked]>; "Richard Henderson" <[email-masked]>; <[email-masked]>; <[email-masked]>; "Judith Oppenheimer" <[email-masked]>; "Joanna Lane" <[email-masked]>; <[email-masked]>; <[email-masked]>; "Bruce Young" <[email-masked]>
> Sent: Tuesday, September 10, 2002 8:28 PM
> Subject: Re: Fuzzy-layering and its suggestion - Towards better QoS solution in the IPv6 network
> 
> 
> > ----- Original Message ----- 
> > From: "Jason Gao" <[email-masked]>
> > To: "Fred Baker" <[email-masked]>
> > > > 
> > > > You don't get to pull a bit out for your private use.
> > > > 
> > > It is still not a requirement that every node in the Internet must be DS-compliant.
> > > 
> > 
> > Actually, it is just the opposite. The edge of the global, public, 32-bit, IPv4++ Internet
> > is defined as the collection of private companies and people, connected together, that
> > pass 160-bit headers with the 8-bit TOS field unchanged. Those 8-bits can be used
> > to expand the addressing at the edges of that network, 4-bits are needed in each direction.
> > That expands the address space by adding 15 more Internets, as large as the legacy net.
> > You can easily obtain code to do this, or help write more code to do it.
> > 
> > http://www.netfilter.org/
> > http://netfilter.samba.org
> > http://www.google.com/search?q=TOS+routing
> > http://www.google.com/search?q=packet+mangling
> > 
> > As for IPv6, one can not assume that the 128-bit DNS implies IPv6. As an example,
> > if you use a 2002 model year address, such as 2002:[IPv4]:* in the 128-bit DNS AAAA
> > records, your computer will likely generate IPv4 packet headers. A6 DNS records are
> > for IPv6. AAAA records work for IPv4++. Private companies and private individuals
> > are working together to define what goes in the AAAA records. You are FREE to
> > participate. Some private companies and closed societies may try to tell you that you are
> > not free to participate, but that is not the case. Even with tens of millions of dollars from
> > domain name sales and address space leasing, they will not be able to pull together enough
> > money to buy the freedom of all people on planet Earth. They may try...but, most people's
> > minds are not for sale.
> > 
> > Jim Fleming
> > 2002:[IPv4]:000X:03DB:...IPv8 is closer than you think...IPv16 is even closer...
> > http://ipv8.dyndns.tv
> > http://ipv8.yi.org
> > http://ipv8.dyns.cx
> > http://ipv8.no-ip.com
> > http://ipv8.no-ip.org
> > http://ipv8.no-ip.biz
> > http://ipv8.no-ip.info
> > http://ipv8.myip.us
> > http://ipv8.dyn.ee
> > http://ipv8.community.net.au
> > http://www.iana.org/assignments/ipv4-address-space
> > http://www.ntia.doc.gov/ntiahome/domainname/130dftmail/unir.txt
> > 
> > 
>

---

From: "Jim Fleming" <[email-masked]>
Date: Tue, 10 Sep 2002 22:11:09 -0500

----- Original Message ----- 

> But, as far as I know, IPv8 doesn't give a solution for the QoS issue. 

IPv8 is intended to be a work-in-progress. It starts with IPv4 and evolves it. Anyone can
then participate, unlike IPv6, which excludes people. You are welcome to add to the
IPv8 melting pot. NAT is an integral part of the IPv8 approach. Many said that NAT would
not be useful or would not work. Some of those people are I* society leaders. It is their way
or the highway. Many have chosen the highway....and route around the situation...China can...
You can....We can....

Before you worry about the protocol, it is important to work out the transitions and the
address space architecture. The 32-bit IPv4 addresses can be expanded, without changing
IPv4. IPv8 assumed from the start that people would likely have one 32-bit site-id for
their gateway. That is now coming to pass with DSL and cable modem services offering
T1 speeds for less than $50 per month. This year's 2002:[IPv4] approach to addressing
was a start to get people's feet wet. People now want more features in the 128-bit DNS
services, and still remain connected to the Internet. They write the code to do that, and
test it on the existing Internet.

128-bit (AAAA) DNS Flag Day Format

[YMDD]:[16-bits for the outer header]:[IPv4]:[48-bit Persistent Address+Port]

The 16-bits for the outer header are...

1-bit to set the "Spare" bit [S]
1-bit to set the Don't Fragment (DF) bit [D]
2-bits to select 1 of 4 common TTL values (8, 32, 128, 256) [LL]
1-bit to set No Options Supported [O]
7-bits to set the Identification Field(dst) [FFFFFFF]
4-bits to set the TOS(dst) field [TTTT]

SDLL.OFFF.FFFF.TTTT

Given an AAAA DNS record, an IPv8 or IPv16 node can then specify,
a Flag Day [YMDD] to start using this particular record, an IPv4 address
for the site's gateway/firewall, 11 bits of extended IPv4++ addressing bits,
plus the spare bit can be controlled, the DF bit, and 4 common TTL values
can be recommended. Finally, the node can mark that it wants to not
support Options on the IPv4 encapsulating header. The node can also of
course include it's 48-bit persistent address and optional 16-bit Port value.

Note, there is only one "Spare" bit, it is not a [src][dst] arrangement.
It can be used to toggle traffic from one net layer to another, and not allow
traffic to flow between those layers. Traffic can be split at each side of the
legacy core IPv4 network, based on that bit.

Jim Fleming