Subject: Re: Introducing the ID tracker

From: Marcus Brunner <[email-masked]>
Date: Tue, 05 Nov 2002 17:15:11 +0100

Thanks a lot for the effort.
I like it very much and I think it is exactly the right way to open up the 
IESG process. I think and hope it will prevent bad feelings about decisions 
and suspicion of extenal influence.

Marcus

--On Montag, 4. November 2002 16:44 -0500 Harald Tveit Alvestrand 
<[email-masked]> wrote:

>
> Hello,
>
> The IESG is always trying to work better.
> We have gotten a number of comments from the community that it is
> sometimes  very hard to find out what the IESG is doing to documents, why
> documents  take a long time to process, who makes comments, what the
> comments are and  so on, and that this is a significant source of
> frustration for the  community.
>
> For the last year or so, the secretariat has been working on a tool to
> help  us keep track of what documents are on our plate, what state they
> are in  and who is responsible for them; we call it the "ID tracker".
> It's been in  use for about 6 months now, and has definitely improved our
> ability to keep  track.
>
> For several months, the "status of items" pages on the IESG web pages
> have  been generated from this tool, showing the high-order bit of who we
> think  is responsible.
>
> In order to help you know more about what we are doing, we've decided to
> open up a public view of the ID tracker itself.
>
> This will allow you to search for the documents you want to look at, and
> for each document see:
>
> - What its current state is
> - What the history of IESG processing is
> - AD and IESG comments on the document
> - For documents in IESG consideration for standards track, what the
> individual ADs have indicated as their opinion on the document, and if
> they  think there are problems with it, what the comments are.
>
> The last point is a revision of previous IESG policy, based on the
> feedback  from the Yokohama plenary; we are now telling you the names
> that go with  each comment from the IESG members.
>
> The system is far from perfect - you can tell from the history of
> documents  that we've been changing this as we go along - but we hope
> that it will be  a useful tool for people to figure out what the IESG is
> doing with their  documents, and for them to have an easier time talking
> to the relevant ADs  in order to get what we all want out of the process
> - relevant, high  quality standards for the Internet.
>
> The tool and its documentation is found at
>
> https://datatracker.ietf.org/public/pidtracker.cgi
>
> The link to it is also visible on the IESG Web page.
>
> Welcome!
>
>               The IESG
>

--------------------------------------
Marcus Brunner
Network Laboratories
NEC Europe Ltd.

E-Mail: [email-masked]
WWW:    http://www.ccrle.nec.de/
Phone: +49 (0) 6221 905 11 29
personal home page: http://www.brubers.org/marcus

---

From: Robert Elz <[email-masked]>
Date: Wed, 06 Nov 2002 17:37:34 +0700

Date:        Mon, 04 Nov 2002 16:44:11 -0500
    From:        Harald Tveit Alvestrand <[email-masked]>
    Message-ID:  <[email-masked]>

  | For the last year or so, the secretariat has been working on a tool to help 
  | us keep track of what documents are on our plate, what state they are in 
  | and who is responsible for them; we call it the "ID tracker".

  | The tool and its documentation is found at
  | 
  | https://datatracker.ietf.org/public/pidtracker.cgi

This looks fairly nice.   I'd like to see a bit more informative information
in the "details" but this stuff is much better than existed before.

(Meaningless query: Is there a reason for https:// when nothing there looks
to actually be secured?)

And a request - could the system be extended, sometime, so that it could
send e-mail to the working group, where there is one, or the (first) author
in other cases, when a doc changes state?

That would avoid the need for continually polling the web page every day
to find out if anything has happened.

kre

---

From: Aaron Falk <[email-masked]>
Date: Wed, 6 Nov 2002 10:07:58 -0800

> to find out if anything has happened.

An excellent suggestion.

--aaron

---

From: Mark Allman <[email-masked]>
Date: Wed, 06 Nov 2002 14:08:16 -0500

> > And a request - could the system be extended, sometime, so that
> > it could send e-mail to the working group, where there is one,
> > or the (first) author in other cases, when a doc changes state?
> 
> An excellent suggestion.

Or, just define a generic mechanism where arbitrary folk can sign up
to "watch" a particular document.

allman

--
Mark Allman -- BBN/NASA GRC -- http://roland.grc.nasa.gov/~mallman/

---

From: Dave Crocker <[email-masked]>
Date: Wed, 6 Nov 2002 15:33:45 -0800

Mark> Or, just define a generic mechanism where arbitrary folk can sign up
Mark> to "watch" a particular document.

Robert's excellent suggestion is simpler for the folks running the service
and it is entirely compatible with existing practise. (When a working group
document is issued, the working group is copied on the notice.)

d/
-- 
 Dave Crocker  <mailto:[email-masked]>
 TribalWise <http://www.tribalwise.com>
 t +1.408.246.8253; f +1.408.850.1850