Subject: RE: Palladium (TCP/MS)

From: "Sean Jones" <[email-masked]>
Date: Fri, 1 Nov 2002 08:48:35 -0000

Good Morning Valdis

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: 29 October 2002 15:39
> To: Sean Jones
> Cc: [email-masked]
> Subject: Re: Palladium (TCP/MS) 

> You're close.  You'd want this for multihomed servers, so a 
> PTR query works
> as you'd expect.  Consider this case:

> www.big-corp.com	A	10.0.0.10
> 			A	192.186.10.10
> mail.big-corp.com	A	10.0.0.10
> 			A	172.16.23.10

> Then you'd want to have PTRs  as follows:
> 
> 192.168.10.10	PTR	www.big-corp.com
> 172.16.23.10	PTR	mail.big-corp.com
 
> (and then the magic)
 
> 10.0.0.10	PTR	www.big-corp.com
> 		PTR	mail.big-corp.com
 
> If you don't have 2 PTR records for that last, you can get 
> into the situation where a system will look up the A record for www, get the IP 
> address, then do a PTR to sanity-check, get back only the mail. address, 
> and get upset. Having both PTR records means that you'll be able to find one 
> to match to the original hostname either way...

Forgive my ignorance, but I thought email was handled by Mail eXchange (MX) records, thus a PTR would not be required?

> > Thinking along a bit more, setting the routers shouldn't be 
> >a big issue, after all Cisco have been producing routers IPv6 capable 
> >for a fair while now, so surely they could incorporate multiple PTR records 
> >within the routers capability?
 
> Routers don't have anything at all to do with PTR records.  
> What I said was that if a company wanted to block all access to 
> Microsoft's servers, they'd have to keep continual track of all the IP addresses 
> in use - which can be interesting if round-robin DNS or other similar things 
> are in use.

I understand where I went wrong. But I doubt that any commercial enterprise would want to block access to MS servers in RL.

Regards

Sean Jones

---

From: [email-masked]
Date: Fri, 01 Nov 2002 08:34:36 -0500

On Fri, 01 Nov 2002 08:48:35 GMT, Sean Jones said:

> Forgive my ignorance, but I thought email was handled by Mail eXchange (MX)
> records, thus a PTR would not be required?

Just because an MTA follows an MX to find where to send a piece of mail
doesn't mean that other things don't use PTR records for other purposes.

To consider the headers in your note:

Received: from mm_w2k1.micromedical.local  (mailgate.peakflowmeter.co.uk
[62.49.78.214] (may be forged))  by dagger.cc.vt.edu (Mirapoint Messaging
Server MOS 3.2.1-GA)  with ESMTP id AUE74943; Fri, 01 Nov 2002 03:56:05 -0500
(EST)

You might think about where "peakflowmeter" came from....
-- 
				Valdis Kletnieks
				Computer Systems Senior Engineer
				Virginia Tech

---

From: John Stracke <[email-masked]>
Date: Fri, 01 Nov 2002 09:10:59 -0500

>I understand where I went wrong. But I doubt that any commercial enterprise would want to block access to MS servers in RL.
Well, it'd be a good way to inhibit people from sneaking Windows into 
the company.

-- 
/===============================================================\
|John Stracke      [email-masked]                      |
|Principal Engineer|http://www.centivinc.com                    |
|Centiv            |My opinions are my own.                     |
|===============================================================|
|If you're going to walk on thin ice, you might as well *dance*!|
\===============================================================/

---

From: [email-masked]
Date: Fri, 01 Nov 2002 10:15:08 -0500

> Well, it'd be a good way to inhibit people from sneaking Windows into 

And in addition, not all the net is a "commercial enterprise".  There's a very
large worldwide presence in the gov/edu/org arenas - and a *LOT* of those
organizations have political, philosophical, or other reasons for blocking
Microsoft.  I'm sure there's privately held companies that can afford to have
similar views - and I'm waiting for a shareholder suit against the board of a
publicly held company for decreasing profits by continuing to permit the use a
certain MUA even though it's one of the leading causes of virus and worm
propagation...

---

From: Christopher Evans <[email-masked]>
Date: Fri, 01 Nov 2002 10:07:00 -0800

Wha? they go outlaw windows?  Shareholders wont do non of that in realm of 
lawsuits because M$ & the media done a good job at brain neutering the masses and 
furthering intellectual ejemity<sp> in the schools. Damn, I taking cis-2 and they 
concentrate in M$ details of operation and not on raw talent,  teacher go ding 
you in the grade dept. if your comment block is not just sooooo perfect... shit.

--chris

11/1/02 7:15:08 AM, [email-masked] wrote:

>> >I understand where I went wrong. But I doubt that any commercial enterprise 
would want to block access to MS servers in RL.