Subject: new.net (was: Root Server DDoS Attack: What The Media Did Not Tell You)

From: Steve Hotz <[email-masked]>
Date: Wed, 27 Nov 2002 08:47:53 -0800

Hi,

vint.c> where are these statistics from - I cannot believe that
vint.c> more than a few percent of the net uses non-USG root.
joe.b> The last poll I conducted on the dns showed at least 5%.
joe.b> But that was a few years ago.  The 30% comes from various
joe.b> discussions we had concerning new.net.
pekka.s> I don't think any source related to new.net regarding
pekka.s> this can be treated as reliable.
valdis> It's called "Snake Oil", Joe....

Hmmmm?
At the risk of feeding a diversionary thread, it does
seem appropriate to address the question of the number
of Internet users who can "see" New.net's domain names.

First, Vint is technically correct regarding non-USG roots.
I can't speak to other "roots", but most Internet users who
can see/access New.net domains do so either (a) via recursives
that rely on USG-root but augment with NN domains, or (b) user
machines that have the NN client plugin (which still relies
on the USG-root).  So, New.net does not contribute significantly
to the use of a non-USG root.  But, this is clearly a technical
minutia that will, no doubt, result in the usual excessive amount
of debate!

As to the number of users:
Yes, the number published on the New.net website (~150M
users) is an estimate that we believe to be correct, and an
explanation of how it is derived is publicly available on
the New.net website.  I have included the text of this
discussion at the end of this message.

For what it's worth, I questioned these numbers when I
arrived at New.net and we are in the process of auditing
them.  Initial findings reveal some factors that will
increase the number and some factors that will decrease it.
I don't know exactly where it will "net out" (no pun intended),
but I am confident that the number is not off by an
order of magnitude (as many nay-sayers might suggest).

With the exception of the user base(s) from New.net's
larger ISP partners, it should not be a surprise that much
of the underlying information is not publicly available.
As is common in many businesses, we are working with
PriceWaterhouseCoopers on a proposal to audit and certify
the output of our methodology as well as the underlying data.
As New.net continues to grow, this should provide additional
confidence in the user numbers and still provide protection
for sensitive information (both our own information and that
of our partners that is under NDA).  The initiative with PWC
is just getting off the ground; I expect these wheels will
take several weeks to run their course.  If you're interested,
I'm certain the final report will be announced on the
New.net website.

Any of you who have measured/estimated any aspect of a system
that is as large or as dynamic as the Internet, know well that
there is considerable complexity behind any of these numbers
(which involves an understanding of the scope, measurement
assumptions, etc).  Hence, it is somewhat surprising to see
the random "pot shots" taken on this list, with little
substantiation for the doubts (other than typical conspiracy
theories and knee jerk reaction to New.net in general).
In reality, I believe you would be hard pressed to find any
statistic regarding the number of users on (or their usage of)
the Internet that is significantly more accurate than the
numbers New.net provides about its user base.

Again, like most marketing statistics about such a broad
measure of the Internet, we could engage in considerable
academic debate about the best way to measure it -- I'll
be glad to do so over beers when I next run into you.
In the meantime, I am hopeful our audited numbers will be
available sooner rather than later.  Please feel free
to contact me about any technical issues you may have
regarding New.net.

Regards,

        Steve Hotz, CTO
        New.net

Here is information about user count available as a link from the
New.net home page ...

New.net bases its estimate of total users with access on two
numbers: 1) the number of ISP accounts with access as reported by
New.net activated ISP partners (for free ISP partners, New.net uses
the ISP’s reported 30 day active number); and 2) users who can access
New.net domain name extensions because they have activated their
browsers by downloading our plug-in. These raw numbers, which represent
either ISP accounts or PCs with access, are adjusted to reflect a
conservative estimate of the actual number of people accessing the
Internet via these sources. In the case of ISP accounts the number
is adjusted based on information from the Department of Commerce
study Falling Through the Net: Toward Digital Inclusion, A Report
on Americans’ Access to Technology Tools and other sources which
estimate 2.1 users per household. For our calculation we
conservatively assume all ISP accounts are residential accounts
despite the fact that in reality many accounts are corporate accounts
with much higher numbers of users per account. In the case of client
downloads in the US, the number is also adjusted based upon
information from the same Department of Commerce study, but only
by a factor of 1.5 to account for the likelihood that some people
are using these PCs from work only and therefore have a lower
average number of users per PC. For clients downloaded outside
the U.S. there is no adjustment made due to lack of any reliable
information for our international markets despite the fact that
one could assume much higher use per computer numbers. Finally,
the number is also reduced to account for the likelihood that some
of the users who download our plug-in access the Internet via an
ISP that already recognizes New.net domain names.

---

From: Rick Wesson <[email-masked]>
Date: Wed, 27 Nov 2002 09:21:15 -0800 (PST)

Steve,

> of Internet users who can "see" New.net's domain names.

[ many lines of self gratification trimmed ]

I don't believe the topic to be relivant to this list, butI do have a
suggestion for you...

turn off the new.net "root" servers and see if any press gets written
about the event. When you get some press, then you'll know some folks can
see you servers, until then they [the new.net servers] probably don't
matter.

best,

-rick

---

From: Keith Moore <[email-masked]>
Date: Wed, 27 Nov 2002 13:05:54 -0500

> about the event.

better yet, change your domain name to use a TLD that isn't served by 
one of the ICANN roots, and see how many customers you get.

---

From: Einar Stefferud <[email-masked]>
Date: Wed, 27 Nov 2002 10:10:37 -0800

Translation:

To test your accuracy, try to commit suicide.
If you succeed, your accuracy is proven.
If you fail, your estimates are false;-)... 
(So perhaps suicide is a good idea in any case).

It is very clear to me that this is a silly place to argue about this topic.

Enjoy your ride;-)...\Stef

---

From: Dave Crocker <[email-masked]>
Date: Wed, 27 Nov 2002 10:50:48 -0800

Steve,

Wednesday, November 27, 2002, 8:47:53 AM, you wrote:
Steve>  most Internet users who
Steve> can see/access New.net domains do so either (a) via recursives
Steve> that rely on USG-root but augment with NN domains, or (b) user
Steve> machines that have the NN client plugin (which still relies
Steve> on the USG-root).  So, New.net does not contribute significantly
Steve> to the use of a non-USG root.

Thanks for making things so perfectly clear, Steve.

d/
-- 
 Dave Crocker  <mailto:[email-masked]>
 TribalWise <http://www.tribalwise.com>
 t +1.408.246.8253; f +1.408.850.1850

---

From: Einar Stefferud <[email-masked]>
Date: Wed, 27 Nov 2002 12:45:23 -0800

Of course;-)...

It should be patently obvious that most people want to see 
"The Whole Internet" when they decide they want to see some 
sites that are not included in the ICANNIC root.

So, any rational arrangement to make non-ICANNIC TLDs visible to 
users will arrange to be additive, as compared to exclusionary.

So, the situation is very simple:

The ICANNIC ROOT is EXCLUSIONARY, so
The other roots must be INCLUSIONARY.

So, the ICANNIC root will always have "more" users, 
no matter what anyone does, short of converting the 
ICANNIC ROOT to be INCLUSIONARY.

Thus this whole discussion thread is just plain silly, 
as long as the ICANNIC root remains EXCLUSIONARY.

But, maybe some good will come from it because 
it puts the blurred ICANNIC game in plain sight.

ICANN stands alone in its EXCLUSIVNESS, while arguing 
that there must only be one root.  All others must die!
So, now the real issue becomes totally clear.

Enjoy;-)...\Stef

---

From: Dave Crocker <[email-masked]>
Date: Wed, 27 Nov 2002 14:36:25 -0800

Keith,

>> turn off the new.net "root" servers and see if any press gets written

Keith> better yet, change your domain name to use a TLD that isn't served by 
Keith> one of the ICANN roots, and see how many customers you get.

this is the perfect suggestion.

if new.net were so sure of the efficacy of their approach, why do they
(redundantly) use new.net in the ICANN/IANA root?

When THEY rely ONLY on their own contorted scheme, THEN it will be
reasonable to expect someone else to.

d/
-- 
 Dave Crocker  <mailto:[email-masked]>
 TribalWise <http://www.tribalwise.com>
 t +1.408.246.8253; f +1.408.850.1850

---

From: Joe Baptista <[email-masked]>
Date: Wed, 27 Nov 2002 17:42:53 -0500 (EST)

> (redundantly) use new.net in the ICANN/IANA root?

they want to be backwards compatible with the old legacy internet.

---

From: [email-masked]
Date: Fri, 29 Nov 2002 00:59:28 -0500

> that there must only be one root.  All others must die!

Think .BIZ.

Now go back and *CAREFULLY* re-read RFC 2826.  Note that nowhere
does it say that ICANN has to be "the root".  What it says is "either you
have one centrally coordinated root, or you have Balkanization".

Then think .BIZ again, and ask yourself what it is you *REALLY* want.

I'm no particular fan of ICANN's actions either, but I wonder how much of
their attitude is due to a fear that they are under attack from people who
don't understand some of the fundamental issues.

Hell, if I were on the ICANN board, *I*'d not want to share control of
the root with people who don't understand the difference between "ICANN
has the root and won't let anybody else have their own" and "ICANN refuses
to share control of the root with anybody else".

Now, both of the above statements are true - one for technical reasons,
and one for political reasons.  Failing to understand which is which merely
guarantees that you won't get *either* what you say you want, or what you
probably really want...