Subject: RE: Last Call: CR-LDP Extensions for ASON to Informational

From: "Ash, Gerald R (Jerry), ALABS" <[email-masked]>
Date: Fri, 24 Jan 2003 09:28:20 -0500

Zhi,

I have followed the ASON and CCAMP work quite closely over the last couple of years.  I am quite familiar and mostly in agreement with your summary of events below.  

What was not well communicated is that the ITU decided (recently) to do the GMPLS/ASON extensions themselves.  I think many of the postings on this thread indicate that people were not aware of, and disagree with, this approach.

I can understand the frustration of not getting attention to the needed ASON requirements in IETF/CCAMP.  IETF/CCAMP had been saying (quoting statements made by chairs and ADs) they need to 'close the gaps' to meet ASON requirements as far back as IETF-53/Minneapolis (March).  CCAMP charter extensions to address same were suggested(IETF-54/Yokohama CCAMP meeting minutes say "The charter update is way overdue. Items may be added - protection/restoration, crankback and multi-area operations."), but CCAMP charter extensions are still pending even to this day.  

However, the answer is not for the ITU (or any other standards body) to extend IETF protocols, and visa versa.  This leads to interoperability problems, I believe, wherein we have 'ITU-TLVs', 'IETF-TLVs', 'OIF-TLVs', etc. for GMPLS protocols.  Furthermore, we are now inheriting many 'ITU-TLVs' for RSVP-TE and CRLDP.  This precludes, or at least inhibits, proper technical discussion to arrive at the best technical approach.  Further discussion on 'ITU-TLVs' (e.g., call control, crankback, etc.) is now moot.

Perhaps we can learn from this and improve the process, e.g.:

a) Bert has proposed a (G)MPLS change process (seems like a good idea),
b) better communication and responsiveness, especially from WG chairs on direct queries (e.g., 'where is the CCAMP charter update?' has been asked many times, but there is no response, still pending).

Regards,
Jerry

> -----Original Message-----
> From: Lin, Zhi-Wei (Zhi) [mailto:[email-masked]]
> Sent: Friday, January 24, 2003 2:57 AM
> To: Ash, Gerald R (Jerry), ALABS; [email-masked]; [email-masked]
> Cc: Stephen Trowbridge; David Charlap; Loa Andersson
> Subject: RE: Last Call: CR-LDP Extensions for ASON to Informational
> 
> Hi Jerry,
> 
> I'm not sure how long you've followed the entire GMPLS and 
> ASON work, but I'm assuming here that you weren't part of the 
> original discussions over the last 1.5 to 2 years on this 
> matter. That's understandable as this wasn't your original 
> area of interest.
> 
> However, if you talk with some folks involved since the 
> beginning, you would realize (and also reading Steve's email 
> on the history, or simply going back to the email archives in 
> both MPLS and CCAMP) that
> (a) ITU-T tried to get the work done in IETF (I believe Steve 
> mentioned Oct. 21, 2001)
> (b) IETF never actually started/initiated work to fill these 
> gaps. So a set of individuals who happens to attend IETF, OIF 
> and ITU decided that they would work towards a solution
> (c) This solution was submitted into IETF, OIF, and ITU -- 
> with clear intention of trying to get feedback from the 
> "true" RSVP experts
> (d) I (and Bala) created I-Ds in IETF (Bala actually started 
> this I think sometime in early 2002? -- Bala you can confirm 
> or correct -- while I submitted my I-D in June 2002)
> (e) These documents were never taken seriously (This is the 
> first email I sent: 
> http://ops.ietf.org/lists/ccamp/ccamp.2002/msg00918.html -- 
> but of course no one responded)
> (f) ITU-T requests which were publicly presented in CCAMP 
> meetings by Wesam and Steve (see Steve's email to see how 
> many requests were made) were never taken seriously
> 
> The ITU-T delayed their process by several months in order 
> for RSVP experts (I guess Bob Braden would call folks who's 
> done this work "non-RSVP experts") to review. Of course no 
> comments were ever provided by the "true" RSVP experts.
> 
> Several individuals tried very hard to try and get a good 
> relationship and collaboration going amongst the three 
> organizations. The break-down is not for lack of trying or 
> exposing the work to the RSVP experts.
> 
> As such, although I agree that the original intent of all the 
> individuals who came into this work expecting to collaborate 
> and do the work in IETF CCAMP WG, the actual situation is 
> very much different, and is a result of certain members of 
> the CCAMP WG community deciding not to bother with paying 
> attention to the work. Again I can understand the perception 
> that you get since you weren't involved from the beginning. 
> But a casual perusal of the email archives (too much work for 
> me, if you're interested you should take a look at the 
> history first) would give you a much better and accurate 
> history of the discussions (see 
> http://ops.ietf.org/lists/ccamp for the CCAMP email archive, 
> and 
> http://cell.onecall.net/cell-relay/archives/mpls/mpls.index.html 
> for the MPLS email archive).
> 
> Thanks
> Zhi

---

From: Stephen Trowbridge <[email-masked]>
Date: Fri, 24 Jan 2003 09:25:20 -0700

Jerry,
Lets be clear on the timeline and what you consider to be "recent".
- The ASON requirements were communicated October 2001 -
  request for help from ccamp (no response)
- Analysis of ASON requirements against GMPLS protocols, identifying gaps,
  completed Febrary 2002 - request ccamp to help close gaps (no response)
- Proposals into ITU-T agreed about how to close gaps communicated May 2002,
  with request now to align the GMPLS documents with ITU-T work (again, no
  response)
- Final request for comments, October 2002, (again no response)

So the beginning of the actual protocol work in ITU-T dates from eight
months ago. This was seven months AFTER we first communicated the ITU-T
requirements to IETF and started asking for IETF help to develop the
solutions (without getting much interest from the IETF in doing so).

From eight months ago, ITU-T proceeded with the protocol work, all the
while communicating to IETF what we were doing, suggesting that IETF
consider aligning their specifications with the ASON extensions, and
requesting input and comments - again, not much interest from the IETF
to do this. Not much interest until THE DAY that the informational RFCs
are to be published and the codepoints assigned, when we are told we
should have come to IETF first. If only we could have gotten this much
interest in the ASON requirements in October 2001 ...

Regards,
Steve