Subject: RE: Protocol Action: iSCSI to Proposed Standard

From: "Spencer Dawkins" <[email-masked]>
Date: Fri, 14 Feb 2003 09:33:59 -0600

Loa, I would make this stronger still - the problem as I understood it
was that "transport" is ambiguous (in the world of iSCSI), so even in
the presence of "strong and explicitly stated reasons" to call SCSI 
transport "transport", more IETF reviewers will be confused than
enlightened.

I'd go for a requirement for Internet terminology - SCSI transport
would always be qualified, in this case.

Spencer

> -----Original Message-----
> From: Loa Andersson [mailto:[email-masked]]
> Sent: Friday, February 14, 2003 1:43 AM
> To: RJ Atkinson
> Cc: Mallikarjun C.; Bob Braden; [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Subject: Re: Protocol Action: iSCSI to Proposed Standard
> 
> 
> 
> Ran,
> 
> would agree to this, and put even stronger
> 
> "... Internet RFCs the normal Inernet terminology SHOULD be 
> used, unless 
> there
> are very stong and explicitly stated reasons not to ..."
> 
> it should als  be that the I* have a guiding role in this
> 
> /Loa
> 
> 
> RJ Atkinson wrote:
> 
> >
> > On Wednesday, Feb 12, 2003, at 13:24 America/Montreal, 
> Mallikarjun C. 
> > wrote:
> >
> >>> All the Internet documentation with which I am familiar, 
> as well as the
> >>
> >>
> >> I think we have a case of overlapping vocabulary from two 
> different 
> >> domains.
> >>
> >> Per SCSI Architecture Model (SAM-2, SAM-3), iSCSI is very clearly
> >> a "SCSI transport protocol" (as opposed to a SCSI 
> application layer 
> >> protocol).
> >> Parallel SCSI, Fibre Channel etc. are all "SCSI 
> transports" per SCSI 
> >> conventions.
> >> That is all the critiqued abstract is trying to describe.
> >
> >
> > In the context of an *Internet* RFC, it seems sensible to 
> use the normal
> > Internet terminology -- unless one very very clearly 
> indicates that a
> > term is being used in some different semantic.  One might 
> postulate that
> > the document's editors and RFC-Editor could work out a 
> mutually agreeable
> > editorial change here to add clarity.
> >
> > Ran
> >
> >
> >
> >
> 
> 
> 
> _______________________________________________
> This message was passed through 
> [email-masked], which is a sublist of 
> [email-masked]. Not all messages are passed. Decisions on what 
> to pass are made solely by Raffaele D'Albenzio.
>

---

From: "David J. Brown" <[email-masked]>
Date: Fri, 14 Feb 2003 13:37:08 -0500

The document uses the term "transport" correctly.  

Chapter 1, from which the sentences in the mail message were drawn, clearly
states that the term transport refers to a "SCSI transport", a phrase which
it defines accurately.  The mail message did omit several sentences from
Chapter 1, including the sentences that defined "SCSI transport" and made it
clear that that's the kind of transport under discussion in the offending
sentence.  Perhaps it should have included the whole chapter verbatim.

Are you objecting to the actual document, namely
draft-ietf-ips-iscsi-20.pdf, or only to the mail message that accompanied
it?

dj

> In the context of an *Internet* RFC, it seems sensible to use the normal
> Internet terminology -- unless one very very clearly indicates that a
> term is being used in some different semantic.

-----Original Message-----
From: Loa Andersson [mailto:[email-masked]]
Sent: Friday, February 14, 2003 2:43 AM
To: RJ Atkinson
Cc: Mallikarjun C.; Bob Braden; [email-masked]; [email-masked];

Ran,

"... Internet RFCs the normal Inernet terminology SHOULD be used, unless 
there
are very stong and explicitly stated reasons not to ..."

/Loa

RJ Atkinson wrote:

>
> On Wednesday, Feb 12, 2003, at 13:24 America/Montreal, Mallikarjun C. 
> wrote:
>
>>> All the Internet documentation with which I am familiar, as well as the
>>
>>
>> I think we have a case of overlapping vocabulary from two different 
>> domains.
>>
>> a "SCSI transport protocol" (as opposed to a SCSI application layer 
>> protocol).
>> Parallel SCSI, Fibre Channel etc. are all "SCSI transports" per SCSI 
>> conventions.
> In the context of an *Internet* RFC, it seems sensible to use the normal
> Internet terminology -- unless one very very clearly indicates that a
> term is being used in some different semantic.  One might postulate that
> the document's editors and RFC-Editor could work out a mutually agreeable