Subject: RE: WG Review: Centralized Conferencing (xcon)

From: "Peterson, Jon" <[email-masked]>
Date: Thu, 14 Aug 2003 17:12:12 -0500

> 
> Jon,
> 
> PJ> So while one might be
> PJ> concerned by the fact that XCON is SIP-specific, I don't believe the
charter
> PJ> is especially disingenuous about that.
> 
> On the other hand, it declares a statement of intended design constraint
> (being sip oriented) but provides no indication of what that means or
> why it is being chosen. As such, it is not possible to evaluate that
> choice.
> 
> Given that a working group charter is a contract for work to be done,
> the contract needs to specify its constraints in a way that provides
> helpful detail.
> 

I think that's reasonable, yes. Hopefully the document citations you counsel
us (below) to include would help with this to some degree. I also think
importing some high-level text to the charter making a few of the more
important points (i.e. the need to identify media security solutions that
can interoperate with application-layer conference administration) would
also probably be appropriate.

> 
> PJ> As to why this proposed WG is more or less SIP-specific, the charter
arises
> PJ> from a set of framework, requirements and mechanism documents that
were
> PJ> proposed in SIPPING.
> 
> Working groups that are chartered with documented constraints are
> expected to cite those documents. If there is a body of prior work, on
> which this working group is being offered as a continuation, then a
> person reading the charter needs to be able to review that work.
> 

Yes, this is also reasonable. The XCON BoF charter cited five SIPPING
documents (largely of a framework/requirements bent), and seven
contributions that were believed to be applicable to XCON itself, but those
documents were not carried over to the proposed XCON WG charter. I think it
would make sense for at least some of these documents to be included in the
WG charter as well.

> Otherwise it is very difficult for a public review of the charter to be
> based on anything substantial.
> 
> If there is no documentation for the constraints, then there is no
> substantial basis for imposing them, other than perhaps citing some
> concerns or perspectives.
> 

Thanks, this was very helpful.

Jon Peterson
NeuStar, Inc.

> 
> d/
> --
>  Dave Crocker <mailto:[email-masked]>
>  Brandenburg InternetWorking <http://www.brandenburg.com>
>  Sunnyvale, CA  USA <tel:+1.408.246.8253>, <fax:+1.866.358.5301>
>

---

From: Adam Roach <[email-masked]>
Date: Wed, 20 Aug 2003 11:53:38 -0500

Harald Tveit Alvestrand writes:

>--On 20. august 2003 10:06 -0500 Adam Roach <[email-masked]> wrote:
>
> > I believe any modifications to the charter that
> > de-emphasized text as a media type would be a
> > disservice to a significant number of potential
> > XCON participants.
> 
> Thanks - that means I misunderstood the charter, and that Marshall's 
> concerns need addressing.

I believe Jon is doing a commendable job of addressing
Marshall's concerns. I agree with, and have nothing to
add to, Jon's response on this topic (sent yesterday).

/a

---

From: Adam Roach <[email-masked]>
Date: Wed, 20 Aug 2003 10:06:31 -0500

Harald Tveit Alvestrand writes:

> Listening in on this conversation, it seems to me that
> Marshall is talking about "conferencing" in a sense which
> includes a lot of different mechanisms, the premier one
> being instant messaging, while Jon (and the XCON charter)
> speaks about "conferencing" in a sense that starts out
> assuming that voice is included, and that video is the
> logical next step, while conferencing based on IM, if
> thought of at all, is regarded as a small side issue.

As one of the chairs of the BOF, such was certainly
*not* my understanding. The solution is intended to
address media streams in general, not just voice
and video.

In particular, many people with whom I have spoken
regarding XCON expressed interest in its application
to instant messaging. Additionally, one of the
strongest motivations within the SIMPLE community
for adding session-mode messaging is the ability to
take advantage of any other capabilities that can be
applied to SIP sessions, such as multiparty
conferencing.

To reinforce that point: one of the primary reasons
(in my estimation) that SIMPLE has not proposed
solutions for chat rooms is the realization that such
functionality comes for free once a general
conferencing solution is defined. I would posit that
the expectation of SIMPLE is that the solution
created by XCON will be usable for this application.

> I don't know how to add markers to the charter to
> make it obvious how the word "conferencing" is
> intended here, however.

/a

---

From: Adam Roach <[email-masked]>
Date: Thu, 21 Aug 2003 00:23:43 -0500

Richard Shockey writes:

> I think the XCON folks were trying to be inclusive
> in their charter development but frankly I don't think
> its necessary. The IETF now has three SIP related WG's
> operating well and producing good work and the scope
> of the XCON proposal IMHO should be directed at SIP
> specifically. Its a complex issue, there is a real
> problem statement and a focused WG could tackle the
> problem head on and deliver results. This was the
> direction we took with SIPPING for the specific IM
> problem and its what we need to do with SIP Conferencing.

I think some clarification is in order.

The SIP conferencing work has been well underway for
quite some time now in the SIP and SIPPING working
groups. It is essentially complete, and will be in WGLC
momentarily. We don't need a SIP conferencing working
group; SIP conferencing already has a home.

That said, for a conferencing solution to be complete,
there are certain things that are required -- such as
floor control and membership permissions -- for which
SIP is simply not appropriate.

The raison d'être for XCON is precisely to do the
part of conferencing that is not SIP. The relationship
between the XCON protocols and SIP are far looser than
would legitimately warrant the level of concern being
expressed on this list.

For example: to be able to talk about specific media
streams in a conference, you need to be able to identify
streams of media. XCON does so in terms of SDP, since
that is the mechanism used by SIP to establish media
streams.

To examine what this means in the context of the charter's
claim that the solutions developed in XCON will not preclude
operation with other signaling protocols: if someone were
to decide to apply XCON to some theoretical IP-based call
control protocol that used PSTN TDM trunks for conveying
media [1], these identifiers could be replaced with SS7
circuit identification codes.

If the initial proposals being presented as input to
XCON had some strong binding to SIP that made their use
in other contexts difficult, I would understand the
concerns being expressed in this forum. However, the
proposed solutions (all of which I expect to instantly
be accepted as working group items in the case that the
working group is chartered) demonstrate no such binding.
I invite those with concerns to carefully examine the
protocol proposals [2] and indicate where they believe
this not to be the case.

/a

[1] This theoretical protocol is intentionally fantastic
    to avoid the discussion being bogged down with descriptions
    of any political reasons why certain protocol communities
    may elect to use different conferencing solutions.

[2] http://www.softarmor.com/xcon/drafts/

---

From: Adam Roach <[email-masked]>
Date: Thu, 21 Aug 2003 13:14:51 -0500

Lisa Dusseault writes:

> I'm also concerned that conferencing semantics could lead to 
> basic interoperability problems that would be difficult to 
> surmount.

Once again, I implore those with concerns to read the
XCON input documents. As can be easily verified, the
model being proposed in no way binds itself to any
SIP-specific concepts.

/a