Subject: Propose some information retrieval protocols for Internet

From: "wang liang" <[email-masked]>
Date: Thu, 25 Dec 2003 09:31:43 +0800

Propose some information retrieval protocols for Internet.

Now most services of Internet such as E-mail, BBS, and FTP are all based on
public protocol. There is no secret technology in these services. But the
information retrieval service, may be the most important service on
Internet, is still dominated by few search engine companies. This may not
comply with the basic rules of Internet.

Some kernel technology, especially the page ranking algorithms, is the top
secret of search engine companies. There is no any surveillance in this
ranking operation. Some search engines just elevate the ranking score of
some pages for the paying of company customer. Every of us publish the
information on Internet, but search engines administrate what you could know
and what you couldn't reach to a large extent. Someone must pay him money to
place their spam in the first place in the search results of everyone. This
may not be the truth of Internet. Search engines should be a public
mechanism. So there should be some standard protocols to build a real public
opening search system for Internet.

Some work of our research group may be useful for an appropriate information
retrieval protocols for Internet.

Our work belongs to a digital library project. The main purpose of our
project is to build a search system that can integrate all kinds of
information resources on Internet. For this aim, we propose an absolutely
new kind of search system,DRIS (domain resource Integrated system). Its main
point is as follows.

DRIS will build an information retrieval infrastructure for the whole
Internet,but not the finial search engines.

The basic principle of DRIS: in appropriate scope (three levels domain),
applying appropriate information retrieval system, DRIS builds an
appropriate information management frame for the whole Internet.

The basic idea of DRIS: search should be the internal function of Internet
and everyone should have his own search engine.

Related papers
1 Make search become the internal function of Internet.
http://arxiv.org/abs/cs.IR/0311015
2 Evolution:Google vs.GRIS. http://arxiv.org/abs/cs.DL/0312024

We have built a testbed for DRIS. I think build a public information
retrieval system is very important for the evolution of Internet.

---

From: Paul Robinson <[email-masked]>
Date: Fri, 26 Dec 2003 16:09:25 +0000

>Propose some information retrieval protocols for Internet.
<snip>

Wang,

I think your ideas are interesting. I also think they would work. 
However, I'd like to make some suggestions to improve them. Firstly 
though, I'd like to offer my services as an Englishman to help tidy up 
the English in your papers. I got the point, but the grammar could do 
with "a tidy up" just to make it clearer in places. If you send me the 
sources (as opposed to the PDF), I will be happy to get them into a form 
that the majority of the IETF readership would be happier to work with. 
It's not a criticism, and I can assure you, hand-on-heart, your English 
is much, much better than my Chinese! :-)

I'd also like to discuss with you via e-mail some details around the 
specific implementations. I think what you have proposed can work quite 
nicely, but it can be improved by moving the emphasis for indexing from 
the owners of domains and address spaces to the owners of the content. 
Unfortunately what you are suggesting seems to suggest that indexing 
available at national and international scopes COULD be owned at a state 
level (the ccTLD owner at any rate) regardless of the content owner's 
wishes. We can tweak the spec and the technology to put ownership back 
where it belongs, but it needs some thought.

Let me know if you would like to discuss this further. With your 
permission I would also like, after being able to tidy up your paper's 
English translation, to forward it to some people I know who have 
studied and research information theory and see if they have any input.

I look forward to your response,

-- 
Paul Robinson

---

From: "wang liang" <[email-masked]>
Date: Sat, 27 Dec 2003 18:02:44 +0800

Paul Robinson,

>We can tweak the spec and the technology to put ownership back

Related papers in word format were sent to you.

In fact, our system can be regarded as an information shared platform. To
integrated different kinds of information resources, DRIS provides two
methods.

1 distributed search interface. Corresponding protocol defines a
platform-independent search interface and a collection description standard
for heterogeneous information resources. An I-D "information retrieval
protocol for digital resources" has been proposed.

2 metadata harvesting. It will define a standard metadata format that can be
compatible with most database system. A protocol based some available
opening standard like OAI will be proposed.

As long as data source can provide the standard distributed search interface
or comply with the metadata harvest format, they can all be brought into
DRIS.

But the web page is a special data source for its distributed character and
large amount. To efficiently integrate web pages on Internet, DRIS will
build a public opening web pages database, which will strictly comply with
the principle of (organization level-conventional database system)-(sub
country Internet level-metadata harvest system)-(country level-distributed
system). All the work is carried out automatically. Like in the bottom
level, we always don't wish to publish all our pages out of school network.
Although all the pages is automatically downloaded and indexed by our DRIS
server, we can limit the metadata of web pages sent to higher layer to
ensure some special considerations.

Other kinds of resources can select appropriate method and be imported in
appropriate layer.