Subject: SA / Spam. Facts.

From: Brett Thorson <[email-masked]>
Date: Thu, 18 Dec 2003 03:03:52 -0500

These are the facts.

On Wednesday 17 December 2003 16:01, Dean Anderson wrote:
> This is ridiculous.  The IETF is not getting a lot of spam, so adding
> SpamAssassin headers is a solution in need of a problem.

"a lot" is a subjective term.  Also, unless you are sniffing the traffic into 
our network, would you know how much spam our MX receives?

A rough approximation is that 1/3 of the mail into the IETF MX is spam.  
Estimate based on a small sample.  If a more accurate number is needed, 
please submit to the tracking system for prioritizing in the queue of IETF 
things to do.

Some spam we already filter out without spam assassin.
For example...
CC'ing mail to ietf-announce (as two of your posts did) gets caught in our 
spam filter because it is not appropriate on that mailing list.

> [email-masked] wrote:
>  > ...this implementation is to allow the IETF community to get used
>  > to having these headers in the messages, and allow us to make any
>  > changes to the filtering rules.....

> The above seems like a thinly veiled attempt to make SpamAssassin headers 
> a defacto standard supported by the IETF, without going through the 
> standards process.

It may seem that way to you, but in reality it isn't.  Just me deciding to use 
it because it worked well with exim, it was quick to setup, seemed to perform 
the task well, didn't need a lot of human intervention, it could be tuned.  
Oh, and it's free, so the IETF could afford it.

Mr. Anderson continued....
> Obviously, if the goal is to standardize these headers, then a standard
> can be produced and put through the standards process.

The goal is to reduce spam, and reduce the human intervention needed to reduce 
spam.  

These are the facts.

--Brett

---

From: Jari Arkko <[email-masked]>
Date: Thu, 18 Dec 2003 11:31:18 +0200

> The goal is to reduce spam, and reduce the human intervention needed to reduce 

Right. I support the secretariat's efforts to reduce spam and
associated management effort on the IETF lists. Personally, I
have a good experience with SpamAssissin, so to me the technical
arrangement looks quite reasonable.

As for the rest, lets all remember that there may be no
fast, perfect, and inexpensive solutions. It may not be
reasonable to require that the false positive rate is zero.
We certainly can't replace spam detecting tools with
e-mail signatures and have it operational tomorrow. And
if the IETF has unused cash, there may be better uses for
it than paying for spam detection software.

--Jari