Subject: RE: Effectiveness of STUN protocol

From: "Michel Py" <[email-masked]>
Date: Tue, 20 Jan 2004 07:33:37 -0800

> Masataka Ohta wrote:
> Is it a client server app or a P2P app?

What a total ignorance of the P2P world.
It appears that some education is needed for our candid friend here.

First, a little history. "THE" P2P app, the original Napster, was
shutdown because of its reliance on centralized servers.
 
Besides, many other P2P apps use servers as well:

- Threedegrees uses MSN messenger's servers.

- Napster offspring such as opennap and edonkey have decentralized the
servers; however the motive behind this was to make them moving targets
operated by different entities in different countries, making the whole
server mesh virtually impossible to be shut down by legal action. At
this very moment the top 6 servers in the edonkey network have between
100,000 and 220,000 simultaneous connections each and account for more
than half of the 1.5M total users on the system.

- On-line games have centralized lobbies where players meet before they
play; there are Quake servers.

- SIP outfits all have centralized registering servers; the first things
to configure on a SIP phone are its own SIP number and the address of
the SIP server.

So yes, P2P usually means server, too.

Michel.

---

From: "Jeroen Massar" <[email-masked]>
Date: Tue, 20 Jan 2004 16:52:49 +0100

-----BEGIN PGP SIGNED MESSAGE-----

> shutdown because of its reliance on centralized servers.

<SNIP>

> So yes, P2P usually means server, too.

And otherwise apps would still fall back to using 
DNS or anycast-IP as the locator service.
DCC on IRC uses the IRC server to communicate the ports used
for the transfer of data between the peers, the data is never
seen though.

Thus P2P has 2 aspects in this part:
 - location service
   (where is that user and where is that IP/port
    the app has to push it's traffic too/from)
 - the actual peers using the location service
   to find out where everything is.

The second part is really Peer-2-Peer, but before
that there has to be a communication with the (decentralized)
location service to actually find out where someone is.

Greets,
 Jeroen

---

From: Masataka Ohta <[email-masked]>
Date: Wed, 21 Jan 2004 00:59:44 +0900

Michel;
 
> First, a little history. "THE" P2P app, the original Napster, was

If you are not joking, you have to distinguish file
exchanges and P2P and to distinguish marketing hype and
technical reality.

It should be noted that

> At
> 100,000 and 220,000 simultaneous connections each

you support my point that (UDP or TCP) connection to STUN (or
whatever) server must be kept alive, which means more load
than DNS.

							Masataka Ohta