Subject: dire outlook on internet and NAT

From: Fred Baker <[email-masked]>
Date: Mon, 12 Jan 2004 10:29:02 -0800

Interesting reading: some have been asking what the cost of moving from a 
peer-to-peer to a service/consumer model are, in terms of applications 
deployed and the ability to build more robust business models. Many ISPs 
are thinking in terms of VoIP as a next generation business, the one after 
"selling bandwidth". But there are issues with that as well...

	http://www.fourmilab.ch/speakfree/eol/

---

From: shogunx <[email-masked]>
Date: Mon, 12 Jan 2004 14:47:36 -0500 (EST)

> 	http://www.fourmilab.ch/speakfree/eol/

IPv6 and NAT cooperate quite well though.  Which would maintain the peer
to peer model on top of NAT.

Scott

sleekfreak pirate broadcast
world tour 2002-3
live from the pirate hideout
http://sleekfreak.ath.cx:81/

---

From: "Michel Py" <[email-masked]>
Date: Mon, 12 Jan 2004 12:05:09 -0800

> Nathaniel Borenstein wrote:
> Pardon me if I'm missing something obvious here, but
> couldn't one just use either XMPP or Simple for presence,
> associate your "server name" with a Jabber/Simple ID, and
> automatically have your "server" findable via these
> general presence protocols?  

One not only could, but does.
http://www.pulver.com/fwd/index.html
Nice IP phones are quite inexpensive these days too.
https://secure.pulver.com/pulverinnovations/order_grandstream.html

> Why isn't that a reasonable approach to peer to
> peer in a NAT world?

It is, although it could use some polishing. That's not the issue; you
still don't have a free bridge to the PSTN, there is no way to regulate
telemarketers, does not work when the power fails, if your kids have
kazaa open voice quality stinks because kazaa gobbles it all.

I pay 5 bucks for long distance a month, explain me why I should bother?

Michel.

---

From: Mark Smith <[email-masked]>
Date: Tue, 13 Jan 2004 10:49:21 +1030

On Mon, 12 Jan 2004 10:29:02 -0800
Fred Baker <[email-masked]> wrote:

> Interesting reading: some have been asking what the cost of
> moving from a peer-to-peer to a service/consumer model are, in
> terms of applications deployed and the ability to build more
> robust business models. Many ISPs are thinking in terms of VoIP
> as a next generation business, the one after "selling
> bandwidth". But there are issues with that as well...
> 

John's articles were part of the motivation for my question as to
whether IPv4 (and IPv4 NAT) would be formally deprecated when
IPv6 was"ready", which I asked a few months ago on the IPv6 ML.

For those interested in reading or reviewing the ensuing
discussion, here is a URL.

http://marc.theaimsgroup.com/?l=ipng&m=106614091529296&w=2

Admittedly I can't remember where I read it, but I've come across
a suggestion that enterprise networks adopting IPv6 is likely to
happen before ISPs provide it in any big way, as enterprise
networks have more to gain from the technology (well, possibly,
assuming they can be convinced that "proper" address space is
better than NAT). Once enterprises have it, they will then ask
for it from their ISP. I'd agree that expecting the drive for it
to come from ISPs is probably incorrect.

Maybe the focus needs to be to work on IPv6 protocols that
enterprises need. Anybody want to work on NetBIOS over IPv6 ?
After all, File and Print would have to be the "killer"
application for enterprise networks - it's the application that
 got networks into most enterprises in the first place in
the last 10 years.

Regards,
Mark.

---

From: Soliman Hesham <[email-masked]>
Date: Tue, 13 Jan 2004 08:25:05 -0500

> better than NAT). 

=> I'm a bit confused as to why enterprises would be interested
in v6. There are even prorietry solutions that allow for VPN
access behind a NAT. And enterprises are not known for encouraging 
p2p apps for their employees. So this business case doesn't
seem like a winner to me. 

My hope has been that p2p apps will one day be "needed now" and 
force people to turn v6 on in their networks.

   Once enterprises have it, they will then ask
 > for it from their ISP. 

=> Sure, but it's not clear that they'd be early adopters. 
Autoconfig of addresses will not be enough, if they ever use it. 

Hesham

I'd agree that expecting the drive for it

---

From: "John" <[email-masked]>
Date: Wed, 14 Jan 2004 15:25:19 +0000

Hesham, 

VOIP with SIP seems like a good app for enterprises.  I think IPv6 helps.

John

Hesham