Subject: RE: Chinese IPv9

From: [email-masked]
Date: Mon, 5 Jul 2004 17:05:25 +0200

See also:

http://www.chinatechnews.com/index.php?action=show&type=news&id=1405

Google gives about 4000 hits for IPv9.

Including of course RFC 1606....

:-)

Gordon

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Monday, July 05, 2004 3:15 PM
To: [email-masked]
Subject: Chinese IPv9

Hi,

a german computer magazine reported that China
is developing their own IP address scheme as
IPv9 ( http://www.heise.de/newsticker/meldung/48859 )
in order to improve "security" (probably spelled: censorship).
They cite

http://news.xinhuanet.com/english/2004-07/05/content_1572719.htm

It is to be used inside China, and they will have routers
as gateways to ipv4 and ipv6 and the borders of China
(obviously not letting everything pass through).

Does anyone know details about this protocol?

What's the IETF's opinion (if IETF does have anything like an 
IETF's opinion) about such an effort?

regards
Hadmut

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "JORDI PALET MARTINEZ" <[email-masked]>
Date: Tue, 6 Jul 2004 00:23:01 +0200

Complete compilation of news at http://www.ist-ipv6.org/modules.php?op=modload&name=News&file=article&sid=622

But I guess is an hoax ?

----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>
Sent: Monday, July 05, 2004 5:05 PM
Subject: RE: Chinese IPv9

> IETF's opinion) about such an effort?

**********************************
Madrid 2003 Global IPv6 Summit
Presentations and videos on line at:
http://www.ipv6-es.com

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

---

From: Michael Thomas <[email-masked]>
Date: Mon, 5 Jul 2004 17:35:02 -0700 (PDT)

> Complete compilation of news at http://www.ist-ipv6.org/modules.php?op=modload&name=News&file=article&sid=622

   Or the revenge of J*m Fl*mm*ng?

      Mike, 4 is to 6 as 6 is to 9?

---

From: Bill Manning <[email-masked]>
Date: Mon, 5 Jul 2004 18:09:59 -0700 (PDT)

% Complete compilation of news at http://www.ist-ipv6.org/modules.php?op=modload&name=News&file=article&sid=622
% 
% But I guess is an hoax ?
% 

	the site seems to be missing some of the chinese language
	reports... :)
	and based on (imho) more informed sources, this is not a
	hoax but a real effort.      

--bill
Opinions expressed may not even be mine by the time you read them, and
certainly don't reflect those of any other entity (legal or otherwise).

---

From: "Tony Hain" <[email-masked]>
Date: Mon, 5 Jul 2004 19:42:33 -0700

Sitting here in Seoul, Janet Sun (BII) said this is self-promotion of a
single researcher looking to improve his funding. There is technical
content, but no business content and the service providers are ignoring it
as a waste of time. Think of it as E-164 on steroids.

Tony

> Bill Manning
> Sent: Monday, July 05, 2004 6:10 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: Chinese IPv9
> 
> % Complete compilation of news at http://www.ist-
> ipv6.org/modules.php?op=modload&name=News&file=article&sid=622
> %

---

From: James Seng <[email-masked]>
Date: Tue, 06 Jul 2004 14:52:06 +0800

See http://james.seng.cc/node/view/235

I receive some email from friends asking me if I know of the recent IPv9 
news from China. I thought I should just blog about it and point them to 
this entry.

I heard of them first time back in 2001. The technology is developed by 
十进制网[1] called "数字域名" which translate roughly to 'Numerical 
Domain Name". They call it ADDA (All Digital Domain Address) and then 
later IPv9. (Okay, I laughed back then too so don't hold back yourself ;-)

The technology as I understand can be summarise as follows: The 10 
digits they refer to are phone numbers (China uses 10 digit local phone 
number). The idea is that you can navigate the web by using phone 
numbers in the browser. The technology is basically a modified DNS and 
the business model is to get you to registered your phone numbers with them.

So it isn't really IP as you would think. But despite these, they seem 
pretty well connected in China and have support from Ministry of 
Information Industry (MII) among others. However, I have not seen any 
actual deployment anywhere. Lots of press release but thats about it.

ps: There is a article in Sina.com[2] explaining the technology pretty 
well but it is written in Chinese.

[1] http://www.em777.net/
[2] http://tech.sina.com.cn/i/w/2004-06-28/2331380918.shtml

-James Seng

---

From: "Steven M. Bellovin" <[email-masked]>
Date: Tue, 06 Jul 2004 11:48:38 -0400

>as a waste of time. Think of it as E-164 on steroids.

Right.  See http://www.theregister.co.uk/2004/07/06/ipv9_hype_dismissed/
and several postings at http://www.interesting-people.org/archives/interesting-people/

		--Steve Bellovin, http://www.research.att.com/~smb

---

From: James Seng <[email-masked]>
Date: Wed, 07 Jul 2004 07:23:47 +0800

-James Seng

---

From: Masataka Ohta <[email-masked]>
Date: Wed, 07 Jul 2004 12:36:49 +0900

Tony Hain wrote:

> There is technical
> as a waste of time.

So, it's almost identical to IPv6.

							Masataka Ohta

---

From: Soohong Daniel Park <[email-masked]>
Date: Wed, 07 Jul 2004 14:58:46 +0900

> So, it's almost identical to IPv6.

It's very interesting indication. Can you show
me several clues why you think so.

- Daniel (Soohong Daniel Park)
- Mobile Platform Lab. Samsung Electronics.

> From: [email-masked] [mailto:[email-masked]]On 
> Behalf Of Masataka Ohta
> Sent: Wednesday, July 07, 2004 12:37 PM
> To: Tony Hain
> Cc: [email-masked]; [email-masked]; 'Bill Manning'

---

From: "JFC (Jefsey) Morfin" <[email-masked]>
Date: Wed, 07 Jul 2004 22:07:51 +0200

At 17:48 06/07/04, Steven M. Bellovin wrote:
>Right.

Dear Steven,
This looks as a well planned, polite and intelligent warning. About 
possible other ways to use/plan the DNS, IPv6, VoIP etc. We probably have 
to get used to Chinese ways. I read this as "are you sure IPv6.001 
numbering plan, IDNA, VoIP and ENUM are Internet Gospel?".

The surprisingly agressive mail of Vint Cerf seems to show he read it that 
way - at least in part. But is not IANA now "an ICANN function"?
I am sure reading comments from IETF and other mailing lists taught a lot 
to the IPv9's team (BTW, hello to them!)
jfc