Subject: RE: Names of standards-track RFCs

From: "Christian Huitema" <[email-masked]>
Date: Wed, 14 Jul 2004 18:06:16 -0700

> Agreed.  Spelling things out becomes even more important as
> documents age.  Consider, for example, "IMP" in some of the
> older RFCs.  I suspect many IETF participants have never seen
> or used one, yet this was probably considered "well known" when
> those RFCs were written.

Or consider the RFC that describes Classical IP and ARP over Automatic
Teller Machines...

-- Christian Huitema

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: John C Klensin <[email-masked]>
Date: Wed, 14 Jul 2004 23:19:00 -0400

--On Wednesday, 14 July, 2004 18:06 -0700 Christian Huitema
<[email-masked]> wrote:

>...
> Or consider the RFC that describes Classical IP and ARP over
> Automatic Teller Machines...

What did you say an ARP was?  Some sort of fuzzy alien, perhaps?
A digestive sound made after excessive SIPPING ?  Or, given
those teller machines, perhaps an Advanced Reimbursement
Procedure?
<grin>

I am not suggesting that we never expand an abbreviation and
never explain an acronym.   I suggest only that 

	* we need to rethink the application of the rules a bit
	for situations in which the constructed or shortened
	term has become a word in its own right and, more
	important, in which an expansion would tend to confuse
	rather than illuminate, and 
	
	* that we get a little more serious about the
	requirement that abstracts be sufficient for someone who
	doesn't know what the document is about to figure that
	out because titles will never be able to adequately do
	that job.

For the second, pretend that you are reading the title that
Christian cites above: "Classical IP and ARP over ATM".  Now
pretend that you don't know much about that corner of the IETF's
work, or even that you are an applications type who doesn't know
much about _anything_ at that layer.  Now expand the
abbreviations and try to convince yourself that you would know
something you didn't know with the present title.  Reaction to
present title: "Huh? Strange abbreviations".   Reaction to title
with abbreviations expanded: "Huh? What on earth do those words
mean?"

I don't see a lot of difference.

     john

---

From: "Randy.Dunlap" <[email-masked]>
Date: Wed, 14 Jul 2004 23:11:07 -0700

On Wed, 14 Jul 2004 23:19:00 -0400 John C Klensin wrote:

| 
| 
| --On Wednesday, 14 July, 2004 18:06 -0700 Christian Huitema
| <[email-masked]> wrote:
| 
| >...
| > Or consider the RFC that describes Classical IP and ARP over
| > Automatic Teller Machines...
| 
| What did you say an ARP was?  Some sort of fuzzy alien, perhaps?
| A digestive sound made after excessive SIPPING ?  Or, given
| those teller machines, perhaps an Advanced Reimbursement
| Procedure?
| <grin>
| 
| I am not suggesting that we never expand an abbreviation and
| never explain an acronym.   I suggest only that 
| 
| 	* we need to rethink the application of the rules a bit
| 	for situations in which the constructed or shortened
| 	term has become a word in its own right and, more
| 	important, in which an expansion would tend to confuse
| 	rather than illuminate, and 
| 	
| 	* that we get a little more serious about the
| 	requirement that abstracts be sufficient for someone who
| 	doesn't know what the document is about to figure that
| 	out because titles will never be able to adequately do
| 	that job.
| 
| For the second, pretend that you are reading the title that
| Christian cites above: "Classical IP and ARP over ATM".  Now
| pretend that you don't know much about that corner of the IETF's
| work, or even that you are an applications type who doesn't know
| much about _anything_ at that layer.  Now expand the
| abbreviations and try to convince yourself that you would know
| something you didn't know with the present title.  Reaction to
| present title: "Huh? Strange abbreviations".   Reaction to title
| with abbreviations expanded: "Huh? What on earth do those words
| mean?"
| 
| I don't see a lot of difference.

:)

Good docs just include a glossary of terms/abbreviations/acronyms.

I'd prefer to see acronyms in the titles.

--
~Randy