Subject: Re: Reminder: Poll about restructuring options

From: [email-masked] (Kai Henningsen)
Date: 01 Oct 2004 18:48:00 +0200

[email-masked] (Harald Tveit Alvestrand)  wrote on 29.09.04 in <EA2F1A1020D9C4B0E1013295@B50854F0A9192E8EC6CDA126>:

> Sigh, Dave.
>
> > It is very unlikely that there is any language on this planet
> > that would equate ""No, I do not wish to state an opinion" with
> > "I wish to state an opinion but you have no provided a category
> > that covers my opinion".
>
> What about English?

Doesn't support your position.

> If I ask you "do you prefer A or B", and you say "I don't wish to say
> whether I prefer A or B, because you have not provided a category that
> covers my opinion", in what way have you said something where "I do not
> wish to state an opinion" is an inappropriate description?

Come on, Harald, that's really lame. You resort to putting words in your  
opponent's mouth to create a strawman.

They don't want to say "I don't wish to say whether I prefer A or B,  
because you have not provided a category that covers my opinion". Probably  
*nobody* wants to say something silly like that.

They want to say "I do wish to say that I prefer a different option from A  
or C".

> I could have written the option in the poll as "I do not wish to state an
> opinion on whether I prefer Scenario C or Scenario O", but I thought this
> was so obvious from context that I did not.

Frankly, I don't see the difference - this fails in exactly the same way.

MfG Kai

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Sandy Wills <[email-masked]>
Date: Sat, 02 Oct 2004 17:51:53 -0400

I am a US citizen who is getting sick of our oficial election 
process.  Unfortunately, the bickering after this poll is beginning to 
remind me of how we choose presidents.

    With this in mind, I'd like to propose a few minor changes, to 
accomodate everyone.  Every election should include the following options:

----------------------------------

Choose _one_ from the following list of _five_ choices:

1.  Choice A (or, in this IETF case, Option C)
    [I believe that Option C is clearly the best option open to us.]

2.  Choice B (or, in this IETF case, Option O)
    [I believe that Option O is clearly the best option open to us.]

(followed, in the general case, by any other choices)

3.  Either (or any) of the above
    [I believe that both options are clearly better than all others, and 
I don't care which we choose.  Count my vote as 1/2 for each one.]

4.  Neither (or none) of the above
    [I believe that both options are clearly worse than at least one 
other that is not listed above.  Count my vote as 1/2 _against_ each one.]

5.  N/A - I don't care
    [I really couldn't care less about this particular poll, but I feel 
obligated to vote simply to re-affirm my right to vote in other upcoming 
elections.  Count this vote as an intentional blank, good only for 
tracking the total number of people voting.  Do _not_ count this in the 
base for determining consensus.]

-----------------------

Check the following if you agree:

6.  This is a negative-based vote
    [I don't really like the candidate I voted for above.  However, I 
feel forced to vote for it/him because I have strong negative feelings 
about the major alternative.  Rather than a vote "for" my choice, it 
should be counted as a vote "against" the other major choice.]

[end of proposed ballot]

It seems to me that, if we are looking for consensus, the winning option 
should have at least a simple majority of all votes cast, after all 
votes are counted as above.  If no option can garner 51% of the vote, 
then you don't have consensus.

Example:  If 100 people vote, and 27 want and vote for A, and 27 vote 
for B, while another 28 vote for A only because they believe that B is 
bad, then A will get 55% of the vote in a traditional American election. 
  On the other hand, counting as suggested above would show A with 27% 
while B ends up with -1% -which tells us that there is a serious problem 
with the two choices.

-- 
: Unable to locate coffee.  Operator halted.
: Reply to [email-masked]

---

From: John C Klensin <[email-masked]>
Date: Wed, 06 Oct 2004 08:27:55 -0400

Dave,

We have a long history of looking at the same data and analysis 
and reaching different conclusions and of looking at different 
data and analysis and reaching similar conclusions.  Since we 
have both been critical of aspects of this process, let me agree 
with you about part of it but supply some different data about 
the rest in the hope we can come closer together.

--On Monday, October 04, 2004 9:10 PM -0700 Dave Crocker 
<[email-masked]> wrote:

>...
> 1. Nothing about the reorganization is going to make IETF
> standards be more useful or be produced significantly more
> quickly.  Hence, reorganization has nothing to do with the
> really  serious threats to IETF long-term survival.

Arguably not true.  The present organizational structure and its 
consequences are sufficient to block some changes that really 
might improve the efficiency of the process.  It is a separate 
set of questions as to whether we prefer those changes and the 
accompanying risks to slogging through with our current 
arrangements (see my note on the "Clerk" function), but it is 
clear that the current organizational structure would block any 
such changes.  See below for more on this.

> 2. The current sense of crisis has mostly come from a loss of
> revenue.  Nothing about the reorganization will necessarily
> fix  that.

Having participated in the "AdminRest" activity and the 
investigations that surrounded it, I don't think this is true. 
The current sense of crisis derives, IMO, primarily from four 
factors:

	* the inability to move funds from one source and
	category to another (to be specific, there is no way to
	move money derived from meeting fees into efforts other
	than the CNRI/Foretec-operated secretariat or to move
	money from ISOC revenues and contributions into that
	secretariat),
	
	* seemingly-unresolveable inability of the IETF
	leadership and community to understand where one of
	those sources/ pools of money are going (to be specific
	about one example, the IETF has been completely
	unsuccessful in getting information about where
	"overhead" being charged by CNRI/Foretec goes and how
	that overhead rate is determined),
	
	* apparent inability of the CNRI/Foretec Secretariat to
	work with the IETF leadership to develop new ways of
	doing things or even to do the existing, historical,
	tasks as well as they were being done a half-dozen years
	ago (to be specific about a few examples, it is my
	understanding that every recent proposal for change or
	improvement from the IESG or IAB has been greeted with
	an indication that it is impossible to think about such
	things without additional revenues, presumably from
	meeting fees.  The community has seen other symptoms.
	For example, meeting dates and locations are being
	nailed down less than six months in advance, not the
	18-24 months which the community has repeatedly
	requested.  We are also seeing an apparent inability to
	keep lists like IETF-Announce to extremely limited
	access for posting (not exactly rocket science)).  There
	are far more serious symptoms: lost documents, delayed
	protocol action announcements, and many other problems
	in document handling and processing, which are
	occasionally visible to document editors and WG chairs
	but, by the nature of their oversight/management role,
	every instance is visible to the IESG and they have to
	deal with them every day.
	
	* and, of course, there are some issues about finances
	going forward, but the present organizational structure
	and relationships have prevented engaging those in any
	serious ways.

> 3. The rest of the sense of crisis is due to interaction
> problems  between some people in IETF leadership and some
> people in the  organizations that the IETF uses for services.
> Nothing in the  reorganization is certain to improve any of
> that, especially  since we do not have precise statements of
> work for them.  (There  is a rather mystical sense that the
> reorganization will fix these  issues, but in fact nothing in
> the simplistic, superficial way  that we are proceeding should
> give us any sense that that  improvement is likely.  Quite the
> opposite.)

Here we partially agree.  There is some risk, given the current 
reorganization process and model, that we will succeed in 
recreating the present situation with a secretariat function 
that doesn't work well in some ways, including being 
unresponsive relative to IESG/IAB expectations.  However, many 
of the problems with the current relationship stem from very 
different assumptions, derived from history, about who has 
ultimate decision authority.   The IETF view is that ultimate 
authority for determining the best interests of the IETF and the 
Internet rests exclusively in the IETF leadership, representing 
the consensus of IETF participants.    The CNRI view seems to be 
that this ultimate authority rests with CRNI, because of their 
founding role, their experience with relationships external to 
the IETF, and their greater experience and longer view of a 
variety of matters.  Regardless of which point of view one 
sympathizes with, the gulf between those points of view is 
fairly significant.

> 4. Most of the reorganization process has been pursued with
> partial statements, incomplete plans, and assertions of
> urgency.  It certainly has not been conducted in a way that
> attended to  concerns as they were raised.  Quite the
> opposite.

Indeed.  I'd go a bit further in comparing this to our processes 
and history of developing specifications.  Somewhat over a 
decade  ago, we discovered that the IAB had gotten out of touch 
with the community and, more important, had begun to substitute 
their judgment for that of the community and to assert their 
right and responsibility to do so.   The Kobe incident was part 
of a series, not a unique event.  The community's response was 
to change the way people were appointed to the IAB and IESG and 
to remove most authority from the former.  The hope was that 
this would fix the problem.  Well, we are arguably seeing the 
same symptoms again (with the body to whom we gave that 
authority and, to a somewhat lesser degree, with some members of 
the IAB),  although more dramatically and clearly with the admin 
issues than with standards.  That said, the problem 
identification effort turned up a number of things that might 
suggest the same problems in the standards process side of the 
house.

> So the view that "delay" will not assist us amounts to a
> statement that we should not worry about the considerable
> range  of serious problems in how we have been pursuing
> organization, or  with our community ignorance about what we
> are doing, but we  should charge ahead (blindly) just to get
> it over with.

We agree about that too.

In a subsequent note, you wrote...

> My point was that the level of naivete and irrationality that
> underlie this reorganization process would never be tolerated
> in  any serious design effort for specifications.
>
> So I was not talking about "rules".
>
> I was talking about being deliberate, constructive risk-averse.

There I think we are making progress, although one could doubt 
the efficiency of the mechanisms.   Certainly Scenario O 
represents a better risk balance than Scenario C, regardless of 
how we have gotten there.

best,
     john