Subject: Re: Level of consultation (Re: a note about the scenarios)

From: "JFC (Jefsey) Morfin" <[email-masked]>
Date: Fri, 01 Oct 2004 13:48:38 +0200

At 11:17 30/09/2004, Dave Crocker wrote:
>On Mon, 27 Sep 2004 18:42:18 +0300, John Loughney wrote:
> >  I have heard that there have been some problems with the
> >  Secretariat, I have not been privy to the fact that the IETF
> >  is going to hell in a handbasket. Are things so dire? I have
> >  been much more concerned about other problrms in the IETF,
> >  though I'm feeling rather burnt out on that topic as well.
>
>Based on the management actions being pursued in the IETF:
>1. Those "other" problems are well in hand, with no emergency
>issues, so there does not need to be a focus on them by the IESG.
>2. The Secretariat and IANA are responsible for all the other
>problems.
>And, yes, that really is an accurate summary of what Harald has
>been saying over the last year or more.

I apologize for not having followed the debate over the IETF
administrative structure as I should have probable done it .
Dave's response seems to be the first I find interesting and
illuminating (may be I lost others).

Is there a draft/wiki documenting all the IETF problems?
How they are addressed or blocked (I read that mail).
(Not the drafts presenting solutions).

I asked a few months ago if it was a problem that IANA
became a "function" of ICANN. I was responded on the list
or privately that it was a real legal/structural problem with
interesting quotes from ISOC, IETF, ICANN. But
no one (as I do it, but probably for non IETF reason) told
me it was also an operational/administrative problem or
source of problems?

I also apologize for not having consulted the yearly budgets
and reports of IETF, IAB, IESG - first because I do not know
where to find them - no link on the polling page to the above
draft and to these information. I would also be interested in
knowing which of the many partial documents, pages, links
IS the IETF legal Charter, to understand what is to be
retained or changed, what are the expected deliverables.

In the case some of these links were not provided because
they do not exist, should it not be a good idea to start
with their writing?

I am engaged for 26 year this August in structuring net
oriented global groups. This is a very complex task where
there is no good solution today. First because there is no
adequate culture yet with an adapted legal solution. As a
non-Yankee, with also a large parallel (howver national)
experience of Minitel oriented similar structures (it could
be a legal obligation) and some international experience
in networks and data network policy, I observed that
common law and US incorporation cannot fill the
the need. There is no problem when there is a structural
leadership somewhere. This is why it is OK for international
US lead structures, but an immediate problem for multinational
open structures. This is the ICANN, this is the ISOC problem.
What one the IETF draft calls the "nexus"  - underlining it
will be read as nexUS by the US law. IETF is the best and
quite successful attempt for an US lead to be a global and
open effort. Let not kill it.

ICANN as a "bottom-up" effort died. @large as a bottom-up
effort died. IETF as an all-together effort survives well. Please
let non pick inadequate solutions which will kill it.

The problem in US law is the BoD. US legal structures are
designed to get money represented and in control. There is
no difference between a profit and a non profit oriented
structure, other than revenue sharing or not and an external
decision you have to provision for. And the founding
document is mainly a description of the BoD organization
(read the scenario C draft).

To be able to work an all-together organization must
consider the BoD as a service, servicing the secretariat
which serves the community. The BoD Chair has NO power
on the activity. His job is to make the secretariat budgeted
and run. His designation and his policy should be under the
control of the Community/Activity Steering Group. I probably
created more than 50 non profits (size in this is of no
interest - it should be kept small whatever the size of the
community being supported - except when administrative
members are also sponsors. I use standard articles I simplified
to fit the bill. The BoD takes 15 lines over 150. They are built
for a non-profit tax exempt structure: a change would need a
State court action. People are interested in what they do
together, not really in administrativia. Someone has to
take care but this does not make him the boss. The
home keeper is not the home master.

Since this is a basic feature for any organization servicing
a (tier and tier) network should we work on a governance
systems RFC first, and then to test it on ourselves?

A last point: I agree 100% with John Klensin. The
BoD does not make an organization, a common culture
based upon a common education/knowledge makes it.
As someone put it an organization where one needs to
read 50 mails a day to stay in, is no organization.

jfc  

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Mon, 04 Oct 2004 12:59:07 +0200

> Is there a draft/wiki documenting all the IETF problems?

Jefsey,

have you read RFC 3716 ("The IETF in the Large: Administration and 
Execution") and RFC 3774 ("IETF Problem Statement")?

---

From: "JFC (Jefsey) Morfin" <[email-masked]>
Date: Mon, 04 Oct 2004 19:16:14 +0200

>Execution") and RFC 3774 ("IETF Problem Statement")?

Dear Harald,
I apologize again about my Frenglish which lead to confusion. I had read 
quickly these RFCs when published. I retained the feeling that one dealt 
with the problems of interrelating with the existing IETF partners, and 
that the other was about the internal IETF life problems. But none about 
the real IETF problems. I then used the then image that one was about 
outside wall painting and the other about inside wall papers, but none 
about the walls themselves and about what they have been built for.

I reread them in detail. This is actually an impressive and honest work. 
The current thinking I give on issues which impact the architectural usage 
of the Internet helps me to see better how parts of this work may help. But 
I have an increased feeling they help in no way the current debate, and 
even make the discussion over different scenarii unreal.

To take back my image. I feel the discussion is : we identified that our 
four contractors have some requests about the cleaning of the road, the 
signs and the parking lot when coming to the house, how much they are paid 
and how to best understand what we tell them.  We identified that the kids 
are not really happy with the wall paper, the overload of the parents, the 
TV show in foreign languages and other family life issues. So let discuss 
the tax relief in building a new house in stone or in wood, in McLean or in 
Geneva, may address the problem.

I am sorry. When I talk about "IETF Problem" I see it from an IETF's user 
point of view. This roughly means five things:

1. content, quality and usefulness of the deliverables (let first define 
them and discuss the demand, this will tell where the money will come from)
2. surety, security, stability, adequacy, scalability, sovereignty respect 
when using the IANA post-delivery services
3. currently missing deliverables (standardized code, missing functions, 
digital convergence, multilingualism, maintained documents, test beds, etc. 
etc.)
4. the interest for me to invest in using IETF deliverables. Will IETF foot 
the real digital ecosystem needs? or stay with the 1983 TCP/IP model? For 
how long? What is the contingency plan?
5. what about its competition? I observe usage architectures (P2P, used 
interphone, spam, "Pluggable Edge Viruses", etc.. come from els where. IETF 
does not foster competition.  No alternative architecture worked on at 
SourceForge - a long long fight against alt-roots, a monopoly oriented IPv6 
design etc.. I accept there may are good reasons for that but I worry that 
they have not been fairly and innovatively worked on.

This is why I considered Dave's mail as enlighting. I had the feeling he 
was not that much talking about "photographed problems" but about real 
users life problems.

But rereading this RFCs in this context, show the amountg of the work you 
engaged. I want to thank you for that.
But I am afraid reorganizing the 2004 IETF to better carry its 1986 job and 
redo the 1992 ISOC differently may not be the best target? The lack of 
consensus about the IETF purpose in life has been identified as a key 
problem. Should it not come before any possible rebuild?

And it is not just to say "write Internet documents". Some ideas about the 
deliverables of these documents is needed. The debate may start with the 
"core values" you quoted but is much, much more. At least IMHO.

Thank you for all.
jfc