Subject: Re: IANA Considerations

From: Bob Braden <[email-masked]>
Date: Wed, 6 Jul 2005 15:23:10 -0700 (PDT)

*> harmful, and that the best way to insure coverage of IANA issues is to have an
  *> explicit check for such things as part of our review process.
  *> 

Ned,

As I expect you know, the IANA checks all documents at Last Call time,
and the RFC Editor checks them before publication, for missing missed
IANA actions.  However, redundancy does not seem to me to be a bad
idea.

Bob Braden

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Ned Freed <[email-masked]>
Date: Wed, 06 Jul 2005 17:53:52 -0700 (PDT)

> IANA actions.  However, redundancy does not seem to me to be a bad

Of course I know this. But the tendency will be for the text to be believed
and for the review to be less thorough.

You're fighting human nature here, and you're gonna lose.

				Ned

---

From: John C Klensin <[email-masked]>
Date: Wed, 06 Jul 2005 20:59:11 -0400

--On Wednesday, 06 July, 2005 15:23 -0700 Bob Braden
<[email-masked]> wrote:

>   *> harmful, and that the best way to insure coverage of IANA
> issues is to have an   *> explicit check for such things as
> part of our review process.
 
> Ned,
> 
> As I expect you know, the IANA checks all documents at Last
> Call time, and the RFC Editor checks them before publication,
> for missing missed IANA actions.  However, redundancy does not
> seem to me to be a bad idea.

Bob, as I expect you know, the IANA no longer has the staff
skills to perform an in-depth analysis of a document to
determine whether there are issues IANA needs to deal with.
Yes, I think they try, but the whole purpose of this section was
to move toward providing them better instructions and hints than
"go do your own detective work".  I'm grateful that the RFC
Editor continues to make those checks, but it is in everyone's
interest that the IANA actions be understood much earlier in the
process, leaving the RFC Editor review as the safety net of last
resort.

That said, I think we should be paying careful attention to
Bruce's implied suggestion about how template
boilerplate-generators should be constructed.   In terms of the
checking process Ned asks for (and which I still believe is the
right solution) there is a world of difference between a
template that generates:

	IANA Considerations
	   Nothing for IANA to do

and one that generates 

	IANA Considerations
	   If you see this text, the author hasn't gotten around
	to thinking about this issue.

john

---

From: Bill Strahm <[email-masked]>
Date: Wed, 06 Jul 2005 18:12:00 -0700

>	to thinking about this issue.
I actually would prefer
IANA Considerations
    This section left intentionally blank

Reminds me of some wonderful manuals back in the day (and frankly 
currently as well)

Bill

---

From: Ned Freed <[email-masked]>
Date: Wed, 06 Jul 2005 18:22:58 -0700 (PDT)

> 	to thinking about this issue.

As I said in a previous response, this may help a little, but not nearly as
much as it might first appear. However, it actually suggests an alternative
approach: FORBID the inclusion of an IANA considerations section until the
document is ready for general public review, then REQUIRE that one be inserted
as part of the review.

The problem with this approach is that it isn't really compatible with our
processes - there are various paths documents take and various review points,
making the selection of the right time for this to happen rather difficult. But
perhaps this is just another facet of our more general problem that all too
often documents end up in front of the IESG without having undergone sufficient
review. If we fix that, we might well make this whole "require empty IANA
considerations" nonsense moot.

				Ned