Subject: RE: Remote UI BoF at IETF63

From: [email-masked]
Date: Mon, 4 Jul 2005 16:05:06 +0300

Hi David,

> 
> Framebuffer-level protocols can be viewed as a special case 
> of graphics-level
> protocols where the drawing commands are restricted to 
> bitblt-like commands.
> 

Yes, it is possible to have a graphics-level protocol with a restricted functionality that is matching that of framebuffer-level protocol but the overhead and the software and hardware complexity required are to high.

> 
> Having the UI adapt to a look-and-feel appropriate to the 
> client device
> (and user's preferences) doesn't automatically imply that it has to be
> the client that does this adaptation. The client could send 
> the server a
> description of the preferred L&F. The advantage of this is 
> that it allows
> clients to be much simpler, putting the complexity on the 
> server which is
> likely to have more memory, processing power, etc.
> 

Yes, you are right. For some simple devices you can do the customisation on the server side in order to reduce the complexity, but in that case it is probably best to use a framebuffer-level protocol rather than a widget-level one; these simple clients typically don't have a windowing system/widget set anyway. 

The work proposed here is for advanced client devices that have their own windowing system and their own widget sets, i.e. desktop, laptop or tablet computers, PDAs or mobile phones. These devices have enough resources and the means to do the scaling and adaptation by themselves.

Vlad

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: [email-masked]
Date: Mon, 4 Jul 2005 18:21:02 +0300

Hi Harald,

I have to recognise that the name choice for this effort was not entirely appropriate as it drags the spotlight on the "user interface" while leaving the "remoting" unfairly in the shadows.

> - What expertise do you see that the IETF has (and other 
> groups do not 
> have) that makes it the right body to work on this set of issues?

With the risk of repeating what Dave already mentioned, I have to point out that in the process of remoting a ui two entities (i.e. the server and the client) are exchanging information about display objects (i.e. widgets) over *the network*.

As there are other bodies that have the experience on defining what display objects are needed and what is their behaviour, the aim of this effort is to develop an open, platform-independent mechanism of creating and maintaining remote display objects and the focus should be on the network-based mechanisms covering the connectivity, reliability, security, etc., on which the IETF has the best experience around.

> - What importance to the Internet does this work have that makes it a 
> correct use of IETF resources?

Broadband and wireless technology will enable more and more "smart" devices (i.e. Internet tablets, PDAs, mobile phones, PCs, etc.) to be connected to the Internet. Soon the proliferation of these devices will make them the most numerous device "category" on the Internet and their users will want to interact remotely, for various reasons, with applications that are not hosted on the devices; thus, making this effort fit within IETF's scope "protocols and practices for which secure and scalable implementations are expected to have wide deployment and interoperation on the Internet, or to form part of the infrastructure of the Internet." 

Vlad