Subject: Re: Question about Obsoleted vs. Historic

From: Bob Braden <[email-masked]>
Date: Mon, 11 Jul 2005 10:53:57 -0700

At 09:54 AM 7/11/2005 +0300, [email-masked] wrote:
>Hi,
>
>I was wondering if someone could help me out on this one.  I was doing a bit
>of analysis on the current RFC list, and noticed that some Draft Standard
>documents are obsoleted.  For example:
>
>  954 NICNAME/WHOIS. K. Harrenstien, M.K. Stahl, E.J. Feinler.
>       Oct-01-1985. (Format: TXT=7397 bytes) (Obsoletes RFC0812) (Obsoleted
>       by RFC3912) (Status: DRAFT STANDARD)
>
>This really made me scratch my head. One would imagine if a protocol is 
>obsoleted
>by another, it would not be listed as a Draft Standard any longer.
>
>What is the reason for continuing to list something obsolete as a Draft 
>Standard?

Because Jon Postel always did it that way?  Seriously, the idea is that the 
document
was a Draft Standard when it was published.  You can obsolete it, but you 
cannot
change its publication status.  Should its status change to Historic when it is
obsoleted? Maybe, although we have never done it that way (and we do have 20+
years of history).

         (Note that in fact the RFC Editor added "publication status" to 
its index
         database last year; the new field is included in rfc-index.xml.  This
         shows the status upon publication, in cases where the status is
         changed later.)

There are quite a few twisty little passages lurking here, and they mostly 
stem from
a basic semantic confusion between a document (RFC) number and the protocol
that is specified in that document (or maybe not).  The RFC number is in fact a
document number, but we have chosen to overload it as a protocol designator.
We say "RFC 793" or "TCP" more or less interchangeably, but 793 is really
only a document.

In my view, a result of the ISD proposal in newtrk should be to cleanly 
remove this
semantic overloading of RFC numbers. An ISD would define a protocol 
independent of
a document identifier (RFC number).  I believe that we should move with all
deliberate speed to engineer an ISD-based system for IETF standards, rather 
than
to make small patches to RFC designations.

Bob Braden

>John
>
>_______________________________________________
>Ietf mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/ietf

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: [email-masked]
Date: Tue, 12 Jul 2005 06:38:48 +0300

Hi John K,

> >> I would point out that it is historically useful to be able
> >> to track changes between draft and full or proposed and draft
> >> and we don't list status information in the RFCs...
> > 
> > I agree with that.
> > 
> > And, my head still hurts thinking about why we'd leave
> > something as a  "Proposed Standard" when its been obsoleted.
> > Seems more like an "Obsolete Standard" ... but perhaps I am
> > just nit-picking.
> 
> If, as a community, we cared, we could easily have both the
> tracking information and the status by introducing the
> little-known term "former", as in "Obsolete, former Draft
> Standard".
> 
> Of course, how many procedural hoops we'd have to jump through
> to get there is another issue.

That seems like the most reasonable approach, to me - putting the
'former' tag, not having to jump through procedural hoops ...

John L.

---

From: [email-masked]
Date: Tue, 12 Jul 2005 07:58:47 +0300

Brian,

> >>What is the reason for continuing to list something 
> obsolete as a Draft Standard?
> > 
> > 
> > Lack of action by the IESG.  
> 
> No, lack of action by the community to request moving 
> documents to Historic.

Section 6.2 of 2026 does say the following:

   When a standards-track specification has not reached the Internet
   Standard level but has remained at the same maturity level for
   twenty-four (24) months, and every twelve (12) months thereafter
   until the status is changed, the IESG shall review the viability of
   the standardization effort responsible for that specification and the
   usefulness of the technology. Following each such review, the IESG
   shall approve termination or continuation of the development effort,
   at the same time the IESG shall decide to maintain the specification
   at the same maturity level or to move it to Historic status. 

My guess is that anything marked as obsolete will be stuck at its
current maturity level in perpetuity, making it a good candidate to
go to Historic. 2026 seems to state that the IESG will handle this.
However, Eliot's Crust removal draft could come to play here.

John

---

From: [email-masked]
Date: Tue, 12 Jul 2005 08:03:57 +0300

Ted,

> I've assumed that it was to tell you it was at Draft Standard when the document
> that replaced it was issued.  That way you can tell whether the new doc is
> a recycle-in-grade, an update to get something to the next step, or a downgrade.
> The real meat of the data here, though, is that you should look at 3912 if
> you want the current spec.  Any other data about an obsolete spec is for
> historical interest only.  If I'm right, that could be made clearer (by saying
> "Status when active:" or some such), but that doesn't really change meat of the
> information.

I'd strongly suggest some tag to indicate that its no longer active. In many cases,
a Standard is marked Obsolete because it has been updated for some reason; often
times because of some critical bug or other issues.  I don't think the IETF
wants to recommend an obsolete standard as something folks should go and implement.

John

---

From: [email-masked]
Date: Tue, 12 Jul 2005 08:22:36 +0300

Bob,

A question for you:

> document was a Draft Standard when it was published.  You can obsolete 
> it, but you cannot change its publication status.  Should its status change to 
> Historic when it is obsoleted? Maybe, although we have never done it that way 
> (and we do have 20+ years of history).

First off, 2026 says:

4.2.4  Historic

   A specification that has been superseded by a more recent
   specification or is for any other reason considered to be obsolete is
   assigned to the "Historic" level. 

So, it would appear, to me, that anything that has been obsoleted is, in fact,
Historic.  But perhaps I am nit-picking.

My question is - what do we mean by an Obsoleted Proposed Standard?  Does this
have any relevance?  What I am still confused about is that, for a particular
technology, what does the IETF 'recommend' or would want to see implemented
for a particular standard?  Obviously, Historic carries the connotation that
the IETF doesn't suggest to be implemented.  Does the IETF think that Standards
that have been Obsoleted SHOULD be implemented or SHOULD NOT be implemented?
If I wanted to do something and had 2 protocols to choose from, one that was
Proposed Standard and one that was Obsolete but Full Standard, which one 
would the IETF like that I implement?  

Perhaps I am asking to much from the RFC Index (http://www.ietf.org/iesg/1rfc_index.txt)
but one would think that we could provide a meaningful way to convey what
we think of our own technology?

>          (Note that in fact the RFC Editor added "publication status" to its index
> There are quite a few twisty little passages lurking here, and they mostly stem from
> In my view, a result of the ISD proposal in newtrk should be to cleanly remove this
> semantic overloading of RFC numbers. An ISD would define a protocol independent of
> deliberate speed to engineer an ISD-based system for IETF standards, rather  than

Well, you can guess my position on this as well.

thanks,
John