Subject: RE: Please make sure that you do not run your WLAN in ad hoc mode

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Fri, 11 Nov 2005 07:14:37 -0800

I think that what we should do is to send the IEEE 801.b/g group a
polite letter pointing out that if our people here at the IETF cannot
figure this stuff out then their less technically astute customers might
be having some trouble as well.

I think that the cause of this 'misconfiguration' is simply people
trying to connect to the network, getting it wrong, twiddling some stuff
at random, trying again and so on. I don't think you are going to stop
that.

Designers should read Donald Norman's 'The Design of Everyday Things'. 

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Nelson, David" <[email-masked]>
Date: Fri, 11 Nov 2005 12:59:31 -0500

Dave Singer writes...
> Some testing and robustness guidelines from the 802.11 group 
> would also help.

While you may believe that IEEE 802.11 should provide these services, I
will note that the Wi-Fi Alliance (WFA) currently fills that gap.

---

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Fri, 11 Nov 2005 13:40:44 -0800

If the architecture profession carried on the way engineers do the world
would be full of buildings with no interior walls or floors.

You sound like a 1950s British trades unionist calling his men out on
strike over demarcation.

> -----Original Message-----
> From: Nelson, David [mailto:[email-masked]] 
> Sent: Friday, November 11, 2005 11:45 AM
> To: Hallam-Baker, Phillip; [email-masked]; [email-masked]
> Subject: RE: Please make sure that you do not run your WLAN 
> in ad hoc mode
> 
> Phillip Hallam-Baker writes...
> 
> I don't believe this is an 802.11 problem.  That group 
> standardizes PHY and MAC (up to Layer 2) protocols.  The 
> usability problems with 802.11 networks are in the device 
> drivers, operating systems and configuration applications.  
> It would be more effective to send mail to Microsoft, Apple, et. al.
> 
> 
> 
>

---

From: "Nelson, David" <[email-masked]>
Date: Fri, 11 Nov 2005 16:57:10 -0500

> You sound like a 1950s British trades unionist calling his men out on

Insult me, if it makes you feel better.  I stand by my advice.

This is a product usability problem, not a technical shortcoming of the
underlying standards.  My observation was as to the most effective way
to raise the issue.  IEEE 802 doesn't do product testing, but the Wi-Fi
Alliance does.

---

From: "Yaakov Stein" <[email-masked]>
Date: Mon, 14 Nov 2005 20:51:15 +0200

> Are you saying we should use 802.11a because it 
> works better or is somehow isolated from malicious or accidental 
> misuse?

No, 802.11a is usually not as good.
That's why fewer chipsets bother supporting it, 
and thus there was less interference for those which do.

This is simply a case where in a multiple-standard environment
the less prevalent one gains an advantage.
(Another case - less common operating systems and software
are attacked by fewer viruses.)

Y(J)S