Subject: Faux Pas -- web publication in proprietary formats at ietf.org

From: [email-masked]
Date: Thu, 03 Nov 2005 19:16:34 -0800

As of 
Wed Nov  2 22:47:14 PST 2005
the "Restaurant Guide" in 
http://www.ietf.org/meetings/IETF-64.html
points to
http://www.ietf.org/meetings/Restaurant_Guide_Map.ppt

This information is provided in Microsoft
PowerPoint, a vendor-specific proprietary format.
This is the only format in which this information
is available on the IETF website.

It is wildly inappropriate for IETF to be using a
proprietary format on its web page.

For years we have been fighting this.  Attached
below is the form letter that I send back each
time I receive a Microsoft Word document. The same
concept applies to Microsoft's PowerPoint.

This is particularly bad for an entity that claims
to be a standards organization. Fix it quick.

---Subject: I Prefer Not to Receive Informaton in Proprietary Formats

This is an automatic message: 

You sent the document in Microsoft Word format, a secret
proprietary format, so it is hard for me to read. If you
send me plain text, HTML, or PDF, then I will read it.

Please recognize that this note is not about what you
may have wished to communicate in that document. You
have made the implicit assumption that I would be able
to easily read the document in that format. That
assumption is a mistake.

Distributing documents in Word format is bad for you and
for others. Receiving Word attachments is bad for you
because they can carry viruses (see
http://www.viruslist.com/eng/viruslist.html?id=7). Sending
Word attachments is bad for you, because a Word document
normally includes hidden information about the author,
enabling those in the know to pry into the author's
activities (maybe yours). Text that you think you
deleted may still be embarrassingly present. See
http://news.bbc.co.uk/2/hi/technology/3154479.stm for
more info.

But above all, sending people Word documents puts
pressure on them to use Microsoft software and helps to
deny them any other choice. In effect, you become a
buttress of the Microsoft monopoly. This pressure is a
major obstacle to the broader adoption of free
software. Would you please reconsider the use of Word
format for communication with other people?

To convert the file to HTML using Word is simple. Open
the document, click on File, then Save As, and in the
Save As Type strip box at the bottom of the box, choose
HTML Document or Web Page. Then choose Save. You can
then attach the new HTML document instead of your Word
document. Note that Word changes in inconsistent
ways--if you see slightly different menu item names,
please try them.

To convert to plain text is almost the same--instead of
HTML Document, choose Text Only or Text Document as the
Save As Type.

Your computer may also have a program to convert to pdf
format. Select File => Print. Scroll through available
printers and select the pdf converter. Click on the
Print button and enter a name for the pdf file when
requested.

Regards,

...Mohsen
http://www.neda.com

PS: For further reasons why .doc should not be the
format of choice when exchanging information
electronically, I invite you to read
http://www.gnu.org/philosophy/no-word-attachments.html
It may be long, but it certainly exposes the compromises
both you, as the sender, and I, as the receiver, are
making by exchanging Microsoft Word documents.

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "James M. Polk" <[email-masked]>
Date: Thu, 03 Nov 2005 21:40:25 -0500

Mohsen

Next time, don't mince your words. Be bold and say what you mean. Take a 
stand and voice an opinion, why don't you....

sheesh!

---

From: Thomas Kuiper <[email-masked]>
Date: Fri, 04 Nov 2005 11:55:44 +0800

Hello,

 > send me plain text, HTML, or PDF, then I will read it.

PDF is *very* vendor-specific and proprietary. Who sets the standards for
PDF? I remember there used to be discussions here if the RFC's should be
published in PDF also. It's always rejected of course, even if PDF is
probably the best standard you can get for a formated document (better than
postscript that it was derrived from). So you may want to ask people for
Postscript there if you are really that centric about open standards. :-)

 > [..] blah blah [..]

I think you are just against Microsoft formats, thats all. You don't really
care about using other proprietary formats or not. But that doesn't concern
this issue, so why you add this?

Concerning this "Restaurant_Guide_Map.ppt", I agree it really should be in
HTML (its not even a Presentation but just one page with one picture).

The use of standards in this world is shyzophrene, I used to be against HTML
emails too, but I got used to it and consider it very practical to mark
words in diffrent colors in long replies. But I imagine if I send a html
mail to this list I will get flamed (depends on the list police of html
email though).

I wonder actually, given that HTML is a open standard, if all the ID's, RFC,
Std's couldn't be spiced up a little with some bold tags and colors :-)

One side effect of open standards is of course that they change all time
cause developpers like to play with them... and it becomes messy (like the Web).

Best Regards,

Thomas

---

From: "Theodore Ts'o" <[email-masked]>
Date: Thu, 3 Nov 2005 23:17:34 -0500

> is available on the IETF website.

Mohsen,

Enclosed please find a copy of the Restaurant_Guide_Map file converted
into OpenDocument format, a non-propietary format approved by the
Massachusetts Information and Technology Division.  Interestingly, it
is 33% smaller than the propietary version of the file.

Regards,

						- Ted

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 05 Nov 2005 18:59:10 +0100

Here's the text. You can pick up a map at the concierge desk
in the Westin. I ate at Wild Garlic last night and it was
excellent.

     Brian

West Coast Cuisine

Cardero's (1) – 1583 Coal Harbour Quay – 604-669-7666
Wild Garlic Restaurant (2) – 792 Denman – 604-667-1663
Tapastree(3) – 1829 Robson – (604)606-4680
White Spot (4) – 1616 Georgia – 604-681-8034
Fish House in Stanley Park (5) – 604-681-7275
Teahouse Restaurant (6) – Stanley Park – 604-669-3281
Prospect Point Café (7) – Stanley Park – 604-669-2737
The Crime Lab (8) – 1280 W. Pender – 604-732-7463

French Cuisine

Café de Paris (9) – 751 Denman – 604-687-1418
Le Gavroche (10) – 1616 Alberni – 604-685-3924
The Chef & The Carpenter (11) – 1745 Robson – 604-687-2700

Mediterranean

Ciao Bella Restaurant (12) – 703 Denman – 604-606-4680
Zev's (13) – 1906 Haro – 604-408-4783
The Grapevine (14) – 805 Denman
La Fonte Restorante Italiano (15) – 854 Denman

Asian Cuisine

Yoshi Sushi (16) – 689 Denman
Great Wall Mongolian (17) – 717 Denman

Coffee & Dessert

Bojangles(18) –1520 Coal Harbour Quay or 785 Denman
True Confections (19) – 866 Denman

---

From: Mohsen BANAN <[email-masked]>
Date: Sat, 05 Nov 2005 14:36:08 -0800

>>>>> On Sat, 05 Nov 2005 18:59:10 +0100, Brian E Carpenter <[email-masked]> said:

  Brian> Here's the text. You can pick up a map at the
  Brian> concierge desk in the Westin. I ate at Wild
  Brian> Garlic last night and it was excellent.
 
Mr. Carpenter, the IETF Chair;

Your restaurant recommendations, I do take seriously.

The goers go, the talkers talk and the doers do.
Remember!

Of course many now visit the ietf.org site primarily
for the restaurant guide. And now that is only
available as a .ppt file.

Is big business now so entrenched at the ietf that use
of Microsoft's PowerPoint is being encouraged at the
ietf.org website?

True to form, like an experienced cult leader, you have
again trivialized a real problem.

My email was not about restaurants or a need for the
text.

Publication of anything in Microsoft PowerPoint format
at the ietf.org website is utterly inappropriate and
wrong. If IETF's Best Current Practices are to be taken
seriously, ietf.org website should lead by example.

A responsible IETF Chair would have:

  - Recognized and acknowledged that publication of 
    anything at the ietf.org web site in Microsoft's
    PowerPoint format is wrong.

  - Immediately addressed the problem and republished
    in an Open/Libre/Free format.

  - Addressed the broader question of what are
    the Open/Libre/Free formats appropriate for web
    publication and what constitutes an Open/Libre/Free
    format.

In between good meals, perhaps you can also consider
your responsibilities.

As of 
Sat Nov  5 14:32:04 PST 2005
the "Restaurant Guide" in 
http://www.ietf.org/meetings/IETF-64.html
points to
http://www.ietf.org/meetings/Restaurant_Guide_Map.ppt

This information is provided in Microsoft PowerPoint, a
vendor-specific proprietary format.  Fix it quick.

Enjoy Vancouver's many good restaurants.
Bon Appetit!

...Mohsen

---

From: Ole Jacobsen <[email-masked]>
Date: Sat, 5 Nov 2005 15:46:37 -0800 (PST)

Chill out.

The restaurant guide is hardly an official document for the IETF. I am 
sure it ended up there because someone was trying to be helpful. Call
that an accident or a poor judgement call if you are a purist, call it
simply insignificant if you're not. The document is more than likely 
available on PAPER for those who actually attend the meeting in Vancouver.
Those who are not attending aren't likely to be significantly injured
by this "egregious mistake".

Ole

Ole J. Jacobsen 
Editor and Publisher,  The Internet Protocol Journal
Academic Research and Technology Initiatives, Cisco Systems
Tel: +1 408-527-8972   GSM: +1 415-370-4628
E-mail: [email-masked]  URL: http://www.cisco.com/ipj

---

From: Doug Royer <[email-masked]>
Date: Sat, 05 Nov 2005 16:59:56 -0700

> available as a .ppt file.

FYI: The PPT file opens just fine in OpenOffice 2.0

-- 

Doug Royer                     | http://INET-Consulting.com
-------------------------------|-----------------------------

               We Do Standards - You Need Standards

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 06 Nov 2005 01:35:55 +0100

Mohsen BANAN wrote:
...
>     in an Open/Libre/Free format.

Do you seriously imagine that this is a high priority
during the final preparations for a meeting?

As a matter of fact I agree with you that it's desirable
to avoid proprietary formats, and I have passed this on
to the IAD for future reference.

    Brian

---

From: Frank Ellermann <[email-masked]>
Date: Sun, 06 Nov 2005 01:36:48 +0100

Mohsen BANAN wrote:

> for the restaurant guide.

http://www.google.com/custom?q=cache:73jsCm44tooJ:www.ietf.org/meetings/Restaurant_Guide_Map.ppt+restaurant&amp;hl=en&amp;ie=UTF-8

> of Microsoft's PowerPoint is being encouraged at the

PPT slide shows of the tutorials are converted to HTML, e.g.
ftp://ftp.ietf.org/ietf-online-proceedings/05mar/proceedings/slides/wgchair-0/sld1.htm
http://www3.ietf.org/proceedings/05aug/slides/newcomer-0/sld1.htm

That's perfectly readable from my POV, unlike some forms of
PDF ("cannot extract embedded font" is now an ISO standard).

> again trivialized a real problem.

http://www.ietf.org/instructions/meeting_materials.html

| .TXT Plain text (Unix / Mac / Dos)
| .DOC MS Word Document (v 95 - latest version)
| .PDF Adobe Portable Document Format (Acrobat 3 - latest version)
| .PPT MS PowerPoint (v 95 - latest version)
|
| For incorporation into the proceedings, presentation slides
| submitted in ppt and doc WILL BE converted to html and pdf,
| respectively.

I can only hope that they pick HTML for all slides that might
interest me later.

> at the ietf.org website is utterly inappropriate and wrong.

With PPT I'm sure that I can't read it, with PDF I never know
without "experiment", that can be rather expensive with V.90.

> a vendor-specific proprietary format

http://www.iana.org/assignments/media-types/application/vnd.ms-powerpoint

                                Bye, Frank

---

From: Mohsen BANAN <[email-masked]>
Date: Sat, 05 Nov 2005 18:03:45 -0800

>>>>> On Sun, 06 Nov 2005 01:35:55 +0100, Brian E Carpenter <[email-masked]> said:

  Brian> As a matter of fact I agree with you that it's desirable
  Brian> to avoid proprietary formats, and I have passed this on
  Brian> to the IAD for future reference.

Thank you.

Glad you agree.

But, I consider it a very sad day when I have to
go through all of that to get the IETF Chair to
agree with me that web publication in proprietary
formats at ietf.org is a faux pas.

...Mohsen

---

From: shogunx <[email-masked]>
Date: Sat, 5 Nov 2005 21:18:25 -0500 (EST)

> without "experiment", that can be rather expensive with V.90.

You can read that with openoffice, albeit OO 2.0 is a large download.
You can visit www.ubuntu.com to request free live and install CD's which
contain openoffice distributed with ubuntu linux.  They will ship to you
free of any charge.  Get 50 and hand them out to your friends.

If you are on a linux machine at present, you can decode pdf's with xpdf
for viewing under X11, or pdftohtml to translate to html suitable for
viewing at a shell.

Proprietary formats have no place in the IETF.  The internet belongs to
everyone, not Microsoft.

Enjoy,
Scott

sleekfreak pirate broadcast
http://sleekfreak.ath.cx:81/

---

From: "Anthony G. Atkielski" <[email-masked]>
Date: Sun, 6 Nov 2005 11:48:07 +0100

> Proprietary formats have no place in the IETF.  The internet belongs to

Proprietary formats don't come exclusively from Microsoft, and a lot
of public formats start as proprietary formats.  Even many public
formats are actually proprietary, even if they are available freely
for use in most cases.

---

From: shogunx <[email-masked]>
Date: Sun, 6 Nov 2005 09:00:29 -0500 (EST)

On Sun, 6 Nov 2005, Anthony G. Atkielski wrote:

> Proprietary formats don't come exclusively from Microsoft,

No, but they come with more abundence from them.  I remember unisys and
the gif debacle, among others.

> and a lot
> of public formats start as proprietary formats.

Some do eventually see the error in their ways.

> Even many public

Like pdf, I understand all of that.  That does not mean we should
encourage their use.

Scott

---

From: Dave Crocker <[email-masked]>
Date: Sun, 06 Nov 2005 06:25:32 -0800

Hi, Mohsen,

It's been awhile,

> for the restaurant guide. ...

Fortunately, you are not a real problem.

d/

-- 

Dave Crocker
Brandenburg InternetWorking
<http://bbiw.net>

---

From: "JFC (Jefsey) Morfin" <[email-masked]>
Date: Sun, 06 Nov 2005 16:15:34 +0100

At 03:18 06/11/2005, shogunx wrote:
>Proprietary formats have no place in the IETF.  The internet belongs 
>to everyone, not Microsoft.

Dear Scott,
I am sorry: ask Frank. RFC 3066 bis imposes the Unicode (IBM/MS/...) 
CLDR format. And excludes the IETF RFC 4151 format. You can use open 
HTML but will have to use langtag closed limited format. Same kind of 
considerations as Words, but more dangerous for the reader as it 
provides a nice meta-spam vehicle for cultural, racial, religious 
profiling and privacy violation.
A kind of problem a societal consideration part should address in an 
Internet document.
jfc

---

From: shogunx <[email-masked]>
Date: Sun, 6 Nov 2005 15:03:07 -0500 (EST)

On Sun, 6 Nov 2005, JFC (Jefsey) Morfin wrote:

> HTML but will have to use langtag closed limited format.

Actually, I don't HAVE to use anything.  I can use crusty old open VRML
and have text floating around as geometry all over the place.

How about everything UTF-8 then converted to hexidecimal?  That should be
pretty universal;)

> Same kind of

Yep.

---

From: "Thomas Gal" <[email-masked]>
Date: Tue, 8 Nov 2005 09:06:32 -0800

Actually quite a lot of people disagree. And this would HARDLY be considered
a MS friendly venue, though clearly as someone mentioned you've got a gripe
with Microsoft and not proprietary standards otherwise you wouldn't have
mentioned PDF.

> Of course many now visit the ietf.org site primarily for the 
> restaurant guide. And now that is only available as a .ppt file.

MANY? Without any quantification that may be true, but so what? 200 people
looked for a restaurant and printed that document? Do you think people not
at the conference are sitting around wondering where to eat in Vancouver,
and have been left by the wayside because they went to the IETF site for
DINING ADVICE and are now forever dissuaded from contributing?

And of course, there also happens to be a free viewer(JUST LIKE ACROBAT),
can be opened by the FREE AND OPEN OO.org app and these files can be opend
by any microsoft app just about....

> Is big business now so entrenched at the ietf that use of 
> Microsoft's PowerPoint is being encouraged at the ietf.org website?
> 

Where is it encouraged? Who encouraged it? What official document has ever
been put out in this format?

> True to form, like an experienced cult leader, you have again 
> trivialized a real problem.
> 

Typically I believe comments like this indicate an evangelist at work. When
you essentially insult someone when they disagree with you, you've clearly
indicated that solving a problem is not your goal, creating it is.

> My email was not about restaurants or a need for the text.
> 

So then you're saying that document was just an excuse to harp on something
you wanted to complain about anyway right? Say out of those 200 people who
downloaded the map, 10 were unable to read it because they don't have access
to any windows office programs, open office, or anything else for some
reason. How does that compare to sending an email to 10,000 people?
Personally I think you've used up much more of peoples valuable time then
that document ever could. How do you feel about that?

> Publication of anything in Microsoft PowerPoint format at the 
> ietf.org website is utterly inappropriate and wrong. If 
> IETF's Best Current Practices are to be taken seriously, 
> ietf.org website should lead by example.
> 

According to you? It appears you've convinced nobody (or very few) of your
incongrous goals, yet are happy to pass judgement on a very hard working
member of the community.

>     in an Open/Libre/Free format.

Several people did that, but clearly that's not what you were looking for.

>     publication and what constitutes an Open/Libre/Free

What does that have to do with the IETF? Did you make any effort to see if
issues like this have been addressed before burdening the list?

> In between good meals, perhaps you can also consider your 
> responsibilities.
> 

	In what way is this document an official IETF document? Did it get
approved by consensus or running code? Does it have an RFC number? Or is it
possible someone was just trying to help people who were hungry out? I'm a
pragmatist, mostly I'm aware of what's going on and I try to handle it as
best as I can. You didn't try to help anyone with a solution, or even a
recommendation that conforms to your stated goals, and seemed happily able
to waste a lot of peolple's time.

<repeated for emphasis>
> My email was not about restaurants or a need for the text.
> 
</repeated>

	I admit it. Stuff like that pisses me off. Not long ago somebody
said in an email that they didn't read some documents, nor care to, but felt
quite able to comment on the process, and it did the same thing. Luckly this
isn't a forum where someone like you can just YELL LOUDER THAN EVERYONE ELSE
to try to affect people's opinions like people did in high school. As far as
I'm concerend the only thing you can claim credit for is causing 500,000
emails or so to circulate without solving any problem at all. And it's not
like everyone doesn't send something not well thought out from time to time,
but you responded:

<more repetition for emphasis>
> True to form, like an experienced cult leader, you have again 
> trivialized a real problem.
> 
</more repetition>

By insulting the current leader as well as the group. Care to comment on
what your true motivation is?

-Tom "I send all my emails in plain text but don't force my ideals on
anyone" Gal
_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Doug Ewell" <[email-masked]>
Date: Sun, 6 Nov 2005 08:41:59 -0800

shogunx <shogunx at sleekfreak dot ath dot cx> wrote:

> No, but they come with more abundence from them.  I remember unisys
> and the gif debacle, among others.

Thus proving Anthony's point.  The GIF debacle had nothing to do with 
Microsoft.

--
Doug Ewell
Fullerton, California, USA
http://users.adelphia.net/~dewell/