Subject: Re: ASCII art

From: "Yaakov Stein" <[email-masked]>
Date: Tue, 29 Nov 2005 17:37:22 +0200

>   I created a random svg file with Inkscape, a cross-platform svg
drawing app.  I created an <artwork> 
> element with src="pretty.svg"; it displayed inline in the
cross-platform xxe XML editor using my xml2rfc 
> plugin (but no inline editing of the graphic) and converted to PDF
reasonably well:

I returned to the original subject line,
as I wish to return to the idea behind the original thread.

Figures are not just "nice to have" additions to text.
There are good reasons to include diagrams that would
be impossible to use today. For example, the ITU has come
up with a diagrammatic technique for describing transport
networks (see e.g. G.805 and G.809). Its use is now required
in all new work there, and the technique is not just
descriptive, it is genuinely useful for catching bugs
and as the final word when English language descriptions differ.

Such a technique could not be adopted at the IETF
under the present ID system, as there would be no normative
method of distributing the diagrams.

Y(J)S

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Stewart Bryant <[email-masked]>
Date: Wed, 30 Nov 2005 08:59:16 +0000

>method of distributing the diagrams.
I agree with Yaakov here. Graphics are a language that allows us
to abstract and describe concepts in a way that is much
clearer (to reader and writer) than is possible in words
or crude diagrams.

I strongly suggest that folks take a look at the
clarity of the work that the ITU are now producing.
They are a major competitor for mind share in many areas
of importance to us (for example MPLS, Pseudowire, VoIP etc).

- Stewart