Subject: RE: EARLY submission deadline - Fact or Fiction?

From: "Gray, Eric" <[email-masked]>
Date: Tue, 29 Nov 2005 13:26:12 -0500

Marshall,

	This would work reasonably well, if we could be sure
that the "planetary alignment" case was unlikely.  Unhappily,
it is not.  What happens to the credibility of this approach
when the ID submitter, WG chair and AD are all from the same
company?

--
Eric

--> -----Original Message-----
--> From: Marshall Eubanks [mailto:[email-masked]] 
--> Sent: Tuesday, November 29, 2005 1:23 PM
--> To: [email-masked]
--> Cc: Gray, Eric; [email-masked]
--> Subject: Re: EARLY submission deadline - Fact or Fiction?
--> 
--> It would seem to me that this could be pushed to a degree onto the  
--> AD's -
--> 
--> late submissions (up to the point allowed by the machinery) 
-->  would be  
--> accepted on the request
--> of the WG Chair and the concurrence of one of the WG AD's.
--> 
--> I have certainly seen cases where such flexibility would have been  
--> useful. Getting two people to concur in the
--> request will make it a lot harder  to abuse the process.
--> 
--> Regards
--> Marshall Eubanks
--> 
--> On Nov 29, 2005, at 1:10 PM, Dave Crocker wrote:
--> 
--> > Eric,
--> >
--> >> 	One of your comments seems to apply to the effectiveness
--> >> of having an early submission deadline.  What is the point of
--> >> monkeying around with early submission deadlines when they are
--> >> not very effective anyway?
--> >
--> > 1. They add administrative hassle to working groups.
--> >
--> > 2. They lead to having the authoritative version of documents be  
--> > outside the Internet-Drafts mechanism, at least for awhile.
--> >
--> >
--> >> 	  Sometimes a WG
--> >> chair schedules time to talk about an ID that doesn't exist at
--> >> the time of the schedule announcement and - sometimes - 
--> still has  
--> >> not been submitted by the time of the meeting.  ...
--> >> 	So, one question is whether or not it is appropriate to
--> >> allow this practice to continue.
--> >
--> > The broad question is how much freedom a working group 
--> should have  
--> > to formulate its own procedures.  In the not-so-distant 
--> past, the  
--> > IETF was quite friendly to wildly different working group 
--> choices.   
--> > More recently our respond to cases (or, yes, patterns) of  
--> > misbehavior has been to make a rule that restricts everyone with  
--> > respect to procedural details.
--> >
--> > My own view is that we need to facilitate working group progress  
--> > while ensuring working group legitimacy (fairness, 
--> timeliness and  
--> > relevance). I believe that progress is facilitated by letting a  
--> > working group do as much self-organizing as it can, while 
--> keeping  
--> > the working under pressure to be productive. We need to 
--> do this by  
--> > watching for a working group going astray, rather than by 
--> imposing  
--> > micro-managing, rigid rules.
--> >
--> > I believe this view is compatible with the core of yours:
--> >
--> >> 	  IMHO,
--> >> I think the common - usage-based - definition is that WG chairs
--> >> get to arbitrate the meaning of these terms as it applies to ID
--> >> submissions for their own WG, especially when submissions are
--> >> late.  ...
--> >
--> >
--> > I suspect we differ on:
--> >
--> >> 	On the other hand, if someone wants to reduce the WG
--> >> chair's role in arbitrating the legitimacy of an ID submission,
--> >> then it is up to them to make sure that their submission is in
--> >> compliance with formal submission deadlines, format, etc. - so
--> >> that no "exception" is required.
--> >
--> > If I understand correctly, you want to retain a deadline, 
--> but give  
--> > the wg chair authority to override it.  This certainly is  
--> > reasonable, but I think it is not practical because it adds  
--> > administrative overhead (and probably delay) in the 
--> Internet-Drafts  
--> > processing mechanism.
--> >
--> > A simpler rule is that the working group gets to decide its  
--> > deadlines and what will be discussed at the meeting.  
--> (All of this  
--> > is predicated on moving towards fully automated I-D issuance.)
--> >
--> >
--> > d/
--> > -- 
--> >
--> > Dave Crocker
--> > Brandenburg InternetWorking
--> > <http://bbiw.net>
--> >
--> > _______________________________________________
--> > Ietf mailing list
--> > [email-masked]
--> > https://www1.ietf.org/mailman/listinfo/ietf
--> 

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Marshall Eubanks <[email-masked]>
Date: Tue, 29 Nov 2005 13:56:06 -0500

Hello Eric;

Note that this is not about approving documents, but about  approving  
the
discussion of documents. The threat model is weaker.

Suppose this was abused. Suppose, as is the case recently in our  
House of Representatives,
that new 400 page documents came up for discussion after having been  
posted a few hours before.
Suppose that the WG Chair was intent on pushing these through.  If I  
was active in the  WG,  I
might complain. If there was reason to discuss this at a higher  
level, say on this list, then
my complaint would include the paper trail ("at IETF-99 we had to  
discuss the 400 page HTTP over BGP
draft only 1 hour after it was posted"). I would like having this  
paper trail. It's a lot easier to show
this abuse than proving, say, that the Chair claimed consensus for  
when there was actually confusion and doubt.

So I think that the threat model is weak, and that in some sense  
abuse will be self correcting. But I do think that there should be  
two people concurring, thus I think that the AD's should have to  
agree too.

Regards
Marshall