Subject: RE: RFCs should be distributed in XML

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Wed, 9 Nov 2005 12:02:23 -0800

What I do find somewhat tedious is coming to edit an internet draft or
RFC someone else wrote and discovering that I have to spend an hour or
so marking up their text because no editing source exists.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Frank Ellermann
> Sent: Tuesday, November 08, 2005 9:15 PM
> To: [email-masked]
> Subject: Re: RFCs should be distributed in XML
> 
> Stephane Bortzmeyer wrote:
> 
>  [your premise snipped ;-]
> > tell why RFC 2629 is not the mandatory official format for 
> RFC, even 
> > now after six years?
> 
> It's an excellent tool to create real drafts and RfCs.  For 
> "real" read text/plain us-ascii in the format defined 
> elsewhere (2223bis among others).
> 
> It's not the only available tool.  Bruce is the maintainer of 
> the nroff tools, and somebody else offers MS word tools.
> 
> The tools team apparently adopted RfC 2629 as the primary 
> format for the automatical handling of submissions, and one 
> of the "document set" drafts also builds on this format.
> 
> Just let it be, eventually it will be as you want it.  
> Numerous tools like rfcmarkup still build on the "real" 
> format, and nothing's wrong with that.
> 
> With xml2rfc you can now also create unpaginated output, nice 
> for creating / posting a quick diff.
> That feature was added this year, it's still a living 
> project, last DTD updates also this year.
> 
> The EULA boilerplates (= 78/79) are also still a moving 
> target (unfortunately).  This is all not yet ready to be cast 
> in stone.  Only the general direction is IMHO more or less 
> clear.  Bye, Frank
> 
> 
> 
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ietf
> 
> 

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Bill Manning <[email-masked]>
Date: Thu, 10 Nov 2005 09:05:52 -0800

so your concerned about editing ASCI text vs. ASCI XML?
i think you'll be spending that hour regardless.

--bill