Subject: RE: EARLY submission deadline - Fact or Fiction?

From: "Gray, Eric" <[email-masked]>
Date: Tue, 29 Nov 2005 14:22:53 -0500

Marshall,

	I don't disagree that having more than one person involved
in making an exception makes the exception-making process more
visible.  It makes it harder as well.

	Part of the complexity (and surprise) involved in allowing
exceptions is when the meeting attendees assume late submissions
will not be allowed and budget their reading time accordingly - 
only to find out that they were wrong.

	Never mind the case where a submission occurs really late
- what about the submission that occurs just in time for an IETF
meeting-goer to print it out (or E-Copy it to their local system)
for reading on the plane.  If they (mistakenly) believe that the
draft will not be allowed because it is really late, they will 
most likely print/copy and read other drafts.

	In one recent case, a raft of late IDs were allowed, most
likely because the affected WG would otherwise have had little 
reason to meet.  Many, if not most, people had not read these
drafts because of - among other things - day-job pressures and
the need to read and determine comments/questions on other work.

	In my opinion, it would have been better if those drafts 
had not been allowed - especially since we have now established
a precendence that deadlines for IDs in that WG are irrelevant.
Attending future meetings of that WG is very likely to be a bit
too interesting.

	IMO, more important than the long term visibility is the
short term commitment of the WG and - particularly - WG chair(s).
Does the fact that a slot is assigned for discussing an ID mean
we must assume that it will be discussed, even if there's nothing
to discuss, or is a more explicit statement of intent required?
In either case, we don't want the requirements of a decision to
be made so difficult that there is a significant delay in getting
a decision.  If there is a noticeable delay, we do not find out 
what the decision is until even later than we become aware that a 
decision may be in the works.  If this happens a lot, then there
is no way to plan our reading in advance of a meeting.

--
Eric

--> -----Original Message-----
--> From: Marshall Eubanks [mailto:[email-masked]] 
--> Sent: Tuesday, November 29, 2005 1:56 PM
--> To: Gray, Eric
--> Cc: [email-masked]; [email-masked]
--> Subject: Re: EARLY submission deadline - Fact or Fiction?
--> 
--> Hello Eric;
--> 
--> Note that this is not about approving documents, but about  
--> approving  
--> the
--> discussion of documents. The threat model is weaker.
--> 
--> Suppose this was abused. Suppose, as is the case recently in our  
--> House of Representatives,
--> that new 400 page documents came up for discussion after 
--> having been  
--> posted a few hours before.
--> Suppose that the WG Chair was intent on pushing these 
--> through.  If I  
--> was active in the  WG,  I
--> might complain. If there was reason to discuss this at a higher  
--> level, say on this list, then
--> my complaint would include the paper trail ("at IETF-99 we had to  
--> discuss the 400 page HTTP over BGP
--> draft only 1 hour after it was posted"). I would like having this  
--> paper trail. It's a lot easier to show
--> this abuse than proving, say, that the Chair claimed consensus for  
--> when there was actually confusion and doubt.
--> 
--> So I think that the threat model is weak, and that in some sense  
--> abuse will be self correcting. But I do think that there should be  
--> two people concurring, thus I think that the AD's should have to  
--> agree too.
--> 
--> Regards
--> Marshall
--> 
--> On Nov 29, 2005, at 1:26 PM, Gray, Eric wrote:
--> 
--> > Marshall,
--> >
--> > 	This would work reasonably well, if we could be sure
--> > that the "planetary alignment" case was unlikely.  Unhappily,
--> > it is not.  What happens to the credibility of this approach
--> > when the ID submitter, WG chair and AD are all from the same
--> > company?
--> >
--> > --
--> > Eric
--> >
--> > --> -----Original Message-----
--> > --> From: Marshall Eubanks [mailto:[email-masked]]
--> > --> Sent: Tuesday, November 29, 2005 1:23 PM
--> > --> To: [email-masked]
--> > --> Cc: Gray, Eric; [email-masked]
--> > --> Subject: Re: EARLY submission deadline - Fact or Fiction?
--> > -->
--> > --> It would seem to me that this could be pushed to a 
--> degree onto the
--> > --> AD's -
--> > -->
--> > --> late submissions (up to the point allowed by the machinery)
--> > -->  would be
--> > --> accepted on the request
--> > --> of the WG Chair and the concurrence of one of the WG AD's.
--> > -->
--> > --> I have certainly seen cases where such flexibility 
--> would have been
--> > --> useful. Getting two people to concur in the
--> > --> request will make it a lot harder  to abuse the process.
--> > -->
--> > --> Regards
--> > --> Marshall Eubanks
--> > -->
--> > --> On Nov 29, 2005, at 1:10 PM, Dave Crocker wrote:
--> > -->
--> > --> > Eric,
--> > --> >
--> > --> >> 	One of your comments seems to apply to the effectiveness
--> > --> >> of having an early submission deadline.  What is 
--> the point of
--> > --> >> monkeying around with early submission deadlines 
--> when they are
--> > --> >> not very effective anyway?
--> > --> >
--> > --> > 1. They add administrative hassle to working groups.
--> > --> >
--> > --> > 2. They lead to having the authoritative version of 
--> documents be
--> > --> > outside the Internet-Drafts mechanism, at least for awhile.
--> > --> >
--> > --> >
--> > --> >> 	  Sometimes a WG
--> > --> >> chair schedules time to talk about an ID that 
--> doesn't exist at
--> > --> >> the time of the schedule announcement and - sometimes -
--> > --> still has
--> > --> >> not been submitted by the time of the meeting.  ...
--> > --> >> 	So, one question is whether or not it is appropriate to
--> > --> >> allow this practice to continue.
--> > --> >
--> > --> > The broad question is how much freedom a working group
--> > --> should have
--> > --> > to formulate its own procedures.  In the not-so-distant
--> > --> past, the
--> > --> > IETF was quite friendly to wildly different working group
--> > --> choices.
--> > --> > More recently our respond to cases (or, yes, patterns) of
--> > --> > misbehavior has been to make a rule that restricts 
--> everyone with
--> > --> > respect to procedural details.
--> > --> >
--> > --> > My own view is that we need to facilitate working 
--> group progress
--> > --> > while ensuring working group legitimacy (fairness,
--> > --> timeliness and
--> > --> > relevance). I believe that progress is facilitated 
--> by letting a
--> > --> > working group do as much self-organizing as it can, while
--> > --> keeping
--> > --> > the working under pressure to be productive. We need to
--> > --> do this by
--> > --> > watching for a working group going astray, rather than by
--> > --> imposing
--> > --> > micro-managing, rigid rules.
--> > --> >
--> > --> > I believe this view is compatible with the core of yours:
--> > --> >
--> > --> >> 	  IMHO,
--> > --> >> I think the common - usage-based - definition is 
--> that WG chairs
--> > --> >> get to arbitrate the meaning of these terms as it 
--> applies to ID
--> > --> >> submissions for their own WG, especially when 
--> submissions are
--> > --> >> late.  ...
--> > --> >
--> > --> >
--> > --> > I suspect we differ on:
--> > --> >
--> > --> >> 	On the other hand, if someone wants to reduce the WG
--> > --> >> chair's role in arbitrating the legitimacy of an 
--> ID submission,
--> > --> >> then it is up to them to make sure that their 
--> submission is in
--> > --> >> compliance with formal submission deadlines, 
--> format, etc. - so
--> > --> >> that no "exception" is required.
--> > --> >
--> > --> > If I understand correctly, you want to retain a deadline,
--> > --> but give
--> > --> > the wg chair authority to override it.  This certainly is
--> > --> > reasonable, but I think it is not practical because it adds
--> > --> > administrative overhead (and probably delay) in the
--> > --> Internet-Drafts
--> > --> > processing mechanism.
--> > --> >
--> > --> > A simpler rule is that the working group gets to decide its
--> > --> > deadlines and what will be discussed at the meeting.
--> > --> (All of this
--> > --> > is predicated on moving towards fully automated I-D 
--> issuance.)
--> > --> >
--> > --> >
--> > --> > d/
--> > --> > --
--> > --> >
--> > --> > Dave Crocker
--> > --> > Brandenburg InternetWorking
--> > --> > <http://bbiw.net>
--> > --> >
--> > --> > _______________________________________________
--> > --> > Ietf mailing list
--> > --> > [email-masked]
--> > --> > https://www1.ietf.org/mailman/listinfo/ietf
--> > -->
--> 

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Gray, Eric" <[email-masked]>
Date: Tue, 29 Nov 2005 14:47:18 -0500

Dave,

	The WGs really can't determine what the reading time
is unless we assume that over-riding the submission deadline
is a given in many/most cases.

	In order to satisfy the processing requirements, an ID
must be submitted weeks in advance of the meeting.  An ID that
is submitted weeks in advance is early enough for people to
have a chance to read it.  

	It would certainly be aberrant if a WG decided on an 
earlier submission date, though I personally would not mind - 
as long as there is advance notification to potential ID 
submitters allowing them to plan their work accordingly. 

	However, for a WG to decide that a later submission date
applies to them is essentially the same as deciding that they
will always make exceptions to the submission deadline.

	This sort of policy would certainly impose strange sorts
of hardships on draft submission, draft processing, and - most
probably - the WG.  As result, I can't imagine a WG establishing 
such a policy - at least not as a result of a formal consensus.  
And informally established policies on a per-WG basis is the 
stuff of which nightmares are made...

--
Eric

--> -----Original Message-----
--> From: Dave Crocker [mailto:[email-masked]] 
--> Sent: Tuesday, November 29, 2005 2:30 PM
--> To: Gray, Eric
--> Cc: [email-masked]
--> Subject: Re: EARLY submission deadline - Fact or Fiction?
--> 
--> 
--> 
--> > 	1) Allow the Secretariat time to post all on-time submissions;
--> 
--> As I recall, this was the primary reason for originally 
--> imposing the limit.
--> 
--> That is why I explicitly stated the requirement that automated I-D 
--> processing be supported.
--> 
--> 
--> > 	2) Allow for some time to read the IDs before the meeting.
--> 
--> A working group can decide what the limit for this.  As 
--> with so many other 
--> potential abuses by a working group, the cognizant AD can 
--> decide when the 
--> working group is misbehaving on this matter.
--> 
--> 
--> Note:
--> 
-->       I think folks often miss the costs of specifying particular 
--> procedures.  Having an approval hierarchy is an enormously 
--> expensive design 
--> and we have ADs that are already vastly overworked.  (The 
--> Secretariat also 
--> is not exactly twiddling its thumbs.)
--> 
--> d/
--> -- 
--> 
--> Dave Crocker
--> Brandenburg InternetWorking
--> <http://bbiw.net>
-->

---

From: "Gray, Eric" <[email-masked]>
Date: Tue, 29 Nov 2005 15:19:11 -0500

Dave,

	I think we're close to agreement here, however there are
(at least) two levels/kinds of enforcement involved in what we
are talking about.  One - the enforcement of policy regarding 
posting to the Internet Draft depository - has to be done by the 
Secretariat.  The other - enforcement of what gets discussed in 
the WG meeting -  is not even an option for the Secretariat.

	I suppose they could put spies in the meetings and schedule 
a much smaller room at the next meeting, if they don't like what
is being discussed in any meeting - but I frankly doubt the have
time, or inclination, to do that.

	What tends to happen in practice (that I've observed) is
that the posting policy usually guides the discussion policy.
Otherwise, there are too many variations in policy and no common
place to find out which one applies where. 

	If we agree that having the WG chair - possibly with some
form of guidance from the AD - decide when exceptions may apply 
to the discussion policy, then we have essentially agreed to what 
is already status quo.  

	Nice chatting with you.  :-)

--
Eric

--> -----Original Message-----
--> From: [email-masked] [mailto:[email-masked]] 
--> On Behalf Of Dave Crocker
--> Sent: Tuesday, November 29, 2005 3:05 PM
--> To: [email-masked]
--> Subject: Re: EARLY submission deadline - Fact or Fiction?
--> 
--> 
--> 
--> > If I understand the two choices you present are:  
--> > 
--> >     1) the wg has to decide to overrule a default deadline; 
--> >     2) the wg has to decide on all of its own deadlines.
--> > 
--> > It seems to me (granted I have limited experience) that 
--> the administrative
--> > overhead is actually higher in the second case -- 
--> frequently it is simplifies
--> > things to just have a default case. 
--> 
--> 
--> The question is who enforces a deadline.
--> 
--> Having the Secretariat enforce it means that the 
--> Secretariat must be 
--> involved in exceptions. That's high overhead and delay.
--> 
--> The alternative is to move both policy and enforcement to 
--> the working group.
--> 
--> Given the amount of agenda-bashing, document-negotiation, 
--> etc. that already 
--> must (and should) take place within a working group, I 
--> think that the matter 
--> of deciding submission deadlines is a small increment.
--> 
--> That said, it can't hurt to have a "guideline" for a 2-week 
--> deadline, or the 
--> like, so that a chair can declare that to be in effect as 
--> the default.
--> 
--> d/
--> 
--> -- 
--> 
--> Dave Crocker
--> Brandenburg InternetWorking
--> <http://bbiw.net>
--> 
--> _______________________________________________
--> Ietf mailing list
--> [email-masked]
--> https://www1.ietf.org/mailman/listinfo/ietf
-->

---

From: "Gray, Eric" <[email-masked]>
Date: Wed, 30 Nov 2005 11:06:49 -0500

Scott,

	 Hmmm.  I thought your "optimistic" assumption was that
people would try to resolve issues before the meetings.  It may
be that I misunderstood, or simply that I am not aware of much
of what goes on in the background at meetings.

	At most meetings, the usual procedure is for people to 
talk about the information most listeners would know already 
if they read the draft and paid attention to the mailing list.
Then the usual questions are: 1) do we accept the draft as a
WG document or 2) is the draft ready for last call?  After the
WG (co-)chair(s) tally hands, or hum-levels, the question then
goes to the mailing list.  This is the procedure for about 5 
out of 6 presentations, almost all the time.  These questions
rarely (if ever) get asked before the meeting and - in many 
cases - the information people have after the meeting is not
any different than they had before the meeting.

	Since the majority of not particularly contentious stuff
gets resolved this way, I would suspect that merely asking the
question before the meeting - rather than after the meeting - 
might eliminate much of the work that currently takes up time 
during each WG meeting. Of course this is based on optimistic
assumptions like people read the drafts before the meeting and
people would aggressively try to resolve at least the easily
resolved issues.

	At a minimum, this would result in a lot of half-hour or
one hour meetings instead of one and two hour meetings.  But
in other cases (where - for example - the only thing discussed
during the meeting is document status) - there would be little
point in having the meeting if the inforamtion was simply put
out on the mailing list before the meeting and there were no
questions about it.

	I believe that making less optimistic assumptions would
mean no change in any respect.  I tend to believe this, more
pessimistic, view is more likely.

--
Eric

--> -----Original Message-----
--> From: [email-masked] [mailto:[email-masked]] 
--> On Behalf Of 'Scott W Brim'
--> Sent: Wednesday, November 30, 2005 10:36 AM
--> To: [email-masked]
--> Subject: Re: EARLY submission deadline - Fact or Fiction?
--> 
--> On Wed, Nov 30, 2005 10:07:27AM -0500, Gray, Eric allegedly wrote:
--> > 	Making your - admittedly optimistic - assumption and following 
--> > it to a conclusion leads me to suspect that many 
--> (possibly most) WG
--> > meetings would likely be subject to last-minute 
--> cancellation if all
--> > remaining issues are resolved immediately before the meetings.
--> 
--> You're even more optimistic than I am.  Essentially every WG has
--> problems that are not resolved by e-mail (and are rarely 
--> resolved even
--> in person).  I wouldn't expect any change in who meets, just in the
--> meeting logistics.  Those that are free of these problems need never
--> meet in person.
--> 
--> > 	And don't for a minute think that Employers would fail to note
--> > that issues got resolved prior to a trip to Iceland but 
--> not before a
--> > similar meeting in Hawaii.
--> 
--> :-).  There you go, another criterion for venue selection.

Out of curiosity, are you suggesting that meetings should be 
scheduled in inhospitable climates so that the incentive for
resolving issues is higher, or are you suggesting the obverse?

--> 
--> swb
-->