Subject: Re: XML2RFC submission (was Re: ASCII art)

From: Bob Braden <[email-masked]>
Date: Mon, 28 Nov 2005 10:38:12 -0800 (PST)

*> 
  *> > - Making XML-RFC versions of existing or new RFCs available to the  
  *> > public.
  *> 
  *> many can be found at http://xml.resource.org/public/rfc/xml/
  *> 
  *> i'm sure that other people have other repositories.
  *> 
  *> /mtr

Marshall,

How is this possible?  AFAIK, XML source for most published RFCs
has never been created.  Significant content changes do happen
during the RFC editorial process, so the authenticity of any
XML sources you may have on hand is, to put it mildly, suspect.

Bob Braden

  *> 
  *> 
  *> _______________________________________________
  *> Ietf mailing list
  *> [email-masked]
  *> https://www1.ietf.org/mailman/listinfo/ietf
  *> 

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Dave Crocker <[email-masked]>
Date: Mon, 28 Nov 2005 11:29:43 -0800

> XML sources you may have on hand is, to put it mildly, suspect.

Hence the desire to have the RFC Editor use xml2rfc, rather than nroff.

Were there still regular use of nroff in the broad community, there might be 
an argument in favor of continuing to have it as the internal representation 
of authoritative rfc text.

But there isn't.  Whereas xml2rfc has been gaining broad (and enthusiastic) 
adoption.

d/

-- 

Dave Crocker
Brandenburg InternetWorking
<http://bbiw.net>

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 29 Nov 2005 12:00:12 +0100

...
> Were there still regular use of nroff in the broad community, there 
> might be an argument in favor of continuing to have it as the internal 
> representation of authoritative rfc text.
> 
> But there isn't.  Whereas xml2rfc has been gaining broad (and 
> enthusiastic) adoption.

The anonymous survey that I ran a few months ago, in case people have forgotten,
appeared to show about 17% preferring nroff and 68% preferring xml2rfc.

    Brian

---

From: Marshall Rose <[email-masked]>
Date: Mon, 28 Nov 2005 14:51:23 -0800

> XML sources you may have on hand is, to put it mildly, suspect.

bob - someone wrote a script to convert many of them automatically.  
someone else wrote a check to a third-party to translate some more of  
them.

no one was claiming these were authentic.

/mtr

---

From: John C Klensin <[email-masked]>
Date: Tue, 29 Nov 2005 10:10:35 -0500

--On Tuesday, 29 November, 2005 12:00 +0100 Brian E Carpenter
<[email-masked]> wrote:

> ...
>> Were there still regular use of nroff in the broad community,
>> there  might be an argument in favor of continuing to have it
>> as the internal  representation of authoritative rfc text.
>> 

At the risk of stating the obvious, 17% is far too large a
number to support the claim that there is no regular use in the
broad community.  One or two percent might be, but...

Disclaimer: Of all of the ways I have composed I-D and RFC text,
nroff has never been one of them -- this is just an observation,
not an attempt to defend a personal habit.

    john

---

From: Ted Faber <[email-masked]>
Date: Tue, 29 Nov 2005 08:20:32 -0800

On Mon, Nov 28, 2005 at 10:38:12AM -0800, Bob Braden wrote:
> How is this possible? 

I went to that URL, picked an RFC older than CRFC2XML and looked at it.
I found this comment:

<!--

     ASCII to XML transformation by Invisible Worlds, Inc.
     http://invisible.net/
     Last transformation: 03-Feb-1999, 02:07:49

     Cannonical version of this document is at:
     http://info.internet.isi.edu/in-notes/rfc/files/rfc2001.txt

     Implementors should verify all content with
     cannonical version.  Failure to do so may result in
     protocol failures.
-->

http://invisible.net/ redirects to
http://museum.media.org/invisible.net/index.shtml which claims to be run
by 

	The Internet Multicasting Service
	A Nonprofit Public Research Corporation

	Welcome to the Internet Multicasting Service, a 501(c)(3)
	nonprofit public research corporation. We build and maintain
	public works projects on the Internet.

So apparently ASCII -> rfc2xml is a public works project.

Your deleted comments about possible mistakes are all true, but also
at least mentioned by the folks at IMS.

-- 
Ted Faber
http://www.isi.edu/~faber           PGP: http://www.isi.edu/~faber/pubkeys.asc
Unexpected attachment on this mail? See http://www.isi.edu/~faber/FAQ.html#SIG
_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf