Subject: RE: XML2RFC submission (was Re: ASCII art)

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Mon, 28 Nov 2005 09:35:09 -0800

The point is that the IETF should publish this information itself with
at least as great a prominence as the teletype formatted versions.

People who insist that they cannot afford a modern computer and are
forced to read from the teletype versions should continue to be served.

But the authors of RFCs should be able to state that the XML version is
the authoritative one and people should be able to find the HTML
generated from the XML source easily on the IETF web site.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Marshall Rose
> Sent: Wednesday, November 23, 2005 2:19 PM
> To: Henning Schulzrinne
> Cc: [email-masked]
> Subject: Re: XML2RFC submission (was Re: ASCII art)
> 
> > - Making XML-RFC versions of existing or new RFCs available to the 
> > public.
> 
> many can be found at http://xml.resource.org/public/rfc/xml/
> 
> i'm sure that other people have other repositories.
> 
> /mtr
> 
> 
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ietf
> 
> 

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Mon, 28 Nov 2005 19:00:43 -0800

> Behalf Of Christian Huitema

> > Hence the desire to have the RFC Editor use xml2rfc, rather than
> nroff.
> 
> I don't think publishing the xml2rfc test is such a good 
> idea. Xml2rfc is a preparation format. The printed result is 
> a combination of the xml2rfc input and a formatting program 
> of some kind. This formatting program is bound to change over 
> time, e.g. when templates change. You want to archive the 
> final result, not the initial input.

Why do you think that?

What you want to do is to get as close as possible to the original
author's intent.

Over time the publication media is going to change. In time very idea of
'print' is going to become an anacronism. If you have a large, high
speed, high resolution display and the ability to comment on the text
paper is a distinctly inferior technology.

Electronic documents do not behave in the same way that people imaging
paper ones do, but paper documents do behave that way either, get over
it.

At the end of the day the real authoritative version of the standard is
the bits on the wire. Any specification that is not updated on a regular
basis - five years or less is going to diverge from reality to a much
greater degree than any imaginable difference in formatting templates.

---

From: Randy Presuhn <[email-masked]>
Date: Mon, 28 Nov 2005 20:48:38 -0800 (GMT-08:00)

Hi -

> From: "Hallam-Baker, Phillip" <[email-masked]>
> Sent: Nov 28, 2005 7:00 PM
> To: Christian Huitema <[email-masked]>, [email-masked], Bob Braden <[email-masked]>
> Cc: [email-masked]
> Subject: RE: XML2RFC submission (was Re: ASCII art)
...
> What you want to do is to get as close as possible to the original
...

No.  Last call is on the *output* of some formatting tool, not its input.
The preference for some input format over another is a question of
convenience and efficiency for documents' editors and the secretariat.

Randy

---

From: Bob Braden <[email-masked]>
Date: Wed, 30 Nov 2005 13:58:59 -0800 (PST)

*> > occasion, and the RFC Editors have sometimes (in non-crunch-time
  *> > situations) been quite happy to provide that. I'd much prefer having the
  *> > source files available at all times so I didn't have to ask them, or
  *> > make do without during those crunch times.
  *> > 

Tony,

As far as we know, the RFC Editor has never failed to promptly provide nroff
source for published RFCs to any who request it.

Bob Braden for the RFC Editor