Subject: RE: RFCs should be distributed in XML (Was: Faux Pas --web publication in proprietary formats at ietf.org

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Thu, 17 Nov 2005 13:43:16 -0800

In OASIS the de facto document markup during the preparation of the
documents is Word. The principle reason for this is that Word allows for
changes to the document to be highlighted.

The ability to see the differences to the document is critical if you
want people to read it thoroughly more than once.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Juergen Schoenwaelder
> Sent: Thursday, November 17, 2005 3:25 AM
> To: Ted Faber
> Cc: [email-masked]
> Subject: Re: RFCs should be distributed in XML (Was: Faux Pas 
> --web publication in proprietary formats at ietf.org
> 
> On Wed, Nov 16, 2005 at 09:45:00AM -0800, Ted Faber wrote:
>  
> > WRT revision control software on I-Ds, I think it's an 
> excellent idea, 
> > but authors should use whatever they agree on.  IMHO, the 
> IETF doesn't 
> > need to provide a system.  CVS vs. RCS vs. subversion vs. 
> $DIETY knows 
> > what is too much of a mess to wade into for the benefit.
> 
> I strongly disagree. I fact, I would love if the IETF could 
> settle on a system and in the long term, even the RFC editor 
> would just use it.
> It will make my life much easier if I do not have to manually 
> track changes applied by the RFC editor to put them back into 
> my version controlled repository so that the editorial fixes 
> are not lost when the ID is up for revision.
> 
> It seems that the open source community much better 
> understands what it means to edit documents and how important 
> it is to even agree on style guidelines in order to be 
> efficient. The IETF is really in the stone age as an 
> organization in this respect.
> 
> Perhaps the reason is that those who still know how to write 
> and maintain code have become the minority in the IETF.
> 
> /js
> 
> -- 
> Juergen Schoenwaelder		    International University Bremen
> <http://www.eecs.iu-bremen.de/>	    P.O. Box 750 561, 
> 28725 Bremen, Germany
> 
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ietf
> 
> 

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Lakshminath Dondeti <[email-masked]>
Date: Thu, 17 Nov 2005 16:12:51 -0800

>want people to read it thoroughly more than once.

Try http://tools.ietf.org/wg/msec/draft-ietf-msec-gdoi/  (or plug in 
your favorite WG and draft name).  The tools team has done an 
excellent job in providing capabilities that you mention above.

For intermediate versions (say for authors' use while revising I-Ds), 
http://tools.ietf.org/tools/rfcdiff/rfcdiff.pyht works quite well.

regards,
Lakshminath

---

From: Masataka Ohta <[email-masked]>
Date: Fri, 18 Nov 2005 09:50:51 +0900

> changes to the document to be highlighted.

I tried and found that, if I modify figures there is no highlightning.

Even if I remove or paste text boxes in figures, there is no
highlightening.

> want people to read it thoroughly more than once.

I'm afraid that with highlightning on changes, people read only the
changed part. A better way is to make the document short.

Anyway, you are saying figures are not critical part of the document,
aren't you?

If so, just use diff.

							Masataka Ohta