Subject: Re: Diagrams (Was RFCs should be distributed in XML)

From: Bob Braden <[email-masked]>
Date: Mon, 14 Nov 2005 13:05:49 -0800 (PST)

*> 
  *> Bob Braden wrote:
  *> 
  *> >   *>  
  *> >   *> > It just struck me as odd that people were grousing about ASCII's
  *> >   *> appearance when PDF is available.  
  *> >   *> 
  *> >   *> People will stop complaining when the ASCII version is allowed to sa
  *> >   *> "see diagram in the PDF version".
  *> >   *> 
  *> >   *> Y(J)S
  *> >   *> 
  *> > 
  *> > Huh?  That has always been allowed.  What am I missing?
  *> 
  *> Please can we be quite clear on this - for the record:
  *> 
  *> I can include a normative diagram in the .pdf version of an RFC
  *> (that is too complex to produce in ASCII art), and say in the
  *> normative text of the ASCII version the diagram you need to
  *> implement this protocol is in the .pdf version of this RFC?

No, the .ps/.pdf is not allowed to be normative.

Bob Braden

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 14 Nov 2005 21:27:46 +0000

> No, the .ps/.pdf is not allowed to be normative.

Which is the point that I was making and Yaakov summarized
so succinctly.

We need to change the publication process so that we can move away
from 1960's improvisations to clear diagrams using modern
techniques. Anything less leaves us without the ability to
describe protocols using the clearest methods currently
available.

- Stewart

---

From: kent crispin <[email-masked]>
Date: Mon, 14 Nov 2005 13:54:53 -0800

> describe protocols using the clearest methods currently

The clearest methods currently available might include visio diagrams or
powerpoint slides -- at least according to some people. 

-- 
Kent Crispin 
[email-masked]    p: +1 310 823 9358  f: +1 310 823 8649
[email-masked] SIP: [email-masked]

---

From: "Randy.Dunlap" <[email-masked]>
Date: Mon, 14 Nov 2005 14:07:00 -0800 (PST)

> powerpoint slides -- at least according to some people.

SVG was mentioned (as spec'd by w3.org IIRC).

So check out Inkscape:
  "using the  W3C standard Scalable Vector Graphics  (SVG) file format."

Available for multiple platforms.

  http://www.inkscape.org/

-- 
~Randy

---

From: Joe Touch <[email-masked]>
Date: Mon, 14 Nov 2005 14:48:34 -0800

Stewart Bryant wrote:
...
> techniques. 

XML is modern? Where's the modern, WYSIWYG, outline-mode capable editor?
And does one exist that's free?

(I'd love to work in XML, but it seems like a 20-yr step backwards to
manually edit the source code of a document)

Joe

---

From: "Gary E. Miller" <[email-masked]>
Date: Mon, 14 Nov 2005 15:12:35 -0800 (PST)

Yo Joe!

> And does one exist that's free?

OpenOffice, XXE, etc.  Google is your friend.

RGDS
GARY
- ---------------------------------------------------------------------------
Gary E. Miller Rellim 20340 Empire Blvd, Suite E-3, Bend, OR 97701
	[email-masked]  Tel:+1(541)382-8588 Fax: +1(541)382-8676

---

From: Bill Fenner <[email-masked]>
Date: Mon, 14 Nov 2005 16:01:24 -0800

On 11/14/05, Joe Touch <[email-masked]> wrote:
> Where's the modern, WYSIWYG, outline-mode capable editor?

Still a work in progress, but see
http://rtg.ietf.org/~fenner/ietf/xml2rfc-xxe/ .  Outline mode is high
on my todo list (I have one working that only does top-level sections,
but haven't gotten it working showing all sections yet.)

  Bill

---

From: Frank Ellermann <[email-masked]>
Date: Tue, 15 Nov 2005 05:54:09 +0100

Bob Braden wrote:

> the .ps/.pdf is not allowed to be normative.

Good.

---

From: "Anthony G. Atkielski" <[email-masked]>
Date: Tue, 15 Nov 2005 06:54:23 +0100

> Available for multiple platforms.

Using an open format that requires people to install special free software
is no different than using a proprietary format that requires people
to install special free software.  And if that is to be the case, PDF
is much more widespread than SVG.

---

From: "Anthony G. Atkielski" <[email-masked]>
Date: Tue, 15 Nov 2005 06:56:06 +0100

Joe Touch writes:

> XML is modern? Where's the modern, WYSIWYG, outline-mode capable
> editor? And does one exist that's free?

XML is fashionable, not necessarily functional.  There's a difference.

> (I'd love to work in XML, but it seems like a 20-yr step backwards
> to manually edit the source code of a document)

A lot of people don't remember that far back.