Subject: draft-rescorla-dtls-05.txt

From: Rob Dugal <[email-masked]>
Date: Thu, 10 Nov 2005 08:51:37 -0500

How does DTLS handle datagrams containing application data that are lost 
or delivered out of order? 
The draft seems to indicate that only handshake messages are subject to 
re-transmission, timeouts, and re-ordering. 

-----------------------------------------------
Robert Dugal
Member of Development Group
Certicom Corp.
EMAIL: [email-masked]
PHONE: (905) 501-3848
FAX  : (905) 507-4230
WEBSITE: www.certicom.com

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 10 Nov 2005 07:17:13 -0800

> re-transmission, timeouts, and re-ordering. 

That's correct. The philosophy here is to provide an interface that's
as much like that provided by normal datagram transport protocols as
possible. Those protocols don't take care of this stuff for application
data, so neither does DTLS.

-Ekr