Subject: RE: EARLY submission deadline - Fact or Fiction?

From: "Gray, Eric" <[email-masked]>
Date: Tue, 29 Nov 2005 12:32:46 -0500

Dave,

	One of your comments seems to apply to the effectiveness
of having an early submission deadline.  What is the point of
monkeying around with early submission deadlines when they are
not very effective anyway?

	There seems to be two elements to your argument: that the
rule does not seem to apply in every case and that exceptions 
seem to favor inappropriate submissions while enforcement tends
to impede submission of "legitimate late postings". 

	I have to admit that I agree with the sentiment that they
are not very effective - at least not always.  Sometimes a WG
chair schedules time to talk about an ID that doesn't exist at
the time of the schedule announcement and - sometimes - still 
has not been submitted by the time of the meeting.  Being used
to somewhat firmer guidelines, that sort of thing catches me
by surprise, unless - like some people - I have grown inured
to this sort of exception within a specific WG.

	So, one question is whether or not it is appropriate to
allow this practice to continue.  That question needs to be
answered - one way or the other - before we can really address
your concern about playing around with submission deadlines.

	However, the bit about exceptions favoring innappropriate
late submissions and enforcement impeding legitimate submissions
depends on how we define "appropriate" and "legitimate".  IMHO,
I think the common - usage-based - definition is that WG chairs
get to arbitrate the meaning of these terms as it applies to ID
submissions for their own WG, especially when submissions are
late.  If _we_ don't like the way that a specific WG chair does 
this, then we can individually complain about it and - if enough 
complaints are heard - something will most likely be done about 
it.  If _we_ don't like the practice in general, then we can 
complain about it in this venue.

	But - as long as the usage definition is that it is up to
the WG chair to define what is an "appropriate" or "legitimate" 
ID submissions - then (by that definition) whatever the chair
allows to be discussed is both appropriate and legitimate.  If
we - as individuals - disagree, then it is up to us to say so
during the highly traditional "agenda bashing" period at each
WG meeting.

	On the other hand, if someone wants to reduce the WG
chair's role in arbitrating the legitimacy of an ID submission,
then it is up to them to make sure that their submission is in
compliance with formal submission deadlines, format, etc. - so
that no "exception" is required.

	How wide-spread the practice of ignoring the deadlines is 
in practice and how much the IETF as a whole may have come to 
accept that this is something that is occasionally done (by any 
definition of occasionally we care to use), is only relevant if 
you would argue that there should be no deadlines.

	This, then, is an implication of your argument and - for
the reasons Harald, and others, stated - this is unacceptable.

--
Eric

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Dave Crocker <[email-masked]>
Date: Tue, 29 Nov 2005 10:10:39 -0800

Eric,

> not very effective anyway?

1. They add administrative hassle to working groups.

2. They lead to having the authoritative version of documents be outside the 
Internet-Drafts mechanism, at least for awhile.

> 	  Sometimes a WG
> has not been submitted by the time of the meeting.  ...
> 
> allow this practice to continue.  

The broad question is how much freedom a working group should have to 
formulate its own procedures.  In the not-so-distant past, the IETF was 
quite friendly to wildly different working group choices.  More recently our 
respond to cases (or, yes, patterns) of misbehavior has been to make a rule 
that restricts everyone with respect to procedural details.

My own view is that we need to facilitate working group progress while 
ensuring working group legitimacy (fairness, timeliness and relevance). I 
believe that progress is facilitated by letting a working group do as much 
self-organizing as it can, while keeping the working under pressure to be 
productive. We need to do this by watching for a working group going astray, 
rather than by imposing micro-managing, rigid rules.

I believe this view is compatible with the core of yours:

> 	  IMHO,
> late.  ...

> that no "exception" is required.

If I understand correctly, you want to retain a deadline, but give the wg 
chair authority to override it.  This certainly is reasonable, but I think 
it is not practical because it adds administrative overhead (and probably 
delay) in the Internet-Drafts processing mechanism.

A simpler rule is that the working group gets to decide its deadlines and 
what will be discussed at the meeting.  (All of this is predicated on moving 
towards fully automated I-D issuance.)

d/
-- 

Dave Crocker
Brandenburg InternetWorking
<http://bbiw.net>

---

From: Marshall Eubanks <[email-masked]>
Date: Tue, 29 Nov 2005 13:22:47 -0500

It would seem to me that this could be pushed to a degree onto the  
AD's -

late submissions (up to the point allowed by the machinery)  would be  
accepted on the request
of the WG Chair and the concurrence of one of the WG AD's.

I have certainly seen cases where such flexibility would have been  
useful. Getting two people to concur in the
request will make it a lot harder  to abuse the process.

Regards
Marshall Eubanks

On Nov 29, 2005, at 1:10 PM, Dave Crocker wrote:

> 2. They lead to having the authoritative version of documents be  
> outside the Internet-Drafts mechanism, at least for awhile.
>
>
>> 	  Sometimes a WG
>> the time of the schedule announcement and - sometimes - still has  
>> not been submitted by the time of the meeting.  ...
> The broad question is how much freedom a working group should have  
> to formulate its own procedures.  In the not-so-distant past, the  
> IETF was quite friendly to wildly different working group choices.   
> More recently our respond to cases (or, yes, patterns) of  
> misbehavior has been to make a rule that restricts everyone with  
> respect to procedural details.
>
> My own view is that we need to facilitate working group progress  
> while ensuring working group legitimacy (fairness, timeliness and  
> relevance). I believe that progress is facilitated by letting a  
> working group do as much self-organizing as it can, while keeping  
> the working under pressure to be productive. We need to do this by  
> watching for a working group going astray, rather than by imposing  
> micro-managing, rigid rules.
>
> If I understand correctly, you want to retain a deadline, but give  
> the wg chair authority to override it.  This certainly is  
> reasonable, but I think it is not practical because it adds  
> administrative overhead (and probably delay) in the Internet-Drafts  
> processing mechanism.
>
> A simpler rule is that the working group gets to decide its  
> deadlines and what will be discussed at the meeting.  (All of this  
> is predicated on moving towards fully automated I-D issuance.)
>
>
> d/
> -- 
>
> Dave Crocker

---

From: kent crispin <[email-masked]>
Date: Tue, 29 Nov 2005 11:53:18 -0800

On Tue, Nov 29, 2005 at 10:10:39AM -0800, Dave Crocker wrote:
> what will be discussed at the meeting.  (All of this is predicated on 
> moving towards fully automated I-D issuance.)

If I understand the two choices you present are:  

    1) the wg has to decide to overrule a default deadline; 
    2) the wg has to decide on all of its own deadlines.

It seems to me (granted I have limited experience) that the administrative
overhead is actually higher in the second case -- frequently it is simplifies
things to just have a default case. 

Kent

-- 
Kent Crispin 
[email-masked]    p: +1 310 823 9358  f: +1 310 823 8649
[email-masked] SIP: [email-masked]

---

From: Dave Crocker <[email-masked]>
Date: Tue, 29 Nov 2005 12:04:52 -0800

> things to just have a default case. 

The question is who enforces a deadline.

Having the Secretariat enforce it means that the Secretariat must be 
involved in exceptions. That's high overhead and delay.

The alternative is to move both policy and enforcement to the working group.

Given the amount of agenda-bashing, document-negotiation, etc. that already 
must (and should) take place within a working group, I think that the matter 
of deciding submission deadlines is a small increment.

That said, it can't hurt to have a "guideline" for a 2-week deadline, or the 
like, so that a chair can declare that to be in effect as the default.

d/

-- 

Dave Crocker

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 29 Nov 2005 16:34:59 -0500

There is an aspect of the deadline that is helpful for me, even when the 
deadline is not rigidly enforced.
The presence of the deadline means that the bulk of I-Ds are in by the 
deadline, and are out by not too long after the deadline.  This means that 
I can collect announcements for I-Ds of interest and have time to read the 
I-Ds across most of the range of working groups that I try to stay current on.
If working groups as a matter of course published I-Ds within a few days of 
the meeting, it would be almost impossible for me to read most of what I 
need to in order to be an informed participant.

Yours,
Joel

At 01:10 PM 11/29/2005, Dave Crocker wrote:
>...

---

From: "Gray, Eric" <[email-masked]>
Date: Tue, 29 Nov 2005 17:31:40 -0500

Joel,

	I agree with your observation completely.  One
essential problem with allowing WGs to independently
determine their own deadlines is that this tries to
assert that impact on people's scheduling needs in a 
WG is independent of similar needs for other working
groups.  Because all of the working groups meet in a
single week and the mix of WGs that each individual 
wants/needs to participate in is not the same for all
participants, it is best if all working groups use a
single common deadline, posted - as is currently the
case - in each meeting's "important meeting dates".

	Perhaps in the fully automated processing Dave
posits for our future, it will be sufficient for the
automated processing to flag a submission as being 
beyond the cut-off - both to the submitter and to the
targetted WG(s).  

	This would certainly be an improvement over the
current process that results in an apparent hold on 
processing anything that is beyond the cut-off - thus
making it very difficult for a WG to effectively make
an exception. 

	Also, there would be no more of an "enforcement"
element in this approach than there is in "enforcement" 
of template and other formatting requirements in the
proposed automated processing. 

	But - as Dave said - all this is predicated on
the existence of a fully automated submission process.
That's an important dependency, because it will never -
quite - happen.  There will always be a need for manual
intervention and - assuming a largely automated process
- the resources available to handle manual intervention
would likely become scarce.

	Consequently, with an automated submission process,
it will usually be the case that a draft submission can
be made independent of processing delays - but - it will
occasionally be the case that an arbitrarily large delay
will be incurred in processing a specific submission.  I
am not sure that this would necessarily be an improvement
- however - in such a case, an early submission date that
takes into account the possible processing requirement 
will help.

--
Eric

--> -----Original Message-----
--> From: [email-masked] [mailto:[email-masked]] 
--> On Behalf Of Joel M. Halpern
--> Sent: Tuesday, November 29, 2005 4:35 PM
--> To: [email-masked]
--> Subject: Re: EARLY submission deadline - Fact or Fiction?
--> 
--> There is an aspect of the deadline that is helpful for me, 
--> even when the deadline is not rigidly enforced.
-->
--> The presence of the deadline means that the bulk of I-Ds 
--> are in by the deadline, and are out by not too long after 
--> the deadline.  
-->
--> This means that I can collect announcements for I-Ds of   
--> interest and have time to read the I-Ds across most of the  
--> range of working groups that I try to stay current on. 
-->
--> If working groups as a matter of course published I-Ds 
--> within a few days of the meeting, it would be almost 
--> impossible for me to read most of what I need to in order 
--> to be an informed participant.
--> 
--> Yours,
--> Joel
--> 
--> At 01:10 PM 11/29/2005, Dave Crocker wrote:
--> >...
--> > A simpler rule is that the working group gets to decide 
--> > its deadlines and what will be discussed at the meeting.  
--> > (All of this is predicated on moving towards fully 
--> > automated I-D issuance.)
--> >
--> >
--> >d/
--> >--
--> >
--> >Dave Crocker
--> >Brandenburg InternetWorking
--> ><http://bbiw.net>
--> >
--> >_______________________________________________
--> >Ietf mailing list
--> >[email-masked]
--> >https://www1.ietf.org/mailman/listinfo/ietf
--> 
--> 
--> _______________________________________________
--> Ietf mailing list
--> [email-masked]
--> https://www1.ietf.org/mailman/listinfo/ietf
-->

---

From: Scott W Brim <[email-masked]>
Date: Wed, 30 Nov 2005 08:33:13 -0500

The reason we have the "deadline" is to protect the Secretariat from
having to be heroes.  However, best would be if the need for such
protection didn't arise.

Instead of assuming that things to be discussed in the meetings will
be written just before the meeting, and creating complexity and
bureaucracy around that assumption, institute a policy that nothing
*will* be discussed in the meeting unless it has already been
discussed on the mailing list and the WG has failed to reach agreement
on the issue (note this is about issues, not documents).  This will
reduce the number of drafts which must get out just before the meeting
to only those which capture the result of ongoing discussion.  The
others won't get discussed anyway.  OK, I'm optimistic, but I see all
this discussion of mechanisms to elaborate a situation we don't want
to be in in the first place.

swb