Subject: Problem with IANA MIME media types registry

From: Bruce Lilly <[email-masked]>
Date: Sun, 11 Dec 2005 09:39:58 -0500

[CC'd to IETF discussion list and ietf-types discussion list]

Hello,

Recent changes to the page at
http://www.iana.org/assignments/media-types/index.html
accessed via the link from the IANA Assigned numbers page
http://www.iana.org/numbers.html#M
have rendered the registry of assigned media types useless.
Prior to the recent change, the media types registry listed
the assigned MIME top-level media types, viz. application, audio,
image, message, model, multipart, text, and video.  Since the
change, only the application top-level type is listed (audio, image,
message, model, multipart, text, and video have vanished without
a trace) and superfluous repetition of the application subtypes
listed in
http://www.iana.org/assignments/media-types/application
has appeared (these of course are not top-level media types).

Could you please investigate what has gone awry and regenerate
a page that provides top-level media types.

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Chris Lilley <[email-masked]>
Date: Mon, 12 Dec 2005 09:30:03 +0100

On Sunday, December 11, 2005, 3:39:58 PM, Bruce wrote:

BL> [CC'd to IETF discussion list and ietf-types discussion list]

BL> Hello,

BL> Recent changes to the page at
BL> http://www.iana.org/assignments/media-types/index.html
BL> accessed via the link from the IANA Assigned numbers page
BL> http://www.iana.org/numbers.html#M
BL> have rendered the registry of assigned media types useless.
BL> Prior to the recent change, the media types registry listed
BL> the assigned MIME top-level media types, viz. application, audio,
BL> image, message, model, multipart, text, and video.  Since the
BL> change, only the application top-level type is listed (audio, image,
BL> message, model, multipart, text, and video have vanished without
BL> a trace)

Or rather, become unlinked. For example
http://www.iana.org/assignments/media-types/image/
is still there, just not linked anywhere.

I suspect its just an update glitch, but anyway....

BL> and superfluous repetition of the application subtypes
BL> listed in
BL> http://www.iana.org/assignments/media-types/application
BL> has appeared (these of course are not top-level media types).

BL> Could you please investigate what has gone awry and regenerate
BL> a page that provides top-level media types.

I agree, stable URIs for media types are very much needed.

-- 
 Chris Lilley                    mailto:[email-masked]
 Chair, W3C SVG Working Group
 W3C Graphics Activity Lead
 Co-Chair, W3C Hypertext CG

---

From: "IANA" <[email-masked]>
Date: Mon, 12 Dec 2005 06:58:40 -0800

All,

I'll check on this today and see what needs to be done to get this fixed.

Michelle Cotton
IANA

-----Original Message-----
From: Chris Lilley [mailto:[email-masked]] 
Sent: Monday, December 12, 2005 12:30 AM
To: Bruce Lilly
Cc: [email-masked]; [email-masked]; [email-masked];
[email-masked]
Subject: Re: Problem with IANA MIME media types registry

BL> Hello,

BL> Recent changes to the page at
BL> http://www.iana.org/assignments/media-types/index.html
BL> accessed via the link from the IANA Assigned numbers page 
BL> http://www.iana.org/numbers.html#M
BL> have rendered the registry of assigned media types useless.
BL> Prior to the recent change, the media types registry listed the 
BL> assigned MIME top-level media types, viz. application, audio, image, 
BL> message, model, multipart, text, and video.  Since the change, only 
BL> the application top-level type is listed (audio, image, message, 
BL> model, multipart, text, and video have vanished without a trace)

BL> and superfluous repetition of the application subtypes listed in 
BL> http://www.iana.org/assignments/media-types/application
BL> has appeared (these of course are not top-level media types).

BL> Could you please investigate what has gone awry and regenerate a 
BL> page that provides top-level media types.

---

From: Chris Lilley <[email-masked]>
Date: Tue, 13 Dec 2005 22:49:43 +0100

On Monday, December 12, 2005, 3:58:40 PM, IANA wrote:

I> All,

I> I'll check on this today and see what needs to be done to get this fixed.

I think
http://www.iana.org/assignments/media-types/application/index.html
got uploaded to http://www.iana.org/assignments/media-types/index.html

I> Michelle Cotton
I> IANA
I>  

I> -----Original Message-----
I> From: Chris Lilley [mailto:[email-masked]] 
I> Sent: Monday, December 12, 2005 12:30 AM
I> To: Bruce Lilly
I> Cc: [email-masked]; [email-masked]; [email-masked];
I> [email-masked]
I> Subject: Re: Problem with IANA MIME media types registry

I> On Sunday, December 11, 2005, 3:39:58 PM, Bruce wrote:

BL>> [CC'd to IETF discussion list and ietf-types discussion list]

BL>> Hello,

BL>> Recent changes to the page at
BL>> http://www.iana.org/assignments/media-types/index.html
BL>> accessed via the link from the IANA Assigned numbers page 
BL>> http://www.iana.org/numbers.html#M
BL>> have rendered the registry of assigned media types useless.
BL>> Prior to the recent change, the media types registry listed the 
BL>> assigned MIME top-level media types, viz. application, audio, image, 
BL>> message, model, multipart, text, and video.  Since the change, only 
BL>> the application top-level type is listed (audio, image, message, 
BL>> model, multipart, text, and video have vanished without a trace)

I> Or rather, become unlinked. For example
I> http://www.iana.org/assignments/media-types/image/
I> is still there, just not linked anywhere.

I> I suspect its just an update glitch, but anyway....

BL>> and superfluous repetition of the application subtypes listed in 
BL>> http://www.iana.org/assignments/media-types/application
BL>> has appeared (these of course are not top-level media types).

BL>> Could you please investigate what has gone awry and regenerate a 
BL>> page that provides top-level media types.

I> I agree, stable URIs for media types are very much needed.