Subject: RE: I-D file formats and internationalization

From: "JFC (Jefsey) Morfin" <[email-masked]>
Date: Thu, 01 Dec 2005 14:57:56 +0100

At 19:43 30/11/2005, Nelson, David wrote:
>It seems that there are parallels for RFCs and I-Ds. If the official
>language of these documents is English, then should we have portions of
>those documents represented in other languages, and more at issue, other
>character sets?  In the attributions sections, one could, of course,
>provide a Latin character set representation in addition to the native
>national character set, for names, addresses, etc.

Correct. This is why the problem is not to support IETF standards in 
other characters as ASCII as long as the IETF stays what it is and 
want to be: an US internationalized open to all entity (as want to be 
ICANN, ISOC, etc.)

The problem is to permit the ASCII IETF document to correctly embed 
the non ASCII authoritative reference they quote. So the user knows 
what the standard says. This seems to resolve to two things (at least?):

1. a way to identify external authoritative non ASCII documents ASCII 
system can use. As indicated I think that IRI can do that.
2. a way to quote as authoritative external quotes to document their 
non authoritative but widely cross-verified translation. The idea of 
an HTML appendix could be a good solution. Also to use the HTML (or 
an RTF version of same format as the text version) as an 
UTF-8  reference and the Text version as the accepted working version.

jfc

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Gray, Eric" <[email-masked]>
Date: Thu, 1 Dec 2005 18:24:35 -0500

Phillip,

	Two things:

	1)	Robert was speculating as to the reason why
		people use chapter and verse rather than pages
		in their references, and
	2)	He said "informal communication."

There is something a bit informal about referring to an
informal communication as "authoritative."

There is something equally casual about inferring that 
what people read is necessarily authoritative.  Usage
is that typically it is what people refer to when they
have a question, that is considered authoritative.  

Otherwise, Executive Summaries would be considered to
be "authoritative" and this would beg the questions -
"why bother including the rest?"

--
Eric

--> -----Original Message-----
--> From: [email-masked] [mailto:[email-masked]] 
--> On Behalf Of Hallam-Baker, Phillip
--> Sent: Thursday, December 01, 2005 6:07 PM
--> To: Robert Sayre
--> Cc: [email-masked]; Keith Moore; Tim Bray; [email-masked]
--> Subject: RE: I-D file formats and internationalization
--> 
-->  
--> 
--> > -----Original Message-----
--> > From: Robert Sayre [mailto:[email-masked]] 
--> > Sent: Thursday, December 01, 2005 5:38 PM
--> > To: Hallam-Baker, Phillip
--> > Cc: Tim Bray; Keith Moore; [email-masked]; [email-masked]
--> > Subject: Re: I-D file formats and internationalization
--> > 
--> > On 12/1/05, Hallam-Baker, Phillip <[email-masked]> wrote:
--> > >
--> > > On a point of information, most of the references I see 
--> in existing 
--> > > RFCs are to sections in any case.
--> > 
--> > I suspect this is because almost everyone refers to an HTML 
--> > version in informal communication. 
--> 
--> Why do you consider the TXT version to be authoritative if 
--> as you admit
--> the HTML version is the one that is read by reviewers and readers?
--> 
--> Meaning is the result of usage.
--> 
--> 
--> _______________________________________________
--> Ietf mailing list
--> [email-masked]
--> https://www1.ietf.org/mailman/listinfo/ietf
-->

---

From: [email-masked] (Noel Chiappa)
Date: Fri, 2 Dec 2005 09:54:22 -0500 (EST)

> From: Masataka Ohta <[email-masked]>

    > A fundamental problem .. of Unicode is that, most people can't
    > recognize most of local characters.
    > With the internationalized context of IETF, it is prohibitively
    > impolite to spell names of people in a way not recognizable by others.

This is a good point; the way to handle it would be to print the person's
name in transliterated ASCII (e.g. "Masataka Ohta") on top, and in local
script (Kanji for you, I assume - I don't know if your name uses Kana) below.

Although now that I make this point, I think it just points out that this is
a silly idea - since we have to have the name in ASCII anyway, adding it in
the local script is just bowing to nationalism and/or personal issues (for
those who would feel slighted if we leave it out), and I would have hoped we
were beyond that - but clearly not.. But I guess it does no harm to add it.

	Noel

---

From: "Gray, Eric" <[email-masked]>
Date: Mon, 5 Dec 2005 11:36:58 -0500

Ted,

--> > 
--> > The IETF does not make any effort to be representative of the Internet
--> > community. 
--> 
--> 1) They do too.
--> 
--> Hmmm.  I would have thought proof by assertion would be more fun. 
--> 
--> Seriously, you can argue that the IETF is failing to reach the
--> stakeholders it claims to represent, but I think it's disingenuous to
say
--> that the group doesn't try to reach them.  There are low barriers to
--> entry for interested parties, and concentrated efforts to find and
--> coordinate with other networking standards bodies.  Those aren't the
--> actions of a group of ostriches.

It is true that the barriers to entry are low.  But, then, ostriches were
not born with their heads in the sand.  How is the IETF process of driving 
new people away because they say stuff nobody wants to hear, different from
burying its head in the sand?

--> -----Original Message-----
--> From: [email-masked] [mailto:[email-masked]] 
--> On Behalf Of Ted Faber
--> Sent: Friday, December 02, 2005 11:25 PM
--> To: Hallam-Baker, Phillip
--> Cc: [email-masked]
--> Subject: Re: I-D file formats and internationalization
--> 
--> _______________________________________________
--> Ietf mailing list
--> [email-masked]
--> https://www1.ietf.org/mailman/listinfo/ietf
-->