Subject: Re: PDF, Postscript, and "normative" versions (was: Re: Baby Steps (was RE: Alternative formats for IDs))

From: Bob Braden <[email-masked]>
Date: Wed, 11 Jan 2006 11:03:09 -0800 (PST)

*> 
  *> Under those conditions, our precedents are that you can probably
  *> convince the WG/WGchairs/ADs, and eventually the RFC Editor,
  *> that a PDF document containing a picture of the Mona Lisa and an
  *> ASCII document with 
  *> 
  *>       _        -----
  *>               /     \
  *>       _       | o o |
  *>               |  |  |
  *>               | __  |
  *>       _       |     |
  *>               \_____/
  *>       _
  *>             |   |  |  |
  *> 
  *> as a substitute for that picture, with the marginal lines
  *> roughly identifying your grid marks and coordinate system, is
  *> "equivalent" or as close to it as one can get. 

John,

AFAIK, there is one worked example of this ... RFC 1119 on NTP.

Philosophers may speculate on the resemblance of NTP to the Mona Lisa...

Bob Braden
  *> 
  *> 
  *> _______________________________________________
  *> Ietf mailing list
  *> [email-masked]
  *> https://www1.ietf.org/mailman/listinfo/ietf
  *> 

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Lars-Erik Jonsson \(LU/EAB\)" <[email-masked]>
Date: Fri, 13 Jan 2006 00:25:06 +0100

John, Stewart and others,

I believe some might have taken my previous note more
personally than intended, as well as John's. As also
made clear by John below, we both looked at this with
a significantly longer time-perspective than just the
last weeks or months, as these issues have been brought
up many times before. I am sorry if someone felt
insulted, that was for sure not the intent.

It is good that we now have discussions trying to figure
out actual cases when more graphics are *really* needed,
then we might actually get out of these discussions with
some new conclusions and agreements that can guide us on
the way forward.

Cheers,
/L-E

----Original Message----
From: John C Klensin [mailto:[email-masked]]
Sent: den 12 januari 2006 17:41
To: Lars-Erik Jonsson (LU/EAB); Stewart Bryant
Cc: Ash, Gerald R \\\\\(Jerry\\\\\); [email-masked]
Subject: RE: PDF, Postscript, and "normative" versions (was:
Re: Baby Steps (was RE: Alternative formats for IDs))

> --On Thursday, 12 January, 2006 12:28 +0100 "Lars-Erik Jonsson
> \\(LU/EAB\\)" <[email-masked]> wrote:
> 
>>> Before I go on, I continue to be fascinated by the observation
>>> that, each time the "we really need pictures and fancy
>>> formatting and need them frequently" argument comes up, the
>>> vast majority of those who make it most strongly are people
>>> whose contributions to the IETF -- in designer, editor, or
>>> other leadership roles-- have been fairly minimal.
>> 
>> This fascinates me too...
>> 
>> With experience, I believe most people learn that the strict
>> ASCII format used for RFC's is actually a strong feature of
>> our ways of working. When I wrote my first drafts, I also
>> believed non-ASCII graphics were needed and I made multiple
>> versions (one TXT and one PS) of each draft, but I do not
>> waste my time on that anymore since I have learned that I
>> can manage very well without non-ASCII graphics.
> 
> While I agree with you, I should stress that the authors of the
> current proposal have been much more in touch with IETF work and
> much more active than many of their predecessors.  We also owe
> them thanks for actually preparing a proposal in I-D form rather
> than simply complaining about our antiquated methods on the
> mailing list.  Most of the point I was trying to make was
> precisely the one you make, more appropriately, above:
> increasing experience within the IETF and with our style of
> developing and working on documents (not just publishing them)
> tends to cause both patience and respect for the ASCII graphics
> and formats to rise.  Experience from other standards bodies or
> similar entities that work in different ways may or may not be a good
> basis for inference. 
> 
> best,
>    john