Subject: RE: ABNF Re: Troubles with UTF-8

From: Misha Wolf <[email-masked]>
Date: Thu, 05 Jan 2006 21:53:34 +0000

See:
   2.2.  ABNF for IRI References and IRIs
in:
   http://www.ietf.org/rfc/rfc3987.txt 

Misha

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Tom.Petch
Sent: 05 January 2006 20:15
To: James Seng
Cc: ietf
Subject: ABNF Re: Troubles with UTF-8

You say that a Unicode code point can be represented by %xABCD but that
is not
spelt out in ABNF [RFC4234].  And when it refers to 'one printable
character' as
'%x20-7E' I get the impressions that coded character sets like Unicode,
with
more than 256 code points, do not fall within its remit.  I have yet to
see any
use of this in an I-D or RFC. I did post a question about this to this
list on
24th December and the lack of response reinforces my view that this is
uncharted
territory.

Tom Petch

To find out more about Reuters visit www.about.reuters.com

Any views expressed in this message are those of the individual sender, except where the sender specifically states them to be the views of Reuters Ltd.

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Tom Petch" <[email-masked]>
Date: Fri, 6 Jan 2006 15:42:11 +0100

----- Original Message -----
From: "Misha Wolf" <[email-masked]>
To: "Tom.Petch" <[email-masked]>
Cc: "ietf" <[email-masked]>
Sent: Thursday, January 05, 2006 10:53 PM
Subject: RE: ABNF Re: Troubles with UTF-8

>    http://www.ietf.org/rfc/rfc3987.txt=20
>
> Misha
>
Misha

Yes, spot on, thanks for that; I had read the IRI RFC and forgotten it.  There
is a (Standards Track) precedent for specifying UCS in ABNF.

Tom Petch