Subject: RE: Engineering our way out of a brown paper bag [Re: Consensus b ased on reading tea leaves]

From: "Gray, Eric" <[email-masked]>
Date: Thu, 5 Jan 2006 15:04:16 -0500

Stewart,
 
    Of course it is.  I think virtually everyone would like to live in 
a perfect world and most of us recognize that this is not it.
 
    Therefore, it is clear that - whatever we might say in any particular
argument - we all want things to get better.  Consequently, proposals 
to change "what is" will always be a recurring event.
 
    The question we really have to ask - as dissected by Brian in some
detail - is whether or not a specific proposal is enough "better" than 
what we have already (assuming that what we have already is both under-
stood and used appropriately) to overcome the "steady-state friction" 
typically used to prevent change for the sake of marginal gain with an 
unquantifiable risk for unanticipated side effects.
 
--
Eric

________________________________

	From: Stewart Bryant [mailto:[email-masked]] 
	Sent: Thursday, January 05, 2006 1:22 PM
	To: Eliot Lear
	Cc: Gray, Eric; Harald Tveit Alvestrand; [email-masked]
	Subject: Re: Engineering our way out of a brown paper bag [Re:
Consensus b ased on reading tea leaves]

	Eliot Lear wrote:

		I agree.  As usual we seem to be stuck in an infinite loop
on this
		mailing list with the cycle being somewhere between 6 months
and 3 years.

	The fact that we keep coming back to this topic may be a message in
itself!
	
	- Stewart

		Eliot
		
		Gray, Eric wrote:

			Brian,
			
				I think it is somewhat unfair to say that we
have
			not tried the steps you outline below.  Where we run
into 
			trouble is when different sets of people disagree as
to
			which of the steps we are currently working on.
			
				Quite frankly, I believe we can address the
second
			step (which of the requirements are not met today?)
with 
			a firm "none."
			
				This is - IMO - the basis for the apparent
stodgy
			resistance to change.
			
			--
			Eric 
			
			--> -----Original Message-----
			--> From: [email-masked]
[mailto:[email-masked]] 
			--> On Behalf Of Brian E Carpenter
			--> Sent: Thursday, January 05, 2006 7:36 AM
			--> To: Harald Tveit Alvestrand
			--> Cc: [email-masked]
			--> Subject: Engineering our way out of a brown
paper bag [Re: 
			--> Consensus based on reading tea leaves]
			--> 
			--> Harald Tveit Alvestrand wrote:
			--> > 
			--> > 
			--> > --On mandag, januar 02, 2006 18:10:15 +0200
Yaakov Stein 
			--> > <[email-masked]> <mailto:[email-masked]>
wrote:
			--> > 
			--> >> The only thing I am sure about is
			--> >> that
			--> >> consensus on this list is for keeping
everything exactly 
			--> as it is.
			--> > 
			--> > 
			--> > I'm pretty sure there's no such consensus.
			--> > 
			--> > I do, however, see a rather strong 
			--> consensus-of-the-speakers against 
			--> > using MS-Word document format for anything
"official".
			--> 
			--> I think we need to tackle this whole issue, if
we do decide to
			--> tackle it, in a much more systematic way.
			--> 
			--> - what are our functional requirements?
			--> - which of them are not met today?
			--> - what are the possible solutions, and what is
their practical
			-->    and operational cost?
			--> - which, if any, solutions should we adopt, on
what timescale?
			--> 
			--> I believe that if we took a systematic approach
like that, the issue
			--> of how we determine consensus would be broken
into enough small
			--> steps that it really wouldn't be an issue.
			--> 
			-->      Brian
			--> 
			--> 
			--> _______________________________________________
			--> Ietf mailing list
			--> [email-masked]
			--> https://www1.ietf.org/mailman/listinfo/ietf
			--> 
			
			_______________________________________________
			Ietf mailing list
			[email-masked]
			https://www1.ietf.org/mailman/listinfo/ietf

		_______________________________________________
		Ietf mailing list
		[email-masked]
		https://www1.ietf.org/mailman/listinfo/ietf

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Gray, Eric" <[email-masked]>
Date: Thu, 5 Jan 2006 15:17:57 -0500

Stewart,

	I didn't want to go through all the RFCs to find a specific 
example, but I distinctly recall seeing an RFC at one point that 
had "figures" which contained only the text "see associated PS
version".  However, I know I can't expect anyone to take my word
for it.

	However, there was an easy way to get around that.  I simply 
ftp'd all 48 of the RFCs that are available in PS format.  I am
still somewhat at a loss to understand why there are none in PDF,
but the observation that other formats may be used obviously still
stands.

	The very first RFC available in PS was RFC 1119.  Surprisingly 
enough, the entire contents of the ASCII version is as follows:

'RFC-1119 "Network Time Protocol (Version 2) Specification and

Implementation" is available only in PostScript form in the file

RFC1119.PS'

	So, what exactly are we arguing about?  :-)

--
Eric

--> -----Original Message-----
--> From: Stewart Bryant [mailto:[email-masked]] 
--> Sent: Thursday, January 05, 2006 1:19 PM
--> To: Gray, Eric
--> Cc: 'Brian E Carpenter'; Harald Tveit Alvestrand; [email-masked]
--> Subject: Re: Engineering our way out of a brown paper bag 
--> [Re: Consensus b ased on reading tea leaves]
--> 
--> Gray, Eric wrote:
--> 
--> >Brian,
--> >
--> >	I think it is somewhat unfair to say that we have
--> >not tried the steps you outline below.  Where we run into 
--> >trouble is when different sets of people disagree as to
--> >which of the steps we are currently working on.
--> >
--> >	Quite frankly, I believe we can address the second
--> >step (which of the requirements are not met today?) with 
--> >a firm "none."
--> >  
--> >
--> 
--> That is not true, we don't address the need to include diagrams.
--> 
--> - Stewart.
--> 
--> >	This is - IMO - the basis for the apparent stodgy
--> >resistance to change.
--> >
--> >--
--> >Eric 
--> >
--> >--> -----Original Message-----
--> >--> From: [email-masked] [mailto:[email-masked]] 
--> >--> On Behalf Of Brian E Carpenter
--> >--> Sent: Thursday, January 05, 2006 7:36 AM
--> >--> To: Harald Tveit Alvestrand
--> >--> Cc: [email-masked]
--> >--> Subject: Engineering our way out of a brown paper bag [Re: 
--> >--> Consensus based on reading tea leaves]
--> >--> 
--> >--> Harald Tveit Alvestrand wrote:
--> >--> > 
--> >--> > 
--> >--> > --On mandag, januar 02, 2006 18:10:15 +0200 Yaakov Stein 
--> >--> > <[email-masked]> wrote:
--> >--> > 
--> >--> >> The only thing I am sure about is
--> >--> >> that
--> >--> >> consensus on this list is for keeping everything exactly 
--> >--> as it is.
--> >--> > 
--> >--> > 
--> >--> > I'm pretty sure there's no such consensus.
--> >--> > 
--> >--> > I do, however, see a rather strong 
--> >--> consensus-of-the-speakers against 
--> >--> > using MS-Word document format for anything "official".
--> >--> 
--> >--> I think we need to tackle this whole issue, if we do decide to
--> >--> tackle it, in a much more systematic way.
--> >--> 
--> >--> - what are our functional requirements?
--> >--> - which of them are not met today?
--> >--> - what are the possible solutions, and what is their practical
--> >-->    and operational cost?
--> >--> - which, if any, solutions should we adopt, on what timescale?
--> >--> 
--> >--> I believe that if we took a systematic approach like 
--> that, the issue
--> >--> of how we determine consensus would be broken into enough small
--> >--> steps that it really wouldn't be an issue.
--> >--> 
--> >-->      Brian
--> >--> 
--> >--> 
--> >--> _______________________________________________
--> >--> Ietf mailing list
--> >--> [email-masked]
--> >--> https://www1.ietf.org/mailman/listinfo/ietf
--> >--> 
--> >
--> >_______________________________________________
--> >Ietf mailing list
--> >[email-masked]
--> >https://www1.ietf.org/mailman/listinfo/ietf
--> >
--> >
--> >  
--> >
-->