Subject: RE: Baby Steps (was RE: Alternative formats for IDs)

From: "Gray, Eric" <[email-masked]>
Date: Thu, 5 Jan 2006 12:41:54 -0500

Jerry,

	And this is a déjà vu over and over again as well.

	We could - in theory - allow draft versions in any
format an author chooses.  It would make quite a mess of
the draft repository and - eventually - the RFC library.

	But we need to agree on one or more versions that 
can be (more or less) viewed by anyone, if we expect that
everyone will actually read and use them.

	I believe the current practice allows for multiple
formats, but requires that at least one is in ASCII text.
And, in cases where the document is expected to be of an
authoritative nature, the "authoritative version" is the
one in the common (ASCII text) format.

	If that were acceptable to everyone, we could stop
there, rather than taking the next "baby step" off the 
top stair.  :-)

	However, there are a number of people who feel that
complex figures are required to understand authoritative
text in at least some cases - and this is a good argument
for making a version that contains these complex figures
authoritative.

	At this point, all agreement breaks down.  The only
way to go forward (assuming that change is part of the
definition of "going forward") is through arbitration.  I
am certain that (déjà vu, yet again) arbitration has been 
tried again and again...

--
Eric 

--> -----Original Message-----
--> From: [email-masked] [mailto:[email-masked]] 
--> On Behalf Of Ash, Gerald R (Jerry)
--> Sent: Thursday, January 05, 2006 9:26 AM
--> To: Yaakov Stein; [email-masked]
--> Cc: Ash, Gerald R (Jerry)
--> Subject: Baby Steps (was RE: Alternative formats for IDs)
--> 
--> Happy New Year to all!
--> 
--> Many thanks to Yaakov for his excellent handling of the 
--> list discussion.  I'm not very surprised with the way it 
--> has gone.  Déjà vu all over again :-)
--> 
--> The challenge is to focus the discussion to try to reach 
--> consensus on moving forward with a process change, i.e., we 
--> need to take baby steps to make progress.
--> 
--> I'd suggest we try to reach consensus first on the following:
--> Alternative format(s) for IDs, in addition to ASCII text, 
--> should be allowed.  
--> 
--> One requirement/motivation for this change (as set forth in 
--> the ID) is to be able to include drawings and diagrams with 
--> something much more flexible than ASCII art.
--> 
--> Based on the prior discussion of 'ASCII art', and the 
--> current discussion, I see few people arguing that ASCII 
--> text is all we need and that no other formats should ever 
--> be allowed.
--> 
--> Let's set aside for now which format(s), and take that as a 
--> later step if we can take this first step.
--> 
--> Thanks,
--> Regards,
--> Jerry 
--> 
--> ________________________________
--> 
--> From: [email-masked] [mailto:[email-masked]] 
--> On Behalf Of Yaakov Stein
--> Sent: Sunday, January 01, 2006 12:37 AM
--> To: [email-masked]
--> Subject: Alternative formats for IDs
--> 
--> Happy new year to everyone.
-->  
--> I would like to call your attention to a new ID
--> http://www.ietf.org/internet-drafts/draft-ash-alt-formats-00.txt.
-->  
--> This ID is the result of discussions here on the general list,
--> and proposes the use of formats other than plain ASCII
--> for IDs and RFCs. In particular, it proposes the allowance
--> of diagrams other than "ASCII-art" as normative.
-->  
--> The authors felt that further discussion on the list would 
--> not be productive, 
--> but that the writing of an ID might force more serious 
--> consideration.
--> We furthermore suggest that this ID be advanced as a BCP
--> under the process for process change.
-->  
--> Y(J)S
--> 
--> _______________________________________________
--> Ietf mailing list
--> [email-masked]
--> https://www1.ietf.org/mailman/listinfo/ietf
--> 

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Bob Braden <[email-masked]>
Date: Fri, 6 Jan 2006 10:06:31 -0800 (PST)

*> >  
  *> >     I just took a quick peek at the RFCs and there does not appear 
  *> > to be a single example of a version that is not in text format.  I 
  *> > don't know if that is because they are not stored in the same place, 
  *> > or they are not carried forward as part of the publishing process.
  *> 

You must not be looking at the official RFC repository maintained by
the RFC Editor.  For Unix fans, looking at the ~in-notes directory:

31% ls -al rfc*.ps|wc
      55     440    3127
32% ls -al rfc*.pdf|wc
      54     432    3124

That is, there are 55 Postscript RFCs and 54 PDF RFCs (they don't
exactly match because some early Postscript files could not be
converted to PDF).

Bob Braden