Subject: RE: how to declare consensus when someone ignores consensus

From: "Gray, Eric" <[email-masked]>
Date: Mon, 23 Jan 2006 13:55:17 -0500

Ned,

	It is certainly fair to say that implementors do participate
in mailing list discussions, and that their participation is very
valuable.  However, many times the number of participants that are
"active" (read - vocal) are those that "lurk" and it is my opinion
- supported by observation of, and discussion with, implementors at 
a number of different companies - that the proportion of lurkers 
that are implementors is somewhat higher than the proportion of 
active participants that are also implementors.  I am also of the
opinion that for each participant (either lurker or active), there
are many implementors that participate "vicariously" through those
others in their organization who are more disposed to participate.

	The number of implementors that do not - therefore - actively
particpate in IETF working groups is many times the number that do
- and this would clearly look to many people (especially to an out-
sider) as if implementors are too busy implementing to participate 
in mailing list discussions.

--
Eric

--> -----Original Message-----
--> From: [email-masked] [mailto:[email-masked]] 
--> On Behalf Of Ned Freed
--> Sent: Monday, January 23, 2006 9:41 AM
--> To: Anthony G Atkielski
--> Cc: [email-masked]
--> Subject: Re: how to declare consensus when someone ignores consensus
--> 
--> > Robert Sayre writes:
--> 
--> > > I suspect the IESG will find that the folks actually 
--> trying to get
--> > > work done in the presence of JFC's emails all feel the 
--> same way. Most
--> > > of the objections seem to be coming from people concerned with
--> > > designing the perfect bureaucratic process. In any WG, there are
--> > > implementers whose support is valuable. The rest of the 
--> participants
--> > > are valuable when they fix bugs. JFC doesn't seem to 
--> fix many bugs,
--> > > and drives implementers away in droves, from what I can see.
--> 
--> > Which implementers are those?
--> 
--> > Implementers don't spend their time jabbering on 
--> discussion groups;
--> > they are too busy implementing.
--> 
--> Gee, it's nice to know I don't exist - that will save me 
--> tons of time...
--> 
--> As it happens I'm actively involved in the implementation 
--> of almost all of the
--> protocol specifications I work on. I typically write the 
--> code myself for SMTP
--> and sieve  stuff, IMAP stuff is usually done by other 
--> people on my team. And
--> this code usually ends up in commercial products used at 
--> lots of sites to
--> support many millions of users - it is hardly an academic exercise.
--> 
--> I know lots of other IETF participants who are involved in 
--> specification
--> implementation. Quite a few of them write the code 
--> themselves. Some work on
--> open source, others on propietary implementations, and 
--> there are even some that
--> appear to do it just to make sure things really are 
--> implementable. In fact
--> there are entire WGs (e.g., sieve) where almost all of the 
--> active participants
--> appear to be implementors.
--> 
--> > Analyze, specific, code, test,
--> > release.  No need for chewing the fat on a mailing list in that
--> > process.
--> 
--> How very wrong you are. This sort of interaction is HUGELY 
--> valuable to
--> implementors.
--> 
--> > And there are only so many hours in a day, so one can spend
--> > them doing things or spend them talking about doing 
--> things, but it's
--> > hard to manage both.
--> 
--> This, at least, is true. But "hard to manage" != 
--> "imposssible to manage".
--> 
--> > > It has been suggested that I be placed under RFC 3683 
--> sanctions in the
--> > > past, though I suppose the offending messages have 
--> always been in
--> > > response to misconduct (not a justification). I don't 
--> think the IETF
--> > > is in any danger of developing a trigger finger here.
--> 
--> > If all the time spent discussing this most useless of RFCs were
--> > dedicated to actually addressing real problems, what might be
--> > accomplished?
--> 
--> Aside from providing comic relief, exactly what does your 
--> your ridiculous
--> assertion that implmentors don't particulate in the IETF 
--> accomplish? 
--> 
--> 				Ned
--> 
--> _______________________________________________
--> Ietf mailing list
--> [email-masked]
--> https://www1.ietf.org/mailman/listinfo/ietf
--> 

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: [email-masked]
Date: Tue, 24 Jan 2006 02:23:14 +0000

-------------- Original message -------------- 
From: Elwyn Davies <[email-masked]> 

> 
> [email-masked] wrote: 
> 
> > 
> > Can you imagine if during every murder trial they had a debate on the 
> > humanity of capitol punishment? 
> > 
> As a non-US citizen, I am a little hazy about some details of the US 
> legal system. Do I assume that this punishment requires the malefactor 
> to sit through a set period of congressional filibusters? 
> 
> I look forwards to a Supreme Court ruling outlawing it as a cruel and 
> unusual punishment. 
> 
yeah I couldnt agree more.  Capitol punishment is barbaric and cruel and the action of vindictive people.  Odd though that you assumed I was saying that the use of capitol punishment needed to be defended instead of that the prevention of it needed to be ensured.  Either way capitol punishment was an analogy and whatever country you hail from I'm sure my point applies the same.  My point, if you are interested, was that if the penalty for a crime had to be redecided during every trial then trials would take forever and choke an already bottlenecked system.  If you can see the parralel to our current situation where once again we debate the breadth and extent of PR-Action policy while we're in the middle of trying to apply it.  It's half-assed and juvenile and disorderly to the point of embarrasment.  The mature voices are few and far between so we're left with a childish melee that would lose us the respect of any grown-up professional who saw it.  It's become a romper room !
 and it's an embarrasment.

---

From: [email-masked] (Noel Chiappa)
Date: Mon, 23 Jan 2006 22:19:31 -0500 (EST)

> From: [email-masked]

    >>> a debate on the humanity of capitol punishment?

    >> Do I assume that this punishment requires the malefactor to sit
    >> through a set period of congressional filibusters?

    > Capitol punishment is barbaric and cruel and the action of vindictive
    > people.

Ah, I suspect that Elwyn was gently pulling your leg about your inability to
spell "capital" (i.e. the death penalty) - "capitol" means "location of the
government" (and similar meanings, including the name of the building which
houses the US federal legislature, which is called "the Capitol") - and that
you've therefore missed the joke...

	Noel

---

From: [email-masked]
Date: Tue, 24 Jan 2006 15:55:14 +0000

-------------- Original message -------------- 
From: [email-masked] (Noel Chiappa) 
> government" 
Ahh haaa....damn word...it'll pay for that...;)
Now imagine if you looked up the word Capital in the dictionary and it read like this:

Capital - Although not exhaustive, examples of the meaning of the word Capital include:  Wealth in the form of money or property; Human resources considered in terms of their contributions to an economy; a city that is the center of a specific activity or industry;  etc.

Maybe some of our inaction comes from having policies that are a little too open-ended.  I don't like being locked into rules but maybe there are cases where we can't be so open ended  (RISC vs. CISC?).  Maybe if we made our operational policies specific and all-inclusive we wouldn't have to reinterpret them every time we went to use them.  Then again maybe we want reinterpretation.

Nick