Subject: RE: Wireless at IETF

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Wed, 18 Jan 2006 10:30:31 -0800

That is solving the problem for ourselves only.

802.11 is a classic case of what happens when unfinished technology is thrown at consumers.

Think about VLSI manufacture, thirty or so production steps each with a finite chance of error. If you have a 5% error rate at each stage your overall yield drops to 20%

Computers are much more complex than VLSI manufacture, the explanations of the technology are much worse than 95% accurate.

All my hardware is allegedly capable of doing WPA or 801.X. I have not got the slightest idea what I would have to do to enable it though, or how it would work, or what the authentication process would be.

It is unfortunate that the cryptographic failures in WEP obscured the much more significant usability failures. The wireless world still does not 'get' it.

The result is that 70% of wireless access points are open and can be used by Internet criminals to achieve anonymous access.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Ed Juskevicius
> Sent: Wednesday, January 18, 2006 12:26 PM
> To: Marshall Eubanks; Harald Tveit Alvestrand
> Cc: [email-masked]
> Subject: RE: Wireless at IETF
> 
> In addition to the content suggested below, I think a few 
> words on "Why ad-hoc mode is BAD during IETF meetings" should 
> also be included.  Not everyone knows the issues caused by 
> ad-hoc mode (e.g. newbie attendees).
> 
> Regards and Happy New Year ...
> 
> Ed
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Marshall Eubanks
> Sent: Sunday, January 15, 2006 4:39 PM
> To: Harald Tveit Alvestrand
> Cc: [email-masked]
> Subject: Re: Wireless at IETF
> 
> 
> I think (and suggested to the IAOC) that there should be an 
> information sheet and / or web site for each meeting with 
> information on how to determine Ad Hoc Mode, how to turn it 
> off, etc., for all major OS choices.
> 
> Regards
> Marshall
> 
> 
> On Jan 15, 2006, at 4:10 PM, Harald Tveit Alvestrand wrote:
> 
> > Tangential:
> > At the IEEE meeting following the IETF, someone asked me "how do I 
> > turn off ad hoc mode".
> >
> > I was hard put to find an answer for Windows XP with the standard 
> > drivers (I use 2000 and a Cisco driver kit).
> >
> > Suggestion: Make instructions *with screenshots* of how to 
> turn off ad 
> > hoc mode on Windows XP available at the next IETF.
> >
> >                        Harald
> >
> >
> > --On søndag, januar 15, 2006 15:23:01 -0500 Henning Schulzrinne 
> > <[email-masked]> wrote:
> >
> >> http://www.nmrc.org/pub/present/shmoocon-2006-sn.ppt 
> describes what 
> >> seems to explain the appearance of IETF6x named 
> computer-to-computer 
> >> wireless networks at IETF meetings. Apparently, there is a 
> feature  
> >> that
> >> has systems automatically advertise the last AP SSID after   
> >> (involuntary)
> >> disconnection. The slides are skimpy on details, but  
> provide a bit 
> >> more background than the usual "turn of ad-hoc mode"  
> exhortations at 
> >> IETF meetings.
> >>
> >> Henning
> >>
> >> _______________________________________________
> >> Ietf mailing list
> >> [email-masked]
> >> https://www1.ietf.org/mailman/listinfo/ietf
> >>
> >
> >
> >
> >
> >
> > _______________________________________________
> > Ietf mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ietf
> 
> 
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ietf
> 
> 
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ietf
> 
> 

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Ted Faber <[email-masked]>
Date: Wed, 18 Jan 2006 10:57:00 -0800

On Wed, Jan 18, 2006 at 10:30:31AM -0800, Hallam-Baker, Phillip wrote:
> The result is that 70% of wireless access points are open and can be
> used by Internet criminals to achieve anonymous access.

Loaded statement?  Check.
Precise statement? Check.
Supported statement? Hmmmm.....

-- 
Ted Faber
http://www.isi.edu/~faber           PGP: http://www.isi.edu/~faber/pubkeys.asc
Unexpected attachment on this mail? See http://www.isi.edu/~faber/FAQ.html#SIG
_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Steven M. Bellovin" <[email-masked]>
Date: Wed, 18 Jan 2006 14:23:49 -0500

>Supported statement? Hmmmm.....

I'm not sure which part your claiming is unsupported; my own informal 
measurements agree with the 70% number.  I'm not at all convinced that 
"Internet criminals" use such access points as a major means of access, 
though.

However, Phillip's larger point -- that our security mechanisms and 
products have lousy user interfaces -- is absolutely correct.  It's a 
major issue.

		--Steven M. Bellovin, http://www.cs.columbia.edu/~smb

---

From: Ted Faber <[email-masked]>
Date: Wed, 18 Jan 2006 11:50:09 -0800

> "Internet criminals" use such access points as a major means of access, 

Well, none of it's supported.  Your statement above about informal
measurements is support for your statement of 70% and indirectly of his.

"70% are open," meaning 70% of wireless (access points|networks) have no
admission control at the link layer seems plausible, but there are lots
of things that seem plausible to me that I'm wrong about later.  Having
a number and not even saying "Bellovin's measurements indicate" always
tweaks my interest.

Going from an open access point to anonymous criminal access seems much
more implausible to me.  There are all sorts of hurdles one could put up
between "no link level protection" and "anonymous criminal access."  But
again, I'm wrong all the time and a citation for that much more damning
statement would be very welcome.  Without one I feel like I'm watching
local news.

The combination of a very provacative statelment "anonymous criminals
access" and precise number makes me uneasy.  After all <joke>90% of all
statictics are made up</joke>.

"An awful lot of access points can be used to anonymously get on the
Internet for criminal purposes" doesn't concern me as much.  But if you
found a number somewhere, let me know where, too.  A real study is
valuable information; an uncited, incorrect (and I don't know it's
incorrect) number is hard to kill.

> products have lousy user interfaces -- is absolutely correct.  It's a 

I absolutely agree.

---

From: "Dassa" <[email-masked]>
Date: Thu, 19 Jan 2006 07:35:19 +1100

|> -----Original Message-----
|> From: [email-masked] [mailto:[email-masked]] 
|> On Behalf Of Ted Faber
|> Sent: Thursday, January 19, 2006 5:57 AM
|> To: [email-masked]
|> Subject: Re: Wireless at IETF
|> 
|> On Wed, Jan 18, 2006 at 10:30:31AM -0800, Hallam-Baker, 
|> Phillip wrote:
|> > The result is that 70% of wireless access points are open and can be 
|> > used by Internet criminals to achieve anonymous access.
|> 
|> Loaded statement?  Check.
|> Precise statement? Check.
|> Supported statement? Hmmmm.....

I don't see the 70% of access points being open actually.  My own figures
indicate less than 20% within the local area, information from capital cities
tends to suggest a slightly higher figure but certainly not that high.  But
then, how many wired networks have link layer access controls?  I don't see
very many of those and implementing it is extremely difficult unless you have
everything set up exactly as the hardware has been designed for.  For example
trying to use password/password combinations instead of token/password has
proven problematic in one practical case I'm aware of for activating port
locking.  It amuses me just how easy it is to walk into a business and plug a
system in with full access to the network.

Most people/businesses do not appear to have security as a high priority.

Darryl (Dassa) Lynch

---

From: Joe Abley <[email-masked]>
Date: Wed, 18 Jan 2006 16:54:10 -0500

On 18-Jan-2006, at 15:35, Dassa wrote:

> tends to suggest a slightly higher figure but certainly not that high.

It depends a lot on the nature of local internet services, I think.

Where I live, flate-rate 3-5Mbit/s cable/DSL internet service is  
cheaper than buying a dedicated phone line to use with a modem at  
~56k, and consumer-grade 802.11g access points can be had for a  
couple of dollars after mail-in rebates.

 From informal wandering around my residential neighbourhood, I would  
say that >98% of access points reachable from the street have no  
access control.

Since there are no scary bills that arrive from ISPs at the end of  
the month if someone outside has been red-lining the DSL, I suspect  
that people have little incentive to keep other people out.

I also suspect that since DSL and cable internet service is so cheap  
here, for most people it's far more sensible to pay for their own  
rather than to stand out on the street in the snow with a laptop and  
a pringles can.

I doubt that it's possible to reverse the trend of widespread,  
unsecured network access. Any manufacturer of access points who turns  
on security measures by default with a random, device-specific  
initial password supplied in the documentation is (a) going to have  
higher production costs, and (b) much higher support costs than  
competitors who ship everything open and ready to run with no  
configuration.

Maybe it doesn't matter. I struggle with the idea that there might be  
roving gangs of organised criminals stealing internet access from  
wifi-equipped black vans. There are surely much cheaper, less labour- 
intensive ways to gain illicit access to the network than that.

(It has certainly been very handy for me, more than once, to be able  
to use my neighbour's cable modem from my living room via 802.11  
while my DSL was down.)

If there's a lesson to be learned here, maybe it's this: if you  
aspire to see your protocol or service reach widespread, consumer- 
level acceptance, and it is desirable that the service or protocol be  
deployed securely, remember that if the security is optional nobody  
will turn it on.

Joe