Subject: RE: Alternative formats for IDs

From: "Lars-Erik Jonsson \(LU/EAB\)" <[email-masked]>
Date: Thu, 5 Jan 2006 09:26:12 +0100

>> If you do not know how to do that with Word, there is help to get.
> 
> Yes, in RFC 3285.
> 
> 3285 Using Microsoft Word to create Internet Drafts and RFCs. M.
>      Gahrns, T. Hain. May 2002. (Format: TXT=34556 bytes) (Status:   
> INFORMATIONAL) 
> 
> [YJS] Yes of course we all have used that.
> 
> However, unfortunately there are problems with that route
> and no-one is supporting it (as XML2RFC is supported).

True, this had not been a problem if the output from Word had
been consistent. Anyway, Joe Touch has been updating these tools
and you can find them at:
http://www.isi.edu/touch/tools/

> For example, when printing directly from Word (rather
> than first producing the ASCII and then printing)
> the margins are all wrong.

True, printing directly is a missing feature of the tools
provided by RFC 3285. Joe's version fixes this, so you should be
happy with his version also for that reason.

> Also, certain combinations of characters I use in ASCII art
> cause (for some unknown and undocumented reason)
> strange unprintable characters to appear in the ASCII version.

Probably this is because you have used characters not part of
7-bit ASCII. It is a good idea to always turn off the auto-correct
features of Word, otherwise you will probably get strange characters.
 
Rgds,
/L-E

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Ole Jacobsen <[email-masked]>
Date: Thu, 5 Jan 2006 02:06:52 -0800 (PST)

As far as I can tell, Microsoft has no idea what ASCII means. You would
expect that "Save As... Text Only" would produce clean ASCII from a
"pretty" Word file, but it does not. Instead, you get a file which
contains various 8-bit encodings of common characters such as curly
quotation marks, en- and em-dashes, bullets and so on, in spite of the
fact that there are perfectly good, and commonly-used ASCII conventions
for all of this stuff (' " * -- --- ...). I can't tell you how much time I
spend "fixing" problems caused by this kind of stupidity. Auto-correct or
not, why can't Word have a simple "ASCII-fy" feature???

Ole

PS. Speaking about Word 11.2 for the Mac, your mileage may vary.

Ole J. Jacobsen 
Editor and Publisher,  The Internet Protocol Journal
Cisco Systems
Tel: +1 408-527-8972   GSM: +1 415-370-4628
E-mail: [email-masked]  URL: http://www.cisco.com/ipj

On Thu, 5 Jan 2006, Lars-Erik Jonsson (LU/EAB) wrote:

[ ... ]