Subject: RE: Alternative formats for IDs

From: "Yaakov Stein" <[email-masked]>
Date: Tue, 3 Jan 2006 08:27:43 +0200

The IETF has thrived for many years using a document format which is
easy to produce, view, and edit on virtually any platform, and easy to
distribute via virtually any means.  I'm not saying there is no room for
change, but any new format needs to do reasonably well with respect to
both of these properties -- only having one is _not_ sufficient.

[YJS] That is the whole problem. ASCII is NOT easy to produce,
it is close to impossible to produce with others,
and it is mind-breakingly frustrating to include even the
simplest figure. Until the tool team and others came up
with an on-line PDF converter it was also extremely
difficult and time-consuming to print. 

Alternatively, it can be created using nroff,
(nroff: noun an obscure outdated mark-up language)
or by XML which was never meant to be a typesetting
language and requires installing a medley of tools
that don't work well together and also does not support
even simple graphics. Neither of these has any support 
for cooperative work.

You must be using some new meaning for the word "easy"
that I haven't come across yet.

Y(J)S

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Russ Allbery <[email-masked]>
Date: Mon, 02 Jan 2006 22:56:29 -0800

Yaakov Stein <[email-masked]> writes:

> Alternatively, it can be created using nroff, (nroff: noun an obscure
> outdated mark-up language) or by XML which was never meant to be a
> typesetting language and requires installing a medley of tools that
> don't work well together and also does not support even simple
> graphics.

While I was installing xml2rfc and Tcl to convert XML into text and to
HTML, fully supporting accompanying graphics, I failed to notice all of
these drawbacks that you seem to believe exist.  In fact, I believe my
entire interaction with this medley of tools with their extensive problems
consisted of:

    aptitude install xml2rfc
    xml2rfc protocol.xml protocol.txt
    xml2rfc protocol.xml protocol.html

Somehow this failed to frighten me off.

> Neither of these has any support for cooperative work.

There is dedicated software for this purpose that works quite well.  Your
inability to install it on your work computers due to local policies is of
about as much interest to me as my inability to install Word because I
don't use a platform to which it has been ported probably is to you.

-- 
Russ Allbery ([email-masked])             <http://www.eyrie.org/~eagle/>

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Tue, 3 Jan 2006 16:39:06 +0100

On Tue, Jan 03, 2006 at 08:27:43AM +0200,
 Yaakov Stein <[email-masked]> wrote 

> Neither of these has any support for cooperative work.

Support is not in the format (what we discuss here) but in the
tools. There are a lot of tools for cooperative work with text /
ASCII, text / UTF-8 or XML files (CVS, xmldiff, diff, Subversion,
darcs, Trac, etc).