Subject: RE: Baby Steps (was RE: Alternative formats for IDs)

From: "Gray, Eric" <[email-masked]>
Date: Thu, 5 Jan 2006 13:17:45 -0500

Stewart,
 
    You bring up a good point.  I have been assuming that - since 
IDs can be submitted in multiple formats - that the additional
formats would also become part of the RFC library on publication.
 
    I just took a quick peek at the RFCs and there does not appear 
to be a single example of a version that is not in text format.  I 
don't know if that is because they are not stored in the same place, 
or they are not carried forward as part of the publishing process.
 
    Frankly, if the process of getting an ID published as an RFC 
seems to require (or at least encourage) use of at least one 
additional format, then the additional format(s) should also be 
incorporated in the RFC library.  In other words, if there was a 
non-ASCII version of the ID, there should also be a non-ASCII 
version of the RFC.
 
    For some reason I thought this at least used to be the case.  
If it is not, then that should be fixed - for exactly the reasons 
you point out.
 
    Irrespective of questions about the "legitimacy" of using a 
non-ASCII version as normative or authoritative, the fact that a 
non-ASCII version might contain useful explanatory material is 
more than sufficient cause to keep it.
 
--
Eric

________________________________

	From: [email-masked] [mailto:[email-masked]] On Behalf
Of Stewart Bryant
	Sent: Thursday, January 05, 2006 12:01 PM
	To: John C Klensin
	Cc: Ash, Gerald R \(Jerry\); [email-masked]
	Subject: Re: Baby Steps (was RE: Alternative formats for IDs)

	John C Klensin wrote:

		--On Thursday, 05 January, 2006 08:25 -0600 "Ash, Gerald R
		\\(Jerry\\)" <[email-masked]> <mailto:[email-masked]>  wrote:

			Happy New Year to all!
			
			Many thanks to Yaakov for his excellent handling of
the list
			discussion.  I'm not very surprised with the way it
has gone.
			Déjà vu all over again :-)
			
			The challenge is to focus the discussion to try to
reach
			consensus on moving forward with a process change,
i.e., we
			need to take baby steps to make progress.
			
			I'd suggest we try to reach consensus first on the
following:
			Alternative format(s) for IDs, in addition to ASCII
text,
			should be allowed.  
			
			One requirement/motivation for this change (as set
forth in
			the ID) is to be able to include drawings and
diagrams with
			something much more flexible than ASCII art.
			
			Based on the prior discussion of 'ASCII art', and
the current
			discussion, I see few people arguing that ASCII text
is all we
			need and that no other formats should ever be
allowed.

		Even those of us who are strongly supportive of ASCII as our
		primary base format and those who believe that the effort
needed
		to simplify illustrations and diagrams sufficiently that
they
		can be accurately represented in ASCII artwork is helpful in
		forcing clarity are reluctant to say "never".

			Let's set aside for now which format(s), and take
that as a
			later step if we can take this first step.

		Jerry, one of the nice things about baby steps is that you
		sometimes discover that the baby learned to take the steps
		without any instruction.
		
		Unless the IESG has changed the rules while I was not
looking,
		it has been permitted to post I-Ds in PDF in addition to
ASCII
		for some years. 

	BUT the pdf is not allowed to be normative. Changing that rule alone
would 
	be sufficient to allow modern graphics to be called up in normative
texts.

		I find it interesting that it has not been taken
		advantage of more often (and, for the record, I'm one of
those
		who has taken advantage of it).  When it has been done for
		artwork purposes, the artwork in the ASCII version has
sometimes
		been pretty rudimentary.   In practice, whether it is "good
		enough" has been made on a case by case basis by WG Chairs
and
		WGs or, for non-WG documents, by whether or not the relevant
		people are willing to read and consider those documents.

	Please clarify this. Are you saying that if the WG/WGchairs/ADs
agree that the non-ASCII
	version should be the normative version (because they want the
better artwork), then  that's
	OK? I thought  I asked this a long time ago and was told no.

		Similarly, when PDF has been posted in order to exhibit
		non-ASCII characters, it has proven helpful to have Unicode
		character offsets (i.e., U+nnnn representations)  in both
the
		ASCII and PDF forms to ensure complete precision even though
the
		character-glyphs themselves appear only in the PDF form.  
		
		So, consider the first baby step to have been taken: nothing
		prevents you from posting an I-D in both ASCII and PDF
today,
		and the relevant sub-community will sort out, on a case by
case
		basis, whether the ASCII is good enough.   

	...and if it's not the pdf version of the text including graphics
will become the RFC?
	
	- Stewart

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: John C Klensin <[email-masked]>
Date: Thu, 05 Jan 2006 13:50:39 -0500

--On Thursday, 05 January, 2006 13:17 -0500 "Gray, Eric"
<[email-masked]> wrote:

> Stewart,
>  
>     You bring up a good point.  I have been assuming that -
> since  IDs can be submitted in multiple formats - that the
> additional formats would also become part of the RFC library
> on publication.  
>     I just took a quick peek at the RFCs and there does not
> appear  to be a single example of a version that is not in
> text format.  I  don't know if that is because they are not
> stored in the same place,  or they are not carried forward as
> part of the publishing process. 
>...

The number is not huge, but some RFCs have, in fact, been
published formally in PS and/or PDF as well as in ASCII (and I'm
on the hook for another one... something else in a too-long
queue).   See RFC 3550 and 3551 for recent standards-track
examples and RFC 1119 for an a Full Standard example that is
legendary in some parts of the community for incomprehensibility
if one has only the ASCII text and diagrams.

     john

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 06 Jan 2006 16:40:08 +0100

> or they are not carried forward as part of the publishing process.

You must have looked in the wrong place. Where there are PS or PDF
versions, they can be found via the search page at
http://www.rfc-editor.org/cgi-bin/rfcsearch.pl

It's less clear that all mirror sites carry them.

    Brian