Subject: RE: Last Call: 'Proposed Experiment: Normative Format in Addition to ASCII Text' to Experimental RFC (draft-ash-alt-formats)

From: "Gray, Eric" <[email-masked]>
Date: Thu, 15 Jun 2006 11:52:17 -0400

Thomas,

	This is a different discussion, however, you are
right on target with that discussion - at least for IDs
in general.  Wouldn't this be subject to a DoS attack,
if applied to individual ID submissions?

--
Eric

--> -----Original Message-----
--> From: Thomas Narten [mailto:[email-masked]] 
--> Sent: Thursday, June 15, 2006 11:12 AM
--> To: Ash, Gerald R (Jerry), ALABS
--> Cc: Bob Braden; [email-masked]
--> Subject: Re: Last Call: 'Proposed Experiment: Normative 
--> Format in Addition to ASCII Text' to Experimental RFC 
--> (draft-ash-alt-formats) 
--> 
--> > It is quite reasonable to last call this draft at this 
--> point.  It has
--> > been reviewed for ~6 months.  This version posted to the list for
--> > comments more than 3 weeks ago, plenty of time for more 
--> comments, but no
--> > comments were posted to the list on this version.
--> 
--> Maybe reviewer fatigue?
--> 
--> One thing missing from this discussion (that I think would have been
--> helpful) is running all the previous comments through an issue
--> tracker, so folk could go review the history, and most important of
--> all, those who raised issue can go see if they believe their issues
--> have been dealt with appropriately. One of the most frustrating and
--> demoralizing aspects of IETF participation is spending time doing a
--> careful review, and then feeling like your comments have been blown
--> off. Trackers make it much harder for that to happen, which in my
--> experience is a very good thing for all involved.
--> 
--> Thomas
--> 
--> _______________________________________________
--> Ietf mailing list
--> [email-masked]
--> https://www1.ietf.org/mailman/listinfo/ietf
--> 

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Thu, 15 Jun 2006 11:33:27 -0700

The problem here is that the requirement to produce ASCII means that many of the advantages of the pdf format are lost.

Any diagrams must be replicated as ASCII art. Any formulas have to be replicated in TXT format.

The result is that producing a good PDF version adds hugely to the already complex process of complying with the TXT requirements.

> -----Original Message-----
> From: Joel M. Halpern [mailto:[email-masked]] 
> Sent: Thursday, June 15, 2006 1:53 PM
> To: [email-masked]
> Subject: Re: Last Call: 'Proposed Experiment: Normative 
> Format in Addition to ASCII Text' to Experimental RFC 
> (draft-ash-alt-formats)
> 
> I would also observe that there is significant evidence that 
> there is not a real problem here.
> 
> It seems to me that if there was a real problem with the 
> graphics, that folks would be publishing RFCs with PS or PDF 
> forms, even if those were not normative.
> For the thousand RFCs starting with RFC 3000, there are  4 PS 
> and 4 PDF documents.  In total, assuming that those are for 
> different documents, that is still less than 1% if those RFCs 
> published in that time period.
> 
> I know some folks are vocal that there is a problem.
> But, the evidence suggests otherwise.
> 
> In contrast, the evidence suggested for judging the 
> experiment is going to be very limited, very subjective, and 
> heavily influenced by the fact that the target are folks who 
> are presumably particularly interested in a positive outcome.
> 
> This experiment is a bad idea.
> I am sorry that this is not "constructive" input.  But 
> sometimes the right answer is "no."
> We already have provision for people to publish pretty 
> pictures when they think that is helpful.
> If lots of folks do that, and if we conclude that those PDFs 
> are more useful than the text documents, then we would have 
> something to discuss.
> 
> Sure, I hate producing ASCII art.  But then, I hate producing 
> document art in any form.  The problem is not ASCII.  It is 
> finding a good, clean, understandable, way to express ones ideas.
> 
> Yours,
> Joel M. Halpern
> 
> 
> 
>

---

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Thu, 15 Jun 2006 13:16:11 -0700

This effect may well be the result of the difficulty of getting the draft through the process.

It is painful enough dealling with the editing process without having the additional complication of having two documents. 

> From: Henrik Levkowetz [mailto:[email-masked]] 
> Sent: Thursday, June 15, 2006 3:29 PM
> To: Joel M. Halpern
> Cc: [email-masked]
> Hi,
> on 2006-06-15 19:52 Joel M. Halpern said the following:
> > I would also observe that there is significant evidence 
> that there is 
> > not a real problem here.
> > 
> > It seems to me that if there was a real problem with the graphics, 
> > that folks would be publishing RFCs with PS or PDF forms, even if 
> > those were not normative.
> > For the thousand RFCs starting with RFC 3000, there are  4 PS and 4 
> > PDF documents.  In total, assuming that those are for different 
> > documents, that is still less than 1% if those RFCs 
> published in that 
> > time period.
> > 
> Oh, *good* point.
> > In contrast, the evidence suggested for judging the experiment is 
> > going to be very limited, very subjective, and heavily 
> influenced by 
> > the fact that the target are folks who are presumably particularly 
> > interested in a positive outcome.
> > 
> > If lots of folks do that, and if we conclude that those 
> PDFs are more 
> > useful than the text documents, then we would have 
> something to discuss.
> 
> Agreed.  Thinking some more about this, the lack of 
> inter-document links seem to be a complaint that I hear much 
> more often than the lack of good graphics support.
> 
> 
> Regards,
> 
> 	Henrik
>