Subject: RE: Image attachments to ASCII RFCs (was: Re: Last Call: 'Proposed Experiment: Normative Format in Addition to ASCII Text' to Experimental RFC (draft-ash-alt-formats))

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Fri, 16 Jun 2006 14:31:51 -0700

> From: Iljitsch van Beijnum [mailto:[email-masked]] 

> When I was 16 years old, I wrote a text editor in BASIC that 
> would probably have allowed me to edit RFCs. 

I wrote a text editor in Basic for the ZxSpectrum that was published commercially when I was 15.

I guess I could use it to edit RFCs as well if I could find a ZxSpectrum that still worked to read the program off the cassette tape.

My computing needs have grown somewhat since then. 

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Peter Dambier <[email-masked]>
Date: Sat, 17 Jun 2006 00:07:51 +0200

> My computing needs have grown somewhat since then. 

You are not programming in APL, are you?

That is the only programming language I know, that does not use either ASCII or EBCDIC.

The modern, not so algorithmic languages like lisp or prolog do rely on ASCII or EBCDIC.
They cannot use wordstar or word documents. I tried it only once in old MSDOS times :)

Cheers
Peter

-- 
Peter and Karin Dambier
Cesidian Root - Radice Cesidiana
Graeffstrasse 14
D-64646 Heppenheim
+49(6252)671-788 (Telekom)
+49(179)108-3978 (O2 Genion)
+49(6252)750-308 (VoIP: sipgate.de)
mail: [email-masked]
mail: [email-masked]
http://iason.site.voila.fr/
https://sourceforge.net/projects/iason/

---

From: Jeffrey Hutzelman <[email-masked]>
Date: Sun, 18 Jun 2006 02:40:07 -0400

> That is the only programming language I know, that does not use either

Some folks at Sun have designed a language whose source format uses Unicode:

<http://research.sun.com/projects/plrg/>

---

From: Jeffrey Hutzelman <[email-masked]>
Date: Sun, 18 Jun 2006 02:51:54 -0400

On Friday, June 16, 2006 02:31:51 PM -0700 "Hallam-Baker, Phillip" 
<[email-masked]> wrote:

> I guess I could use it to edit RFCs as well if I could find a ZxSpectrum
> that still worked to read the program off the cassette tape.
>
>

... and, you've completely missed the point.

Currently, RFC's are published and distributed in a form which is so 
straightforward that a child could write software to view or produce it.

Show me a PDF viewer written by a 16-year-old in BASIC, or whatever it is 
that bored kids write software in these days.

-- Jeff