Subject: IDs first? RE: Last Call: 'Proposed Experiment: Normative Format in AdditiontoASCII Text' to Experimental RFC (draft-ash-alt-formats)

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Tue, 20 Jun 2006 13:25:36 -0700

> From: Keith Moore [mailto:[email-masked]] 

> > A standards based, future proof, non proprietary solution 
> to this problem is to adopt:
> > 
> >   * Use of MHTML as the archive packaging.
> >   * Use of XHTML 1.0 as the document encoding.
> >   * Use of a standard IETF defined style sheet.
> >   * Use of PNG encoding for all images.
> 
> I like the idea.  But it has to be compatible with software 
> that people already have.  How many browsers that people 
> actually use these days support MHTML?

It is supported in IE and Firefox and has been for about five years or so.

The format is currently defined by a Microsoft note but this can easily be made into an RFC, it is a widely supported standard extension of MIME.

The above would be a restriction on the archive. The only thing one might want to add in would be the option of adding a last segment that contains a signature over the other components. This is just ignored.

Creating one of these archives is easy, just view the HTML page and click 'save as archive'.

Another point to consider, the only sustained objection being made to this proposal is that future generations may be unable to read the documents.

This particular objection cannot be made credibly with respect to Internet Drafts which expire in 6 months in any case. Nor do I think it is reasonable to require support for people using obsolete software in this case. If someone can't install the latest version of Firefox their ability to contribute to a WG is going to be negligible in any case.

Innovating in the drafts space makes better sense than in the RFC space. I am willing to create a one off TXT version. Its having to repeatedly deal with them that is irritating.

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Keith Moore <[email-masked]>
Date: Tue, 20 Jun 2006 19:36:26 -0400

> It is supported in IE and Firefox and has been for about five years or so.

That might not be quite good enough, but it's close enough to warrant
further investigation.

> The format is currently defined by a Microsoft note but this can easily be made into an RFC, it is a widely supported standard extension of MIME.

What was wrong with RFC 2557?  How can we assume that this is a stable
format given that MS apparently felt they could change it on a whim?

> Creating one of these archives is easy, just view the HTML page and click 'save as archive'.

My copy of firefox doesn't seem to have that feature.

> This particular objection cannot be made credibly with respect to Internet Drafts which expire in 6 months in any case. Nor do I think it is reasonable to require support for people using obsolete…

Unfortunately, many IETF participants are expected by their employers
to use broken software.

As someone who has actually tried producing I-Ds in alternate formats,
I'm not sure that I agree that there's much benefit to having only I-Ds
use the new format.   People who review the document need to be able to
see something close to the version that will actually be published.  

Keith

---

From: Julian Reschke <[email-masked]>
Date: Wed, 21 Jun 2006 01:40:01 +0200

> It is supported in IE and Firefox and has been for about five years or so.

Hm. Just for the record: IE does not support XHTML. But of course we 
could use HTML 4.01 instead.

Re: MHTML: I just tried to open an MHT file created by IE in Firefox, 
and all it offered was to open it in IE. Pilot error?

 > ...

Best regards, Julian

---

From: Dave Cridland <[email-masked]>
Date: Wed, 21 Jun 2006 08:53:51 +0100

> see something close to the version that will actually be published. 

I would find it interesting if the I-Ds were at least available in 
their source format as well as their TXT format, though, especially 
if that was xml2rfc, and it's certainly a more practical zone for 
experiments about formats than the RFC series itself.

Dave.
-- 
Dave Cridland - mailto:[email-masked] - xmpp:[email-masked]
  - acap://acap.dave.cridland.net/byowner/user/dwd/bookmarks/
  - http://dave.cridland.net/
Infotrope Polymer - ACAP, IMAP, ESMTP, and Lemonade