Subject: Re: Last Call: 'A Process Experiment in Normative Reference Handling' to Experimental RFC (draft-klensin-norm-ref)

From: Eric Rosen <[email-masked]>
Date: Thu, 01 Jun 2006 10:49:43 -0400

> The IESG plans to make a decision in the next few weeks, and solicits
> final comments on this action. 

If the individual  submission is approved as an  Experimental RFC, does that
mean that  the IETF will  adopt the proposed  "experiment"?  If so,  I don't
think this  draft should be approved.   (Actually, I suspect the  fix is in,
but for the record ...) 

The proposal seems primarily intended  to deal with the following "problem".
Sometimes  there are  cases in  which a  doc is  ready to  become a  DS, but
cannot, because of the infamous "downref  rule", which states that no DS can
normatively reference a PS. 

The proposal leaves the downref rule in place, but allows it to be waived if
the  WG  is  willing  to   approve  derogatory  text  about  the  referenced
technology: 

      "A note is included in the reference text that indicates that the
      reference is to a document of a lower maturity level, that some
      caution should be used since it may be less stable than the
      document from which it is being referenced,"

Frankly,  I  think  this   wavier  procedure  is  outrageous,  and  entirely
unacceptable.  The fact  The fact that the referenced  document has not gone
through some bureaucratic process does not  mean that it is any less stable,
or that any more caution is  required in its use.  Inserting this derogatory
language about technology which may  be well-proven and widely deployed will
be extremely misleading to the industry. 

I  think that  any rule  which requires  us to  insert false  and misleading
statements in the documents should be strongly opposed. 

Even worse: 

     "The IESG may, at its discretion, specify the exact text to be used"

Great, not only is the WG  required to denigrate its own technology, but the
IESG is given free rein to insert whatever derogatory remarks they feel like
putting in. 

Of course, we'll be told not to worry, since:

      "If members of the community consider either the downward reference or
       the annotation text  to be inappropriate, those issues  can be raised
       at any time  in the document life cycle, just as  with any other text
       in the document."

Great.  Another useless thing to argue  about in the WG, and another useless
thing to argue about with the IESG.

There  are  also   other  reasons  why  I  find   this  proposed  experiment
disheartening. 

For  one  thing, it  really  misses  the point.   We  need  to simplify  our
processes, not make them more  complicated.  Either we need the downref rule
or we  don't.  If we want  to experiment, let's  experiment with eliminating
the rule entirely, not with fine tuning it.

The  real underlying  problem of  course  is the  the multi-stage  standards
process is just a relic from another  time, and makes no sense at all in the
current environment.  Experiments in fine tuning the process are nothing but
a distraction.

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: John C Klensin <[email-masked]>
Date: Thu, 01 Jun 2006 11:34:57 -0400

--On Thursday, 01 June, 2006 10:49 -0400 Eric Rosen
<[email-masked]> wrote:

> 
>> The IESG plans to make a decision in the next few weeks, and
>> solicits final comments on this action. 
> 
> If the individual  submission is approved as an  Experimental
> RFC, does that mean that  the IETF will  adopt the proposed
> "experiment"?  If so,  I don't think this  draft should be
> approved.   (Actually, I suspect the  fix is in, but for the
> record ...) 

Actually, Eric, I don't have any idea what you are talking
about.  
IETF doesn't "adopt" protocol experiments, regardless of how
they are "approved" (some unfortunate language about "process
experiments", which are really quite different,
notwithstanding).  Of course, since individual submissions (as
distinct from independent ones) are processed, and in that sense
approved, by the IESG, the IESG can presumably pay as much or at
little attention to them as they think the community finds
appropriate.  But that still has little or nothing to do with
this draft.

This draft is addressed primarily --almost exclusively-- to
publication of documents describing standards-track protocols,
not experimental or informational pieces.  
 
> The proposal seems primarily intended  to deal with the
> following "problem". Sometimes  there are  cases in  which a
> doc is  ready to  become a  DS, but cannot, because of the
> infamous "downref  rule", which states that no DS can

That is correct.

> The proposal leaves the downref rule in place, but allows it
> to be waived if the  WG  is  willing  to   approve  derogatory
> text  about  the  referenced technology: 
> 
>       "A note is included in the reference text that indicates
> that the       reference is to a document of a lower maturity
> level, that some       caution should be used since it may be
> less stable than the       document from which it is being
> referenced,"

Until and unless the definitions of maturity levels are changed,
that text is not derogatory, but a simply statement of fact.  It
carefully says "may be less stable", which is true.  Now, if it
said "...caution should be used because the referenced document
is incomplete and a piece of c**p", _that_ would be derogatory.
But no such implication is present.
 
> Frankly,  I  think  this   wavier  procedure  is  outrageous,
> and  entirely unacceptable.  The fact  The fact that the
> referenced  document has not gone through some bureaucratic
> process does not  mean that it is any less stable, or that any
> more caution is  required in its use.  Inserting this
> derogatory language about technology which may  be well-proven
> and widely deployed will be extremely misleading to the
> industry. 

If a WG agrees with you about a particular piece of technology,
they have three choices:

	(i) Do nothing, in which case their would-be Draft
	Standard will sit in queue until that well-proven and
	widely -deployed technology is, itself, advanced to
	Draft Standard (or to not try to advance their Proposed
	Standard to Draft Standard at all).
	
	(ii) Pick up the obviously well-documented definition of
	the well-proven and widely deployed technology and
	advance it to Draft Standard.
	
	(iii) Invoke the RFC 3967 procedure for downrefs, which
	is more burdensome in terms of processing than the new
	proposal, but does not involve disclaimers.  You can
	think of the RFC 3967 procedure as requiring a community
	determination that the referenced technology is stable
	enough to be referenced in a document of a given
	maturity level.

So the proposed new rule adds one option to the three that are
there already.  It is up to the WG (or individual submitter)
which one to use.   This one is intended to be much more
lightweight and quick than any of the existing options, but no
one is forcing its use.  And I assume that, if it is found too
unpleasant or derogatory, then no one will use it and it will
disappear after a year.  Personally, that wouldn't bother me one
bit -- you will recall that I have proposed and/or backed much
more radical and extensive solutions to this type of problem --
but that is a rather different discussion.

> I  think that  any rule  which requires  us to  insert false
> and misleading statements in the documents should be strongly
> opposed. 

But there is no requirement that this procedure be used at all.
If I writing a document that needed to reference a specification
that was as well-defined, mature, and stable as you posit, I'd
first try to get that specification advanced to the right
maturity level or, if there was some bar to doing so, I'd invoke
the RFC 3697 procedure.  Or I might try to build consensus for
some serious discussion and action on
draft-ietf-newtrk-promotion-00.txt, which essentially proposes
fast-tracking the advancement of such specifications on the
basis of their marketplace acceptance (and which is showing
signs of vanishing without a trace).

> Great, not only is the WG  required to denigrate its own
> technology, but the IESG is given free rein to insert whatever
> derogatory remarks they feel like putting in. 

First, this seemed appropriate for an experiment of the type
specified.  In addition, like it or not, current procedures, as
practiced, essentially give the IESG free rein to insert
whatever remarks (derogatory or otherwise) they feel like
inserting in anything.  They are prevented from doing so by some
combination of good sense and the presence of the appeals
procedure, which is exactly what the paragraph you complain
about below says...
>       "If members of the community consider either the
> downward reference or the annotation text  to be
> inappropriate, those issues  can be raised at any time
> in the document life cycle, just as  with any other text
> in the document."
> 
> Great.  Another useless thing to argue  about in the WG, and
> another useless thing to argue about with the IESG.

But the assertion you are making about a (e.g.) Proposed
Standard specification being stable, mature, well-defined,
widely-deployed, etc., is one that presumably should get some
community review, rather than simply being accepted as the
result of the divine rights of the author/editor.  And that
brings us back to the three existing choices above, which the WG
presumably needs to argue about today.   The WG's only choice
without such an argument is to not try to advance any document
that would require a downref... and that is an opportunity to
argue as well.

> There  are  also   other  reasons  why  I  find   this
> proposed  experiment disheartening. 
> 
> For  one  thing, it  really  misses  the point.   We  need  to
> simplify  our processes, not make them more  complicated.
> Either we need the downref rule or we  don't.  If we want  to
> experiment, let's  experiment with eliminating the rule
> entirely, not with fine tuning it.

I don't know how to do that and still get back if there is a
conclusion that it wasn't a good idea.  And, remember, I have
proposed more radical solutions to the underlying problem here.
It is evident at this point that they lack adequate traction
(people who care) and consensus, so adding a lightweight option
within the current framework seemed to be an idea worth
exploring.

> The  real underlying  problem of  course  is the  the
> multi-stage  standards process is just a relic from another
> time, and makes no sense at all in the current environment.
> Experiments in fine tuning the process are nothing but a
> distraction.

Well, we disagree about that.  Perhaps more important, there is
little evidence of community consensus for that position
although it certainly has several loud advocates.  I suppose one
can rationally oppose any proposal to make the current system
work better on the grounds that it should be made to work worse
in order to gain more traction for getting rid of maturity
levels.  Maybe, from that point of view, you should support this
on your theory that it will create more arguments and bog things
down further.  On the other hand...

       john

---

From: Eric Rosen <[email-masked]>
Date: Thu, 01 Jun 2006 13:28:23 -0400

> that text is not derogatory, but a simply statement of fact. 

Sorry, but however you may try to  talk your way out of it, a statement like
"that technology may be unstable" is derogatory.  

> Until and unless the definitions of maturity levels are changed, that text
> is not derogatory, but a simply statement of fact. 

I'm afraid that the facts as to whether a technology is stable are in no way
dependent on the IETF's definitions of maturity levels.  

> If a WG agrees with you about a particular piece of technology,

Well, 4: they can issue the doc as a PS obsoleting the old PS. 

> maturity level

That's  an interesting  fact about  yourself, but  personally I'd  prefer to
spend my time doing something useful.

> community review

Sure.   The WG  should not  advance a  doc  to DS  if it  really depends  on
something which  isn't stable.  The WG needs  to be aware of  the facts, and
should not be compelled to insert statements which they know to be false.  

> you should support this on your  theory that it will create more arguments
> and bog things down further. 

No,  I  don't think  there's  any  need to  do  anything  that creates  more
arguments  and bogs  things  down  further.  I  understand  that there's  no
consensus on how to avoid the iceberg,  but that doesn't mean I want to take
the time  to run experiments  on more complicated  ways to arrange  the deck
chairs.

---

From: "C. M. Heard" <[email-masked]>
Date: Fri, 2 Jun 2006 06:29:46 -0700 (PDT)

> current environment.  Experiments in fine tuning the process are nothing but

For the record, I completely agree with the above sentiments (and have so
stated on the newtrk mailing list).

Mike Heard

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 12 Jun 2006 12:20:28 +0200

> stated on the newtrk mailing list).

I'd like to ask people who *don't* agree with the above sentiments
(i.e. who support this experimental process change) to say so, before
the Last Call ends in two days. (Obviously, people who *do* agree are welcome
to say so too, but a problem with Last Calls is that it's very hard to
judge whether silence means consent.)

     Brian

---

From: John C Klensin <[email-masked]>
Date: Mon, 12 Jun 2006 07:57:48 -0400

--On Monday, 12 June, 2006 12:20 +0200 Brian E Carpenter
<[email-masked]> wrote:

>...
>> For the record, I completely agree with the above sentiments
>> (and have so stated on the newtrk mailing list).
> 

FWIW, I still think the approach in the draft is a good idea
given that...

(1) We have not been able to get consensus eliminating a
multistep standard process.   For reasons explained elsewhere, I
personally consider that eliminating that process would be a bad
idea, but that is another discussion.   The present reality is
that we don't have that consensus and that blocking incremental
improvements within it is a strange form of "see if we can make
things worse so as to build momentum for a more basic change".
I don't believe in that style of doing things.

(2) We have had repeated claims that the downref issue is a
major cause of perceived IETF slowness in getting documents out
and, especially, of getting documents to advanced maturity
level.  I think that validating (or invalidating) those claims
would be helpful as a goal in itself.  If it results in a
significant number of documents being advanced, that would be a
good thing.  If it results in few or no documents being
advanced, then we know that particular argument is not a
significant part of the picture, and that would, itself, be
useful.

     john

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 12 Jun 2006 10:43:57 -0400

I think this experiment is a good idea.
While we have discussed throwing out the whole structure, we have not 
agreed to do so.  (I happen to not like the 1-step proposals, but 
that is not the point.)
Whether we eventually throw out the whole thing or not, in teh mean 
time this improves our current procedures in a sensible fashion.

Yours,
Joel M. Halpern

---

From: Ned Freed <[email-masked]>
Date: Mon, 12 Jun 2006 09:02:22 -0700 (PDT)

> significant part of the picture, and that would, itself, be

I agree wi.neustar.com)
	by megatron.ietf.org with esmtp (Exim 4.43)
	id 1FpotX-0007Mo-IK; Mon, 12 Jun 2006 12:04:03 -0400
To: John C Klensin <[email-masked]>
Date: Mon, 12 Jun 2006 09:02:22 -0700 (PDT)
From: Ned Freed <[email-masked]>
Cc: [email-masked], [email-masked]
Subject: Re: Last Call: 'A Process Experiment in Normative Reference
 Handling' to Experimental RFC (draft-klensin-norm-ref)

> significant part of the picture, and that would, itself, be

I agree with both of these points. One signs of a good experiment is that you
learn something from it no matter what the outcome. I see nothing but upside
here and fully support running this process experiment.

				Ned

th both of these points. One signs of a good experiment is that you
learn something from it no matter what the outcome. I see nothing but upside
here and fully support running this process experiment.

				Ned

---

From: Pekka Savola <[email-masked]>
Date: Tue, 13 Jun 2006 00:05:26 +0300 (EEST)

> significant part of the picture, and that would, itself, be

FWIW, I also agree with these and that running the experiment is a 
good idea.  I don't think I'd want to eliminate downref rule 
completely, but this would seem to allow explicit acknowledgement 
and/or justification of each downref, which would seem like a good 
enough for an experiment and not that much work.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings