Subject: Re: are we willing to do change how we do discussions in IETF? (was: moving from hosts to sponsors)

From: "Burger, Eric" <[email-masked]>
Date: Fri, 23 Jun 2006 18:10:51 -0400

Very much agreed.

--
Sent from my Palm Treo - Sorry if Terse

 -----Original Message-----
From: 	Keith Moore [mailto:[email-masked]]
Sent:	Friday, June 23, 2006 05:25 PM Eastern Standard Time
To:	Burger, Eric
Cc:	[email-masked]
Subject:	Re: are we willing to do change how we do discussions in IETF? (was: moving from hosts to sponsors)

On Fri, 23 Jun 2006 16:18:40 -0400
"Burger, Eric" <[email-masked]> wrote:

> I would offer that in *some* groups the running code bar is reasonable.

I would have little objection to requiring running code as a test of feasibility of a new idea.  I would object strongly to an argument that just because someone has running code, means it's a good indication of adequacy of the protocol...DKIM is a great example of a poorly designed protocol that has been justified by running code.
_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Dave Crocker <[email-masked]>
Date: Mon, 26 Jun 2006 08:37:20 +0200

Burger, Eric wrote:
> I would have little objection to requiring running code as a test of
> feasibility of a new idea.  I would object strongly to an argument that
> just because someone has running code, means it's a good indication of
> adequacy of the protocol...DKIM is a great example of a poorly designed
> protocol that has been justified by running code.

I am hoping that you are agreeing with the stated principle, rather than the
provided exemplar.

As Michael noted, the exemplar asserts the assertion of justification that was
never made.  (It also asserts a quality assessment that is humorously incorrect,
but gosh I suspect we ought not to slide down that slope.)

Anyhow, I am probably missing something basic about this thread, since it seems
to be re-discovering an item already in the formal IETF standards process:

> 4.1.1  Proposed Standard
...
>    Usually, neither implementation nor operational experience is
>    required for the designation of a specification as a Proposed
>    Standard.  However, such experience is highly desirable, and will
>    usually represent a strong argument in favor of a Proposed Standard
>    designation.
> 
>    The IESG may require implementation and/or operational experience
>    prior to granting Proposed Standard status to a specification that
>    materially affects the core Internet protocols or that specifies
>    behavior that may have significant operational impact on the
>    Internet.

If folks are suggesting changes to this text, then what are the changes?

d/