Subject: RE: are we willing to do change how we do discussions in IETF? (was: moving from hosts to sponsors)

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Mon, 26 Jun 2006 07:51:19 -0700

> From: Keith Moore [mailto:[email-masked]] 

> there is one important class of bad ideas that doesn't go 
> away in IETF -- the class of bad ideas that is obviously bad 
> from a wider perspective but which looks good to a set of 
> people who are focused on a narrow problem.  and in IETF what 
> we often do with those ideas is to protect them and encourage 
> development of them in isolation by giving them a working 
> group.  we sometimes even write those groups' charters in 
> such a way as to discourage clue donation or discussion of 
> other ways of solving the problem.

That is a somewhat cynical way to describe IPSEC isn't it? Care to mention any other groups that fit that description?

The IESG and the IETF in general has hardly demonstrated an infalible understanding of what is and is not a bad idea, nor for that matter has anyone else. This is a research area and there are plenty of areas where the great and the good get it wrong.

Take Gopher for example, I remember the days when the assumption was that the Web would merge into gopher rather than the other way round. After all the Gopher people knew so much more about networking. Only they did not understand the UI issue and it turned out thsat Tim had a much more powerful idea despite not being an IETF longtimer.

My theory is that Vint and Jon set up the whole IETF infrastructure as a Gordian knot test. Keep the systems safe from over tampering until someone comes along who is decisive enough and addressing a need that is so urgent that either the layers of obfustication will yield or they will snap.

No Keith, you are not Vint Cerf, or Tim Berners-Lee and neither is anyone else here including me.

I know that folk focused on narrow problems have tended to come up with narrow solutions. That is hardly suprising, the rules of engagement here prohibit the discussion of the general.

Take DKIM for example we are about to discuss a one off policy language to serve a single protocol, not because there is only a single protocol that requires policy but because there are people in the establishment who tried policy fifteen years ago, failled to solve the problem and have declared it 'insoluble'. There is also the problem of the other group who need s to be part of the policy discussion which has repeatedly demonstrated itself to be unwilling to listen to any outside view. Try to explain a problem to them and its 'la la la I'm not listening'.

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Keith Moore <[email-masked]>
Date: Mon, 26 Jun 2006 11:14:12 -0400

> That is a somewhat cynical way to describe IPSEC isn't it? Care to mention any other groups that fit that description?

DKIM comes to mind, as does zeroconf.  But I've seen so many examples
of this over the years (including IPsec) that I've lost track.

> The IESG and the IETF in general has hardly demonstrated an infalible understanding of what is and is not a bad idea, nor for that matter has anyone else. 

true.  but the fact that we're not infallable doesn't mean we shouldn't
try to improve things.

> No Keith, you are not Vint Cerf, or Tim Berners-Lee 

and neither are the real Vint or Tim, respectively.  (both smart guys
whom I respect, but there's a difference between any real person and his
reputation.  and this isn't an discussion about personalities, it's a
discussion about how to do protocol enginering)

> I know that folk focused on narrow problems have tended to come up with narrow solutions. That is hardly suprising, the rules of engagement here prohibit the discussion of the general.

which is my point - we need to change the rules of engagement.

> Take DKIM for example we are about to discuss a one off policy language to serve a single protocol, not because there is only a single protocol that requires policy but because there are people in…

DKIM as currently described in the I-Ds is a lot more broken than that,
but they're not listening either.  But it's a lot bigger problem than
any single working group.  I find DKIM a convenient example in this
discussion because it's current, and because of my long history of
working with email I have a keener interest in that WG than most.
But it's not hard to find other examples.

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 26 Jun 2006 16:25:58 +0100

Keith Moore wrote:
> but they're not listening either.  

Eh - to be fair, your concerns wrt DKIM haven't been posted to that
list since roughly the Vancouver BoF at which you took an action to
propose some charter text you liked better ([1], action item #1).

I can understand that you may be reluctant to dive back in having
seen the WG formed but I think "not listening" isn't really correct.
Maybe you meant "didn't listen"?

Anyway the general point that getting people who've agreed to do
reviews, to actually do them, is another problem to add to your list
(as I know from the secdir reviews where I'm currently some weeks
behind),

Regards,
Stephen.

[1] http://tools.ietf.org/wg/dkim/minutes?item=minutes64.txt

---

From: Keith Moore <[email-masked]>
Date: Mon, 26 Jun 2006 11:43:30 -0400

> propose some charter text you liked better ([1], action item #1).

Regarding the charter, I believe I did send suggestions for
improvements to DKIM chairs and to appropriate area directors, though
perhaps not to the DKIM mailing list.

While in Vancouver I also had several discussions with individual DKIM
proponents and document authors about the problems with DKIM, and made
suggestions for how to address them.  

I tried to improve DKIM through back channels because the abusive
behavior of some DKIM proponents (in the BOFs and in private email)
convinced me that it wasn't likely that attention could be focused on
these technical issues in a large group setting.   I also saw the DKIM
mailing list as a set of people who had largely already decided that 
DKIM was "the solution" even if they didn't understand what the problem
was. 

I also know that others have raised similar issues on the DKIM list
since then, and fairly recently.  But the current documents don't
reflect any awareness of those issues or attempt to address
them.   That's why I said "not listening".

> reviews, to actually do them, is another problem to add to your list

a tracking system for these would be an interesting tool.

Keith

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 26 Jun 2006 16:58:11 +0100

> perhaps not to the DKIM mailing list.

I don't recall that mail but maybe you didn't send it to both of
the chairs.

> DKIM was "the solution" even if they didn't understand what the problem

I can understand your approach in this case, since there was a bit
of rancour about, but I assume its not what'd be recommended as a
general approach in any case.

> them.   That's why I said "not listening".

I don't recall recent messages along those lines, and still disagree
that "not listening" is fair, but its ok that we disagree.

> a tracking system for these would be an interesting tool.

Hmm - a hall of fame/shame - not sure if I'd like that or not;-)

Stephen.

---

From: Michael Thomas <[email-masked]>
Date: Mon, 26 Jun 2006 09:00:41 -0700

>them.   That's why I said "not listening".
We have from day one had an issue tracker. Please be specific.

       Mike

---

From: Keith Moore <[email-masked]>
Date: Mon, 26 Jun 2006 12:11:29 -0400

> We have from day one had an issue tracker. Please be specific.

I haven't looked at the issue tracker.  I've seen messages that were
posted to the list that were saying much the same things I said at the
BOFs and before the WG was chartered, and I've read the current
documents and seen that the issues are not addressed or acknowledged.

---

From: Michael Thomas <[email-masked]>
Date: Mon, 26 Jun 2006 09:18:34 -0700

>documents and seen that the issues are not addressed or acknowledged.
Which is to say that we have a process -- that we've published and 
followed --
and you couldn't be bothered to use it. Our issues tracker has been 
ridiculously
open to issues too, but still no issues, no specific complaints. The 
prerequisite of
listening is utterances somewhat crisper than "Harrumph".

       Mike

---

From: Keith Moore <[email-masked]>
Date: Mon, 26 Jun 2006 13:52:39 -0400

> followed -- and you couldn't be bothered to use it. 

I spent a lot of time trying to get DKIM heading in a useful direction
before the WG was chartered - and failed to do so.   Based on the DKIM
charter, my experience with previous IETF working groups, and my
limited exchanges with people on the DKIM mailing list and in the BOFs,
I concluded that it was not a good use of my time to try to participate
actively in the DKIM discussion or follow the mailing list. That's
presumably why I wasn't aware of the tracker.  I'm glad you have one,
though I don't think it really addresses the need for external review
that I've been talking about.

Regarding DKIM, my current intention is to write up a detailed review
of the current DKIM specs and publish that review as an I-D.    Perhaps
issues for the tracker can be gleaned from that I-D.  

Keith

---

From: Eliot Lear <[email-masked]>
Date: Tue, 27 Jun 2006 08:58:23 +0200

Keith,
> issues for the tracker can be gleaned from that I-D.  

As the keeper of the tracker in question I ask you not to do this, but
instead send your individual issues to the working group mailing list
with "new issue" in the subject.  I will then track those into the RT
running on rt.psg.com.  The chairs have been very business-like in
dealing with any open issue.  A jabber session has been held roughly
once a week to address open issues.  To be sure, some consensus points
are rougher than others, but that's typical IETF.

I do not promise to properly track issues that are hidden in a draft or
in a message that is other than as described above, although I will do
my best.

Eliot

---

From: Dave Crocker <[email-masked]>
Date: Tue, 27 Jun 2006 10:26:39 +0200

> running on rt.psg.com.  

By way of adding to your encouragement I'll note that the working group (through
 your considerable efforts) has made a point of adding every issue that gets
raised, without vetting it's appropriateness, reasonableness, support, etc.

In other words, it is trivial to get on the tracking list and hence be assured
that the item will get formal attention.

The outcome of that attention is, of course, a separate matter.

As it should be.

d/

---

From: Dave Crocker <[email-masked]>
Date: Tue, 27 Jun 2006 14:00:40 +0200

> Maybe you meant "didn't listen"?

Even if that's what he really meant, it is not correct.

My recollection is that every issue raised, by anyone, got considered.

There's quite a difference between "not listening" vs. "not agreeing".

d/

---

From: Keith Moore <[email-masked]>
Date: Tue, 27 Jun 2006 09:26:50 -0400

On Tue, 27 Jun 2006 08:58:23 +0200
Eliot Lear <[email-masked]> wrote:

> with "new issue" in the subject. 

Eliot,

To the extent that they can be understood as separable issues, I don't have a problem with doing what you describe in addition to writing the I-D.  But I believe these issues need a wider visibility than just within the DKIM wg.  

Keith

---

From: Keith Moore <[email-masked]>
Date: Wed, 28 Jun 2006 09:28:21 -0400

> My recollection is that every issue raised, by anyone, got considered.

Well, you kept claiming that we couldn't possibly anticipate the ways in 
which the DKIM protocol would be used, therefore there was no 
justification for the WG to change DKIM significantly from its original 
design.

That's not what I would call "consideration".  There are lots of things 
I could call it, none of which are flattering.

Keith

---

From: Dave Crocker <[email-masked]>
Date: Wed, 28 Jun 2006 17:41:30 +0200

> justification for the WG to change DKIM significantly from its original

1. I did not say anything like what you are stating. Please read more carefully.

2. I am but one voice.  It means little what I say.

3. What DOES matter is that a) there was discussion, and b) you failed to obtain
group support.  THESE mean quite a lot.

You continue to confuse your not getting what you want with a group's failing to
do due diligence. They are quite different.

The critical concept that you seem to make a point of missing is called "rough
consensus".

d/

---

From: Keith Moore <[email-masked]>
Date: Wed, 28 Jun 2006 14:19:03 -0400

No, Dave, you insisted on interrupting me and shouting me down when I tried
to raise these issues in the BOFs - doing your best to prevent me from making
my case.  And you're not just one voice, you are one of the document authors.  

As for rough consensus, you seem to forget that there are two necessary
conditions for standardization - one is rough consensus, the other is technical
soundness.  

Keith

---

From: Michael Thomas <[email-masked]>
Date: Wed, 28 Jun 2006 11:48:38 -0700

Keith Moore wrote:

>my case.  
We had three bof's, and Dave was a chair of bof #2 only.

>And you're not just one voice, you are one of the document authors.  
>  
>

No he isn't.

>conditions for standardization - one is rough consensus, the other is technical
Thus far, I see a huge amount of effort on your part at making disparaging
oblique remarks with no substance that anybody could act on if they were
so inclined. The last round produce the same harrangue with promises to
tell us why we're all screwed up and... no follow through. Until we see
some real follow through with real issues, I have to assume that you're
more interested in the art of harrangue than saving DKIM from the heathens.

       Mike

---

From: Keith Moore <[email-masked]>
Date: Wed, 28 Jun 2006 15:12:00 -0400

> >And you're not just one voice, you are one of the document authors.  

I stand corrected.  Too much history between me and Dave, I suppose.

> tell us why we're all screwed up and... no follow through. 

And furthermore, because of the I-D cutoff and my travel schedule you
won't see any I-D until early August at the earliest.  

> Until we see

I'm more interested in fixing the WG process than in fixing DKIM.  But
I'm still interested in fixing DKIM.

Keith