Subject: Question on The Mobility Header in Mobile IPv6

From: "Gotienne Rodrigue-Y18516C" <[email-masked]>
Date: Mon, 26 Jun 2006 14:18:30 -0400

Hi All,
 
I have question in regard to the field "header len" of the Mobility
header (RFC 3775 [31]).
Is That field indicates the length of the mobility header in 8-bits Unit
(1 octet Unit), excluding the first 8 bits (first octet), or is that
really indicates the length of the mobility header in 8-octets (8*8
bits) Unit, excluding the first 8 octets (8*8 bits) as it is currently
written in the RFC ?
 
Thanks
 
Rodrigue Gotiene
 
_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Soliman, Hesham" <[email-masked]>
Date: Mon, 26 Jun 2006 11:22:40 -0700

Hi All,

	I have question in regard to the field "header len" of the
Mobility header (RFC 3775 [31]).
	Is That field indicates the length of the mobility header in
8-bits Unit (1 octet Unit), excluding the first 8 bits (first octet), or
is that really indicates the length of the mobility header in 8-octets
(8*8 bits) Unit, excluding the first 8 octets (8*8 bits) as it is
currently written in the RFC ? 
	 
	=> It's the length in 8-octet units. 
	 
	Hesham 
	 
	Thanks
	 
	Rodrigue Gotiene

---

From: Jari Arkko <[email-masked]>
Date: Tue, 27 Jun 2006 14:12:32 +0300

Soliman, Hesham wrote:

>     *8-bits Unit (1 octet Unit)*, excluding *the first 8 bits (first
>     octet)*, or is that really indicates the length of the mobility
>     header in *8-octets (8*8 bits) Unit*, excluding *the first 8
>     octets (8*8 bits)* _as it is currently written in the RFC_ ? 
>      
As Hesham already responded, it is indeed counted in
units of 8 octets and the first 8 octets are not included
in the length. That is, if your message is 16 bytes
long you would place value 1 in the Length field.

For further questions, the mip6 list is probably a better
place:

    http://www1.ietf.org/mailman/listinfo/mip6

--Jari