Subject: Re: IDs first? RE: Last Call: 'Proposed Experiment: Normative Format in AdditiontoASCII Text' to Experimental RFC (draft-ash-alt-formats)

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Tue, 20 Jun 2006 18:53:22 -0700

The format is straight mime with one added feature, a content header to specify the url of the segment so that links in the document can be disambiguated. 

It should be an rfc, just need someone to get round to writing it up.

I may do that soon because I am looking into using mhtml as an archival format for notarized versions of html documents.

 -----Original Message-----
From: 	Keith Moore [mailto:[email-masked]]
Sent:	Tue Jun 20 16:35:27 2006
To:	Hallam-Baker, Phillip
Cc:	[email-masked]
Subject:	Re: IDs first? RE: Last Call: 'Proposed Experiment: Normative Format in AdditiontoASCII Text' to Experimental RFC (draft-ash-alt-formats)

> > I like the idea.  But it has to be compatible with software 
> > that people already have.  How many browsers that people 
> > actually use these days support MHTML?
> 
> It is supported in IE and Firefox and has been for about five years or so.

That might not be quite good enough, but it's close enough to warrant
further investigation.

> The format is currently defined by a Microsoft note but this can easily be made into an RFC, it is a widely supported standard extension of MIME.

What was wrong with RFC 2557?  How can we assume that this is a stable
format given that MS apparently felt they could change it on a whim?

> Creating one of these archives is easy, just view the HTML page and click 'save as archive'.

My copy of firefox doesn't seem to have that feature.

> Another point to consider, the only sustained objection being made to this proposal is that future generations may be unable to read the documents.
> 
> This particular objection cannot be made credibly with respect to Internet Drafts which expire in 6 months in any case. Nor do I think it is reasonable to require support for people using obsolete software in this case. If someone can't install the latest version of Firefox their ability to contribute to a WG is going to be negligible in any case.

Unfortunately, many IETF participants are expected by their employers
to use broken software.

As someone who has actually tried producing I-Ds in alternate formats,
I'm not sure that I agree that there's much benefit to having only I-Ds
use the new format.   People who review the document need to be able to
see something close to the version that will actually be published.  

Keith

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Harald Alvestrand <[email-masked]>
Date: Wed, 21 Jun 2006 00:31:38 -0700

Hallam-Baker, Phillip wrote:
>
> The format is straight mime with one added feature, a content header 
> to specify the url of the segment so that links in the document can be 
> disambiguated.
>
> I may do that soon because I am looking into using mhtml as an 
> archival format for notarized versions of html documents.
>
if you write it up, make sure you obsolete RFC 2557 (PS since 1999). No 
reason to have two specs for it.

---

From: Scott W Brim <[email-masked]>
Date: Wed, 21 Jun 2006 07:15:45 -0400

> My copy of firefox doesn't seem to have that feature.

Maybe you need to include the archive extension:  http://maf.mozdev.org.

When I do I get three options: MAF archive, MAF ZIP archive and MAF
MHT archive.  On Windows, if I save it in Firefox as an MHT archive,
then doubleclick on it, it opens apparently correctly in Internet
Explorer.

---

From: Keith Moore <[email-masked]>
Date: Wed, 21 Jun 2006 08:28:50 -0400

> Maybe you need to include the archive extension:  http://maf.mozdev.org.

apparently it's not supported on macs.