Subject: Re: Intermediate wg summaries

From: Eric Burger <[email-masked]>
Date: Mon, 15 Jan 2007 06:24:39 -0800 (PST)

I fully agree with what Henning proposes.  However, I am not sure it would be practical.  Namely, folks get their employers to pay for going to IETF to get work done.  Will that still happen if the meeting becomes, "What's going on in the IETF?"  I know when I was in startup mode, the holder of my purse said, "Buy and read the proceedings" when I wanted to go to a technical conference where I was not presenting.

Because of this (or maybe I've got the symptom confused with the cause), WG meetings have become face-to-face work session: "Read all the documents, all the e-mails, and absolutely NO tutorials in your presentation" is the mantra of many work groups.

That said, I have purposely scheduled tutorials in some of my work groups when the technology, OR BUSINESS DRIVER, is obscure but significantly impacts the direction of our work.  I made a point of inviting those whom I expected to balk at our work product if they did not know why we want that route.  So far, that has been successful.

On 1/8/07 3:02 PM, "Henning Schulzrinne" <[email-masked]> wrote:

> I think it is helpful to distinguish at least three types of IETF  
> work products:
> 
> (1) fully new protocols, at the level of (say) MPLS or NSIS
> 
> (2) extensions of existing protocols, such as a new DHCP option or a  
> new RTP payload type (another huge fraction of our current activities)
> 
> (3) "bis" versions of existing protocols (a very large chunk of our  
> current repertoire)
> 
> Some efforts will fall somewhere in-between, but I suspect that we're  
> mainly worried about (1), and maybe (3) ["ten years hence, what have  
> we learned and should we scrap the old stuff instead of adding a  
> layer of paint"].
> 
> Fortunately or unfortunately, the number of concurrent (1) efforts is  
> very small.
> 
> Currently, WG and IETF meetings could be a good opportunity to get  
> people to do cross-area review, as they are in IETF mode. HoweveFrom [email-masked] Tue Jan 16 08:56:48 2007
Date: Mon, 15 Jan 2007 06:24:39 -0800 (PST)
From: Eric Burger <[email-masked]>
To: [email-masked]
Subject: Re: Intermediate wg summaries
Reply-To: Eric Burger <[email-masked]>

I fully agree with what Henning proposes.  However, I am not sure it would be practical.  Namely, folks get their employers to pay for going to IETF to get work done.  Will that still happen if the meeting becomes, "What's going on in the IETF?"  I know when I was in startup mode, the holder of my purse said, "Buy and read the proceedings" when I wanted to go to a technical conference where I was not presenting.

Because of this (or maybe I've got the symptom confused with the cause), WG meetings have become face-to-face work session: "Read all the documents, all the e-mails, and absolutely NO tutorials in your presentation" is the mantra of many work groups.

That said, I have purposely scheduled tutorials in some of my work groups when the technology, OR BUSINESS DRIVER, is obscure but significantly impacts the direction of our work.  I made a point of inviting those whom I expected to balk at our work product if they did not know why we want that route.  So far, that has been successful.

On 1/8/07 3:02 PM, "Henning Schulzrinne" <[email-masked]> wrote:

> I think it is helpful to distinguish at least three types of IETF  
> work products:
> 
> (1) fully new protocols, at the level of (say) MPLS or NSIS
> 
> (2) extensions of existing protocols, such as a new DHCP option or a  
> new RTP payload type (another huge fraction of our current activities)
> 
> (3) "bis" versions of existing protocols (a very large chunk of our  
> current repertoire)
> 
> Some efforts will fall somewhere in-between, but I suspect that we're  
> mainly worried about (1), and maybe (3) ["ten years hence, what have  
> we learned and should we scrap the old stuff instead of adding a  
> layer of paint"].
> 
> Fortunately or unfortunately, the number of concurrent (1) efforts is  
> very small.
> 
> Currently, WG and IETF meetings could be a good opportunity to get  
> people to do cross-area review, as they are in IETF mode. However, we  
> seem to have intentionally or unintentionally made this difficult.
> 
> In WG meetings, we're encouraged to talk about open issues, which  
> often means that the same three people that have been arguing some  
> angels-on-a-pin point on the mailing list, having lost everybody  
> else, take turns at the microphone, while the remaining 247 people in  
> the audience are paying full attention - to their email. I would find  
> it much more helpful to have the ability to walk into a WG as an  
> interested party that's not on a mailing list and catch up quickly.  
> Interim meetings and phone conferences often seem better suited to  
> that level of detail, particularly for large WGs.
> 
> Similarly, in the plenaries, we rehash NAT and RFC-over-HTML  
> arguments or learn about the number of enterprise numbers that have  
> been assigned. That time might be better spent in giving not just the  
> IRTF slot time, but also any (1) and significant (3) development,  
> with an emphasis on the architectural issues being raised by the  
> effort and maybe an attempt to highlight the big-ticket open issues.  
> Right now, the only time this tends to happen, at best, is during the  
> BOF, which is usually and hopefully too early.
> 
> Henning
> 
> 
>> necessarily interested in the subject area are few and far between.
>> Extra documents don't help much, either, because they're *strongly*
>> resented by WG members who see them as just more process imposed by  
>> the
>> IESG.
>> 
>> I tried several things myself when I was AD.  If I were still AD, I'd
>> keep trying.  But I don't have any new ideas, and I'm skeptical of
>> repeating old ones.
>> 
>> 
>> 
>> --Steve Bellovin, http://www.cs.columbia.edu/~smb
>> 
>> _______________________________________________
>> Ietf mailing list
>> [email-masked]
>> https://www1.ietf.org/mailman/listinfo/ietf
> 
> 
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ietf

____________________________________________________________________________________
Never Miss an Email
Stay connected with Yahoo! Mail on your mobile.  Get started!
http://mobile.yahoo.com/services?promote=mail

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 16 Jan 2007 09:02:55 -0500

I don't think these have to be either-or propositions. A mixture of  
both, combined with pre-scheduled "breakout" sessions that  
parallelize some of the lower-interest drafts, might offer value to  
all participants. Naturally, details depend on the state and size of  
the working group. SPEECHSC, say, presumably has very different needs  
and scheduling constraints than, say, SIPPING. (SIPPING had  
approximately 75 new (00) drafts last year, counting both draft-ietf  
and draft-personal-sipping.)

An observer of many large WGs would argue that paying $500 to read  
email or play Solitaire isn't a particularly good investment, either...

On Jan 15, 2007, at 9:24 AM, Eric Burger wrote:

> I fully agree with what Henning proposes.  However, I am not sure  
> it would be practical.  Namely, folks get their employers to pay  
> for going to IETF to get work done.  Will that still happen if the  
> meeting becomes, "What's going on in the IETF?"  I know when I was  
> in startup mode, the holder of my purse said, "Buy and read the  
> proceedings" when I wanted to go to a technical conference where I  
> was not presenting.
>
> Because of this (or maybe I've got the symptom confused with the  
> cause), WG meetings have become face-to-face work session: "Read  
> all the documents, all the e-mails, and absolutely NO tutorials in  
> your presentation" is the mantra of many work groups.
>
> That said, I have purposely scheduled tutorials in some of my work  
> groups when the technology, OR BUSINESS DRIVER, is obscure but  
> significantly impacts the direction of our work.  I made a point of  
> inviting those whom I expected to balk at our work product if they  
> did not know why we want that route.  So far, that has been  
> successful.