Subject: [FW: Re: IETF last call on draft-barany-eap-gee-04.txt]

From: Yoshihiro Ohba <[email-masked]>
Date: Thu, 04 Jan 2007 20:55:55 -0500

Let me forward my response with reducing quotes since it got bounced.

----- Forwarded message from Yoshihiro Ohba <[email-masked]> -----

From: Yoshihiro Ohba <[email-masked]>
Subject: Re: IETF last call on draft-barany-eap-gee-04.txt
To: "Joseph Salowey (jsalowey)" <[email-masked]>
Cc: Yoshihiro Ohba <[email-masked]>,
	"Narayanan, Vidya" <[email-masked]>,
	"Barany, Pete" <[email-masked]>,
	Bernard Aboba <[email-masked]>,
	Jari Arkko <[email-masked]>, [email-masked]
User-Agent: Mutt/1.5.13 (2006-08-11)
X-UIDL: `*T"!3ga"!Eh'#!<h>"!

Hi Joe,

Your comment would be valid if GEE were defined just as a function not
as a protocol.  As long as GEE is defined as a protocol, I do not
agree with the statement that GEE is not an EAP lower layer, because
in RFC 3748, EAP lower layer sits immediately below EAP layer and
there is no shim layer.  That is why the only way for GEE to comply
with RFC 3748 is to view GEE as part of EAP lower layer.

Yoshihiro Ohba

On Thu, Jan 04, 2007 at 04:17:58PM -0800, Joseph Salowey (jsalowey) wrote:
> 
> <snip> 
> > > * EAP lower layer and GEE - Bernard's review pointed out 
> > that the EAP 
> > > lower layer transport requirements are not discussed in the 
> > GEE draft.
> > > GEE is not an EAP lower layer. GEE is a protocol that the EAP lower 
> > > layer can use to allow multiple parallel authentications.
> > 
> > As I already commented, GEE is part of EAP lower layer in 
> > term of RFC 3748.  This fact does not change even if the 
> > lower layer of GEE negotiates the use of GEE between the peer 
> > and authenticator.
> > 
> [Joe] GEE is not an EAP lower layer, it is intended to be transparent to
> the EAP method layer.  GEE does not provide lower layer functionality by
> itself, rather it relies upon the processing of a lower layer that meets
> the RFC 3748 requirements. 

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Lakshminath Dondeti <[email-masked]>
Date: Thu, 04 Jan 2007 18:15:40 -0800

Yoshi,

We are going in circles on this topic.  What is your point?  We have 
already clarified that the figures will be removed since they are confusing.

Lakshminath

---

From: Yoshihiro Ohba <[email-masked]>
Date: Fri, 05 Jan 2007 16:03:50 -0500

Even if figures are removed, if text still says that GEE is not EAP
lower layer, that is still incorrect from protocol layering point of
view.

So, I think that what needs to be clarified in the draft so that it
complies with RFC 3748 is:

- From functional point of view, GEE provides an additional
functionality to run parallel EAP conversations, which is not a
required functionality for EAP lower layer.

- From protocol layering point of view, GEE is part of EAP lower layer
in terms of RFC 3748.

Hope this helps,
Yoshihiro Ohba

---

From: "Narayanan, Vidya" <[email-masked]>
Date: Fri, 5 Jan 2007 17:10:27 -0800

> -----Original Message-----
> From: Yoshihiro Ohba [mailto:[email-masked]] 
> Sent: Friday, January 05, 2007 1:04 PM
> To: Dondeti, Lakshminath
> Cc: [email-masked]
> Subject: Re: [FW: Re: IETF last call on draft-barany-eap-gee-04.txt]
> 
> Even if figures are removed, if text still says that GEE is 
> not EAP lower layer, that is still incorrect from protocol 
> layering point of view.
> 
> So, I think that what needs to be clarified in the draft so 
> that it complies with RFC 3748 is:
> 
> functionality to run parallel EAP conversations, which is not 
> a required functionality for EAP lower layer.
> 

No dispute here. The document doesn't say that it is a required function
for any lower layer. 

> - From protocol layering point of view, GEE is part of EAP 
> lower layer in terms of RFC 3748.
> 

This is what I said we will clarify as part of the "EAP lower layer and
GEE" text in my earlier email. 

So, seems like we are in agreement. 

Vidya

> > >----- Forwarded message from Yoshihiro Ohba 
> <[email-masked]> 
> > >-----
> > >
> > >Your comment would be valid if GEE were defined just as a function 
> > >not as a protocol.  As long as GEE is defined as a 
> protocol, I do not 
> > >> > > GEE is not an EAP lower layer. GEE is a protocol 
> that the EAP 
> > >> > > lower layer can use to allow multiple parallel 
> authentications.
> > >> >
> > >> > As I already commented, GEE is part of EAP lower layer 
> in term of 
> > >> > RFC 3748.  This fact does not change even if the lower 
> layer of 
> > >> > GEE negotiates the use of GEE between the peer and 
> authenticator.
> > >> >
> > >> [Joe] GEE is not an EAP lower layer, it is intended to be 
> > >> transparent to the EAP method layer.  GEE does not provide lower 
> > >> layer functionality by itself, rather it relies upon the 
> processing 
> > >> of a lower layer that meets the RFC 3748 requirements.
> > >
> > >