Subject: RE: one example of an unintended consequence of changing the /48boundary

From: [email-masked] (Noel Chiappa)
Date: Mon, 27 Aug 2007 13:47:10 -0400 (EDT)

> From: <[email-masked]>

    > This message will soon reach the investment community so you will soon
    > see investment analysts asking very tough IPv6 deployment questions,
    > and rating stocks appropriately.
    > ...
    > Think back to the days when the OSI protocols were expected to be the
    > next big thing

No doubt the savvier members of the investment community will remember those
days, and the predictions of how much money would be made/lost by those who
did/didn't invest in OSI, and will take that into account when they hear
similar claims (such as yours) about IPv6.

I can see the marketing slogans now: "IPv6, the OSI of the 21st Century!"

	Noel

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Mon, 27 Aug 2007 13:20:57 -0700

Quite, and one of the key reasons that OSI lost out to IP was the transition issue.
 
DECNET Phase V was going to be one of the principal deployment vehicles. But the transition from DECNET Phase IV to V was a complete bear, something that was going to mean huge expense and huge effort.
 
If OSI had provided an organic transition mode that preserved the deployed base rather than a flag day they might have got away with it, or at least had a chance of doing so. 

I don't think that the IPv6 problem is hopeless, far from it. But I do think that we need to approach the issue as a marketting problem and not just a technical one.
 
In particular we must decide on the key pain point that deployment of IPv6 compatible infrastructure is going to solve. Unfortunately lack of address space is not a pain point for the vast majority of Internet users and their ISPs. If Mr Greedy Bastard has an IPv4 address he is not likely to consider the fact that Ms Netless does not to be a pain point for him personally. Worse an ISP who years for a return to the walled garden model is going to see hyperNAT as being a net benefit not a pain point.
 
We have to find a pain point that affects the people we need to deploy new infrastructure to support both IPv6 and the transition.
 
The only pain point I can see as a viable driver is the cost and complexity of network management.

________________________________

From: Noel Chiappa [mailto:[email-masked]]
Sent: Mon 27/08/2007 1:47 PM
To: [email-masked]
Cc: [email-masked]
Subject: RE: one example of an unintended consequence of changing the/48boundary

        Noel

---

From: <[email-masked]>
Date: Mon, 27 Aug 2007 22:28:11 +0100

> No doubt the savvier members of the investment community will 
> remember those days, and the predictions of how much money 
> would be made/lost by those who did/didn't invest in OSI, and 
> will take that into account when they hear similar claims 
> (such as yours) about IPv6.
> 

In my analogy, IPv4 is the analog of OSI, and IPv6 is the analog of the
1990's Internet Protocol. In the 1990's people could see that the
DECNET/IPX/Banyan/NetBIOS/LU6.2 was not workable in an internetworked
world. It was clear that we needed a common-denominator protocol to
interwork between them all. OSI and IP both targeted that space but OSI
lagged behind in implementation of tools and protocols. The analysts
missed this, and even believed that IP was lagging behind, because they
did not take open-source deployments into account.

In today's world, it is clear that IPv4 networks cannot grow beyond
three years from now, but IPv6 networks can grow. There is no competitor
to IPv6 other than the possibility of making IPv4 even more complex with
triple and quadruple NAT or some other weird stuff. The market impacts
of open source are now well known and carefully studied, so when someone
says that Linksys has no home gateway boxes, a savvy investment analyst
knows that they are leveraging Linux technology and since Linux fully
supports IPv6, Linksys can ramp up production very quickly if they are
motivated.

This time we know that there is a tipping point about to happen and this
time, the investment community knows a lot more about technology and how
a technology shift can turn up-and-comers into buggy-whip manufacturers.
Given the large percentage of VC funded businesses who tie their
business growth to the Internet (and often to its growth), I fully
expect them to start asking tough IPv6 questions before this year is
out.

--Michael Dillon