Subject: Re: [manet] Last Call: draft-ietf-manet-iana (Internet AssignedNumbers Authority (IANA) Allocations for the Mobile Ad hocNetworks (MANET) Working Group) to Proposed Standard

From: "Ian Chakeres" <[email-masked]>
Date: Fri, 10 Aug 2007 07:01:25 +0530

I think that supporting both UDP and an IP protocol number would make
ensuring interoperability more difficult. If I hear from the WG that
there is a leaning toward leaving UDP and switching to an IP protocol
number, then we can consider it.

As of today, I have not heard enough support for this change.

Ian Chakeres

On 8/9/07, Teco Boot <[email-masked]> wrote:
> > Ian wrote:
> > Before you voiced your suggestion to allocate an IP protocol number,
> > the issue has never arisen. Unless there is WG support to allocate an
> > IP protocol number, I do not think it will be allocated.
> >
> [Teco]
> I did rise this question before, see below.
> Maybe the issue is not that important; UDP overhead is 8 octets, brings
> checksum and could take advantage of header compression for UDP. But using a
> native IP protocol is more in line with other IETF routing protocols.
>
>
> -----Original Message-----
> From: Teco Boot [mailto:[email-masked]]
> Sent: woensdag 25 april 2007 13:28
> To: 'Ian Chakeres'
> Cc: [email-masked]
> Subject: [manet] manet-iana WG Last Call: site-local address and UDP only
>
> Hi Ian,
>
> You request a site-local multicast address. I cannot find any usage of it in
> the current I-Ds. Do we need this? Or always perform hop-by-hop forwarding
> using a link-local address? I think the latter is used by OLSRv2 and DYMO
> protocols, but I can miss something.
>
> You also do not request an IP protocol number. Maybe I missed a discussion
> before and the outcome could be using UDP only, (may be TCP also). I cannot
> find any reference. Using UDP checksum is a reason.
>
> Regards, Teco
>
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/manet
> > Regarding packetbb IANA considerations and other MANET WG protocols
> > additional IANA needs they are addressed in their documents. For
> > example, see packetbb's IANA section.
> >
> > Ian
> >
> > On 8/9/07, Bo Berry <[email-masked]> wrote:
> > >
> > > Given that the WG is working to define two standards
> > > - Reactive MANET Protocol (RMP)
> > > - Proactive MANET Protocol (PMP)
> > > that may or may not converge, do we need to allocate
> > > two port numbers so these protocols can co-exist?
> > >
> > > There has also been a suggestion to allocate an IP protocol
> > > number for a MANET routing protocol.  Should this be
> > > included in this draft?
> > >
> > > The various MANET protocols are moving to packetbb which
> > > will require the definition of several/many TLV identifiers.
> > > Where are these type IDs going to be allocated and tracked?
> > > If in the separate protocol drafts, is there a potential
> > > problem with overlap if IDs?   If so, perhaps the MANET
> > > type IDs should be defined here.
> > >
> > > draft-ietf-manet-packetbb-08 currently reserves IDs
> > >    "Message type 0 MUST NOT be allocated because a zero-octet signifies
> > a
> > >    packet header and zero-octets are used for padding.  Message types 1
> > >    to 4 are reserved because they are used by OLSR [4], which uses a
> > >    compatible packet/message header format."
> > >
> > >
> > >
> > > Thanks
> > > -Bo
> > >
> > >
> > >
> > > The IESG wrote:
> > > > The IESG has received a request from the Mobile Ad-hoc Networks WG
> > > > (manet) to consider the following document:
> > > >
> > > > - 'Internet Assigned Numbers Authority (IANA) Allocations for the
> > > >    Mobile Ad hoc Networks (MANET) Working Group '
> > > >    <draft-ietf-manet-iana-05.txt> as a Proposed Standard
> > > >
> > > > The IESG plans to make a decision in the next few weeks, and solicits
> > > > final comments on this action.  Please send substantive comments to
> > the
> > > > [email-masked] mailing lists by 2007-08-18. Exceptionally,
> > > > comments may be sent to [email-masked] instead. In either case, please
> > > > retain the beginning of the Subject line to allow automated sorting.
> > > >
> > > > The file can be obtained via
> > > > http://www.ietf.org/internet-drafts/draft-ietf-manet-iana-05.txt
> > > >
> > > >
> > > > IESG discussion can be tracked via
> > > >
> > https://datatracker.ietf.org/public/pidtracker.cgi?command=view_id&dTag=15
> > 731&rfc_flag=0
> > > >
> > > >
> > > >
> > > > _______________________________________________
> > > > manet mailing list
> > > > [email-masked]
> > > > https://www1.ietf.org/mailman/listinfo/manet
> > > >
> > >
> > >
> > > _______________________________________________
> > > manet mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/manet
> > >
> >
> >
> > _______________________________________________
> > manet mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/manet
>
>

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Ian Chakeres" <[email-masked]>
Date: Thu, 9 Aug 2007 23:24:21 +0530

The decision to allocate one port was discussed in the MANET group. We
chose to reserve a single port to allow multiple protocols to be used
together. For example, it is extremely likely that NHDP will be used
with both DYMO and OLSRv2.

Ian

On 8/9/07, Bo Berry <[email-masked]> wrote:
>    "Message type 0 MUST NOT be allocated because a zero-octet signifies a
> > final comments on this action.  Please send substantive comments to the
> > https://datatracker.ietf.org/public/pidtracker.cgi?command=view_id&dTag=15731&rfc_flag=0
> >
> >
> >

---

From: Bo Berry <[email-masked]>
Date: Fri, 10 Aug 2007 11:53:17 -0400

Ian Chakeres wrote:
> Comments inline.
> 
> On 8/10/07, Bo Berry <[email-masked]> wrote:
>> Thanks for the responses Teco (separate email) and Ian.
>>
>> Ian Chakeres wrote:
>> OK. Perhaps the WG should discuss it before we discount it.
> 
> This issue is open for discussion, but as I mentioned I do not think
> there is sufficient WG support. I personally do not think asking for
> both a UDP port and an IP protocol number is good for ensuring
> interoperability - and this is the main reason we have requested the
> IANA allocations in this document.

I think running a routing protocol over UDP is less efficient
than directly over IP.  As long as the rough consensus is
happy w/ UDP, I'll chill-out.

If the MANET protocols will be UDP and packetbb based, should
the text in packetbb be modified to be more specific?

   ""The packets defined by this specification are designed to carry a
   number of messages between in a single transmission.  The packets may
   be unicast or multicast and may use any transport protocol (TCP, UDP,
   ...) appropriate to the protocol using this specification and may
   travel over a single logical hop which might consist of one or more
   IP hops.  When the diffusion mechanism enabled by this specification
   is employed, UDP may be most appropriate.""

>From my read, there is confusion when a draft trys to remain
so generic in one sense and then specific in another. Perhaps
it is just me and the pieces will come together in due time.

> Regarding packetbb's IANA needs, I think they are best served in the
> PacketBB document. PacketBB requests the registries associated with
> its type spaces. The other documents (e.g. TimeTLV, NHDP, DYMO,
> OLSRv2, and metrics documents under consideration) then request IANA
> allocations from the spaces created by the packet BB document.
> 
> Ian Chakeres
> 
>> I have.  It appears to suggest three different IANAs.
>>  A new registry for message types must be created
>>  A new registry for packet TLV types must be created,
>>  A new registry for address block TLV types must be created.
>>
>> Can these be in one draft, the MANET IANA doc, or is the plan to have
>> three separate drafts.  Or is the plan for each protocol to track
>> its own?  I went back through the archives and did not see such
>> discussion.
>>
>> I am suggesting that the MANET IANA draft may be a good place,
>> specifically if multiple protocols will co-exist, sharing TLVs
>> and ports.
>>
>> Sorry if I missed the discussions on these.
>>
>>> Ian
>>>

---

From: "Teco Boot" <[email-masked]>
Date: Thu, 9 Aug 2007 20:09:50 +0200

[Teco] 

-----Original Message-----
From: Teco Boot [mailto:[email-masked]] 
Sent: woensdag 25 april 2007 13:28
To: 'Ian Chakeres'
Cc: [email-masked]
Subject: [manet] manet-iana WG Last Call: site-local address and UDP only

Hi Ian,

Regards, Teco

---

From: "Ian Chakeres" <[email-masked]>
Date: Fri, 10 Aug 2007 07:08:55 +0530

Comments inline.

Ian Chakeres

---

From: Bo Berry <[email-masked]>
Date: Thu, 09 Aug 2007 11:13:43 -0400

Thanks
-Bo

---

From: Bo Berry <[email-masked]>
Date: Thu, 09 Aug 2007 16:57:52 -0400

---

From: Bo Berry <[email-masked]>
Date: Thu, 09 Aug 2007 16:57:52 -0400