Subject: RE: Beggars _can_ be choosers?

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Wed, 1 Aug 2007 11:24:37 -0700

The problem here does not appear to be the DHCP protocol, it is the binding into the WiFi stack and in particular the specific software implementations.

I know all about layering, but no, DHCP does not seem to be right for wifi. Where you have an explicit gateway device and a link level session the DHCP data should be served within the same context.

Less points of failure that way.

Sent from my GoodLink Wireless Handheld (www.good.com)

 -----Original Message-----
From: 	David W. Hankins [mailto:[email-masked]]
Sent:	Wednesday, August 01, 2007 09:03 AM Pacific Standard Time
To:	[email-masked]
Subject:	Beggars _can_ be choosers?

On Tue, Jul 31, 2007 at 06:59:58PM -0400, John C Klensin wrote:
> Almost independent of the IPv6 autoconfig issues, I find it
> deeply troubling that we seem to be unable to both
> 
> 	* get the ducks lined up to run IPv6 fully and smoothly,
> 	with and without local/auto config.
> 	
> 	* get a DHCP arrangement (IPv4 and, for those who want
> 	to use it, IPv6) that performs reliably, consistently,
> 	and largely invisibly (if I have to worry about what a
> 	DHCP server is doing, it isn't working well).
> 
> and have both of those working seamlessly no later than Sunday
> afternoon of the meeting.
> 
> If we can't do that, we should be very seriously reviewing our
> protocols and specifications: that sort of thing shouldn't be,
> in any sense, an experiment at this stage.

Wow!  Is that an "IETF First" for anyone else?

Ever since my first IETF, I was well aware that many folks held to the
unfortunate fallacy that, "because we do X at IETF meetings and it
works allright, it is therefore sufficient for the rest of the
Internet."  No matter how much people point out the error in this
thinking, it is perpetuated...as recently as the IETF 69 tech plenary,
where we were told that firewalls were becoming obsolete, evidenced by
their lack of use at IETF meetings.

There's only one word for it:  Astounding.

I have never, until now, heard the contrary fallacy attempted.  That
is, "because we did X at an IETF meeting and it did not work
allright, it is therefore insufficient for the Internet."

That's a new one on me.

Clever, but wrong: networks much larger than 1,200 laptops use DHCPv4
on a daily basis all over the Internet without similar symptoms.

-- 
Ash bugud-gul durbatuluk agh burzum-ishi krimpatul.
-- 
David W. Hankins	"If you don't do it right the first time,
Software Engineer		     you'll just have to do it again."
Internet Systems Consortium, Inc.		-- Jack T. Hankins
_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Wed, 1 Aug 2007 11:30:50 -0700

As a vendor this is precisely the information I would most want. Code is free, QA costs the money.

What I would not want is to have the result taken as a product review.

 -----Original Message-----
From: 	David W. Hankins [mailto:[email-masked]]
Sent:	Wednesday, August 01, 2007 10:36 AM Pacific Standard Time
To:	[email-masked]
Subject:	Re: Beggars _can_ be choosers?

On Wed, Aug 01, 2007 at 09:12:14AM -0700, Joel Jaeggli wrote:
> Told by whom?

Hain...something like that?  I can't remember.  You'll have to check
whatever minutes or recordings are up.

> Start by asking the contractor, the volunteers and the IAD for a
> postmortem on the operation of the network. anything else is just
> speculation.

Why?

It's a lot of work, and I think we already know the conclusion, given
what we can observe as users.

It berates our volunteers and sponsors who provide us with the network
services during our stay...treating them like children that have to be
kept after school to explain themselves.

It embarrasses vendors who provide us with gear or software, making
them less likely to provide either.

And all we're going to discover is, "It hurts when you go like this,
so don't do that then."

A useless and frivolous excercise.

If we wanted to stop begging, and really buy a network for every
IETF meeting, complete with SLA's and funding extensive testing
before opening it 'live', then that's one thing.  One totally
rediculous thing.

But in lieu of an absence of begging, we should stop being so
choosy.

They did a good job, and we more or less had net the entire meeting.

I don't think we have anything to complain about.