Subject: Re: Change the subject! RE: [IAOC] Re: IPv4 Outage Planned for IETF71 Plenary

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Sun, 30 Dec 2007 10:15:25 -0800

It is a question of ambition. At sixteen I was interested in mastering the computer at its most fundamental level. I wrote arcade games in 6502 and Z80 assembler.

Today the idea of booting linux on a laptop would not make my top ten, hundred or thousand list of must do before I die experiences. In other words I have a life.

I can see the point of creating a drop dead date for the ipv6 world to get its act together and be ready for prime time - including support for dns records servers and the like.

I do not see the point of any test predicated on the assumption that legacy IPv4 devices are upgraded. 

Nor do I see any point in any test predicated on the expectation that large numbers of people will ever learn about IPv6 administration.

I know what micrcode is, I have even written some.  I know the role of microcode in VLSI design. If I was teaching a comp sci course I would want the students to know all about microcode. That does not mean that I want or need the microcode for my cpu before I program it. 

I don't know what lesson will be drawn here. The one I believe should be drawn is that we need to ask what the problem we are really trying to solve is.

Sent from my GoodLink Wireless Handheld (www.good.com)

 -----Original Message-----
From: 	Dave Crocker [mailto:[email-masked]]
Sent:	Friday, December 28, 2007 02:12 PM Pacific Standard Time
To:	Chris Lonvick
Cc:	[email-masked]
Subject:	Re: Change the subject! RE: [IAOC] Re: IPv4 Outage Planned for IETF71 Plenary

Chris Lonvick wrote:
> Hi,
> 
> Several people have written on this thread that they might not 
> participate in this experiment because they either won't have an IPv6 
> stack or that they're unwilling to experiment with the network settings 
> on their PCs. I'll suggest that those people can double their 
> experimental fun in a very low risk way by booting a live linux 
> distribution during the experiment.

While this looks like helpful information, for those able to use it, I think 
the point that the core point is still being missed:

      Some folks do not have that kind of control over their laptops.  They 
work for organizations which keep strict control over the software on the 
machines and/or the attendee does not happen to be someone who messes around 
with changes to their operating system.

While the press for testing IPv6 scenarios and demonstrating how to make many 
different ones work is definitely a Good Thing, the coercive quality about the 
approach to this particular exercise has an oddly macho tone:

      Real Geeks Hack Their Laptops.

In reality, it is entirely reasonable -- and for most of the world, essential 
-- for people to distinguish between a production platform and an experimental 
one, and to treat their mobile office platform as production.

Given the urgent need to get IPv6 more fully used, there is probably a good 
argument for forcing a public event like this (if it goes well... and maybe 
even if it doesn't) but we really ought to acknowledge that some attendees are 
disenfranchised.

d/

-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf
_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Greg Skinner <[email-masked]>
Date: Sun, 30 Dec 2007 21:43:51 +0000

Hallam-Baker, Phillip <[email-masked]> wrote:

> It is a question of ambition. At sixteen I was interested in mastering
> the computer at its most fundamental level. I wrote arcade games in
> 6502 and Z80 assembler.

> Today the idea of booting linux on a laptop would not make my top ten,
> hundred or thousand list of must do before I die experiences. In other
> words I have a life.

Actually, for someone with some Linux or Unix sysadmin experience, it
is not that difficult with Linux live distros.  Insert the CD- or
DVD-ROM with the distro in the CD/DVD drive and reboot. (It may be
necessary to tell the BIOS to boot from the CD/DVD drive; check the
laptop manufacturer's manual for the proper instructions.) Linux
should come up right away.  I used Ubuntu 6.06 and both IPv4 and IPv6
were enabled when the system came up.  Since I didn't have native IPv6
connectivity, I needed to build a tunnel.  The Linux+IPv6-HOWTO
documentation (http://www.tldp.org/HOWTO/Linux+IPv6-HOWTO) was very
helpful.  I was able to confirm that I was using IPv6 by visiting
www.ripe.net at its IPv6 address and verifying my IPv6 address on
their page.

If you have little or no Linux or Unix sysadmin experience, I'd advise
going through the process before the meeting.  No changes will be made
to your hard disk (unless you make them).  If you get stuck, you can
always reboot and start over from scratch.

> [snip]

> Nor do I see any point in any test predicated on the expectation
> that large numbers of people will ever learn about IPv6
> administration.

> I know what micrcode is, I have even written some.  I know the role
> of microcode in VLSI design. If I was teaching a comp sci course I
> would want the students to know all about microcode. That does not 
> mean that I want or need the microcode for my cpu before I program it.

> I don't know what lesson will be drawn here. The one I believe
> should be drawn is that we need to ask what the problem we are really
> trying to solve is.

Unfortunately, using a live Linux distro won't help people who need
what they normally use that isn't available on the distro CD (or can
be downloaded).  However, it can be a useful exercise just for getting
people to use IPv6 who might not otherwise.

--gregbo