Subject: Re: Revising full standards

From: "Eric Burger" <[email-masked]>
Date: Fri, 7 Dec 2007 05:45:21 -0800

Good point: there is no effective difference between MAIL-1982 / MAIL-2001 and RFC 822 / RFC 2822.

I'd second the motion to whack STD designation. Nobody wants STD's, anyway ;-)

--
Sent from my wireless e-mail device. Sorry if terse.  We all need lemonade: see <http://www.standardstrack.com/ietf/lemonade> for what lemonade is.

----- Original Message -----
From: John C Klensin <[email-masked]>
To: Eric Burger; [email-masked] <[email-masked]>
Sent: Fri Dec 07 05:35:55 2007
Subject: Re: Revising full standards

--On Thursday, 06 December, 2007 19:33 -0800 Eric Burger
<[email-masked]> wrote:

> 61 of the 67 have nmemonic identifiers, like SMTP and MAIL. I
> would also lean toward IETF-SMTP-2008.

A proposal from a family that, as you might recall, has been
discussed many times and gone nowhere.  Of course, as soon as
one attaches a date, one has solved a problem different from
"stable identifier for the current version of the standard".
And, of course, unless these can identify other than Full
Standards, they don't solve any of the STD problem that concerns
me.

And, FWIW, if you think "MAIL" is the identifier for some
protocol or set of protocols, you have illustrated another
problem.  :-)

> I actually have mixed feelings about interop. Part of me says
> that going to Internet Standard is mostly about removing
> cruft. However, in theory, a full regression test is not over
> the top. I still vote for ad hoc. Let the IESG or, since there
> are so few, the IAB, decide if this particular revision of
> that protocol warrants a full redo of the interoperability
> report.

This works for me as long as we solve the STD problem in some
way.   And simply throwing them away so they aren't misleading
would fall into the class of options I'd consider a solution.

I'd like to hear from others.  If no one else cares, I'll just
generate an I-D/ proposal to abolish STDs on the grounds that
the 'running code' doesn't work.

     john

Notice:  This email message, together with any attachments, may contain information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated entities,  that may be confidential,  proprietary,  copyrighted  and/or legally privileged, and is intended solely for the use of the individual or entity named in this message. If you are not the intended recipient, and have received this message in error, please immediately return this by email and then delete it.

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Bob Braden <[email-masked]>
Date: Mon, 10 Dec 2007 11:27:31 -0800

>I'd second the motion to whack STD designation. Nobody wants STD's, anyway ;-)

I believe that many people want stable definitions of "well-known" Internet 
standards.\,
like SMTP (or IP, for that matter).  STDs were a relatively simple but 
inadequate
solution for this.  Let's not kill STDs before we agree on a better solution.

Bob Braden

---

From: Dave Crocker <[email-masked]>
Date: Mon, 10 Dec 2007 11:46:00 -0800

Bob Braden wrote:
> standards. like SMTP (or IP, for that matter).  STDs were a relatively 
> simple but inadequate solution for this.  Let's not kill STDs before we 
> agree on a better solution.

The two limitations to the current STD scheme seem to be a) use of a number,
and b) inability to support simultaneous versions of the same specification.

Numbers are not mnemonic, and we do have the reality of revisions that take a
long time to replace the earlier version.

Switching to an acronym label with a year qualifier ought to fix both of these.

Hence the change would be to the STD naming rule, not the existence of STD.

d/

-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net