Subject: are we the ISDTF? was: Let's look at it from an IETF oldie's perspective... Re: IPv4 Outage Planned for IETF 71 Plenary

From: [email-masked]
Date: Thu, 20 Dec 2007 19:34:36 +0200

Are we the Internet Standardization Development Task Force? It seems by this thread, many of us are afraid to do any engineering and just work on emails and paper.   
I don't know about others, but I always liked testing some new technology at IETF meetings, but that seems less common these days.
John 

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Marshall Eubanks <[email-masked]>
Date: Thu, 20 Dec 2007 13:46:49 -0500

For a long time, there was a fair amount of multicast debugging and  
deployment that was driven / accelerated / or took advantage of the  
IETF meetings being multicast. (On that note I wish that there was  
still at least some multicast video going out from the IETF, say of  
the plenaries.) I also remember that my first use of 802.11  
technology was at an IETF meeting (Pittsburgh, IIRC) and IETF  
meetings have been used to test MANET's on a wireless LAN. I'm sure  
that there have been other cases over the years.

This is a good thing, I think, and should be supported and continued.

Regards
Marshall

On Dec 20, 2007, at 12:34 PM, [email-masked] wrote:

> Are we the Internet Standardization Development Task Force? It  
> seems by this thread, many of us are afraid to do any engineering  
> and just work on emails and paper.
> I don't know about others, but I always liked testing some new  
> technology at IETF meetings, but that seems less common these days.
> John
>
>

---

From: Sam Hartman <[email-masked]>
Date: Thu, 20 Dec 2007 15:37:24 -0500

>>>>> "john" == john loughney <[email-masked]> writes:

    john> Are we the Internet Standardization Development Task Force?
    john> It seems by this thread, many of us are afraid to do any
    john> engineering and just work on emails and paper.  

I *knew* there was some reason I didn't like ISDs from newtrk:-)

---

From: Dave Crocker <[email-masked]>
Date: Thu, 20 Dec 2007 16:48:02 -0500

> I don't know about others, but I always liked testing some new technology at IETF meetings, but that seems less common these days.

John,

Apparently you missed the several notes that thought experimentation was fine 
and that pursuing a focused interoperability activity would be an excellent task.

The distinction is between "experimentation" and "production", rather than 
resistance to any experimentation.

-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

---

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Fri, 21 Dec 2007 07:27:12 -0800

It is a different conception of engineer.
 
My conception of being an engineer is similar to that of a doctor over a nurse practitioner. A doctor has to be able to do any of the minor surgical performed by nurse practitioners (removing stitches, injections, etc.) but that is not where they provide input.
 
In the Roman army the engineers were the soldiers that designed the fortifications, roads, seige engines etc. The actual manual labor was performed by enlisted men and slaves.
 
My conception of Internet engineering is that we are rather too fond of performing the equivalent of manual labor. Configuring machines should not be work for any human, let alone an engineer. We need to become more intollerant of the need for configuration hackery, not less.

The computer asks to connect to the network and the network figures out how to support it. If the machine only knows how to ask for an IPv4 address its the job of the network to just figure it out.

________________________________

From: [email-masked] [mailto:[email-masked]]
Sent: Thu 20/12/2007 12:34 PM
To: Lucy Lynch
Cc: Bob Braden; [email-masked]
Subject: are we the ISDTF? was: Let's look at it from an IETF oldie's perspective... Re: IPv4 Outage Planned for IETF 71 Plenary