Subject: Re: Revising full standards

From: "Eric Burger" <[email-masked]>
Date: Thu, 6 Dec 2007 19:33:13 -0800

61 of the 67 have nmemonic identifiers, like SMTP and MAIL. I would also lean toward IETF-SMTP-2008.

I actually have mixed feelings about interop. Part of me says that going to Internet Standard is mostly about removing cruft. However, in theory, a full regression test is not over the top. I still vote for ad hoc. Let the IESG or, since there are so few, the IAB, decide if this particular revision of that protocol warrants a full redo of the interoperability report.

--
Sent from my wireless e-mail device. Sorry if terse.  We all need lemonade: see <http://www.standardstrack.com/ietf/lemonade> for what lemonade is.

----- Original Message -----
From: John C Klensin <[email-masked]>
To: Eric Burger; [email-masked] <[email-masked]>
Sent: Thu Dec 06 18:25:39 2007
Subject: Re: Revising full standards

--On Thursday, 06 December, 2007 16:55 -0800 Eric Burger
<[email-masked]> wrote:

> Hardly seems worth the effort.
> 
> Of the 5092 RFCs published, just 67 are Full Standards.
> 
> Of those, how many realistically need updates?
> 
> Ad hoc may be a more efficient approach.  Or, are you thinking
> about a "lessons learned from RFC 2821-bis"?

Most of it would actually be "lessons learned from RFC 2821".
The only new issue introduced by 2821bis is the need, as some
have read the rules, to formally demonstrate that email works
and interoperates (not just whatever changes were introduced in
2821, but the whole business).  Now, if you and a few thousand
other people get this message, I'd claim a reasonable case has
been made that it works, but one could always debate that.

On the other hand, the STD number situation is leading us into
silly states.  For example, there are documents all around the
world that do what we told them, which is to write "implement
STD 10" for "support SMTP".   Try the exercise of determining
what STD 10 is today (because a pointer to RFC 821 would be
wrong and one to 2821 would violate the rules).  So one
alternate fix is to abandon STD numbers.  Those silly states are
a bad idea and since, as you point out, there are only 67 full
standards, maybe we don't need the numbers.

    john

Notice:  This email message, together with any attachments, may contain information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated entities,  that may be confidential,  proprietary,  copyrighted  and/or legally privileged, and is intended solely for the use of the individual or entity named in this message. If you are not the intended recipient, and have received this message in error, please immediately return this by email and then delete it.

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: John C Klensin <[email-masked]>
Date: Fri, 07 Dec 2007 08:35:55 -0500

> would also lean toward IETF-SMTP-2008.

A proposal from a family that, as you might recall, has been
discussed many times and gone nowhere.  Of course, as soon as
one attaches a date, one has solved a problem different from
"stable identifier for the current version of the standard".
And, of course, unless these can identify other than Full
Standards, they don't solve any of the STD problem that concerns
me.

And, FWIW, if you think "MAIL" is the identifier for some
protocol or set of protocols, you have illustrated another
problem.  :-)

> I actually have mixed feelings about interop. Part of me says
> that going to Internet Standard is mostly about removing
> cruft. However, in theory, a full regression test is not over
> the top. I still vote for ad hoc. Let the IESG or, since there
> are so few, the IAB, decide if this particular revision of
> that protocol warrants a full redo of the interoperability
> report.

This works for me as long as we solve the STD problem in some
way.   And simply throwing them away so they aren't misleading
would fall into the class of options I'd consider a solution.

I'd like to hear from others.  If no one else cares, I'll just
generate an I-D/ proposal to abolish STDs on the grounds that
the 'running code' doesn't work.

     john

---

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Fri, 7 Dec 2007 09:15:23 -0800

John,
 
Stating that a proposal has been discussed before is a standard strategy of agenda denial. Every time the issue is raised the reason for making no change is either 'we have not done things that way in the past' or 'this has been discussed before'. We go round in circles without discussing the substance of the problem, the result reinforces the failed status-quo.
 
Maybe an amateur approach to semiotics is as counter-productive as the 'amateur lawyering' you detest when the points raised conflict with your own point of view. The STD series has been a failure by any standard. As a former experimental scientist I beleive that when you try something and it fails you consider the possibility something else might be better.
 
I did not want to take the bait you left Tuesday morning because I wanted to concentrate on the substance rather than engage in a snark-fest. On that occasion you continued. Given that you have identified the fact that there is a problem, let us leave asside the snark and address the actual issues.

The proposal I originally made had two levels:
 
IETF-SMTP for the mail protocol standard
IETF-SMTP-YYYY for a particular version of the standard
 
In some cases one wishes to refer to a particular version, in others not. In the example I gave the distinction between the versions was relevant. In other cases it is not. For example a Web Service might well state that it is layered on IETF-HTTP might not speficy the version of HTTP.
 
The reason for specifying IETF-SMTP rather than mere SMTP is twofold:
 
1) We need to clearly distinguish a protocol standard from a protocol. The term SMTP does not carry the intended semiotics.
 
2) The choice of IETF vs some other label (e.g. STD) is both the fact that STD is unacceptable and the fact that there are multiple competing standards bodies out there and the IETF can benefit from the branding leverage.

One of the experimental results we might deduce from the relative success of IETF application protocols over their OSI competitors is that text based mnemonic labels are more successful than pure numbers. From: and To: make for a much more successful protocol than their ASN.1 equivalents.
 
Steve Crocker's original proposal for the RFC series was close to the spirit of a modern Wiki. The numbering scheme was proposed precisely because the identifiers should not matter. We are now trying to influence the direction of the worlds most successful communication infrastructure with over a billion users. The manner in which we communicate our message has a greater effect than the message itself.
 
The vast majority of the people we need to influence have no knowledge of or concern for IETF traditions. We have to communicate in ways that they are receptive to.

The bigger problem is that for whatever reason, Vint, Jon and co did not provide an effective mechanism for changing the opperating practices of the IETF. We can accrete new traditions but we are unable to shed or modify old ones, no matter how much make-work this results in.
 
I can write up my proposal as an Internet draft, but what is the process for reviewing or progressing it? 

________________________________

From: John C Klensin [mailto:[email-masked]]
Sent: Fri 07/12/2007 8:35 AM
To: Eric Burger; [email-masked]
Subject: Re: Revising full standards

--On Thursday, 06 December, 2007 19:33 -0800 Eric Burger
<[email-masked]> wrote:

> 61 of the 67 have nmemonic identifiers, like SMTP and MAIL. I
> would also lean toward IETF-SMTP-2008.and resolved in the past does not excuse you 

     john