Subject: Deployment Cases

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Sun, 23 Dec 2007 10:32:37 -0800

Problem: We have a lot of specifications that work fine, but have not seen deployment
 
Examples: Most security specifications, IPv6, etc. etc.
 
Cause: The economic case for deployment is not made. This is a particular concern when the protocol deplends on the network effect. Until the network is established the protocol has minimal value.
 
Proposed Solution: Deployment Cases
 
As engineers we are now used to considering use cases, that is representative use scenarios that illustrate particular intendeded uses. The output of use cases are requirements.
 
Deployment cases are similar except that we consider the economic incentives for transition. 
 
For example, Alice the home user has three computers and two network addressable printers, all of which currently support IPv4, Bob is the netop at a medium sized corporation, Carol is CIO of a F500 corporation.
 
For each adoption case consider the costs and benefits of proposed transition architectures. 
 
I develop the underlying theory in The dotCrime Manifesto. The problem we face is very similar to the problem faced in the area of energy conservation, how does a state persuade consumers to use less electricity so it does not need a new power plant? Until this discussion however I had not really considered the problem of how to build these considerations into the standards process.
 
We have to take adoption really seriously. Take a look at your email client, chances are 0.95 or better that it supports S/MIME. How many emails do you see each day that are S/MIME signed? We cannot accept a 'success' of that type here.
_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Rémi Després <[email-masked]>
Date: Sun, 23 Dec 2007 22:04:32 +0100

Hallam-Baker, Phillip wrote :
> *Problem*: We have a lot of specifications that work fine, but have not 
> seen deployment

That's coming.

See:
http://www.telecompaper.com/news/article.aspx?id=196198

And, if you read French:
http://www.freeplayer.org/viewtopic.php?p=55711#55711

An I-D on the (new) technique used for this rapid and actual deployment 
is being worked on.
It should comme soon (after holidays).

Regards.

Rémi

---

From: Marc Manthey <[email-masked]>
Date: Sun, 23 Dec 2007 22:50:19 +0100

On Dec 23, 2007, at 10:04 PM, Rémi Després wrote:

>> *Problem*: We have a lot of specifications that work fine, but  
>> have not seen deployment
>
> That's coming.
>
> See:

hello Rémi

thanks for the pointer, found  them on the native ipv6 pops site at  
sixxs.net
<http://www.sixxs.net/faq/connectivity/?faq=native>
	Proxad / Free SAS	 	DSL	6to4rd	IPv6 Press Release

> An I-D on the (new) technique used for this rapid and actual  
> deployment is being worked on.

i see they use "6to4rd" technologie so its a gateway ? You know any  
english details ,
is that what you talking about ? THANKS!!!

merry christmas

marc

> Rémi

"Any intelligent fool can make things bigger and more complex...
It takes a touch of genius - and a lot of courage to move in the  
opposite direction."
Albert Einstein

web: http://www.let.de

Fingerprint=0x40dec07168d2e810

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 27 Dec 2007 09:32:41 +1300

Phill,

> Deployment cases are similar except that we consider the economic incentives for transition. 

IMHO, whenever the IETF has tried to do anything like this, we've
failed. A good (er, bad) example was draft-ietf-iab-case-for-ipv6,
which had so many issues that it was allowed to curl up and die.

Basically, we aren't business-oriented people or economists,
and we don't tolerate marketing-style bending of the facts.

I'm pessimistic about trying this in the IETF, even for
technologies that are aimed at the greater good, where the
economic arguments are not about short term returns for
individual companies.

     Brian

---

From: Franck Martin <[email-masked]>
Date: Thu, 27 Dec 2007 14:55:53 +1200

Brian et al,

I remember Vint told me in the early days, he had to pay people to
develop a TCP/IP stack on various OSes. This is how partly he got
adoption and interoperability.

While it is not the role of IETF to do that, I feel part of the
solution is there. Pay people to implement protocols for the greater
good on various platforms, the market will do the rest after a
significant user base is built.

Cheers

Brian E Carpenter wrote:
>> Cause: The economic case for deployment is not made. This is a
>> particular concern when the protocol deplends on the network
>> effect. Until the network is established the protocol has minimal
>>  value.
>>
>> As engineers we are now used to considering use cases, that is
>> representative use scenarios that illustrate particular
>> intendeded uses. The output of use cases are requirements.
>>
> Basically, we aren't business-oriented people or economists, and we
> don't tolerate marketing-style bending of the facts.
>
> technologies that are aimed at the greater good, where the economic
> arguments are not about short term returns for individual
> companies.
>
> Brian
>
> _______________________________________________ Ietf mailing list
> [email-masked] https://www1.ietf.org/mailman/listinfo/ietf

- --
- -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Franck Martin
[email-masked]
"Toute connaissance est une réponse à une question"
G. Bachelard