Subject: Re: Appeal against IESG blocking DISCUSS on draft-klensin-rfc2821bis

From: Bernard Aboba <[email-masked]>
Date: Mon, 23 Jun 2008 19:41:27 -0700

Russ Housley said:
 
"I agree with this principle. In fact, I think that the IESG has taken many steps over the last four or more years to reduce the nearly-end-of-process surprises. Obviously, you do not think these measures have been sufficient. One lesson from the many attempts to make updates to RFC 2026 is that such policy documents needs to set expectations without taking away flexibility and judgement. "
 
Can you elaborate on what steps the IESG has taken to reduce the "nearly-end-of-process surprises" and why effect this has had, if any?  For example, have the delays resulting from IESG reviews actually *decreased* as a result?
 
The research by Prof. Simcoe of the Rotman School is not encouraging:
http://www.rotman.utoronto.ca/strategy/research/working%20papers/Simcoe%20-%20Delays.pdf

_______________________________________________
IETF mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Tue, 24 Jun 2008 11:41:34 +0200

--On Monday, June 23, 2008 07:41:27 PM -0700 Bernard Aboba 
<[email-masked]> wrote:

> Russ Housley said:
>
> "I agree with this principle. In fact, I think that the IESG has taken
> many steps over the last four or more years to reduce the
> nearly-end-of-process surprises. Obviously, you do not think these
> measures have been sufficient. One lesson from the many attempts to make
> updates to RFC 2026 is that such policy documents needs to set
> expectations without taking away flexibility and judgement. "
>
> Can you elaborate on what steps the IESG has taken to reduce the
> "nearly-end-of-process surprises" and why effect this has had, if any?
> For example, have the delays resulting from IESG reviews actually
> *decreased* as a result?
>

The Simcoe dataset ends in approximately 2001.

This was 2 years before the I-D tracker got implemented. 'Nuff said.

                  Harald

---

From: Russ Housley <[email-masked]>
Date: Tue, 24 Jun 2008 10:19:06 -0400

Bernard:

Many of the IESG activities are listed in John's appeal.  The DISCUSS 
Criteria document is probably the biggest step that was taken.  ADs 
routine challenge each other to stay within those guidelines.

At the IESG Retreat we had a discussion on this topic.  It is very 
hard to measure.  During the discussion, we quickly discovered that 
there are a number of DISCUSS positions related to some comment that 
was raised in Last Call but not addressed in any way.  One cannot 
call these "late surprises" and most of them are resolved very quickly.

We have a way to count DISCUSS positions, but we do not have a way to 
figure out what percentage of them are perceived as "late surprises" 
by the community.  So, while we are taking action in an attempt to 
make things better, we do not have a way to measure our success or 
failure beyond community perception.  Suggestions on making this more 
objective and less subjective are greatly appreaciated.

Russ

At 10:41 PM 6/23/2008, Bernard Aboba wrote:
>Russ Housley said:
>
>"I agree with this principle. In fact, I think that the IESG has 
>taken many steps over the last four or more years to reduce the 
>measures have been sufficient. One lesson from the many attempts to 
>make updates to RFC 2026 is that such policy documents needs to set 
>"nearly-end-of-process surprises" and why effect this has had, if 
>any?  For example, have the delays resulting from IESG reviews 
>actually *decreased* as a result?
>
><http://www.rotman.utoronto.ca/strategy/research/working%20papers/Simcoe%20-%20Delays.pdf>http://www.rotman.utoronto.ca/strategy/research/working%20papers/Simcoe%20-%20Delays.pdf

---

From: Bernard Aboba <[email-masked]>
Date: Tue, 24 Jun 2008 08:32:37 -0700

> objective and less subjective are greatly appreciated.
> 
> Russ

I agree that it might be hard to measure the effect of particular actions (e.g. changes in
procedures).  However, it is *not* hard to measure overall trends in performance, and
to break these trends down between areas and types of documents. 

My understanding is that the Simcoe dataset continues beyond 2001, and that with some
relatively modest effort, a detailed analysis could be produced quantifying how the IETF
has performed.  This would give us a window into what the actual results have been. 
_______________________________________________
IETF mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf