Subject: RNET: Randon Network Endpoint Technology

From: Chad Giffin <[email-masked]>
Date: Thu, 19 Jun 2008 12:48:35 -0400

Chad Christopher Giffin
Suite 205
123 Mayfair Avenue
Winnipeg, Manitoba
Canada   R3L 0A1

Phone: 1  204  475-1210

June 18th, 1145h CDT

To all members of the IETF mailing list;

     I have posted a description, twice, of the RNET protocol to this mailing list.  I have also provided some updates concerning peer to peer connections between RNET Hosts.

     I have yet to receive /any/ response (other then an email with an empty body) concerning by postings.

     Please tell me what you, as members of this list, think about RNET.

     Should it exist?
     Who should be allowed to use it?
     Should it exists and remain hidden?
     Has anything been overlooked in it's design? 
     How much more work is needed to make this a reality (besides have the Vendors of routing equipment and software incorporate this technology into their IP stacks?)

     I am a great many people support this technology and we wish it to be a reality.

     Please provide some response.
     It need not be too revealing.
     At least show some support.

     So many of us would appreciate anonynimity on the Internet to avoid being detected by those who should never know of our identity and/or location.  As well, it will deter quite effificiently crackers from attacking our systems.

     The end result would simply be that all serious individual users (nodes) of the Internet would have anonymous endpoints and the advertised endpoints would be what is publically accessible.

Yours Truly,

Chad Christopher Giffin
a.k.a.  "typo"

_________________________________________________________________

_______________________________________________
IETF mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf

---

From: "Dan Wing" <[email-masked]>
Date: Thu, 19 Jun 2008 09:57:18 -0700

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Chad Giffin
> Sent: Thursday, June 19, 2008 9:49 AM
> To: IETF
> Subject: RNET: Randon Network Endpoint Technology
> 
> 
> 
> Chad Christopher Giffin
> Suite 205
> 123 Mayfair Avenue
> Winnipeg, Manitoba
> Canada   R3L 0A1
> 
> Phone: 1  204  475-1210
> 
> June 18th, 1145h CDT
> 
>      I have posted a description, twice, of the RNET protocol 
> to this mailing list.  I have also provided some updates 
> concerning peer to peer connections between RNET Hosts.
> 
>      I have yet to receive /any/ response (other then an 
> email with an empty body) concerning by postings.

Here is a response, which appeared to have been CC'd to you:
http://www.ietf.org/mail-archive/web/ietf/current/msg51774.html

I agree with Eric; based on the description of RNET, it sounds much like STUN
combined with a rendezvous protocol (e.g., SIP).  RNET is also similar to
HIP's NAT traversal.

STUN is RFC3489 and draft-ietf-behave-rfc3489bis.  SIP is RFC3261.  The use of
STUN with SIP is best described in draft-ietf-sipping-nat-scenarios.  HIP's
NAT traversal is described in draft-ietf-hip-nat-traversal.  

Hope that helps,
-d

>      How much more work is needed to make this a reality 
> (besides have the Vendors of routing equipment and software 
> incorporate this technology into their IP stacks?)
> 
>      So many of us would appreciate anonynimity on the 
> Internet to avoid being detected by those who should never 
> know of our identity and/or location.  As well, it will deter 
> quite effificiently crackers from attacking our systems.
> 
>      The end result would simply be that all serious 
> individual users (nodes) of the Internet would have anonymous 
> endpoints and the advertised endpoints would be what is 
> publically accessible.
> 
> 
> Yours Truly,
> 
> Chad Christopher Giffin
> a.k.a.  "typo"
>