Subject: RE: Single-letter names (was: Re: Update of RFC 2606 based on therecent ICANN changes?)

From: Ted Hardie <[email-masked]>
Date: Mon, 7 Jul 2008 09:47:10 -0700

At 9:25 AM -0700 7/7/08, [email-masked] wrote:
> > However, many concepts in modern Chinese
>dialects require multiple syllables to express them and
>therefore multiple characters to write them. So there isn't
>really a one to one mapping of word, syllable, concept as
>many people suppose.

While there may not be a one-to-one mapping of word,
character, and concept every time, there are many words
and concepts which can be given (and commonly given)
in a single character.  Forcing  those to use multiple characters
to get around a policy limitation may introduce, rather than reduce confusion. 

Why would we want to insist on that?
				Ted
_______________________________________________
Ietf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf

---

From: Eric Brunner-Williams <[email-masked]>
Date: Mon, 07 Jul 2008 23:49:42 -0500

Ted,

As Edmond pointed out, the position at present is that:

"Single and two-character U-labels on the top level and second level of a domain name should not be restricted in general."

I personally expect that for applications made as "IDN ccTLD", whether 
"fasttrack" or not, will be reviewed for some "meaning". It is my 
understanding however, that in general, an application for a generic TLD 
is not, in the plan of record, presently reviewed for "meaning", at 
least, not in any sense that would preclude a single Unicode glyph.

Example, the Cree character for the "i" vowel (a delta triangle), 
encoded as xn--zce, is a "single character", and has no "sense" other 
than a vowel, is allowable, as is the ascii character sequence "iii", 
which also has no "sense" other than a (repeated) vowel.

Your milage may vary, etc.

Eric

Ted Hardie wrote:
> Idna-update mailing list
> [email-masked]
> http://www.alvestrand.no/mailman/listinfo/idna-update
>
>
>

---

From: John C Klensin <[email-masked]>
Date: Mon, 07 Jul 2008 15:14:09 -0400

--On Monday, 07 July, 2008 09:47 -0700 Ted Hardie
<[email-masked]> wrote:

> in a single character.  Forcing  those to use multiple
> characters to get around a policy limitation may introduce,
> rather than reduce confusion. 
> 

Given that there are more than enough characters in the Han
(CJK) script to make the risks of off-by-one errors fall in the
same range as two or three character domains in more alphabetic
scripts, I hope no one.  

Unless someone seriously believes that these limits --whatever
they might or might not be-- should be enforced by the IDNA
protocol, can we stop coping that mailing list on this
discussion?  I don't believe anyone has suggested protocol-level
enforcement so far.

    john