Subject: Re: DNS/IP

From: Toni Stoev <[email-masked]>
Date: Mon, 12 Jan 2009 23:56:29 +0200

On Monday 12 January 2009 00:51:24 TSG sent:
> Toni Stoev wrote:
> > Hi,
> >
> > DNS job
> >
> > When a connection to a network node is to be initiated its DNS name is resolved to an IP address which shows the location of the node on the network. So network nodes are findable by name even if their locations change.
> >   
> I think you are backwards...  The nodes are still reachable if they 
> change their physical location or the assigned networks addresses 
> temporarily mapped too those names by DNS or DHCP.

Findable, not reachable, even just identifiable, is what is essential for the naming system DNS.

> > The job of the DNS is to identify a node by its name. Another job is to maintain information about node's current location so a new connection can be started at any time.
> >   
> Hmm... I think the job of DNS is to map the 'text based system names' to 
> a network address that the routing infrastructure and features can 
> create a set of pathways for that data to reach said system.

The job of the Domain Name System, not routing or delivery system, is to map names to identity. Furthermore, identity mapped to may be of entire routing domains, aggregating nodes.

> > Why should DNS be bothered with connectivity and/or topology status?
> > There must be a distinct mechanism to handle mapping of node identity to network location.
> >   
> GeoPriv would have you believe that another

Still network location is disticnt from geographic.

I suggest that there be a networking asset, an address type, that represents network identity of nodes. And addresses of that type be resolved to by DNS name queries and be mapping to unicast network addresses.
This way DNS shall be unburdened of connectivity, routing and reachability issues related to named nodes.
_______________________________________________
Ietf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf

---

From: "Hui Deng" <[email-masked]>
Date: Mon, 12 Jan 2009 21:27:10 -0700

May I chime in, I feel identity type is a good idea.

But if you map DNS to other identity,
how network socket connection could work in that case/

thanks for your consideration

-Hui

2009/1/12 Toni Stoev <[email-masked]>

> > > When a connection to a network node is to be initiated its DNS name is
> resolved to an IP address which shows the location of the node on the
> network. So network nodes are findable by name even if their locations
> change.
> > >
> > > The job of the DNS is to identify a node by its name. Another job is to
> maintain information about node's current location so a new connection can
> be started at any time.
> > >
> The job of the Domain Name System, not routing or delivery system, is to
> map names to identity. Furthermore, identity mapped to may be of entire
> routing domains, aggregating nodes.
>
> I suggest that there be a networking asset, an address type, that
> represents network identity of nodes. And addresses of that type be resolved
> to by DNS name queries and be mapping to unicast network addresses.

---

From: Toni Stoev <[email-masked]>
Date: Wed, 14 Jan 2009 01:43:53 +0200

> how network socket connection could work in that case/

Shortly, like socket connection for anycast TCP does.
You tune right in, see identity type is useful namely for connection inititation and re-establishment. It thereforе shall natively underlie IP mobility.

---

From: "Raman Chan" <[email-masked]>
Date: Wed, 14 Jan 2009 10:32:09 +0800

HIP?

On Wed, Jan 14, 2009 at 7:43 AM, Toni Stoev <[email-masked]> wrote:

> You tune right in, see identity type is useful namely for connection
> inititation and re-establishment. It thereforе shall natively underlie IP
> mobility.
>
> >
> > > Findable, not reachable, even just identifiable, is what is essential
> for
> > > the naming system DNS.
> > >
> > > > > There must be a distinct mechanism to handle mapping of node
> identity
> > > to network location.
> > > > >
> > > This way DNS shall be unburdened of connectivity, routing and
> reachability
> > > issues related to named nodes.

---

From: Toni Stoev <[email-masked]>
Date: Thu, 15 Jan 2009 05:19:14 +0200

> HIP?

In HIP the Host Identity is a public key. I suggest that node identity be network connectivity cognition, i.e., an identity address shall be an acquaintance path to a node. Acquaintant are two nodes that know each other's unicast addresses. A packet with identity address destination shall travel acquaintance path. Identity is formed of acquaintances.
Socket formation in HIP is a good idea.