Subject: DNS/IP

From: Toni Stoev <[email-masked]>
Date: Sun, 11 Jan 2009 23:14:15 +0200

Hi,

DNS job

When a connection to a network node is to be initiated its DNS name is resolved to an IP address which shows the location of the node on the network. So network nodes are findable by name even if their locations change.
The job of the DNS is to identify a node by its name. Another job is to maintain information about node's current location so a new connection can be started at any time.
Why should DNS be bothered with connectivity and/or topology status?
There must be a distinct mechanism to handle mapping of node identity to network location.
_______________________________________________
Ietf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf

---

From: TSG <[email-masked]>
Date: Sun, 11 Jan 2009 14:51:24 -0800

> When a connection to a network node is to be initiated its DNS name is resolved to an IP address which shows the location of the node on the network. So network nodes are findable by name even if t…
I think you are backwards...  The nodes are still reachable if they 
change their physical location or the assigned networks addresses 
temporarily mapped too those names by DNS or DHCP.
> The job of the DNS is to identify a node by its name. Another job is to maintain information about node's current location so a new connection can be started at any time.
Hmm... I think the job of DNS is to map the 'text based system names' to 
a network address that the routing infrastructure and features can 
create a set of pathways for that data to reach said system.
> There must be a distinct mechanism to handle mapping of node identity to network location.
GeoPriv would have you believe that another
> ------------------------------------------------------------------------
>
>
> Internal Virus Database is out of date.
> Checked by AVG - http://www.avg.com 
> Version: 8.0.176 / Virus Database: 270.10.4/1880 - Release Date: 1/7/2009 8:49 AM
>
>