Subject: World IPv6 Day and Us

From: Sabahattin Gucukoglu <[email-masked]>
Date: Tue, 15 Feb 2011 17:45:01 +0000

Noting the increasing length of the list at http://isoc.org/wp/worldipv6day/participants/ (now with many former staunch nay-sayers on it, pleasingly), and that the ISOC considers itself a member, I think it only right to point out that we (IETF, IRTF, IESG, IAB, ICANN, IANA, et al) are not listed.

I don't suppose now is the time for an April 1 RFC discussing our commitment to the IPv6 protocol, and our intent to be present on World IPv6 day ......... is it?

Yes, I think we probably deserve a small slice of that publicity pie, too. :-)

Cheers,
Sabahattin

---

From: Shumon Huque <[email-masked]>
Date: Tue, 15 Feb 2011 13:56:23 -0500

Maybe it's because IETF/IRTF already have their outward facing
services available over IPv6 (Web, Mail, &, DNS at least - I checked 
only for ietf.org and irtf.org).

The stated purpose of IPv6 day seems to be to get folks who don't 
have any IPv6 in production yet to make it available for a 24-hour 
period for a "test drive":

	On 8 June, 2011, Google, Facebook, Yahoo!, Akamai and
	Limelight Networks will be amongst some of the major organisations
	that will offer their content over IPv6 for a 24-hour "test
	flight". The goal of the Test Flight Day is to motivate organizations
	across the industry ? Internet service providers, hardware makers,
	operating system vendors and web companies ? to prepare their services
	for IPv6 to ensure a successful transition as IPv4 addresses run out.

But sure, it sounds fine to me if we are also publicising 
organizations who already have production IPv6 services running long
in advance of "World IPv6 Day".

--Shumon.

On Tue, Feb 15, 2011 at 05:45:01PM +0000, Sabahattin Gucukoglu wrote:
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf

-- 
Shumon Huque
University of Pennsylvania.

---

From: Sabahattin Gucukoglu <[email-masked]>
Date: Tue, 15 Feb 2011 19:50:27 +0000

> only for ietf.org and irtf.org).

Perhaps, but the same is true for ISOC.org.  Anyway, I'm not questioning ISOC's policy on the event, just making an observation.

Cheers,
Sabahattin

---

From: Russ Housley <[email-masked]>
Date: Tue, 15 Feb 2011 15:14:10 -0500

I have asked that www.ietf.org be added to the sites that are already IPv6 enabled.  I've also nudged the folks associated with these other organizations to do the same.

Russ

---

From: Lars Eggert <[email-masked]>
Date: Wed, 16 Feb 2011 11:13:37 +0200

On 2011-2-15, at 19:45, Sabahattin Gucukoglu wrote:
> Noting the increasing length of the list athttp://isoc.org/wp/worldipv6day/participants/

...I mostly note that I see very few eyeball ISPs on that list (with the notable exception of two large US cable ISPs - great, guys!)

Turning on IPv6 on the content provider side is great and all, but without the eyeballs on IPv6, I wonder a bit about the point of this exercise.

Lars

---

From: "Richard L. Barnes" <[email-masked]>
Date: Wed, 16 Feb 2011 08:29:49 -0500

Parts of the challenge here is that turning on IPv6 (publishing a AAAA) can also cause brokenness for users that have no IPv6 connectivity, e.g., those relying on broken 6to4 relays.  This has been documented all over the place, for example here:
<http://ripe61.ripe.net/presentations/162-ripe61.pdf>

So even if there are very few IPv6 eyeballs, this event can serve to flush out that flavor of brokenness.  As I understand it, part of the idea of everyone moving together is to get people to see the brokenness across multiple sites, thus to blame the network not the content provider, thus to pressure the networks to fix things.

--Richard

On Feb 16, 2011, at 4:13 AM, Lars Eggert wrote:

> Lars_______________________________________________
> Ietf mailing list
> [email-masked]

---

From: Marshall Eubanks <[email-masked]>
Date: Wed, 16 Feb 2011 08:58:58 -0500

> Turning on IPv6 on the content provider side is great and all, but without the eyeballs on IPv6, I wonder a bit about the point of this exercise.

You have to start somewhere...

And, this has been good at getting some publicity for IPv6, which is not negligible. 

Marshall

---

From: "Worley, Dale R (Dale)" <[email-masked]>
Date: Wed, 16 Feb 2011 09:43:11 -0500

> Turning on IPv6 on the content provider side is great and all, but without the eyeballs on IPv6, I wonder a bit about the point of this exercise.

The point is that eventually, someone will notice that the IETF is lobbying hard for IPv6 as the necessary next step for the Internet, but that the IETF doesn't actually use IPv6 in its own infrastructure, and we are greatly embarrassed.

It would be like lobbying regarding global warming while owning 500 coal-fired power plants.  It doesn't make what you *say* wrong, but it looks very, very bad.  It suggests that despite our advocacy of IPv6 there is some great difficulty to going to IPv6 that we are not admitting.

Dale

---

From: "Livingood, Jason" <[email-masked]>
Date: Wed, 16 Feb 2011 14:47:42 +0000

>Parts of the challenge here is that turning on IPv6 (publishing a AAAA)
>can also cause brokenness for users that have no IPv6 connectivity, e.g.,
>those relying on broken 6to4 relays.  This has been documented all over
>the place, for example here:
>So even if there are very few IPv6 eyeballs, this event can serve to
>flush out that flavor of brokenness.  As I understand it, part of the
>idea of everyone moving together is to get people to see the brokenness
>across multiple sites, thus to blame the network not the content
>provider, thus to pressure the networks to fix things.

Richard is exactly right on where a lot of value is. This is an
opportunity to find and fix the ~0.05% level of brokenness. Even
"non-participating" ISPs will need to take steps to prepare, and this is
of course a great forcing function within companies to ask what their IPv6
plans and to begin/continue IPv6 technical training, etc.

Jason

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 17 Feb 2011 08:19:38 +1300

> plans and to begin/continue IPv6 technical training, etc.

Over in v6ops, we have had some vigorous discussion about the anycast 6to4
brokenness and there is a draft:
   draft-carpenter-v6ops-6to4-teredo-advisory
My hope is that this will be in good enough shape prior to June 8th
that it can contribute to the day. Discussion welcome on the v6ops list.

    Brian