Subject: XKCD - Nanobots

From: Pete Resnick <[email-masked]>
Date: Mon, 28 Feb 2011 01:32:22 -0600

I'm sorry, but how could this *not* be posted to the IETF list?

<http://xkcd.com/865/>

pr

-- 
Pete Resnick<http://www.qualcomm.com/~presnick/>
Qualcomm Incorporated - Direct phone: (858)651-4478, Fax: (858)651-1102

---

From: Bob Hinden <[email-masked]>
Date: Mon, 28 Feb 2011 00:40:18 -0800

Pete,

> I'm sorry, but how could this *not* be posted to the IETF list?

I did a rough calculation and think they would have not run out of IPv6 addresses :-)

I assumed a nanobot was 1 x 10^-6 M^2 and the surface of the earth was 5.1 x 10^11 M^2 (from Wikipedia).  This means it would take 5.1 x 10^17 nanobots to cover the earth.  The IPv6 address space is 3.4 x 10^38.  Of course, I assumed only one layer deep. 

Bob

---

From: Yoav Nir <[email-masked]>
Date: Mon, 28 Feb 2011 10:58:05 +0200

> I assumed a nanobot was 1 x 10^-6 M^2 and the surface of the earth was 5.1 x 10^11 M^2 (from Wikipedia).  This means it would take 5.1 x 10^17 nanobots to cover the earth.  The IPv6 address space i…

Yes, but I think the nanobots are supposed to devour the entire earth, so it's volume that counts. The volume is about 1x10^21 m^3. So 40% is 4 x 10^20 m^3.  

3.4 x 10^38 nanobots comes to 8.5 x 10^17 nanobots per m^3, or about 1.17 microns^3 per nanobot.

Sounds about right.

---

From: João Damas <[email-masked]>
Date: Mon, 28 Feb 2011 10:16:28 +0100

> I assumed a nanobot was 1 x 10^-6 M^2 and the surface of the earth was 5.1 x 10^11 M^2 (from Wikipedia).  This means it would take 5.1 x 10^17 nanobots to cover the earth.  The IPv6 address space i…

is that with a /48 or a /64 per bot?

---

From: Bob Hinden <[email-masked]>
Date: Mon, 28 Feb 2011 11:41:39 +0200

> is that with a /48 or a /64 per bot?

A /128, of course.  I assume nanobots have very efficient ways to use subnets.

Bob

---

From: Bob Hinden <[email-masked]>
Date: Mon, 28 Feb 2011 11:45:38 +0200

Yoav,

> Yes, but I think the nanobots are supposed to devour the entire earth, so it's volume that counts. The volume is about 1x10^21 m^3. So 40% is 4 x 10^20 m^3.  

But they start from the outside and eat down.  This causes the surface area to decrease and less nonobots are required.  Or to put it another way, the don't have to replace the earth with nonbots :-)

> 3.4 x 10^38 nanobots comes to 8.5 x 10^17 nanobots per m^3, or about 1.17 microns^3 per nanobot.

This must have been one of the design goals :-)

Bob

---

From: Chris Elliott <[email-masked]>
Date: Mon, 28 Feb 2011 05:39:48 -0500

Bob, et al.:

I took the liberty of informing Randall that he hit the IETF list on his forum here:

http://forums.xkcd.com/viewtopic.php?f=7&t=68893

May take a bit for my post to get approved.

And, yes, I did point out that you commented...and were involved with the development of IPv6... ;-)

Enjoy, and see you all in Prague!
Chris.

--
Chris Elliott

---

From: Chris Elliott <[email-masked]>
Date: Mon, 28 Feb 2011 06:17:16 -0500

And I'll point out that this is not the first xkcd cartoon to be
referenced by IETF'ers:

http://www.ipv6now.com.au/news/TheStandardAug09.pdf

The referenced comic is # 195, "Map of the Internet,

http://www.xkcd.com/195/

And, as always with xkcd comics, check out the tool tip!

Enjoy again!
Chris.

-- 
Chris Elliott
[email-masked]

---

From: Yoav Nir <[email-masked]>
Date: Mon, 28 Feb 2011 13:18:15 +0200

Yup. It's posted (right after mine)

On Feb 28, 2011, at 12:39 PM, Chris Elliott wrote:

> Scanned by Check Point Total Security Gateway.

---

From: Michael StJohns <[email-masked]>
Date: Mon, 28 Feb 2011 11:08:23 -0500

>But they start from the outside and eat down.  This causes the surface area to decrease and less nonobots are required.  Or to put it another way, the don't have to replace the earth with nonbots :-)

Umm... are you ignoring conservation of mass?  Or are you assuming perfect conversion to energy?  If the latter, I would expect the nanobots to melt - actually vaporize or turn into plasma.  If the former, I'd expect replacing the earth with nanobots.  Or at least something with some mass and volume. 

>_______________________________________________
>Ietf mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/ietf

---

From: "Dan Wing" <[email-masked]>
Date: Mon, 28 Feb 2011 10:47:26 -0800

> I'm sorry, but how could this *not* be posted to the IETF list?

It appears www.xkcd.com added its AAAA on the same day, too.

-d