Subject: Final IPv4 Unicast Address Allocations

From: IETF Chair <[email-masked]>
Date: Thu, 3 Feb 2011 14:44:05 -0500

You have probably already heard the news, but just to make sure no one is left out of the loop, I am posting this note.

The last five /8 IPv4 address blocks were assigned today.

Two /8s were recently allocated to APNIC, which triggered the implementation of the Exhaustion Phase set out in the Global Policy for the Allocation of the Remaining IPv4 Address Space.  Today in Miami, Florida in a very nice ceremony, this policy was implemented, and each RIR received one of the final /8 address blocks.  As of now, there are no more unallocated IPv4 unicast /8s in the IANA pool. The current status of the IPv4 address space can be seen in the IANA IPv4 Address Space Registry at:

   http://www.iana.org/assignments/ipv4-address-space/ipv4-address-space.xhtml

We have all known that this day was coming for a long time.  In preparation, the IETF developed IPv6.  IPv6 is ready, and it has been ready for a long time.  This milestone simply increases the urgency for IPv6 deployment.  The explosive growth of the Internet can only continue with the bigger address space offered by IPv6.
 
The depletion of the IANA IPv4 address pool is not a crisis.  Next week the Internet will not be significantly different that it was a week ago.  There will not be any notable short-term effects caused by the empty IANA IPv4 address pool.
 
There is no crisis, but there is a need for action so that the Internet can continue to grow.  The transition to IPv6 requires the attention of many actors.  However, our parents, spouses, and children will be largely unaware of the transition.  They will continue to be amazed of the endless possibilities offered by the growing Internet.  For them, this milestone will remain insignificant.

To the universal deployment of IPv6,
  Russ

---

From: Lucy Lynch <[email-masked]>
Date: Thu, 3 Feb 2011 11:59:08 -0800 (PST)

On Thu, 3 Feb 2011, IETF Chair wrote:

>
> You have probably already heard the news, but just to make sure no one 
> is left out of the loop, I am posting this note.
<snip>
> To the universal deployment of IPv6,

Hear Hear. It seems a bit odd to down a shot of single malt at 11:56am PST
but it *is*  special occasion.

A toast to everyone in the IETF who struggled through the long process to 
get us here and to the universal deployment of IPv6...

- Lucy

>  Russ
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf
>

---

From: Daniel Brown <[email-masked]>
Date: Thu, 3 Feb 2011 15:10:50 -0500

> There is no crisis, but there is a need for action so that the Internet can continue to grow.  The transition to IPv6 requires the attention of many actors.  However, our parents, spouses, and chil…

    Until they see a documentary on newfound evidence recovered from
ancient Internet archives, including your very message, Russ, and a
disaster-science-fiction-movie producer creates a film called "IPv4:
The Unpredicted Eighth Seal."

-- 
</Daniel P. Brown>
Network Infrastructure Manager
http://www.php.net/

---

From: Sabahattin Gucukoglu <[email-masked]>
Date: Fri, 4 Feb 2011 00:03:40 +0000

> There is no crisis, but there is a need for action so that the Internet can continue to grow.  The transition to IPv6 requires the attention of many actors.  However, our parents, spouses, and chil…

Putting aside any bumps in the transition itself, and noting that I'm quite sure the IETF is capable of sensible decision-making in times of crisis and would wish the transition to be as transparent as possible, I think it's more often the case that reconciliation to those who do not immediately see our passions is sometimes difficult, but ultimately possible.

I explained it to my social worker today, and he bookmarked the test IPv6 site, while connected to my home network with IPv6 enabled, and said he'd try it at work.  I explained it to my brother and sister-in-law, and prepared them for IPv6 from their ISP.  I urged every person who I was in contact with to give attention to the issues, and to be selective about who they did business with, as a precondition of acquiring new services and hardware, in order the better to further IPv6 wherever possible, and rightly so.  You want to be able to explain why this milestone is such a great achievement - maybe not with any immediate effect, but an achievement nonetheless - and make your unfortunate hearer understand it.  Perhaps then they'll understand what all the wasted time in revery of a great community of technical friends and colleagues is really all about.  It isn't for nothing that IPv6 is such great news; it will mean a better and more fulfilling Internet for everybody who it touches, including every member of your circle, and will bring them even closer together.  It is even quite surprising how many of them, inspired with that urgency, wish to understand it more completely than they might have otherwise, or try to imagine how a dotted-decimal address can actually be made longer. :-)

Cheers,
Sabahattin

---

From: Desiree Miloshevic <[email-masked]>
Date: Fri, 4 Feb 2011 18:48:13 +0000

On 3 Feb 2011, at 20:10, Daniel Brown wrote:

>> There is no crisis, but there is a need for action so that the  
>> Internet can continue to grow.  The transition to IPv6 requires the  
>> attention of many actors.  However, our parents, spouses, and  
>> children will be largely unaware of the transition.  They will  
>> continue to be amazed of the endless possibilities offered by the  
>> growing Internet.  For them, this milestone will remain  
>> insignificant.
>
According to Dan Brown's books, It's usually all the Illuminates  
fault.  ;-)

Desiree
--