Subject: Please check this idea

From: Sreeraj <[email-masked]>
Date: Fri, 06 Apr 2012 00:28:56 +0530

Hi

We are following longest match logic to route packet in the internet.

we have another choice - Hierarchical Routing

Please check this example

Route to Seat-500 NehruStadium Kochi Kerala India

                 Longest match 
route                                       Hierarchical Routing

 From source     Where is   India Kerala Kochi NehruStadium 
Seat-500       where is India
In India        Where is   India Kerala Kochi NehruStadium 
Seat-500       where is Kerala
In Kerala       Where is   India Kerala Kochi NehruStadium 
Seat-500       where is Kochi
In Kochi        Where is   India Kerala Kochi NehruStadium 
Seat-500       where is NehruStadium
In Stadium      Where is   India Kerala Kochi NehruStadium 
Seat-500       where is Seat-500

In Longest match route, the Seat-500  must contain the complete address 
(India Kerala Kochi NehruStadium Seat-500).
Otherwise that is not the destination. A simple Seat-500 is not enough.

In this method we have to summarize, and again summarize the summary to 
reduce the routing table size,
must keep unnecessary information in routing table.And we need many 
routing protocols (IGP and BGP) to route packet.

Here the logic is "where the designation is". Will not check "where we are"

If we follow hierarchical routing, we don't need to summarize, a 
hierarchical structure will summarize itself.
The logic is "where we are" and "where we want to go".
And the size of routing table is limited (to 133053 routes).

Naming

In the longest match rule, we have to use a very complex naming method

Example: -       3ffe:1900:4545:3:200:f8ff:fe21:67cf

In hierarchical routing, it is simple.

Example :-     200

Hierarchical Routing is simple and easy

https://datatracker.ietf.org/doc/draft-sreeraj-new-ip-address-structure/

Thank you

    C.V Sreeraj
    Ernakulam
    Kerala
    INDIA

---

From: Nick Hilliard <[email-masked]>
Date: Fri, 06 Apr 2012 23:14:25 +0100

> Hierarchical Routing is simple and easy

"For every complex problem, there is a solution that is simple, neat, and
wrong." — H.L. Mencken

Nick