Subject: Gen-ART LC Review of draft-ietf-pwe3-static-pw-status-10

From: Ben Campbell <[email-masked]>
Date: Thu, 26 Apr 2012 17:55:31 -0500

I am the assigned Gen-ART reviewer for this draft. For background on
Gen-ART, please see the FAQ at
<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please resolve these comments along with any other Last Call comments
you may receive.

Document:  (Proposed RFC 6478) (was draft-ietf-pwe3-static-pw-status-10)
Reviewer: Ben Campbell
Review Date:  2012-04-26
IETF LC End Date:  2012-04-30

**** Note: This draft has previously been approved as RFC 6478, but I understand we are last calling it again due to some material changes in AUTH48. Therefore this is a review of the diff between revision 10 and the text at http://www.rfc-editor.org/authors/rfc6478.txt ****

Summary:

The edited text is essentially ready for publication, but I have a couple of minor issues that might should be considered first.

Major issues:

None

Minor issues:

-- 5.3, last paragraph:

The last sentence changed from a non-normative statement to "This SHOULD cause the PE sending the PW status notification message with a PW status code equal to zero to stop sending and to continue normal operation."

Is that really intended as a normative statement, or a statement of fact? I suspect it's the latter, but if the former, then it should be stated more of the form "If the sending PE receives ... it SHOULD stop ..."

-- IANA considerations:

Maybe I missed it, but I don't see a registration policy for adding things to the new registry. This wasn't an AUTH48 change, but it should probably be there.

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 30 Apr 2012 18:25:39 +0100

> Maybe I missed it, but I don't see a registration policy for adding things to the new registry. This wasn't an AUTH48 change, but it should probably be there.
Hi Ben

Thank you for your review.

The IANA policy is stated as IETF Review (end of first para in IANA)

The normative text is deliberate - this was part of the change that we 
needed to make.

- Stewart

---

From: Ben Campbell <[email-masked]>
Date: Mon, 30 Apr 2012 13:32:26 -0500

> The IANA policy is stated as IETF Review (end of first para in IANA)

Okay, I guess I just missed it.

> 
> The normative text is deliberate - this was part of the change that we needed to make.
> 

Then as a reviewer, I think the proposed text is a bit confusing, as a paragraph describing how one element operates seems to make a normative requirement on the behavior of a different element. It would be better to make that assertion in the description of behavior for that other element. This is not a big deal, and certainly not a show stopper if people are attached to the current approach. It's just a personal opinion.

(Sorry, I'd offer more specifics, but am not in a position to pull up the text at the moment, so I'm responding from memory. I will look again when I get the chance.)

Thanks!

Ben.