Subject: Liaison letter from ONF to IETF

From: Dan Pitt <[email-masked]>
Date: Wed, 6 Jun 2012 16:11:29 -0700

To: IETF
From: Dan Pitt, executive director, ONF
Subject: Liaison between ONF and IETF

ONF (www.opennetworking.org) was established to promote Software Defined Networking (SDN) by creating a forum for users and vendors to discuss all aspects of SDNs, to create technical specifications and standards, and to evangelize SDNs to the networking industry and its customers. ONF’s scope spans data planes, control planes, and management planes, enabling programmability and management of the SDN. 

ONF's first task has been to standardize the OpenFlow protocol, the lowest level building block upon which SDN networks can be built. OpenFlow conveys flow-based forwarding information from a logical entity called a controller (or network operating system), which embodies the control-plane intelligence, to the network switches, which actually forward the packets based on directions received from the controller. The OpenFlow protocol therefore represents the controller’s southbound interface, and a protocol is indeed necessary because the switches and controller are assumed to be physically and geographically separate.

The controller’s conceptual northbound interface permits other software entities representing such factors as policy, security, traffic engineering, and energy management to influence the controller’s determination of flow paths. ONF has not yet standardized the controller’s northbound interface, or determined its nature, and so it is too early to standardize orchestration of SDNs controlled via ONF standards. 

We in ONF are very interested to discuss potential SDN use cases developed by the IETF with a view to demonstrating how these can be expressed with ONF constructs, possibly as direct functions of the controller. ONF is further interested in the IETF’s orchestration of existing, stable non-SDN data and control planes that already have stable northbound interfaces (e.g., SNMP MIB, Netconf/Netmod).

We recommend that ONF and IETF work together on SDN specifications, under the ONF framework of chartered ONF Working Groups (via mailing lists, wikis, and conference calls), ONF discussion groups (via mailing lists, wikis, and conference calls), and the ONF Technical Advisory Group (for oversight). 

ONF specifications will use and interact with IETF standards, such as Netconf and BFD. As ONF develops SDN specifications, ONF will work with IETF to bring requests for additions and changes to existing IETF specifications, and for new code points, as the need arises.

ONF further believes there would be considerable benefit if code points defined in ONF specifications are assigned from registries managed by the IANA (Internet Assigned Numbers Authority). We would like to discuss with you the best way to achieve this.

Finally, ONF is interested in discussing cross-publishing future specifications at the IETF, and would welcome a discussion on how best to accomplish this as well.

Dan Pitt
Executive Director
Open Networking Foundation
Palo Alto, California
m. 617-803-5938
[email-masked]
www.opennetworking.org

---

From: "Worley, Dale R (Dale)" <[email-masked]>
Date: Mon, 11 Jun 2012 14:33:24 -0400

> [...] Finally, ONF is interested in discussing cross-publishing future
> specifications at the IETF, and would welcome a discussion on how best
> to accomplish this as well.

Who will ONF be sending to the next IETF meeting in Vancouver?
(http://www.ietf.org/meeting/84/index.html) That is where you will
have productive discussions about coordinating activities.

Dale