Subject: Change in I-D announcement format

From: Brian E Carpenter <[email-masked]>
Date: Wed, 13 Jun 2012 08:47:55 +0100

Did I miss an announcement of the change in format of
I-D announcement messages?

There's no longer a URL for the standard .txt format. That's
mildly annoying for me (extra time and extra mouse clicks)
and must be a nuisance for anyone who processes these messages
automatically.

At least, I would have expected a warning message about the change.

-- 
Regards
   Brian Carpenter

---

From: Yoav Nir <[email-masked]>
Date: Wed, 13 Jun 2012 10:58:56 +0300

This line is not too hot either:

There's also a htmlized version available at:
http://tools.ietf.org/html/submission.filename }}-01 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Brian E Carpenter
Sent: 13 June 2012 10:48
To: IETF discussion list
Subject: Change in I-D announcement format

Did I miss an announcement of the change in format of I-D announcement messages?

There's no longer a URL for the standard .txt format. That's mildly annoying for me (extra time and extra mouse clicks) and must be a nuisance for anyone who processes these messages automatically.

--
Regards
   Brian Carpenter

Scanned by Check Point Total Security Gateway.

---

From: [email-masked] (Martin Rex)
Date: Wed, 13 Jun 2012 11:50:59 +0200 (CEST)

> Brian E Carpenter wrote:
>> There's no longer a URL for the standard .txt format.
>> That's mildly annoying for me (extra time and extra mouse clicks)
>> and must be a nuisance for anyone who processes these
>> messages automatically.

I did not see an announcement either.

I don't mind addition of URLs.  But I strongly dislike removal of URLs!
I would also appreciate if that URL was put back in.

After noticing download failures due to the lack of the URL to the TXT,
I changed my I-D download perl-script on 11-Jun-2012 to accomodate for that
unexpected change.  Since the URL is gone, I have resorted to synthesize
the URL to the TXT document myself from the unqualified filename.

   if ( $_ =~ m/^\s+Filename\s+:\s+(draft-.*\d\d\.txt)/ ) {
        push(@link, "http://tools.ietf.org/id/$1");
   }

Additionally, for some time now, I'm seeing errors trying to download
I-D TXT documents which have been superseded by a successor version
_before_ I feed the announcement EMail to my download script.

What is the purpose of the change to deny previous TXT versions of I-Ds?

> http://tools.ietf.org/html/submission.filename }}-01 

This puzzles me too.

How about adding a mailto: URL into I-D announcements to
report bugs for the software that creates them?

-Martin

---

From: Russ Housley <[email-masked]>
Date: Wed, 13 Jun 2012 09:06:55 -0400

Brian:

There was no announcement that this change was about to be deployed; however, there was a long discussion of the change.  It started with a request for the HTML version of the I-D instead of the plain text version.  At the end of the discussion the decision was to use the Datatracker URL as it allows anyone to get the plaintext or a diff with just one more click.

Russ

---

From: [email-masked] (Martin Rex)
Date: Wed, 13 Jun 2012 15:28:40 +0200 (CEST)

Russ Housley wrote:
> Brian:
> 
> There was no announcement that this change was about to be deployed;
> however, there was a long discussion of the change.  It started with
> a request for the HTML version of the I-D instead of the plain
> text version.  At the end of the discussion the decision was to use
> the Datatracker URL as it allows anyone to get the plaintext or a
> diff with just one more click.

I recall a different outcome, because this reasoning looks flawed to me.

Tools that process the announce-Emails automatically
will be unable to "perform another mouse-click" in order to
get to a page where there is an URL to the TXT document, 
so that option does not exist.

Those who use a graphical frontend that is sensitive to follow
URLs on mouse-click, will probably prefer the HTML variant
over the TXT variant.

The two changes that I would appreciate:
Put the direct TXT URL back into the announcement.
Fix the new URL to the HTML version in the announcment.

-Martin