Subject: IETF...the unconference of SDOs

From: Michael Richardson {quigon} <[email-masked]>
Date: Wed, 05 Sep 2012 09:12:47 -0400

When I started attending IETF meetings in 1996, it was after about 6 years of reading mailing lists, at a time when "netetiquette"
or "Internet 101" was actively taught.  We (because I taught others after learning it) taught people enough about how email worked so that
they would understand basic things like quoting intelligently.  Further, in 1996, the IETF had not entered the "endless September"
(even though the Internet might have as a whole), and had time to actually guide people, and I am thankful to have learned what I did. 
The newcomer's orientation were simpler (because there was less to learn), but they occurred, and having attended Scott's orientation 
again this year (in Paris), I think they continue to do a very good job for the person who is attending.

They don't work at all for the person who has yet to attend a meeting.  We have a slow influx of very smart people who can and
do read all of rules, but like all organizations, not all of our rules are equally applied. It's also possible that some grey beards 
who have only remote attended for years (Yes, I thinking about you Melinda, Keith...) might have missed some subtle change in process.

The IETF's endless september mostly ended after the bust, leaving us, I think, in a summer session with few new people; I'd put us in January now.  
Few freshmen joining.

What I am writing about is that I think that we a problem with transfer students... those who did their september elsewhere, and 
have now switched schools for the winter semester.  It doesn't occur to them that they don't know how the IETF works... it must work
like other SDOs, they think.  Worse of all, I think, many of these people have doing what they thought was email for around a decade,
(yes, using Outlook), they have no idea how email works, nor do they even know there is another interface.  They simply do not know what happens 
to their mis-formatted emails, and why often this results in people being unable to listens to them in the mailing list.  

I don't have an answer to this; I'm not even sure there is a problem; I have a problem of writing too long emails.

I got thinking about this while reading this blog entry about structureless-ness:
   http://eaves.ca/2009/07/06/structurelessness-feminism-and-open/

In particular he notes the way that Elites form/exist.  I would quote it here, but it's hard to take it out context, so please read it.

Let me suggest that at the IETF, where the mailing list is king, you can't join the Elite if you can't quote email properly.  
Maybe we should *state* this.   
Maybe I'm also concerned because many in the former "elite" have moved to Apple Mail, and it seems that it is bug 
compatible with Outlook in it's assumption that format=flowed is the default, an act which destroys email quoting, and therefore discussion.

-- 
Sent from my android transformer, running CM9

---

From: Melinda Shore <[email-masked]>
Date: Fri, 07 Sep 2012 10:12:03 -0800

On 9/5/12 5:12 AM, Michael Richardson {quigon} wrote:
> It's also possible that some grey beards who
> have only remote attended for years (Yes, I thinking about you
> Melinda, Keith...) might have missed some subtle change in process.

This is a great note, Michael, and now that I'm attending again
I have to say that the changes are not at all subtle.  Processes
are more formal in part to protect the organization from legal
threats, in part because the boom in internetiness has increased
the number of bodies and therefore the need to negotiate both
relationships and space, and in part because of the reasons
you've identified.  There have also been some geopolitical changes
that ripple down into the IETF, and while there have been problems
and pressures as a result I think that there's been a very large
net benefit.  More has needed to be codified, though.

> Let me suggest that at the IETF, where the mailing list is king, you
> can't join the Elite if you can't quote email properly.

Well, okay, but I have to say that that's probably the least
of the failures of culture transfer.  I have a bigger problem
with the very large number of junk drafts being generated for
political reasons.

Still, I understand what you're saying and agree with it.  Maybe
we can start with getting something into the wg chairs wiki and
starting a discussion on the mailing list.

Melinda

---

From: Simon Perreault <[email-masked]>
Date: Fri, 07 Sep 2012 14:31:18 -0400

> compatible with Outlook in it's assumption that format=flowed is the default, an act which destroys email quoting, and therefore discussion.

Two things:

1) I agree it's a pain. But in Thunderbird there is Edit --> Reflow 
which helps a lot. It's not perfect, but it makes the pain bearable.

2) You too are guilty. Your email was not flowed and with very long 
lines (not infinite like Apple, but still way more than 80 characters).

Simon
-- 
DTN made easy, lean, and smart --> http://postellation.viagenie.ca
NAT64/DNS64 open-source        --> http://ecdysis.viagenie.ca
STUN/TURN server               --> http://numb.viagenie.ca

---

From: Scott Brim <[email-masked]>
Date: Fri, 07 Sep 2012 14:36:28 -0400

On 09/05/12 09:12, Michael Richardson {quigon} allegedly wrote:
> What I am writing about is that I think that we a problem with
> transfer students... those who did their september elsewhere, and
> have now switched schools for the winter semester.  It doesn't occur
> to them that they don't know how the IETF works... it must work like
> other SDOs, they think.

Yes, and within WGs there are attempts to teach culture.  However, the
IETF is an amalgamation of its participants, and the IETF culture
should be able to adapt.  Like any technical architecture, the basic
framework of the IETF should be robust and flexible enough that it can
adapt to unforeseen inputs.

> Worse of all, I think, many of these people have doing what they
> thought was email for around a decade, (yes, using Outlook), they
> have no idea how email works, nor do they even know there is another
> interface.  They simply do not know what happens to their
> mis-formatted emails, and why often this results in people being
> unable to listens to them in the mailing list.

We know how to deal with this in our friends and relatives every day,
and we can learn to do it in the IETF.  On occasion I've reorganized
received outlook mail into the form I wanted to respond to.  I did
once get asked "why don't you just put your response at the top like
everybody else" :-)  But anyway we can be lenient in what we receive.
The smart ones will adapt, themselves, so we won't have to do so for
long with them.

> I don't have an answer to this; I'm not even sure there is a
> problem; I have a problem of writing too long emails.

You can get help for that.

> Maybe I'm also concerned because many in the former "elite" have
> moved to Apple Mail, and it seems that it is bug compatible with
> Outlook in it's assumption that format=flowed is the default, an act
> which destroys email quoting, and therefore discussion.

and if you figure out the right settings in Thunderbird please let me
know.

On 09/07/12 14:12, Melinda Shore allegedly wrote:> On 9/5/12 5:12 AM,
Michael Richardson {quigon} wrote:
> This is a great note, Michael, and now that I'm attending again I
> have to say that the changes are not at all subtle.  Processes are
> more formal in part to protect the organization from legal threats,
> in part because the boom in internetiness has increased the number
> of bodies and therefore the need to negotiate both relationships and
> space, and in part because of the reasons you've identified.

It's also a reflex of a technologist mind.  If there's uncertainty,
put in a procedure.

Scott (writing this in emacs)

---

From: Simon Perreault <[email-masked]>
Date: Fri, 07 Sep 2012 14:53:35 -0400

> and if you figure out the right settings in Thunderbird please let me

Thunderbird is correct by default AFAIK.

Simon

---

From: Melinda Shore <[email-masked]>
Date: Fri, 07 Sep 2012 11:15:16 -0800

> Thunderbird is correct by default AFAIK.

Unfortunately not on Mac OS.  It's become automatic for me to
hit command-R when replying, but that doesn't solve the basic
problem.

Melinda

---

From: Simon Perreault <[email-masked]>
Date: Fri, 07 Sep 2012 15:30:09 -0400

> hit command-R when replying, but that doesn't solve the basic

That's what we've been saying. Apple sends broken mail. Thunderbird has 
a function to fix broken mail (command-R). Thunderbird is correct. Apple 
is broken.

Simon

---

From: Melinda Shore <[email-masked]>
Date: Fri, 07 Sep 2012 11:35:55 -0800

> a function to fix broken mail (command-R). Thunderbird is correct. Apple

Sure, but the default wrapping is wrong for many of us and wrong
for IETF email.  Thunderbird needs to provide an option to wrap at
a given column by default.

Unfortunately there's some stuff going around that line
wrapping with hard line terminations is retrograde and goes
back to punch cards.  I guess that's probably true but
aside from the fact that I'm retrograde and go back to
punch cards, myself, application line wrapping and flowed
text don't deal well (yet) with multiple character sets,
fonts, etc. and I'll take readability over application
purity every single time.

Melinda

---

From: SM <[email-masked]>
Date: Fri, 07 Sep 2012 13:25:51 -0700

Hi Michael,
At 06:12 05-09-2012, Michael Richardson {quigon} wrote:
>like other SDOs, they think.  Worse of all, I think, many of these 
>people have doing what they thought was email for around a decade,
>(yes, using Outlook), they have no idea how email works, nor do they 
>even know there is another interface.  They simply do not know what happens
>to their mis-formatted emails, and why often this results in people 
>being unable to listens to them in the mailing list.

People use email in various ways.  Each person has his/her own idea 
of how email works.  I wonder if people think about whether a message 
will be formatted differently making it more difficult for the reader 
to understand.

>can't join the Elite if you can't quote email properly.

Some quoting styles make it tedious to follow the conversation.  Some 
people consider it as inefficient to trim the content in their 
reply.  That has been triggering more digests  from an IETF mailing 
list.  Some message bodies are a continuation of the subject line.

Whether any of the above is a good idea is subjective.

Regards,
-sm

---

From: Randy Bush <[email-masked]>
Date: Sat, 08 Sep 2012 12:51:23 +0900

really good message michael.  shame about the line wrap :)

> Unfortunately not on Mac OS.  It's become automatic for me to hit
> command-R when replying, but that doesn't solve the basic problem.

in the new ietf, everyone will use emacs.  the old dogs' macos users
list is rife with pleas for apple and tbird mua config magic, with rare
screams of shock, pain, and disgust from someone who has to use
outschnook for $dayjob mail.

i have given up reading the horribly mis-quoted email.  i concluded
there was a high correlation between not knowing how to use email and
other, even more drastic, clue gaps.  i just hit delete.  there already
is too much clueful mail to read.

if y'all come up with a constructive plan and i can help, holler.  i say
scott should teach emacs :)

randy

---

From: "John Levine" <[email-masked]>
Date: 9 Sep 2012 19:25:57 -0000

I have to say that I'm baffled at the perverse pride that people seem
to take in being so technically backward that they're unable to handle
the mail that 99% of the world uses today.  While not being a fan of
overdecorated HTML and endless font changes, and strongly preferring a
mail program that lets me keep my fingers on the keyboard, I can deal
with it.  (I use Alpine, keep meaning to take another look at mutt.)
I remember how to punch drum cards, but I have no interest in using
one to send mail in 2012.

For the large majority of mail that is written in paragraphs rather
than tables, line wrapping is a useful feature, regardless of the
character set, particularly for those of us who sometimes read our
mail on a tablet or phone while changing planes.  For mail that is a
table and stuff has to line up in columns, use HTML tables. That's
what they're for.

R's,
John

PS: Yes, this is top posted.  You can deal with that, too.

---

From: Melinda Shore <[email-masked]>
Date: Sun, 09 Sep 2012 11:36:28 -0800

On 9/9/12 11:25 AM, John Levine wrote:
> the mail that 99% of the world uses today.

99% (I made up a number!) of the world is sending fairly
straightforward email within one language group and one set of
recipients.  IETF participants use a heterogeneous set of
technologies and that seems to me to be a very good thing.
It seems reasonable to me to keep the formatting
that needs to be applied by the mail reader to a minimum.
There's some stuff that's being sent that is extremely
difficult to pull apart.

Melinda

---

From: "John Levine" <[email-masked]>
Date: 10 Sep 2012 00:49:25 -0000

>There's some stuff that's being sent that is extremely

Really?  Like what?  (This is an honest question -- it's been
ages since I recall seeing a message that my fairly dorky
mail software couldn't handle.)

R's,
John

---

From: Randy Bush <[email-masked]>
Date: Mon, 10 Sep 2012 11:52:25 +0900

> Really?  Like what?

try reading the nov3 list in a text mua.  and do not tell folk what mua
they should use.

randy

---

From: "John R Levine" <[email-masked]>
Date: 9 Sep 2012 23:50:59 -0400

> try reading the nov3 list in a text mua.  and do not tell folk what mua

Gee, this whole argument is about telling people what MUA to use.
Apparently nothing written since about 1996 need apply.

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
"I dropped the toothpaste", said Tom, crestfallenly.

---

From: Tony Finch <[email-masked]>
Date: Mon, 10 Sep 2012 09:47:39 +0100

Michael Richardson {quigon} <[email-masked]> wrote:

> can't join the Elite if you can't quote email properly.  Maybe we should
> *state* this.

:-)

> Maybe I'm also concerned because many in the former "elite" have moved
> to Apple Mail, and it seems that it is bug compatible with Outlook in
> it's assumption that format=flowed is the default, an act which destroys
> email quoting, and therefore discussion.

I feel a bit sorry for Apple Mail. It used to use format=flowed very
nicely, but stopped presubably for bug compatibility with Outlook which
treats a flowed paragraph as a sequence of one-line paragraphs.

There are some other interop problems caused by Outlook's gratuitous
disregard for standards:

multipart/mixed; Content-Disposition: inline doesn't work very well.
(I predict Apple Mail will stop generating this too.)

message/rfc822 attachments don't work. If it did it would be a much better
way to do forwarding and top-posting repliesthan at present. (For
instance, Outlook can hide those horrible confusing email addresses rather
than stripping them out.)

Tony.
-- 
f.anthony.n.finch  <[email-masked]>  http://dotat.at/
Forties, Cromarty: East, veering southeast, 4 or 5, occasionally 6 at first.
Rough, becoming slight or moderate. Showers, rain at first. Moderate or good,
occasionally poor at first.

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Mon, 10 Sep 2012 10:46:59 +0000

If someone wants to provide guidance on how to do a least bad job
with Outlook, that will be gratefully received. But advice that says
"don't use Outlook" will be filed with the advice that says "pick
another employer to work for".

-- 
Christopher Dearlove
Senior Principal Engineer, Communications Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked] | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of John Levine
Sent: 09 September 2012 20:26
To: [email-masked]
Subject: Re: the usual mail stuff, was IETF...the unconference of SDOs

----------------------! WARNING ! ----------------------
This message originates from outside our organisation,
either from an external partner or from the internet.
Keep this in mind if you answer this message.
Follow the 'Report Suspicious Emails' link on IT matters
for instructions on reporting suspicious email messages.
--------------------------------------------------------

R's,
John

>purity every single time.

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 10 Sep 2012 13:04:00 +0200

On Sep 10, 2012, at 12:46, "Dearlove, Christopher (UK)" <[email-masked]> wrote:

> with Outlook, that will be gratefully received.

I'm not an expert for this, but, as far as I am aware of, it has not been 
possible to productively participate in e-mail conversations using Outlook.

> But advice that says

For a while, the stock advice has been slightly different:
"Get a $WEBMAIL account", where one popular value for WEBMAIL is "gmail".

Of course, if policies prevent using the Web from workplace, I feel your pain.

Grüße, Carsten

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Mon, 10 Sep 2012 08:46:58 -0700

On 09/10/2012 03:46 AM, Dearlove, Christopher (UK) wrote:
> If someone wants to provide guidance on how to do a least bad job with
> Outlook, that will be gratefully received. But advice that says "don't use
> Outlook" will be filed with the advice that says "pick another employer to
> work for".
> 

OK, here's how your post looks in my mailer:

http://ietf.implementers.org/irony.png

- -- 
Marc Petit-Huguenin
Email: [email-masked]
Blog: http://blog.marc.petit-huguenin.org
Profile: http://www.linkedin.com/in/petithug

---

From: Dave Crocker <[email-masked]>
Date: Mon, 10 Sep 2012 08:58:31 -0700

>> can't join the Elite if you can't quote email properly.  Maybe we should
...
> than stripping them out.)

Plaintive humor notwithstanding, this all starts to look as if some sort 
of BCP or even protocol "profile" is warranted, to describe preferred 
practices in the creation and interpretation of RFC5322 objects within 
"conversational exchanges".

I'd be happy to participate in a specification effort, assuming 
community interest.

d/
-- 
  Dave Crocker
  Brandenburg InternetWorking
  bbiw.net

---

From: Simon Perreault <[email-masked]>
Date: Mon, 10 Sep 2012 12:08:34 -0400

> with Outlook, that will be gratefully received.

Found this using the Google:
http://home.in.tum.de/~jain/software/outlook-quotefix/

No idea if it's any good as I don't have access to Outlook...

Simon

---

From: Glen Zorn <[email-masked]>
Date: Tue, 11 Sep 2012 13:14:18 +0700

> possible to productively participate in e-mail conversations using Outlook.

Actually, I managed to do so for more than 10 years (at least I received 
very few complaints once I learned how to reply in ASCII ;-)

>> another employer to work for".

Or, since we're all "volunteers", we could just do IETF work on our own 
time & using our own computers.

Grüße, Carsten