Subject: Draft IESG Statement on Ethertype Assignments for IETF Protocols

From: IETF Chair <[email-masked]>
Date: Mon, 3 Sep 2012 20:02:21 -0400

The IESG is considering this IESG Statement.  Comments from the community are solicited.

On behalf of the IESG,
Russ

--- DRAFT IESG STATEMENT ---

Subject: Ethertype Assignments for IETF Protocols

The IEEE Registration Authority Committee (RAC) assigns Ethertypes.
(See http://standards.ieee.org/develop/regauth/ethertype/.)  Some IETF
protocol specification make use of Ethertypes.  Since Ethertypes are a
fairly scarce resource, the IEEE RAC will not assign a new Ethertype to
a new IETF protocol specification that needs one until the IESG has
approved the protocol specification for publication as an RFC.

To let the IEEE RAC know that the IESG has approved an IETF protocol
specification for publication, all future requests for assignment of
Ethertypes for IETF protocol specifications will be made by the IESG.

Note that playpen Ethertypes have been assigned in IEEE 802 [1] for use
during development and experimentation.

[1] IEEE Std 802a-2003 (Amendment to IEEE Std 802-2001).
   IEEE standard for Local and Metropolitan Area Networks:
   Overview and Architecture -- Amendment 1: Ethertypes for
   Prototype and Vendor-Specific Protocol Development.

---

From: Joe Touch <[email-masked]>
Date: Fri, 07 Sep 2012 07:51:23 -0700

Hi, all,

This statement seems fine, but it's worth noting that it would apply 
only to  *IETF* protocol specs. The IESG has, IMO, no authority to make 
such claims for independent submissions (and what about IRTF ones?), and 
the IEEE should recognize that such protocols are described by RFCs too.

Joe

---

From: Ralph Droms <[email-masked]>
Date: Fri, 7 Sep 2012 12:15:19 -0400

On Sep 7, 2012, at 10:51 AM 9/7/12, Joe Touch wrote:

> Hi, all,
> 
> This statement seems fine, but it's worth noting that it would apply only to  *IETF* protocol specs.

What did you have in mind as "noting"?  This text seems pretty clear to me as applying only to "IETF protocol specifications": 

  the IEEE RAC will not assign a new Ethertype to
  a new IETF protocol specification that needs one until the IESG has
  approved the protocol specification for publication as an RFC.

> The IESG has, IMO, no authority to make such claims for independent submissions (and what about IRTF ones?), and the IEEE should recognize that such protocols are described by RFCs too.

Where do you see any such claims in this statement?  What would you change?

- Ralph

---

From: Joe Touch <[email-masked]>
Date: Fri, 07 Sep 2012 09:26:09 -0700

Hi, Ralph,

I agree with your assessment below, but historically the IETF guidelines 
work more smoothly when cases are spelled out rather than dealt with by 
omission. I think a few sentences being more explicit about what is not 
covered would be useful, esp. for the IEEE.

Joe

---

From: Eric Gray <[email-masked]>
Date: Tue, 11 Sep 2012 06:30:30 -0400

Ralph,

	It cannot hurt to try to make this as unambiguous as possible.

	The IETF cannot instruct the IEEE RAC not to assign an Ethertype to anyone who
applies for it, assuming they otherwise comply with RAC requirements and are willing to
pay for the assignment, if necessary.  

	However, the IETF can caution the RAC that any such assignment can only be (or 
become) associated with an IETF protocol specification upon its approval and publication 
as an IETF RFC.

--
Eric

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ralph Droms
Sent: Friday, September 07, 2012 12:15 PM
To: Joe Touch
Cc: IETF Chair; IETF list discussion
Subject: Re: Draft IESG Statement on Ethertype Assignments for IETF Protocols

- Ralph

>> (See http://standards.ieee.org/develop/regauth/ethertype/.)  Some 
>> IETF protocol specification make use of Ethertypes.  Since Ethertypes 
>> are a fairly scarce resource, the IEEE RAC will not assign a new 
>> Ethertype to a new IETF protocol specification that needs one until 
>> the IESG has approved the protocol specification for publication as an RFC.
>> 
>> Note that playpen Ethertypes have been assigned in IEEE 802 [1] for 
>> use during development and experimentation.
>> 
>>

---

From: Eric Gray <[email-masked]>
Date: Tue, 11 Sep 2012 06:36:02 -0400

Has anyone considered the possibility that the application for an Ethertype to be associated 
with an IETF protocol specification should become a responsibility for IANA?

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Eric Gray
Sent: Tuesday, September 11, 2012 6:31 AM
To: Ralph Droms; Joe Touch
Cc: IETF Chair; IETF list discussion
Subject: RE: Draft IESG Statement on Ethertype Assignments for IETF Protocols

Ralph,

	The IETF cannot instruct the IEEE RAC not to assign an Ethertype to anyone who applies for it, assuming they otherwise comply with RAC requirements and are willing to pay for the assignment, if necessary.  

	However, the IETF can caution the RAC that any such assignment can only be (or
become) associated with an IETF protocol specification upon its approval and publication as an IETF RFC.

--
Eric

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ralph Droms
Sent: Friday, September 07, 2012 12:15 PM
To: Joe Touch
Cc: IETF Chair; IETF list discussion
Subject: Re: Draft IESG Statement on Ethertype Assignments for IETF Protocols

- Ralph

---

From: Ralph Droms <[email-masked]>
Date: Tue, 11 Sep 2012 06:43:18 -0400

> pay for the assignment, if necessary.  

Eric - As I understand the IESG statement, the intent is not to give any instructions to the IEEE RAC.  I read the text I quoted in my e-mail:

as a restatement of the IEEE RAC policy, which was included in the IESG statement as explanation for this text:

which describes how the IESG will inform the IEEE RAC about which protocol specifications meet the IEEE RAC policy.

- Ralph

---

From: Eric Gray <[email-masked]>
Date: Tue, 11 Sep 2012 06:53:07 -0400

Ralph,

	The statement "the IEEE RAC will not assign" sounds very explicitly like an instruction
to the IEEE RAC, does it not?

	Also, it is difficult to enforce, since an implementer can certainly get their company 
to request an Ethertype to be used on their own proprietary version of an IETF protocol,
and it is not within the purview of the IETF (or IESG) to prevent an assignment in this case.

	If it then turns out that the implementation that uses this Ethertype subsequently
becomes a de-facto standard that happens to align perfectly with the published RFC, then
the intention of the proposed wording is subverted.

--
Eric

-----Original Message-----
From: Ralph Droms [mailto:[email-masked]] 
Sent: Tuesday, September 11, 2012 6:43 AM
To: Eric Gray
Cc: Joe Touch; IETF Chair; IETF list discussion
Subject: Re: Draft IESG Statement on Ethertype Assignments for IETF Protocols
Importance: High

On Sep 11, 2012, at 6:30 AM 9/11/12, Eric Gray wrote:

> 	The IETF cannot instruct the IEEE RAC not to assign an Ethertype to 
> anyone who applies for it, assuming they otherwise comply with RAC 
> requirements and are willing to pay for the assignment, if necessary.

- Ralph

>  the IEEE RAC will not assign a new Ethertype to  a new IETF protocol 
> specification that needs one until the IESG has  approved the protocol 
> specification for publication as an RFC.
> 
> 
> 
>>> IETF protocol specification make use of Ethertypes.  Since 
>>> Ethertypes are a fairly scarce resource, the IEEE RAC will not 
>>> assign a new Ethertype to a new IETF protocol specification that 
>>> needs one until the IESG has approved the protocol specification for publication as an RFC.
>>>

---

From: Eric Gray <[email-masked]>
Date: Tue, 11 Sep 2012 06:54:21 -0400

I guess what you're saying is that "will" in this case is a statement of IEEE RAC policy.

In that case, I understand your point...

-----Original Message-----
From: Ralph Droms [mailto:[email-masked]] 
Sent: Tuesday, September 11, 2012 6:43 AM
To: Eric Gray
Cc: Joe Touch; IETF Chair; IETF list discussion
Subject: Re: Draft IESG Statement on Ethertype Assignments for IETF Protocols
Importance: High

- Ralph

---

From: Ralph Droms <[email-masked]>
Date: Tue, 11 Sep 2012 08:29:04 -0400

> I guess what you're saying is that "will" in this case is a statement of IEEE RAC policy.

Yup ... Would s/will not/has adopted a policy not to/ clarify that part of the statement?

- Ralph

---

From: IETF Chair <[email-masked]>
Date: Tue, 11 Sep 2012 11:57:26 -0400

I propose the following rewording to address the issue that has been raised.

Russ

= = = = = = = = =

The IEEE Registration Authority Committee (RAC) assigns Ethertypes.
(See http://standards.ieee.org/develop/regauth/ethertype/.)  Some IETF
protocol specification make use of Ethertypes.  Since Ethertypes are a
fairly scarce resource, the IEEE RAC has let us know that they will not
assign a new Ethertype to a new IETF protocol specification that needs
one until the IESG has approved the protocol specification for
publication as an RFC.

Note that playpen Ethertypes have been assigned in IEEE 802 [1] for use
during protocol development and experimentation.

---

From: Eric Gray <[email-masked]>
Date: Tue, 11 Sep 2012 12:36:59 -0400

Yes, something along those lines would make it clearer.  Thanks!

-----Original Message-----
From: Ralph Droms [mailto:[email-masked]] 
Sent: Tuesday, September 11, 2012 8:29 AM
To: Eric Gray
Cc: Joe Touch; IETF Chair; IETF listdiscussion
Subject: Re: Draft IESG Statement on Ethertype Assignments for IETF Protocols
Importance: High

- Ralph

>>    The IETF cannot instruct the IEEE RAC not to assign an Ethertype 
>> to anyone who applies for it, assuming they otherwise comply with RAC 
>> specification that needs one until the IESG has  approved the 
>> protocol specification for publication as an RFC.
>> 
>> 
>> 
>>>> To let the IEEE RAC know that the IESG has approved an IETF 
>>>> protocol specification for publication, all future requests for 
>>>> assignment of Ethertypes for IETF protocol specifications will be made by the IESG.
>>>>