Subject: Gen-ART LC Review of draft-ietf-eai-rfc5721bis-07,

From: Ben Campbell <[email-masked]>
Date: Tue, 18 Sep 2012 20:18:30 -0500

I am the assigned Gen-ART reviewer for this draft. For background on
Gen-ART, please see the FAQ at

<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq> .

Please resolve these comments along with any other Last Call comments
you may receive.

Document:  draft-ietf-eai-rfc5721bis-07
Reviewer: Ben Campbell
Review Date: 2012-09-18
IETF LC End Date: 2012-09-20

Summary:   The draft is mostly ready for publication as a draft standard. I have a few editorial comments that should be considered prior to publication.

Major issues: None

Minor issues: 

Nits/editorial comments:

-- IDNits has some complaints; please check.

-- The abstract should mention that this obsoletes 5721

-- section 2.1, 2nd paragraph: "The character encoding format of maildrops may not be UTF-8 or ASCII."

I'm confused by this sentence, as it seems to say that the format can't be UTF-8 or ASCII, which otherwise seem to be the only ones contemplated by the draft.  Do you mean to say that it may be some format other than those?

-- same paragraph : "The UTF8 command MAY fail."

Under what circumstances? (this seems sort of tacked onto the paragraph--does it belong there?)

-- 2.1, 4th paragraph: "...need not be accurate, but it is preferable if they were."

Not preferable enough for a SHOULD? (Note that the previous sentence used SHOULD for reporting actual message size counts)

-- section 7, 3rd paragraph: "It is possible for a man-in-the-middle attacker to insert a LANG command in the command stream, thus making protocol-level diagnostic responses unintelligible to the user."

This seems a bit unnecessary to call out, given that a MiTM could just change the diagnostic responses into Klingon even in the absence of the LANG command. It's at least worth mentioning that the LANG command really doesn't make this issue worse than it already was.

---

From: Ben Campbell <[email-masked]>
Date: Tue, 18 Sep 2012 20:20:51 -0500

> Summary:   The draft is mostly ready for publication as a draft standard. I have a few editorial comments that should be considered prior to publication.

Oops, I meant proposed standard. Sorry for the confusion.

---

From: Ben Campbell <[email-masked]>
Date: Tue, 18 Sep 2012 20:45:43 -0500