Subject: New mailing list for DNS-SD/mDNS Extensions

From: Stuart Cheshire <[email-masked]>
Date: Wed, 10 Oct 2012 15:53:30 -0700

A new IETF mailing list has been created for discussions regarding DNS-SD/mDNS Extensions:

<https://www.ietf.org/mailman/listinfo/mdnsext>

This is in response to recent events in the industry and marketplace.

In August, EDUCAUSE delivered a petition to Apple asking for improvements to Bonjour (aka DNS-SD/mDNS) to allow discovery of services beyond the local link.

<http://www.networkworld.com/news/2012/080312-bonjour-petition-261390.html>
<https://www.change.org/petitions/from-educause-higher-ed-wireless-networking-admin-group>
<http://listserv.educause.edu/cgi-bin/wa.exe?A2=ind1208&L=WIRELESS-LAN&O=D&P=31656>

In principle DNS-SD can already be used in conjunction with conventional unicast DNS to enable wide-area service discovery, but in practice this capability is not widely used. This disconnect between customer needs and current practice suggests that we need to revisit how to solve this problem.

In response to this customer demand, Aerohive, Aruba, Cisco, and Xirrus have all recently announced "Bonjour gateway" products which allow service discovery beyond the local link. However, these were brought to market rapidly, and it's unclear whether they represent a desirable long-term direction for service discovery protocol development. Other companies are also reported to be developing their own "Bonjour gateway" products, not yet announced.

It would be beneficial for the end users, network operators, these vendors, and for the long-term health of the Internet to bring this work into the IETF where all interested parties can collaborate on it.

Proposed Scope of Work:

The MDNSEXT mailing list discussions will focus on service discovery solutions suitable for:

1. Enterprise networks
2. Academic/Educational/University networks
3. Multi-link home networks, such as that envisaged by HOMENET*
4. Mesh networks, such as SE2.0/ZigBee/6lowpan-style networks

* It is hoped that MDNSEXT can develop a solution that is suitable for all four network environments, including the HOMENET case. Of course the HOMENET WG is free to evalulate for itself whether it wishes to adopt the MDNSEXT solution, or develop something different.

Proposed Goals:

1. Enable discovery of services across multiple links.

2. Zero configuration operation possible, but not mandatory.
   - i.e. Zero configuration operation is supported by the protocols,
   but administrative control is also available on networks where that
   is desired.

3. Scalability, in terms of:
   - Network traffic
   - CPU and memory requirements on network entities
   - User interface (huge flat list is not user friendly)
   - Having a smooth continuum of operation from local link to site to
     global, rather than wildly different incompatible modes of
     operation at different network scales
   - Granularity of services available on a server (extend the notion of service?)

4. Suitable for both local (zero-config) and global (configured) use
   - i.e. Suitable out-of-the box defaults should enable zero-
     configuration use on many small- to medium-sized networks, while still
     allowing for administrative control in networks where that's desired.

5. Incremental deployability
   - Identify what changes to existing network elements will be
     required, and attempt to minimize those changes.
   - Don't break existing DNS-SD/mDNS functionality and devices

A BoF session is tentatively planned for 1520-1650 Tuesday 6th November 2012, subject there being enough interest to warrant moving ahead to that stage.

Stuart Cheshire

---

From: Bob Hinden <[email-masked]>
Date: Thu, 11 Oct 2012 07:04:22 -0700

Stuart,

Looks very interesting.  I will try to attend the BOF.

Bob