Subject: Proposed BCP addition - No-Late-Patent-Filing Rights - contract provision for BCP/NoteWell - Re: [Nea] IPR Disclosure: Cisco's Statement of IPR Related to draft-ietf-nea-pt-tls-07

From: tglassey <[email-masked]>
Date: Fri, 05 Oct 2012 07:22:46 -0700

On 10/4/2012 9:23 PM, Stephen Hanna wrote:
> IETF Secretariat wrote:
>> An IPR disclosure that pertains to your Internet-Draft entitled
>> "PT-TLS: A TCP-based Posture Transport (PT) Protocol"
>> (draft-ietf-nea-pt-tls) was submitted to the IETF Secretariat
>> on 2012-10-04
> Well, that's a pain in the neck!
Actually its much more than that. Its why full disclosure at the start 
of a process of who the parties legally represent and what their 
interests in the standard process are so that full disclosure is there.

But fixing this process is actually VERY SIMPLE... Just a 'component of 
an updated BCP which contractually commits that IETF members and their 
sponsors may not engage in submarining' its actually pretty simple to 
stop this... you folks just have to want to.

The propose text could look something like:

   " Whereas - all parties working in the IETF have an open 
collaboration agreement, it is agreed that any Intellectual Properties 
developed by a commercial sponsor to the IETF will have full disclosure 
of their licensing provisions prior to any development taking place in 
the IETF and that those rights must be properly disclosed to all parties 
in the interest of open collaboration and global standards development."

     "Further any party formally participating or supplying IP to these 
initiative waves any rights to change those access rights and disclosure 
requirements by participating in the process after the development 
commences on any initiative".

Todd
> I'm not happy to see these
> IPR disclosures come in so late in the process. PT-TLS is
> already with the IESG and PT-EAP has passed two WGLCs and
> is almost ready to go to the IESG. This IPR should have
> been disclosed much earlier, if at all possible.
>
> At this time, I would encourage nea participants to read
> (or re-read) RFC 3979, which describes how we handle IPR
> disclosures in IETF. Also read the IPR disclosures to see
> what's included in the patents in question and what IPR
> licensing terms are being offered.
>
> I would ask Cisco to please provide a link to the actual
> patent application (since I guess there is no patent yet
> and I can't find the patent application) so that we can
> see what technology is claimed to be covered.
>
> Thanks,
>
> Steve
>
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]] On Behalf Of
>> IETF Secretariat
>> Sent: Thursday, October 04, 2012 5:45 PM
>> To: [email-masked]; [email-masked]; [email-masked]
>> Cc: [email-masked]; [email-masked]; [email-masked]
>> Subject: [Nea] IPR Disclosure: Cisco's Statement of IPR Related to
>> draft-ietf-nea-pt-tls-07
>>
>>
>> Dear Paul Sangster, Nancy Cam-Winget, Joseph A. Salowey:
>>
>>   An IPR disclosure that pertains to your Internet-Draft entitled "PT-
>> TLS: A TCP-
>> based Posture Transport (PT) Protocol" (draft-ietf-nea-pt-tls) was
>> submitted to
>> the IETF Secretariat on 2012-10-04 and has been posted on the "IETF
>> Page of
>> Intellectual Property Rights Disclosures"
>> (https://datatracker.ietf.org/ipr/1890/). The title of the IPR
>> disclosure is
>> "Cisco's Statement of IPR Related to draft-ietf-nea-pt-tls-07."");
>>
>> The IETF Secretariat
>>
>> _______________________________________________
>> Nea mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/nea
> _______________________________________________
> Nea mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nea
>
>
> -----
> No virus found in this message.
> Checked by AVG - www.avg.com
> Version: 2013.0.2677 / Virus Database: 2591/5808 - Release Date: 10/03/12
>
>

-- 
Regards TSG
"Ex-Cruce-Leo"

//Confidential Mailing - Please destroy this if you are not the intended recipient.

---

From: tglassey <[email-masked]>
Date: Fri, 05 Oct 2012 10:17:12 -0700

On 10/5/2012 9:03 AM, Dale R. Worley wrote:
>> From: tglassey <[email-masked]>
>>
> Unless someone has already constructed contracts to do this in some
> similar circumstance and time has shown that the contracts work as
> intended, I wouldn't assert that it is known to be simple.
Dale -
The contracts are airtight and supported through items like the Federal 
and State Courts ruling about the contractual strength of NDA agreements 
in rulings like Grail Semi v Mitsubishi. In this case the contract is 
the exact opposite of a NDA it is a guaranteed disclosure agreement - a 
no secrets here variant so this is in fact a no-brainer to solve.

Yes - the Jury may have screwed up the damage calculation but not the 
issue of whether the NDA controlled relationship was enforceable and 
that is the key. It is ...

Again - to fix this issue all you have to do is want to...

Todd
> Certainly
> there are many times in protocol design where conceptually simple
> goals prove to be remarkably difficult to achieve in practice.  There
> is no reason that believe that similar problems don't show up in the
> legal field.
>
> That's not to say that this proposal is a bad idea.  But let's not
> assume that it will take little work to achieve.
>
> Dale
>
>
> -----
> Version: 2013.0.2677 / Virus Database: 2591/5810 - Release Date: 10/04/12
>
>

-- 
Regards TSG
"Ex-Cruce-Leo"