Subject: Re: I-D Action: draft-farrell-ft-01.txt

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 4 Dec 2012 10:59:56 +0900

Stephen,

Your goal is laudatory, but the devil will be in the details. For example,
you wrote:

   Note also that this experiment just needs an implementation that
   makes it possible for the WG chairs and responsible AD to verify (to
   the extent they chose) that the implementation matches the draft.

Will this require WG chairs and/or document shepherds to do a code review
to verify that the implementation and code match? A better criteria might
be that there be at least two independent implementations that successfully
interoperate.  That would also show greater WG interest than just a single
individual or organization.

Open source code is a plus, but shouldn't be a requirement, as such a
requirement might discourage some vendors from implementing.

Thanks,
Andy

On Tue, Dec 4, 2012 at 1:48 AM, <[email-masked]> wrote:

>
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
>
>
>         Title           : A Fast-Track way to Proposed Standard with
> Running Code
>         Author(s)       : Stephen Farrell
>         Filename        : draft-farrell-ft-01.txt
>         Pages           : 9
>         Date            : 2012-12-03
>
> Abstract:
>    This memo proposes an optional fast-track way to get from a working
>    group document to IESG review that can be used for cases when a
>    working group chair believes that there is running code that
>    implements a working group Internet-Draft.  The basic idea is to do
>    all of working group last call, IETF last call and area director
>    review during the same two week period, and to impose a higher
>    barrier for comments that might block progress.  The motivation is to
>    have the IETF process have a built-in reward for running code,
>    consistent with the IETF's overall philosophy of running code and
>    rough consensus.  This version is solely proposed by the author (and
>    not the IESG) to attempt to ascertain if there is enough interest in
>    this to warrant trying out the idea as an RFC 3933 process
>    experiment.
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-farrell-ft
>
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-farrell-ft-01
>
> A diff from the previous version is available at:
> http://www.ietf.org/rfcdiff?url2=draft-farrell-ft-01
>
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 4 Dec 2012 11:01:18 +0900

Whoops, I meant that the draft and implementation match, sorry about that.

Cheers,
Andy

On Tue, Dec 4, 2012 at 10:59 AM, Andrew G. Malis <[email-masked]> wrote:

>> Internet-Draft<https://www.ietf.org/mailman/listinfo/i-d-announceInternet-Draft>directories:
>> http://www.ietf.org/shadow.html

---

From: Yoav Nir <[email-masked]>
Date: Tue, 4 Dec 2012 06:01:54 +0000

Speaking of the devil in the details…

On Dec 4, 2012, at 3:59 AM, "Andrew G. Malis" <[email-masked]>
 wrote:

> Stephen,
> 
> Your goal is laudatory, but the devil will be in the details. For example, you wrote:
> Will this require WG chairs and/or document shepherds to do a code review to verify that the implementation and code match? A better criteria might be that there be at least two independent implementations that successfully interoperate.  That would also show greater WG interest than just a single individual or organization.

Define "independent". If the draft author contributes to two open source implementations, does it count as independent? What if one author contributes to an open source implementation, the other author implements it in her company's product, and they claim interoperability?  That doesn't say much about the quality of the spec, other than that the authors understand it.

> Open source code is a plus, but shouldn't be a requirement, as such a requirement might discourage some vendors from implementing.
> 
> Thanks,
> Andy
>