Subject: Re: request to make the "tools version" of the agenda the default

From: Julian Reschke <[email-masked]>
Date: Mon, 03 Dec 2012 21:21:12 +0100

On 2012-11-30 20:16, Richard Barnes wrote:
>
> On Nov 30, 2012, at 2:10 PM, Wes Hardaker <[email-masked]> wrote:
>
>> John C Klensin <[email-masked]> writes:
>>
>>> I think changing the default is fine.  I'd also be reluctant to
>>> see the "normal" HTML version go away immediately but would be
>>> especially reluctant to see the plain text version go away or
>>> even become less accessible (require more clicks or searching to
>>> navigate too).
>>
>> I suspect we can all agree that this would be optimal:
>>
>> 1) have the tools version be the default (my original statement)
>> 2) have the html version still present
>> 3) have the text version still present
>> 4) produce an xml version for better parsing
>>    (ever try and write an agenda app? Half your time is spent writing a
>>    .txt or .html parser)
>
> s/xml/json/
>
> Ever try writing an XML app?  Half your time is spent writing a .xml parser.

Hahaha.

Best regards, Julian

---

From: Wes Hardaker <[email-masked]>
Date: Tue, 04 Dec 2012 10:25:40 -0800

> Ever try writing an XML app?  Half your time is spent writing a .xml parser.

No, see...  you're expecting good xml.

  use XML::Simple
  $x = xmlIn("file.xml");

It's the easiest thing in the world to use.  But it doesn't parse
complex without more pain (but who wants that) and it's "still perl"
(and who wants that?)
-- 
Wes Hardaker
SPARTA, Inc.

---

From: Wes Hardaker <[email-masked]>
Date: Tue, 04 Dec 2012 10:26:20 -0800

Michael Richardson <[email-masked]> writes:

> There is .csv and obviously there is .ics too already.

Didn't know about the CSV; that'd be just fine.  .ics is 'too much' in
general though.
-- 
Wes Hardaker
SPARTA, Inc.