Subject: Re: Last Call: <draft-hanes-dispatch-fax-capability-06.txt> (Indicating Fax over IP Capability in the Session Initiation Protocol (SIP)) to Proposed Standard

From: Hadriel Kaplan <[email-masked]>
Date: Fri, 21 Dec 2012 18:28:26 +0000

Howdy,
I've read the draft and overall it looks good.  

Some minor comments:
The examples in section 5 of the draft repeatedly show a Via header as follows:
Via: SIP/2.0/TCP [email-masked];branch=z9hG4bK309475a2
This is not a legal Via header format, since the sent-by field cannot contain a '@'.  It's meant to be a host or host:port, not a user@host... and more likely a host:port since this is TCP for this example.

Also, the examples show a Contact URI host of the domain in the REGISTER request, the same as the target request-URI.  While not technically illegal I guess, it's extremely unusual - the purpose of a REGISTER is to register the Contact URI as the reachable target for the Address of Record, and thus the Contact URI should indicate the specific host registering.  I suggest changing it to:
Contact: <sip:[email-masked];transport=tcp>;+sip.fax="t38"

Lastly, the example INVITE at the end of section 5 is malformed, both because it's missing mandatory headers, and because the From header has no tag param.

-hadriel

On Nov 29, 2012, at 9:46 AM, The IESG <[email-masked]> wrote:

> 
> The IESG has received a request from an individual submitter to consider
> the following document:
> - 'Indicating Fax over IP Capability in the Session Initiation Protocol
>   (SIP)'
>  <draft-hanes-dispatch-fax-capability-06.txt> as Proposed Standard
> 
> The IESG plans to make a decision in the next few weeks, and solicits
> final comments on this action. Please send substantive comments to the
> [email-masked] mailing lists by 2012-12-27. Exceptionally, comments may be
> sent to [email-masked] instead. In either case, please retain the
> beginning of the Subject line to allow automated sorting.
> 
> Abstract
> 
> 
>   This document defines and registers with IANA the new 'fax' media
>   feature tag for use with SIP.  Currently, fax calls are
>   indistinguishable from voice at call initiation.  Consequently, fax
>   calls can be routed to SIP user agents that are not fax capable.  A
>   'fax' media feature tag implemented in conjunction with caller
>   preferences allows for more accurate fax call routing.
> 
> 
> 
> 
> The file can be obtained via
> http://datatracker.ietf.org/doc/draft-hanes-dispatch-fax-capability/
> 
> IESG discussion can be tracked via
> http://datatracker.ietf.org/doc/draft-hanes-dispatch-fax-capability/ballot/
> 
> 
> No IPR declarations have been submitted directly on this I-D.
> 
>

---

From: Gonzalo Salgueiro <[email-masked]>
Date: Fri, 21 Dec 2012 15:21:06 -0500

Thanks for the review, Hadriel.  After the IESG review I'll make the suggested edits to the SIP headers in the examples.

Cheers,

Gonzalo