Subject: Simplifying our processes: Conference Calls

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 3 Dec 2012 17:41:43 +0200

Hi all, 

seeing all these discussions related to process improvements I just noticed one annoying thing related to working group conference calls. 

It turns out that the IESG guidelines on that topic (see http://www.ietf.org/iesg/statement/interim-meetings.html) say the following: 
"
* Conference calls and jabber sessions must be announced at least two weeks prior to the call or session, and the agenda must be published at least one week before call or session

* Announcement text must be sent to [email-masked]
"

Having just scheduled conference calls for the OAuth mailing list I announced them on the OAuth WG mailing list (where I naively thought it belongs and forgot to re-read the IESG guidelines again). 

Why do we need to announce conference calls (or Jabber chats) on the IETF announce mailing list? How likely is it that someone cares about a working group effort, does not subscribe to the WG mailing list, has not seen a poll about the date and time, and wants to participate in the conference call? To me - this seems rather unlikely. 

Could we please change that? 

Ciao
Hannes

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 03 Dec 2012 16:06:53 +0000

> Why do we need to announce conference calls (or Jabber chats) on the IETF announce mailing list? How likely is it that someone cares about a working group effort, does not subscribe to the WG maili…

The point is that we work in public, so the whole community should know.
I regularly attend WG meetings where I am not subscribed - it's one of the
side benefits of the week-long meetings - and who's to say that I might not
want to drop into OAuth too?

Suppose I happened to notice (I am making this up) that the foobar WG has
decided to use the IPv6 Flow Label for an unintended purpose? I'd like
to know if they are going to have a conf call, so that I can explain
RFC 6437 to them. Otherwise, I have no interest in foobar.

> Could we please change that? 

I hope not.

    Brian

---

From: SM <[email-masked]>
Date: Mon, 03 Dec 2012 10:01:33 -0800

Hi Hannes,
At 07:41 03-12-2012, Hannes Tschofenig wrote:
>Why do we need to announce conference calls (or Jabber chats) on the 
>IETF announce mailing list? How likely is it that someone cares 
>about a working group effort, does not subscribe to the WG mailing 
>list, has not seen a poll about the date and time, and wants to 
>participate in the conference call? To me - this seems rather unlikely.

There are people contributing to a working group who are not 
subscribed to the mailing list.  There are probably people who are 
not actively following a working group who might attend a conference call.

>Could we please change that?

Sending an email through ietf-announce@ is not that much work [1] 
[2].  If you broadcast the announcement to the entire community it's 
public.  You don't have to worry about the questions you asked above 
or conspiracy theories.

Regards,
-sm

1. http://www.ietf.org/mail-archive/web/scim/current/msg00782.html
2. http://www.ietf.org/mail-archive/web/ietf/current/msg72510.html

---

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 3 Dec 2012 21:37:27 +0200

On Dec 3, 2012, at 8:01 PM, SM wrote:

> There are people contributing to a working group who are not subscribed to the mailing list.  There are probably people who are not actively following a working group who might attend a conference call.

Any data that supports your argument? Are there people subscribed to the IETF announce list who just wait for conference calls they can join. 
With the same argument we should just forward every "interesting" mail from the working group just in case that someone on the IETF announcement list cares about it. 

If you do not follow the mailing list how likely is it that you will understand the discussions during the conference call? 

Ciao
Hannes

---

From: Bob Hinden <[email-masked]>
Date: Mon, 3 Dec 2012 11:59:14 -0800

Hannes,

> If you do not follow the mailing list how likely is it that you will understand the discussions during the conference call? 

If the announcement is sent to IETF announce, then people who are not subscribed to the mailing list can decide to participate by subscribing to the mailing list, reading the archive, read the drafts, and participate in the call.  If they never see the announcement, then this can't happen.

I don't see this as a worthwhile simplification to our process.

Thanks,
Bob

---

From: SM <[email-masked]>
Date: Mon, 03 Dec 2012 13:27:50 -0800

Hi Hannes,
At 11:37 03-12-2012, Hannes Tschofenig wrote:
>Any data that supports your argument? Are there people subscribed to 
>the IETF announce list who just wait for conference calls they can join.

Please do not read this as data.  There are about five messages daily 
about webfinger from non-subscribers.  I doubt that these individuals 
are subscribed to the IETF announce mailing list.

>With the same argument we should just forward every "interesting" 
>mail from the working group just in case that someone on the IETF 
>announcement list cares about it.

If I understood correctly it was a question of "meetings" and not 
"interesting" messages.

>If you do not follow the mailing list how likely is it that you will 
>understand the discussions during the conference call?

It's unlikely that I would be able to understand the discussions if I 
have not read the mailing list.

Regards,
-sm

---

From: "Tschofenig, Hannes (NSN - FI/Espoo)" <[email-masked]>
Date: Tue, 4 Dec 2012 10:28:08 +0200

Hi Brian, 

> The point is that we work in public, so the whole community should

Working group mailing lists are also public. 

> want to drop into OAuth too?

Are you talking about IETF meetings? I am talking about conference calls here. 

Are you regularly joining conference calls of working groups where you are not subscribed to the mailing lists?

> RFC 6437 to them. Otherwise, I have no interest in foobar.
How would you find this out from the announcement of the conference call given that the agenda does not have to announced at the same time? (unless you join every conference call to figure out whether there is something of interest for you?)

Ciao
Hannes

---

From: joel jaeggli <[email-masked]>
Date: Tue, 04 Dec 2012 00:38:56 -0800

> Are you regularly joining conference calls of working groups where you are not subscribed to the mailing lists?

I belive you're drawing a distinction between conference call and 
virtual interim which does not presently exist. It could, but doesn't.

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 04 Dec 2012 10:23:47 +0000

Hannes,

> Working group mailing lists are also public. 

Well yes, but we are talking here about (virtual) meetings.

> Are you talking about IETF meetings? I am talking about conference calls here. 

There's no difference in principle.

> Are you regularly joining conference calls of working groups where you are not subscribed to the mailing lists?

No. My point is that I have the right to. If not, it's a design team, and
that's a different discussion.

> How would you find this out from the announcement of the conference call given that the agenda does not have to announced at the same time? (unless you join every conference call to figure out whet…

I assume that the announcement would point to the agenda. Or I could look
at the WG mail archive at that point. In any case, I couldn't complain
later that the discussion had been kept private.

I don't see that informing the secretariat about virtual interims is a
significant burden on WG Chairs, compared to all the other work
involved.

    Brian

     Brian

---

From: "Tschofenig, Hannes (NSN - FI/Espoo)" <[email-masked]>
Date: Tue, 4 Dec 2012 10:51:27 +0200

> virtual interim which does not presently exist. It could, but doesn't.

No, I am not doing that. I know that we call conference calls virtual interim meetings. 

I also attend various working group meetings during an IETF week just to see what is going on but I do not randomly join conference calls of groups where I am not subscribed. Are you joining calls of groups you do not care enough about to look at the mailing list? 

Ciao
Hannes

---

From: Dave Crocker <[email-masked]>
Date: Tue, 04 Dec 2012 09:47:13 -0800

> I also attend various working group meetings during an IETF week just to see what is going on but I do not randomly join conference calls of groups where I am not subscribed. Are you joining calls…

You appear to be using your personal choices as a basis for making a 
conceptual distinction.  It does not matter what the statistics of the 
choices are.

The concept is simple:  a time-specific gather is a meeting.  Meetings 
require prior announcement beyond the working group.

d/

-- 
  Dave Crocker
  Brandenburg InternetWorking
  bbiw.net

---

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 04 Dec 2012 19:59:13 +0200

> require prior announcement beyond the working group.

I am not against a meeting announcement. I am suggesting to announce the
meeting where the audience is -- in the working group.

---

From: Donald Eastlake <[email-masked]>
Date: Tue, 4 Dec 2012 16:41:54 -0500

It's a question of costs and benefits. The cost of the IETF Announce
posting is small. There are not that many of them and I don't find
them to be a burden. The benefit in openness and transparency is
large. Thus the answer is simple and the policy should remain as it is
for now. If conditions change, it can certainly be revisited.

Thanks,
Donald
=============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

---

From: Doug Barton <[email-masked]>
Date: Tue, 04 Dec 2012 19:09:44 -0800

Hannes,

You've stated your perspective several times now. Each time a
non-trivial number of people have spoken up to say that they understand
your perspective, and that while under certain circumstances it may be a
reasonable one; that's not how the IETF operates.

Can we move on now?

Doug

---

From: "Tschofenig, Hannes (NSN - FI/Espoo)" <[email-masked]>
Date: Wed, 5 Dec 2012 11:25:43 +0200

Hi Donald, 

> them to be a burden.

How many conference calls as part of working group activities did you
organize in the last two years?

Maybe there are not that many because the overhead is too high to
organize them. 

> The benefit in openness and transparency is
> large.

Are working group activities not open and transparent in your view?

> Thus the answer is simple and the policy should remain as it is
How many conference calls of working groups you are not subscribed to
did you attend? 

Ciao
Hannes

---

From: Marc Blanchet <[email-masked]>
Date: Wed, 5 Dec 2012 11:09:48 -0500

> organize in the last two years?

I did some.

> Maybe there are not that many because the overhead is too high to

don't agree. Matter of minutes.

>> The benefit in openness and transparency is

I agree with Donald.

Marc.

---

From: Dave Crocker <[email-masked]>
Date: Wed, 05 Dec 2012 08:24:42 -0800

> organize in the last two years?

Hannes, your question is in response to the assertion that the cost of 
adding the IETF Announce list is small.  Ignoring the apparent 
non-sequitor of your response, the nature of your question implies that 
you think it is not small.  Please explain.

At base, you want to treat conference calls according to different rules 
than f2f meetings.  What I haven't seen is a principled explanation from 
you that justifies this.  So:  what are the underlying principles that 
justify treating conference calls as different from other time-specific 
IETF interactions?

d/

---

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 7 Dec 2012 12:17:35 +0200

I think I have gotten enough responses to my question on the mailing list and also off-list. Thanks a lot.  

Ciao
Hannes