Subject: RE: draft-bonica-special-purpose-04.txt

From: Ronald Bonica <[email-masked]>
Date: Fri, 4 Jan 2013 03:37:42 +0000

Hi Randy,

I have just posted draft-bonica-special-purpose-05. I hope that this version addressed the issues that we discussed, off-line.

                                             Ron

> -----Original Message-----
> From: Ronald Bonica
> Sent: Friday, December 21, 2012 10:49 AM
> To: 'Randy Bush'; IETF Disgust
> Subject: RE: draft-bonica-special-purpose-04.txt
> 
> Hi Randy,
> 
> It seems that we need one or both or the following:
> 
> - a better title for the new column
> - a better definition to be associated with that column
> 
> Any suggestions?
> 
>               Ron
> 
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] On Behalf
> > Of Randy Bush
> > Sent: Friday, December 21, 2012 9:45 AM
> > To: IETF Disgust
> > Subject: draft-bonica-special-purpose-04.txt
> >
> > i remain confused.  i am not being pedantic just to be a pita.  i
> > really worry that this document will be used to justtify strange
> > brokenness.
> >
> > from my 2012.11.29 message:
> >
> > > are the following definitions
> > >
> > >    o  Routable - A boolean value indicating whether a IP datagram
> > whose
> > >       destination address is drawn from the allocated special-
> purpose
> > >       address block is routable (i.e., may traverse more than a
> > single
> > >       IP interface)
> > >
> > >    o  Global - A boolean value indicating whether a IP datagram
> whose
> > >       destination address is drawn from the allocated special-
> purpose
> > >       address block is routable beyond a specified administrative
> > >       domain.
> > >
> > > intended to be baked in hardware, or are they SHOULDs to operators?
> > i
> > > look at RFC 1918 space and 127.0.0.0/8 and am not so sure how hard
> > > these boundaries are meant to be.  i worry because i think we
> regret
> > > how we specified (threw away is more like it) E space.
> > >
> > > does the prefix describes a specific prefix length or a covering
> > range?
> > >
> > > e.g. 192.0.0.0/24 is neither routable nor global, while a subnet,
> > > 192.0.0.0/29, is routable.  i.e. might i route and forward
> > > 192.0.0.128/25?
> >
> > another annoying example.
> >
> > 0.0.0.0/8 is said to be not routable, yet we commonly announce it in
> > bgp (or igp) and propagate it.  a protocol implmentor reading this
> > document would be justified in preventing the injection of 0.0.0.0/8
> > into a routing protocol.  [ let's not get into that it is commonly in
> > the fib. ]
> >
> > randy

---

From: Randy Bush <[email-masked]>
Date: Fri, 04 Jan 2013 17:41:56 +0900

ron,

> I have just posted draft-bonica-special-purpose-05. I hope that this
> version addressed the issues that we discussed, off-line.

indeed it does.  s/prefix/address block/  and  s/routable/forwardable/
hits my two issues on the head.  thank you.

it might be good if, now that these changes have been made, for someone
more knowledgeable than i to go through each entry.  i kinda did and
nothing set off large alarms.

randy